HyperCard” IIgs
Reference

i



Apple Computer, Inc.

This manual and the software described in it are copyrighted, with all rights
reserved. Under the copyright laws, this manual or the software may not be
copied, in whole or part, without written consent of Apple, except in the
normal use of the software or to make a backup copy of the software. The
same proprietary and copyright notices must be affixed to any permitted
copies as were affixed to the original. This exception does not allow copies to
be made for others, whether or not sold, but all of the material purchased
(with all backup copies) may be sold, given, or loaned to another person.
Under the law, copying includes translating into another language or format.

You may use the software on any computer owned by you, but extra copies
cannot be made for this purpose.

The Apple logo is a registered trademark of Apple Computer, Inc. Use of the
“keyboard” Apple logo (Option-Shift-K) for commercial purposes withou.
the prior written consent of Apple may constitute trademark infringement
and unfair competition in violation of federal and state laws.

© Apple Computer, Inc., 1990 GEnie is a trademark of General
20525 Mariani Avenue Electric Company.

Cupertino, CA 95014-6299 ITC Zapf Dingbats is a registered
(408) 996-1010 )
trademark of International
Apple, the Apple logo, Apple I1Gs, Typeface Corporation.
AppleShare, HyperCard,
HyperTalk, ImageWriter,

Linotronic is a registered trademark

LaserWriter, Macintosh, and IIGS of Linotype Co.

are registered trademarks of Apple Microsoft is a registered trademab
Computer, Inc. of Microsoft Corporation.

Finder is a trademark of Apple QMS is a registered trademark, and
Computer, Inc. ColorScript is a trademark, of
Adobe and PostScript are registered QMS, Inc.

trademarks, and Adobe Garamond QuarkXPress is a registered

is a trademark, of Adobe Systems trademark of Quark, Inc.

Incorporated. Studio/8 is a trademark of

CompuServe is a registered service Electronic Arts.
mark of CompuServe, Inc.

Simultaneously published in the
United States and Canada.




Preface  About This Book xiii

What you need to know to use this book xiv
How to use this book xv
Where to get HyperCard stacks  xvii
Other sources of information  xvii
Other learning materials  xviii
User groups  xix

Chapter 1  Using HyperCard Stacks 1

What is HyperCard? 2
Cards and stacks 4
. What you need to use HyperCard 6
HyperCard and your computer’s memory 7
Checking your computer’s memory 7
Symptoms of low-memory conditions 8
Installing HyperCard 9
Starting HyperCard 10
Beginning with the Home stack 10
Beginning with a stack other than Home 12
HyperCard icons and the Finder 13




The Home stack 14
The Home cards 15
User levels and options 17
Setting your user level 17
The Text Arrows option 21
The Power Keys option 24
The Blind Typing option 24
How HyperCard finds stacks 24
Getting to the Home stack 26
Opening and closing stacks 27
Opening a stack 27
Opening a stack protected with a password 29
Opening a locked stack 30
Closing a stack 31
Looking through stacks 32
Stack menus 32
Displaying the menu bar 32
Moving around in a stack 33
Using commands in the Go menu 34
Using the alternate Go menu and Go palette 36
Clicking buttons to move around 38
Clicking text to move around 39
Using the arrow keys to move around 39
Going to a specific card 41
Seeing all the cards in a stack 42
Looking for specific text 43
Finding field text anywhere in a stack 43
Finding text in a specific background field 45
Finding a whole word or phrase 46
Moving from one stack to another 48
Looking through cards you've visited 48
Returning Home 50
Entering text 50
Opening applications 52
Getting help in HyperCard 53

Using a stack on a file server 55

Contents




Chapter 2

Using a stack on a CD-ROM 56
Quitting HyperCard 57

Creating and Modifying Stacks 59

Creating stacks 60
The card layer versus the background layer 63
What buttons, fields, and graphics can do for your stacks 66
Using HyperCard’s tools 68
Selecting buttons, fields, and graphics 72
Planning a stack 75
The stack-building process 76
Modifying an existing stack 78
Examining a stack 80
Undoing your mistakes 87
Modeling your stack after an existing one 88
Making a new stack 89
Copying parts from other stacks 90
Getting information about a stack 92
Naming a stack 93
Changing a stack’s color set 95
Saving a copy of a stack 98
Reclaiming free space in a stack 99
Protecting your stack 101
Restricting access to a stack 101
Protecting a stack from changes or deletion 103
Limiting the user level 106
Removing a password 108
Setting user access for a stack on a file server 109
Deleting a stack 110
Customizing your Home stack 111
Adding buttons to your Home cards 112
Adding a button that opens a stack 112
Adding a button that opens an application 114
Renaming a Home card 117
Changing the appearance of the Home cards 118
Using the Home stack as your control center 119

Contents A




vi

Chaper3 Working With Cards and Backgrounds 121

Working with cards 122
Adding a new card to a stack 122
Copyingacard 126
Movingacard 127
Making a card the first card in the stack 128
Getting information about a card 129
Naminga card 130
Excluding card and background fields from text searches
Protecting a card 132
Changing a card’s color set 133
Deletinga card 135

Working with backgrounds 135
Creating a new background 138
Moving between backgrounds 139
Copying a background 140
Getting information about a background 142
Naming a background 143
Excluding background fields from text searches 143
Protecting a background 145
Changing a background’s color set 146
Deleting a background 148

Chaper 4 Working With Buttons 151

Adding a button to a card or background 152
The tools for working with buttons 153
Copying readymade buttons 154
Creating a button 157
Creating a button with text 158
Creating a button with an icon 161
Combining text with an icon 164
Creating a button with a graphic 165

Contents

131




Managing icons 166

Installing an icon by pasting a button 168

Installing an icon with the Icon dialog box 170
Locating buttons 171
Changing the appearance of a button 173

Changing the size of a button 173

Choosing a button’s style 174

Adding, changing, or removing button text 176

Setting the format for button text 176

Assigning, changing, or removing an icon 177

Changing a button’s colors 179
Linking information 180

Using the Link To method 181

Scripting a link 183
Making a button highlight when it’s clicked 186
Making a button appear highlighted on certain cards 187
Making a group of buttons highlight as a family 189
Naming a button 191
Moving a button around on a card or background 192
When elements overlap 193

Reordering buttons 195

Making a button opaque or transparent 197
Copying a button 198

Copying a button on the same card 198

Copying a button to another card or background 199
Moving a button from the card to the background 200
Moving a button from the background to the card 201
Moving a button to another card or background 202
Opening a button’s script 203
Deleting a button 204

Contents

Vil




Chaper 5 Working With Text and Fields 205

Adding text 206
Adding a field to a card or background 207
The tools for working with fields 208
Creating a field 209
Entering and editing text in a field 211
Where’s the I-beam pointer? 212
Using the arrow keys to move through text 213
Moving from one field to another 214
Undoing your typing 217
Setting the text format for a field 217
Making field text appear on every card 219
Locating fields 220
Changing the appearance of a field 221 ‘
Changing the size of a field 222
Choosing a field’s style 223
Adding margins 225
Displaying lines in a field 226
Changing a field’s colors 227
Naming a field 228
Moving a field around on a card or background 230
When elements overlap 231
Reordering fields 233
Making a field opaque or transparent 235
Copying a field 236
Copying a field on the same card 236
Copying a field to another card or background 236 ‘
Moving a field from the card to the background 238
Moving a field from the background to the card 239
Moving a field to another card or background 240
Locking and unlocking a field 242
Excluding a field from text searches 244
Deleting a field 245

viii Contents




Chapter 6 Working With Graphics 247
Adding graphics to a card or background 248
The tools for working with graphics 249
Selecting a graphic 253
Selecting a rectangular area 254
Selecting a nonrectangular area 255
Selecting an individual graphic element 257
Selecting the graphic you've just created 259
Selecting all the graphic elements on a card or background 260
Selecting the entire card picture or background picture 261
Copying graphics that come with HyperCard 262
Undoing your mistakes 263
’ Painting with the Brush, Spray tool, and Bucket 264
Painting with the Brush 264
Painting with the Spray tool 266
Filling an area with a pattern or color 267
Filling an enclosed area 268
Filling an unenclosed area 269
Creating your own patterns 270
Changing color sets 272
Changing a stack’s color set 274
Changing a card’s color set 275
Changing a background’s color set 276
Importing a new color set for a card or background 278
Drawing lines and shapes 279
Drawing a line or a free-form shape 280
‘ Drawing circles, ovals, and rectangles 281
Drawing a regular polygon 283
Drawing an irregular polygon 285
Drawing with the Pencil 287
Drawing with patterns, colors, and different line widths 288
Drawing a shape filled with a pattern or color 288
Drawing with different line widths 290
Drawing borders with patterns and colors 291
Moving a graphic around on a card or background 292

Contents X




Creating special graphic effects 293
Drawing in multiples 293
Aligning graphics 295
Combining options for unique effects 297
Adding Paint text 298
Turning field text into Paint text 300
When elements overlap 302
Making a graphic opaque or transparent 303
Changing the appearance of a graphic 305
Magnifying a graphic for editing 305
Changing the size of a graphic 308
Changing the pattern or color of a graphic 309

Usin% the Fill command to change a graphic’s pattern
or color 309

Using the Bucket to change a graphic’s pattern or color 310

Using the Pickup command to change a graphic’s pattern
or color 311

Inverting a graphic 313

Outlining a graphic 314

Rotating a graphic 90° 315

Flipping a graphic vertically or horizontally 316
Working with Paint tools when memory is low 318
Using power keys 319
Using modifier keys with Paint tools 321
Double-clicking Paint tools, patterns, and colors 322
Saving the graphics on a card or background = 323
Reverting to the last version of a graphic 323
Copying a graphic 324 .

Copying a graphic on the same card 324

Copying a graphic to another card or background = 325
Moving a graphic from the card to the background = 327
Moving a graphic to another card or background = 328
Importing a graphic 329
Exporting a snapshot of a card or background 330
Creating a miniature picture of a card 331
Deleting a graphic 332

Contents




Chapter 7 Printing 333

Preparing ro print 334
Printing a single card 336
Printing the cards in a stack 336
Printing a report 340
Creating templates 343

Creating a card template 343

Creating a report template 348
Exporting a template to another stack 360
Copying a template within the same stack 361
Renaming a template 361
Deleting a template 362

Glossary 363
Index 369
HyperCard IIs Quick Reference Card

Tell Apple card

Contents







About This Book

HyperCard® [IGs® is a software package that allows you to create
your own ways of doing things on your Apple IIGS® computer.

This book is a reference to everything you might need to know as
you use HyperCard, including how to use and create “smart”
documents called stacks. Stacks can do many of the things that
ordinary Apple IIGS application programs can do, and more,
because you can decide for yourself how you want your stacks to
work—without knowing a word of programming,

If you do know something about programming, or even if you're
just curious, you might want to learn more about HyperTalk? the
programming language that’s built into HyperCard. This book
doesn’t cover HyperTalk in detail. You don't need to know anything
about HyperTalk to use HyperCard effectively; but if you want to
learn more about it, you can read the HyperTalk Beginner’s Guide.




What you need This book assumes that you know how to use your Apple IIGs,
to kﬂOW tO use and that you understand the fundamentals of HyperCard.

. You should know
this book

s How to use the mouse and keyboard

= How to choose from a menu

= How to use (3-key commands (such as G3-X)

s How to copy files and disks

= How to open disks, folders, applications, and documents
s How to do simple text editing

» How to use the directory dialog box to locate files

s What a HyperCard stack is

s  What the components of HyperCard stacks are—cards,
backgrounds, buttons, fields, and graphics

If you’re not sure how to do all of the first seven tasks listed, go
through the documentation that came with your Apple IIGs before
you do anything else.

If you dor't know what a HyperCard stack is, or if you’re not
familiar with the components of stacks, go through the book
Getting Started With HyperCard I1GS and the Tour that comes

with HyperCard before using this book. (Geting Started With
HyperCard 11Gs tells you how to start the Tour.) These tutorials
teach the concepts you need to know to use this book. ®
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How to use
this book

This book is a reference to everything you might need to know as
you use HyperCard. (It doesn’t cover scripting with HyperTalk—
HyperCard’s programming language.) This book is designed to
help you find answers to your questions quickly and get on with
your work.

Once you understand the basic concepts presented in the Tour
stack and the book Getting Started With HyperCard I1Gs, refer to
this book as you begin doing your own work in HyperCard. If
you're still not sure how to use the Home stack or how to find
your way around in HyperCard, you might want to review the
information in Chapter 1, “Using HyperCard Stacks.” If you
want to begin building stacks, consult Chapter 2, “Creating and
Modifying Stacks.”

This book is organized according to tasks. Use the Contents or the
Index to locate instructions for specific tasks. You can also use the
Index to find information about individual topics and commands.

Descriptions of specific tasks in this book often include numbered
steps. Each step consists of a short instruction in boldface type
followed (usually) by further explanation in plain type. Depending
on your level of expertise with the Apple I1GS, you may find that
you can speed through some or all of the instructions by reading
just the boldface steps.

The book contains the following chapters and appendix:

»  Chapter 1, “Using HyperCard Stacks,” describes how to
use HyperCard stacks—“smart” documents created with
HyperCard. This chapter also explains how to get help with
HyperCard and how to use stacks stored on file servers and
compact discs.
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» Chapter 2, “Creating and Modifying Stacks,” provides
information about building stacks. This chapter includes specific
instructions for working with a stack as a whole.

s Chapter 3, “Working With Cards and Backgrounds,” explains
how to create and modify individual cardsand backgrounds.

s Chapter 4, “Working With Buttons,” explains how to create and
modify buttons (“hot” spots) and use them to link related pieces
of information.

» Chapter 5, “Working With Text and Fields,” explains how to
create and modify fields (the places you create to hold text), how
to enter text into fields, and how to control text styles.

s Chapter 6, “Working With Graphics,” describes HyperCard’ﬁ‘
Paint tools and commands and shows you how to use them to
create graphics.

s Chapter 7, “Printing,” explains how to print the information in
a stack.

You can find definitions of unfamiliar terms in the Glossary. Terms
that appear in italics in this book are defined in the Glossary.

The HyperCard 11Gs Quick Reference Card gives keyboard

shortcuts for HyperCard operations.

At the end of the book is a Tell Apple card. By answering the
questions and mailing the card to Apple$ you help us improve our
products and documentation. Fill the card out after you've worked

with this book.
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Whefe {0 get A HyperCard stack can be as simple as a collection of information,
}{VPGI'C'JI’(] stacks oras complex as any Apple IIGS application program. (Chapter 2
’ shows some examples of HyperCard stacks.) You can use the stacks
that come with HyperCard, create stacks yourself, or get stacks
from a variety of other sources:

= You'll find HyperCard stacks for sale at your local computer
software store.

»  Check with your local Apple IIGS user group to find out the
meeting time of the HyperCard special interest group. Members
often share their stacks with each other. (The next section
explains how to find a local Apple IIGS user group.)

»  Most on-line electronic information services like CompuServe®
® and GEnie™ have HyperCard special interest groups. These
groups have stacks you can get free, except for the service’s
time charges.

Other sources Although this book is a reference to HyperCard, it doesn’t contain
of information tutorial instruction for novice users, and it gives only a brief look at
scripting (creating programs that control the actions of HyperCard).
Other kinds of information and instruction on HyperCard are
available from a variety of sources. This section describes some
of these sources.
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Other leaming materials  In addition to this book, the following learning materials are
included in the HyperCard package:

Gettmg Started With HyperCard 11Gs: A book that tells you how to

' install HyperCard, teaches the basic skills you
need to get going, and shows you how to start
creating and modifying stacks.

Tour: A stack that introduces basic HyperCard concepts by
gé_ showing you what HyperCard can do.

Hypeerm’ 1IGs Help: A stack that answers your questions while @
& é you're using HyperCard.

Hypeﬂk//e Beginner’s Guide: A book that teaches you how to use
HyperCard’s programming language by helping

you create a new stack one step ata time.

Hyperthl/e Help: A stack that provides easy access to information
about HyperTalk for people who use
HyperCard’s programming language.

If you’re serious about building stacks, you may also want to
consult the following books, which were written at Apple and
are published by Addison-Wesley as part of the Apple Technical
Library:

HyperCard Stack Design Guidelines: A book that provides
information about how to design and build effective stacks. Its
focus is the look and behavior of stacks (for example, navigation
methods and card layouts) rather than the mechanics of scripts.
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HyperCard 1IGS Script Language Guide: A book that provides
detailed reference information about scripts and HyperTalk. This
book is for people with some programming or scripting experience.

Several other excellent books have been written about HyperTalk.
Books about HyperTalk that were written for HyperCard 1.2.5,
which runs on Macintosh® computers, contain much information

that also applies to HyperCard IIGs.

User groups  Apple IIGs user groups can be a great source of information about
HyperCard, and about Apple computers in general. Members of
user groups meet to share ideas, discuss problems, and exchange
software and information. By attending user group meetings, you
can learn more about HyperCard and see how others are using it.

Ask your authorized Apple dealer for the name of the Apple IIGS
user group nearest you, or call (800) 538-9696, Extension 500.
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Chapter 1

Using HyperCard Stacks

T;lis chapter begins with a brief summary of what HyperCard®
IIGs® is and what you can do with it. One of the first things you'll
learn is that documents created with HyperCard are called stacks.

The remainder of the chapter describes what you need to know to
use HyperCard stacks effectively, including

»  What hardware and software you need to use HyperCard
= How to start HyperCard

= How to use the Home stack

= How to open, explore, and close stacks

@ = How to get help

To do the tasks described in this chapter, you need to have your

user level set to Typing or higher. When a task requires a user level
higher than Typing, the instructions say so. (The section “User
Levels and Options” in this chapter explains how to set your

user level.)




What is HyperCard?

HyperCard lets you create your own ways of doing things on your
computer. Unlike most application programs, which are designed to
perform one type of task (such as word processing or creating
graphics), HyperCard can be used for many different kinds of tasks.
For example, you can use HyperCard to do any of the following:

» Gather information and organize it in any way you like.

= Browse through information you’ve assembled yourself, or
information gathered by someone else. You can follow links to
topics you want to know more about, skip over things you're not
interested in, and search for specific facts or text.

» Create HyperCard stacks that meet your own specific needs—
for example, stacks that help you write a report, learn a new ®
language, organize a collection of electronic clip art, or present
information stored on a videodisc.

s Customize your computer work space—so that, for example,
with a single mouse click, you can log onto another computer,
launch an application that’s hidden away in a folder, or send a
message to a friend.

Using HyperTalk®, HyperCard’s English-like script language, you
can gain even more control over your HyperCard environment,
whether or not you have prior programming experience. You can
tap the power of HyperTalk without knowing anything about how
it works. For example, you can link a button to a stack—creating a
script that tells the button to take you to that stack—without
writing a word of HyperTalk. And HyperCard comes with
readymade scripts you can copy and paste. (You can learn ro create
your own scripts by working through the exercises in the HyperTalk

Beginner’s Guide.)
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The more you learn about HyperCard, the more uses you'll see for
it. HyperCard allows you to shape the way your computer organizes
and presents information, which can help you use the information
efficiently. You may even find that HyperCard helps you discover
new ways of organizing your work and new approaches to old
problems. HyperCard provides you with a creative environment
that’s limited only by your imagination.

Chapter 2 shows examples of the kinds of stacks you can create with
HyperCard.
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Cards and stacks  In HyperCard, information appears on cards. HyperCard cards
are a lot like paper index cards on which you can jot notes or
miscellancous information. In HyperCard, cards can contain
both text and pictures:

i1 Once upon a time there was a
il princess and a prince and o
[l queen and o king and a dragon

A

:;f.1Snow ol “'"‘

A Owls have special wings that help them fly

: 1 quietly at night while they are hunting for
‘ food. The edges of their wings are soft and
jogged and the wings themselves are lorge,

i n
l‘[ i
i

Lg
WM

i

i

q«

B} l
John 8, Bloom [ :
Greenhouse Industries .. i [k l“

Weed
)
89647

999:9087 .

Stack Info

BHRY
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Home |

Figure 1-1  Cards—HyperCard’s fundamental units of information
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Cards are grouped into szacks. The cards within a stack are usually
(but not necessarily) related to one another, or based on a common
theme. They usually have the same look and contain similar
information.

Taupo Stamp ;s
NEW ZEALAND

Tauranga Stamp
| NEWZEALAN "'

NEW ZEALAND

(BotoHistory Stack)<a 12> Ty

Figure 1-2  Cards are grouped into stacks

Every stack has a name. An icon for each stack appears in

the Finder™:

-

StampStack

Figure 1-3 A HyperCard stack icon in the Finder

< If your stack icons look different: HyperCard stack icons will look
like the icon in Figure 1-3 only if you have followed the standard
installation procedure. If your stack icons look different, see

“HyperCard Icons and the Finder,” later in this chapter.
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What you need
to use HyperCard

You can learn a lot about the power of HyperCard just by exploring
the stacks that come with it. These stacks provide good examples of
the kinds of things HyperCard can do. If you wish, you can obtain
additional stacks from the sources described in the Preface.

HyperCard includes tools you can use for modifying and creating
stacks. With these tools, you create and manipulate the elements,
or building blocks, that make up stacks. You can arrange the
information on cards in any way you like. And you can tie together
related information by creating /inks—so that a single click takes
you immediately to the information you want, whether it’s in the
same stack or a different one.

|
\ -
i

1
Whakatane ~ History of New Zealand
HEW ZEALAND ... vvvvvvve WHAKATANE

(Goto History Stack el

».
3.9

Figure 1-4 A link from one stack to another

When you're ready to begin building stacks of your own, go to
Chapter 2, “Creating and Modifying Stacks.”

To use HyperCard, you need the following hardware and software:

s An Apple [IGS® computer with 1.5 megabytes (MB) of memory
or more. (To find out how much memory your computer has,
follow the instructions in “Checking Your Computer’s
Memory,” later in this chapter.) Your authorized Apple dealer

can help you add memory to your computer.

s An 800K disk drive.
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» A hard disk. If you don’t have a hard disk of your own, your
computer must have access to a file server over an AppleShare®
network.

= System software version 5.0.3 or later. Your authorized Apple
dealer can help you obtain the system software you need.

» To print with HyperCard, you need the appropriate printer
driver for your printer. The printer driver must be in the Drivers
folder, which in turn must be in your System folder when you
start your computer. For example, if you have an ImageWriter
printer, the Drivers folder must include the ImageWriter driver.
"The documentation that came with your Apple I1Gs discusses
how to install system updates, including drivers.

HyperCard and your HyperCard requires a minimum of 1.5 MB of random-access

computer’s memory memory (RAM) to run efficiently. However, the more memory
you have installed in your computer, the better HyperCard will
perform. The sections that follow describe how to find out how
much memory your computer has and how to identify and deal
with symptoms of low-memory conditions.

Checking your computer’s memory

Once your computer is set up, you can easily find out whether you
have enough memory to run HyperCard. Just follow these steps:

‘ 1. Choose Control Panel from the Apple menu.
2. Scroll through the icons on the left until you see the RAM

icon.
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3. Click the RAM icon and check the numbers labeled “Memory

. » <« »
in use” and “Free memory.

If these numbers add up to 1,536 or more, you have enough

memory.

S0==——= (ontrol Panel
RAM Disk:  RAM Cache:

.
- | Memory in use: 1177K | These numbers
| [ree memory: 938K should add up 1o

| f
= at least 1,530.

Figure 1-5 Checking your computer’s memory

Your authorized Apple dealer can help you add memory to your
computer if you need it.

Symptoms of low-memory conditions

HyperCard’s use of memory depends on many factors, including
the number of desk accessories you have installed in your system,
the network software you're using (if any), and the complexity of;
the card or stack you’re currently working with. Even if you have
1,536K or more of RAM installed in your computer, you may find
that HyperCard sometimes performs differently than you expect.
This is most likely to happen if your computer has close to the
minimum amount of memory you need to run HyperCard and is
part of an AppleShare network.
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[nstalling HyperCard

After you have installed HyperCard and learned to usc it, you may
want to evaluate its use of your computer’s memory. The following
symptoms are signs that HyperCard is running out of memory:

» Fields and buttons in the card layer disappear when you’re using
the Paint tools in the card layer.

» Fields and buttons in the background layer disappear when
you're using the Paint tools in the background layer.

» The Undo command doesn’t always work when you’re using the
Paint tools.

= Burttons that play complex sounds don’t work.

You can keep working if these symptoms occur—HyperCard’s
behavior remains the same in most other ways, although it may run
more slowly than it would with more memory.

The best way to avoid low-memory conditions and to improve
HyperCard’s speed and general performance is to install additional
RAM. However, it may help to remove some of the desk accessories
you have installed in your system; avoid using a RAM disk; and
lower the RAM cache to 32K (or, if all else fails, to 0K).

For information about desk accessories, RAM disks, and the RAM

cache, see the documentation that came with your computer.

For information about working with the Paint tools under low-
memory conditions, see “Working With Paint Tools When
Memory Is Low” in Chapter 6.

Before using HyperCard, you should install it on your hard disk.
(You must have a hard disk to run HyperCard.) See the book
Getting Started With HyperCard 11GS for installation instructions.
It you don't follow those instructions exactly, the HyperCard icons
in the Finder may look and behave differently than you expect.
For more information, see “HyperCard Icons and the Finder,”
later in this chapter.
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Starting HyperCard

Beginning with
the Home stack

After you install HyperCard, make sure you have a backup copy of
each disk that comes with it, and lock your backup disks. (If you
don’t know how to lock a disk, see the documentation that came
with your Apple I1GS.) It’s a good practice to back up any new
software before using it. However, it’s particularly important to do
this with HyperCard, because HyperCard automatically saves any
changes you make to stacks—without asking. Keep a backup copy
of each stack that comes with HyperCard, so that you can always
retrieve the original copy of any stack.

Before you start HyperCard, make sure you have a backup copy of
each disk that comes with it, as described in the preceding section‘

The Home stack serves as a home base whenever you use
HyperCard, and it’s a good place to start exploring. It includes
a visual directory of other HyperCard stacks and provides easy
access to them. (You need to have a Home stack to run

HyperCard.)

If you followed the installation instructions in Geting Started With
HyperCard 11Gs, there are two ways to start HyperCard so that it
opens the Home stack:

& Inthe Finder, ... ordouble-click
Ek;._'_lﬁt' double-click the g;-i*:k‘; the Home icon. ‘
HyperCardI1GS HyperCardicon... Home

Figure 1-6  Starting HyperCard with the Home stack

You might have to close windows or open folders to find the
HyperCard icon or the Home icon.
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If you did not follow the installation instructions exactly, or if you
have subsequently moved the HyperCard program file to another
location on your hard disk, you may find that these icons look or
behave differently from the way they are described in this section.
For more information, see “HyperCard Icons and the Finder,” later
in this chapter.

= Where is Home? When you start HyperCard by double-clicking
its icon, it looks for the Home stack (1) in the System folder;
(2) in your user folder, if you’re running HyperCard over an
AppleShare network, or in the folder that contains the
HyperCard program, if you’re not running HyperCard over a
network; and (3) in any folder named Stacks that’s inside the
@ folder it checked in (2). If it cant find Home in any of these
places, HyperCard displays the directory dialog box and asks
where Home is. Use the directory dialog box (shown in the
following figure) to locate and open the file called Home. +

This is the current directory level. You
can see the next higher level in your disk
directory (if there is one) by clicking
here or pressing Esc.

Where is Home?
<23:HardDisk:HyperCard:

m You can view the

[ Stacks volumes that are
03 Tour currently available
to your computer

by clicking here or
pressing the Tab

key.

You can open a stack, folder, or volume in
this list by double-clicking it. You need to
locate the Home stack and open it.

Figure 1-7  The directory dialog box for finding a file
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For more information about using the directory dialog box, see the
documentation that came with your system software.

For more information about Home, see “The Home Stack,” later
in this chapter.

Beginning with a stack  You can start HyperCard so that it opens to a particular stack other
other than Home  than Home, as shown in the following figure:

.-'%___ In the Finder,
E’.F_-Egk double-click the
Stack stack’s icon.

Figure 1-8  Starting HyperCard with a stack other than Home ‘

You might have to close windows or open folders to locate the
stack’s icon.

If you can't start HyperCard by double-clicking a stack’s icon, or if
the icon looks different from the one shown in Figure 1-8, see the
next section, “HyperCard Icons and the Finder.”

% Where is Home? When you start HyperCard by double-clicking
a stack’s icon, it looks for the Home stack (1) in the System
folder; (2) in the same folder as the stack you double-clicked;

(3) in your user folder, if you’re running HyperCard over an
AppleShare network, or in the folder that contains the
HyperCard program, if you’re not running HyperCard over a ‘
network; and (4) in any folder named Stacks that’s inside the
folder it checked in (3). If it can’t find Home in any of these
places, HyperCard displays the directory dialog box shown in
Figure 1-7, which you must use to locate the file called Home.
After you tell it where Home is located, HyperCard opens to the
stack whose icon you double-clicked. <
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.\ Important: Whether or not you want to start HyperCard with the

HyperCard icons
and the Finder

Home stack, you need to have a Home stack on your disk to run

HyperCard. A

% See a padlock (&) in the menu bar? When you open a locked
stack, a padlock appears in the menu bar to the right of the
rightmost menu title. The padlock means the stack is
locked—you can't make changes to it. The section “Opening
a Locked Stack,” later in this chapter, describes how to work
with such stacks. «

If you install HyperCard exactly as described in Gerting Started
With HyperCard 11Gs, and if you leave the HyperCard program and
the Home stack where the Installer program puts them on your
hard disk, the icons for the HyperCard program, Home, and other
HyperCard stacks will look just like those in Figures 1-6 and 1-8
(that is, like miniature stacks). If you don't follow the instructions
exactly, or if you move the HyperCard folder, the HyperCard
program, or Home after installation, you may find that double-
clicking stack icons to open them from the Finder won't work.

You may also find that HyperCard’s icons change their appearance,
so that they look like standard Apple I1Gs application and
document icons.

When the Installer program installs HyperCard on your hard

disk, it also places two files (called FTYPE.HyperCard and
HyperCard.Icons) in the Icons folder on the same disk. These files
contain information the Finder needs about HyperCard’s icons and
the location of the HyperCard program on your hard disk. If these
files aren’t inside the Icons folder, the Finder uses its standard icons
instead of the HyperCard icons for all the HyperCard files, and
cannot automatically locate the HyperCard program file. When this
is the case, you can start HyperCard only by double-clicking the
HyperCard program icon. Double-clicking the icon for a
HyperCard stack won't work.
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[f the HyperCard icons you see in the Finder are correct, but

you still can’t start HyperCard by double-clicking a stack icon,

it’s probably because you have changed the arrangement of
HyperCard’s files on your hard disk. Even if the correct files are

in your Icons folder, the information they contain about the
location of the HyperCard program on your startup disk will not
be valid if you have moved it. To avoid this situation, keep both the
HyperCard program file and the Home stack where the Installer
places them: inside the HyperCard folder, which in turn should be
at the top level of your hard disk directory (visible in your hard
disk’s window).

If you need to keep the HyperCard program somewhere else, make
sure you keep the Home stack at the same directory level (in the @)
same window) as the HyperCard program file, and remember that
you must always start HyperCard by double-clicking its icon.
Double-clicking stack icons to open them won't work, but

otherwise HyperCard will function the same way.

The Home stack  Homeis HyperCard’s central stack. You can return o it easily from
any other stack at any time. You use the Home stack as your base
of operations, a jumping-off point for your work in HyperCard.
This section describes the standard Home stack that comes with

HyperCard.

The cards in the standard Home stack contain information vital t(‘
HyperCard’s performance:

= The first five cards in the Home stack, called the Home cards,
are designed to hold buttons that take you to stacks.
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= The Scarch Paths card tells HyperCard where to find stacks,
applications, and documents that you use frequently.

= The User Preferences card lets you customize the way you
interact with HyperCard.

The Home cards are

1 . S :
designed to hold [ Fome s o R
buttons that take you , L Teturn
to your stacks.

=t | @ —

perCard I )
Home Stack /SearchPaths (= orrirmees Bl

il 5 e I | SN =
e BlE——

L

Lo

The User Preferences
card lets you customize
& B the way you interact
. f EEI\ ;_E; | The Search Paths card with HyperCard.
= - ~ tells HyperCard where to
look for different files.

Horte Stack,/ Welcome perLard L S
Create QuickLink...

User Preferences

Pr— e [ [ —

Figure 1-9  The cards in HyperCard's standard Home stack

A Warning: HyperCard will not operate without a Home stack.
Do not delete the Home stack. a

The Home cards  1f you haven't customized your standard Home stack, the first
three Home cards (the first three cards in the stack) contain
buttons that take you to all the stacks that come with HyperCard—
. from collections of electronic art to special stack-building tools.
In addition, the standard Home stack has two blank Home cards.

Collectively, the Home cards provide a visual directory for
your stacks.
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[ Home 5t

Create QuickLink... :

Help Picture Puzzler

4

Tour Story Board

Copyright © 1990 Apple Computer, Inc

T CIVTO0 0 | Deskset  |[ Toolkit J[ Attic ][ Basement ]fi

P a1 o 1T i
{ Home Stack / Deskset HyperCard IG5 -

User Name
Create QuickLink... |i
Calendar

the first three
Home cards take
| you to the stacks
These buttons reroone ] ISR [ Tooiki ][ o ][ Sosement Jf that come with
move you through HyperCard.
the cards in the
Home stack.

|_The buttons on

Addresses

VL gk
| Home Stack / Tool Kit User Name

s

Create QuickLink.

" User Preferences
= P i
Scripter's Tools frt 1deas

(S5

g || !
Button Ideas Icon Editor

—Welcome ][ Deskse | [NEEETINCCINN [ Aueic

J[_Busement

Figure 1-10  The first three Home cards .

As you become more comfortable with HyperCard, you can make
your Home cards even more useful by adding buttons that link
your Home cards to your favorite cards, stacks, and applications.

P Seealso: e “Customizing Your Home Stack”™ in Chaprer 2
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User levels and Oplons  You can adjust the settings on the User Preferences card to

When you click a
higher user level . . .

... the appearance of
the User Preferences
card changes to
reflect your choice.

customize the way you interact with HyperCard. To get to the
User Preferences card, first go to the Home stack (if you're not

already there) by choosing Home from the Go menu, or pressing
J-H. Then click the User Preferences button.

Setting your user level

On the User Preferences card, click the user level that matches what
you want to do in HyperCard:

This column explains what you can
do at each user level.

i G I 0031110
Home Stack / User Preferences

Search Paths
Return

Click here to
change the user

Your Name: User Name

3. Edit the scripts of buttons, fields,

— e

Scripting cards, backgrounds, and stacks. name.
ing | Y. Creote buttons and fields. Link
Authormg buttons to cards and stacks.
T 3. Use the Paint tools to change the
Pamtmg appearance of cords and backgrounds.

|

Y . Use stacks. Enter and edit text in
o fields.

. For clicking only. Youmay explore
stacks but not change them.

D [ Text Arrows

-

Browsing

- BRI ISE13 11111111111

{ Home Stack / User Preferences

yperCIIGS

Search Paths

[Z1Blind Typing

Edit the scripts of buttons, fields,
cards, backgrounds, and stacks.

4. Create buttons and fields. Link

Authoring _buttons to cards and stacks.
gl 3. Use the Paint tools to change the
Painting appearance of cards and backgrounds. [ Pover Keys
in 2. Use stacks. Enter and edit text in ] Text Arrows
1% fields.
Aot 1. For clicking only. Youmay explore
Browsing _stacks but not change them.

Figure 1-11  Setting your user level
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The features available at the different user levels are cumulative—
that is, each level gives you all the features from the previous levels,
and also gives you additional capabilities. For example, the features
available at the Browsing level are also available at the Typing level;
the features available at the Browsing and Typing levels are also
available at the Painting level; and so on. The higher the user

level you choose, the more you can do with HyperCard.

You might want to set a low user level now and change it to a higher
one later, when you feel comfortable experimenting with more
advanced features. You can change your user level at any time.
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User level

Browsing

Typing

Painting

Authoring

Scripting

What you can do

Open, close, and browse through stacks, search
for text, click buttons, move between stacks, save
copies of stacks, and print the information in
stacks.

The same things you can do at Browsing level,
plus type and edit text in existing fields, set the
"Text Arrows option on the User Preferences card
in the Home stack (explained in the next section),

and add and delete cards.

The same things you can do at Typing level, plus
set stack protection, delete stacks, create graphics
with the Paint tools in the Tools menu, edit
graphics and patterns using the Paint, Options,
and Patterns menus (which appear when a Paint
tool is selected), move between the background
layer and the card layer, and use the Power Keys
(explained in “The Power Keys Option,” later in
this chapter).

The same things you can do at Painting level,
plus create, modify, and delete buttons, links,
fields, cards, backgrounds, and stacks using the
Button tool, the Field tool, and commands in the
Objects menu.

The same things you can do at Authoring level,
plus write and edit scripts and use the Blind
Typing option (explained in “The Blind Typing
Option,” later in this chapter).
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The File and Edit
menus you get
when your user
level is Browsing
or Typing.

The File and Edit

menus you get
when your user
level is Painting,
Authoring, or
Scripting.

New Stack...
Open Stack... a0
Save a Copy...

Page Setup...
Print Card aP
Print...

Undo

fut, 4K
Gony H3
Paste aV
Cleay

Quit HyperCard a0

New Card GN
Delete Card

New Stack... Undo

Open Stack... a0

Save a Copy... Lt {44
Lapy gL

Compact Stack Paste 3y

Protect Stack... {ieay

Delete Stack...

---------------------------------------------------------------------- New Card N
Page Setup... Delete Card
Print Card 3P Cut Card
Print... Copy Card
Quit HyperCard a0 Texy Seple.. o

Background B

Figure 1-12  Short and full File and Edit menus
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+  User preferences and stack protection: The tools and commands
you have at your disposal while you’re using a specific stack
are determined by both the user level you set on your User
Preferences card and the stack’s user level (which is set in the
Protect Stack dialog box). When a stack is set for a different user
level than the one set on your User Preferences card, HyperCard
uses the lower setting. (Lower means “closer to Browsing.”)
For information on setting and changing a stack’s user level,
see “Protecting Your Stack” in Chapter 2. «

The Text Arrows option

When you click any user level button except Browsing on the
O User Preferences card, a check box labeled Text Arrows appears
(see Figure 1-11). You select or deselect this option by clicking it.

When this option is turned off, the arrow keys on the keyboard
move you through cards in a stack; when this option is turned on,
the arrow keys move the insertion point through text—just as they
do in most word processors. (The Message box is a place where you
can type instructions to HyperCard. It’s discussed in the section
“Looking for Specific Text,” later in this chapter.)
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[ 1Text Arrows

Takes you to the Takes you to the Takes you back Takes you forward
previous card in next card in the through cards through cards
the current stack current stack you've seen you've reviewed

B Text Arrows

Moves the Moves the Moves the Moves the

insertion point insertion point insertion point insertion point

left over text right over Lext down through up through lines
lines in a field, in a field. or to
or to the end of the beginning of
the line in the the line in the
Message box Message box

Figure 1-13  The effect of the Text Arrows option
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When ‘lText Arrows is turned on, you must press the Option kcy in
combination with the arrow keys to move through cards in a stack:

To go to the previous card
in the current stack

To go to the next card
in the current stack

To go back through cards

‘ you've seen

To go forward through
cards you've reviewed

Figure 1-14  Moving through cards when the Text Arrows option is turned on

» Seealso: o “Moving Around in a Stack™ in this chapter

| S
o
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How HyperCard
finds stacks

The Power Keys option

When you click Painting (or a higher user level) on the User
Preferences card, a check box labeled Power Keys appears (see
Figure 1-11). When the Power Keys option is turned on, you can
use specific keys on the keyboard to make changes to graphics—
pressing a single key does the work of choosing a menu command
that affects the selected graphic (or the graphic element you've just

created). You select or deselect the Power Keys option by clicking it.

P Seealso: o “Using Power Keys” in Chapter 6

The Blind Typing option

When you click Scripting on the User Preferences card, a check bo..
labeled Blind Typing appears (see Figure 1-11). When this option s
turned on, you can type in the Message box even when it’s hidden

(as long as the insertion point isn't in a field). Typing in the Message
box sends instructions to HyperCard.

You select or deselect the Blind Typing option by clicking it. When
the Blind Typing option is turned off, you can type in the Message
box only when you see it on the screen. When this option is turned
off, HyperCard beeps if you try to type in the Message box when

it’s hidden.

The Message box 1s discussed in the section “Looking for Specific

Text,” later in this chapter.

When you tell HyperCard to open a document, an application,
or a stack—by clicking an icon on onc of the Home cards, for
example—HyperCard searches for the file by first looking in the
folder that contains the current stack. Then it checks the Search
Paths card in the Home stack (described next) to see where clse to
look for the requested file.

To sce the Search Paths card, first go to the Home stack (if you're
not already there) by choosing Home from the Go menu or
pressing (-H. Click the User Preferences button, and when the
User Preferences card appears, click the Search Paths button.
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This line tells

HyperCard to look L [Traske:

for stacks in the
folder Stacks.

The following figure shows the Search Paths card:

You can click these buttons to see the Search Paths ficlds for non-
HyperCard documents or applications. The information in these
fields helps HyperCard find documents and applications you try
to open from within HyperCard.

i —E NI
| Home Stack / Search Paths

m Lﬂpplicutions ] [ Documents ]

User Preferences
Return

=

Help:

Figure 1-15  Where HyperCard looks for stacks

There are three fields on the Search Paths card that tell HyperCard
where to look for files. One tells HyperCard where (in which
folders) to look for stacks, another tells it where to look for
documents, and a third tells it where to look for applications.

1o view cach field, click the appropriate button on the Search Paths
card. These fields contain lists of search paths, or pathways through
the folders on your disk, that HyperCard should follow to retrieve
a stack, application, or document.

It you ask HyperCard for a file it can’t find (that is, one whose
search path isn't recorded in the appropriate field on the Search
Paths card), it displays a directory dialog box and asks you where
the file is. (Figure 1-7 shows a directory dialog box.) Use the
directory dialog box to locate the file. Once you’ve located the file,
HyperCard notes the disk and folder (and subfolder, if necessary)
where the file is located, and records this information in the
appropriate field on the Search Paths card. The next time you ask
for that file, HyperCard will know where to look for it without
having to ask you (unless you’ve renamed it or changed the name
of the disk or folder that contains it).
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Although HyperCard updates the Scarch Paths card for you (as just
described), you can also add search paths to the card yourself. For
example, if you move a stack into a folder named Old.Stacks within
the Stacks folder, you can add the following line to the Stacks field
on the Search Paths card (so HyperCard will know where to find
the stack):

:HardDisk:HyperCard:Stacks:01d.Stacks:

To add a line to one of the Search Paths fields, just click and type.
When you rename a disk, folder, or file, you can change its name in
the appropriate Search Paths field. Or, if you prefer not to deal
directly with these cards, you can always use the directory dialog

box to help HyperCard locate the files you need.
@ Occasional housecleaning: HyperCard keeps a search path on .

record until you erase it. It's a good idea to erase a search path
you no longer use, to free that space on the Search Paths card
and help HyperCard search for files more efficiently. To erase a
search path, just drag to select it, then choose Clear from the

L)

Edit menu. <

(,}L‘I{iﬂf_’, tothe  While you're using Hyper(}ard, you can get to the Home stack
Home stack by doing any of the following:

s Choose Home from the Go menu.

s Press I-H (press and hold the > key while you press H
for Home). ‘

a Click the button with a house icon, which appears in many
stacks, or another button that’s linked to the Home stack.

s Choose Message from the Go menu (or press  -M), type
"Home", and press Return.

s Choose Open Stack from the File menu (or press -0), and
locate and open the Home stack using the directory dialog box.
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Opening Llnd Because HyperCard automatically (without asking) saves any
JAad t10lcq  changes you make to stacks as you work, it’s a good idea to make
closing stacks ~ changesy Y irsag |
o sure you have a backup copy of a stack before you open it. That way,
if you change the stack (intentionally or otherwise), you can always
go back to the original version. (“Saving a Copy of a Stack” in
Chapter 2 gives instructions for making a backup copy of a stack.)

Opening a stack  There are several different ways to open a stack:

3 Double-click the stack’s icon in the
_ ¥='='E5=:: Finder.
PicturePuzzler

o B Click a button that’s linked to the stack
"‘ (if there is such a button).

Picture Puzzler

0
go to stack "PicturePuzzler" Choose Message from the Go menu to
open the Message box, type go to

stack and the stack’s name (in quotes),
and press the Return key.

New Stack...

Open Stack 40 Choose Open Stack from the File menu

g c and open the stack.
ave a Lopy...

Figure 1-16  Opening a stack

+  About stack names: A stack name that you see in the Finder or in
a directory dialog box may differ from the name that appears on
the HyperCard button that takes you to that stack. This is
because the stack’s name must follow the standard Apple I1Gs
naming rules for documents, whereas the rules for naming
HyperCard buttons are more flexible. When you type in the
Message box to open a stack, you must type the stack’s name
the way it appears in the Finder. «
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Locate the stack
you want to open
by double-clicking
to open folders or
volumes in this list.
When you see the
stack vou want,
double-chick i

LO open 1.

When you double-click a stack’s icon in the Finder, HyperCard
will launch (and the stack will open) only if you have installed
HyperCard correctly and have not subsequently moved any of its
files. For more information, see “HyperCard Icons and the Finder,”
earlier in this chapter.

When you click a button or type in the Message box to open a
stack, HyperCard looks for the stack using the strategy described in
the section “How HyperCard Finds Stacks,” earlier in this chaprer.
[f it can’t find the stack, HyperCard displays the directory dialog
box and asks you to tell it where the stack is. (If the stack is on a
floppy disk, make sure that disk is in one of your drives.)

When you choose the Open Stack command, HyperCard ®
displays a directory dialog box and waits for you to tell it which
stack to open:

This is the current directory level. You
can see the next higher level in your disk
directory (if there is one) by clicking
here or pressing Esc.

Choose a stack:
<=):HardDisk:HyperCard:

( Volunes — You can view the

volumes that are

9 Home

(0 Stacks
3 Tour

currently available
( Open ) 1O vour computer
E—— by clicking here

(Tlose ) or pressing the
b key P

Figure 1-17  Opening a stack with the Open Stack command
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Opening a stack protected
with a password

After you double-click the stack (or select it and click Open),
HyperCard closes the stack you are currently looking at and opens
the stack you selected.

When you tell HyperCard to open a stack that’s set for private
access, you see the following dialog box:

This stack requires a password:
f 1 Type the password
here and click OK.

'j 0K i@ |Cuncel|

Figure 1-18 Opening a stack set for restricted access

To open the stack, you must know the password and type it
correctly, character for character—except that capitalization doesn't
matter. (As you type, you will see asterisks, not the actual letters you
type.) Then click OK. If the password you type is incorrect,
HyperCard tells you so and won't open the stack.
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Opening a locked stack  When you open a stack that’s locked—for example, a stack for
which “Can’t modify stack” is selected in the Protect Stack dialog
box—a small padlock (&) appears in the menu bar:

< File Edit Go Tools Objects a—— The small padlock
|l|l||‘|1|I|J|HHHHNHHHINHW!Q|1|Wm|J|\“NUlll\|\I||lll\ll|\|mm|\|}|l|\1NNHNWNWH”H R [L’”S y Ou [hu[ [])C

White Pelican stack is locked—

""""""""" /ou can't make an
White pelicans have long beaks shaped like y‘( U e n‘[ :
scoops to help them catch wriggly, slippery changes to it.
fish. They hunt cooperatively, surrounding
fish in the water.

When they hatch, pelicans have no feathers
and need their parents to protect them from
the sun.

In the summer, pelicans like the openwater
of marshes in the northern United States and
southern Canada. They spend the winter in
Florida, California, and Mexico.

g

Figure 1-19  Working with a locked stack

You can use a locked stack and copy information from it, but if you
try to make any changes to it, the following dialog box appears:

Can't modify this stack.

(L)

Figure 1-20  Trying to make changes to a protected stack .

» Seealso: “Protecting Your Stack” in Chapter 2

30 Chapter 1: Using HyperCard Stacks




Cl()h’m}_’, astack  There are two ways to close a stack:

= Quit HyperCard. HyperCard saves any changes you’ve made to

the current stack before closing it and quitting,

= Open another stack. (See “Opening a Stack,” earlier in this
chapter, for instructions.) HyperCard saves any changes you've
made to the current stack before closing it and opening the
other stack.

< Before you close a stack: 1t’s a good idea to choose Compact Stack
from the File menu before you close a stack that you've changed
significantly. This rearranges the current stack on the disk,
removing any unused space so that it fits into the smallest
possible space. The Compact Stack command is always visible
‘ when your user level is Painting (3) or higher. You can make it
visible when your user level is Typing (2) by holding down the

K/

key while you pull down the File menu. «
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Looking
through stacks

Stack menus

Displaying the menu bar

One of the best ways to learn about HyperCard is to explore
stacks—including the stacks that come with HyperCard, and any
other stacks you can find. (The Preface gives information about
where you can get additional stacks.)

Many stacks have a button you click to learn about the stack.
[t usually looks like one of these:

iy R

Figure 1-21  Buttons you can click to get information about a stack

HyperCard allows stack developers to customize the menus that
appear with a stack. Therefore, you may encounter stacks that have
one or more of their own menus. You see a stack’s custom menus
(if it has any) only when the stack is active. The Picture Puzzler
stack and the Addresses stack are examples of stacks with their
own menus.

Customizing menus requires a knowledge of HyperTalk and
external commands (XCMDs). For information about customizing
menus, see the Scripter’s Tools stack.

If you use stacks other than the ones that come with HyperCard,
you might encounter stacks in which the menu bar is hidden. To
see the hidden menu bar, press the ¢ % key and the Space bar at th
same time. To hide the menu bar again, press = —Space bar again.
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Moving around in a stack

This is the Browse
tool. Use it for
clicking buttons
to browse
through stacks.

Moving around in HyperCard stacks—moving from card to card,
& ypP &
going to other stacks, and so on—is called browsing.

There are several ways to browse through stacks:

s Choose commands from the Go menu (or type their “-key
equivalents).

» Click icons on the Go palette.

» Click buttons or text in the stack.

m  Press arrow keys on the keyboard.

= Iype commands in the Message box.

» Use the Find command to search for specific text.

To browse through stacks by clicking buttons, you must first choose
HyperCard’s Browse tool ().

o
5| 7
P d Pl
] . (.

e
0
[

Figure 1-22  Choosing the Browse tool

% Cant see the Tools menu? 1f you can't see the menu bar, you can
make it appear by pressing ( —Space bar. If you can see the
menu bar but not the Tools menu, you can make the Tools
menu appear by changing your user level to Painting, Authoring,
or Scripting. (For instructions, see “User Levels and Options,”
earlier in this chapter.)

The techniques for browsing are described in the sections that
follow.
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Using commands in the Go menu

You can use the commands in the Go menu to look through cards
in the current stack, look for specific text, go to another stack, or go
back through cards and stacks you've already seen.

6o I

Back g~
Home aH
Help 3?
Recent aR
First 31
Prey 32 .
Next 33
Last @y
Find... &F
Message aM
Show A11 Cards

Figure 1-23  The Go menu
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-key

Command equivalent
Back e~

Home -H

Help -7

Recent -R

First S-1or Ci-¢
Prev -2

Next 53

Last S-4or -
Find o-F
Message 3-M

Show All Cards  (No C key)

What the command does
Takes you back to the last card you saw.
Takes you to the Home stack.

Takes you to Help.

Lets you review up to the last 18 cards you saw.

Takes you to the first card in the current stack.

Takes you to the previous card in the current
stack.

Takes you to the next card in the current stack.
Takes you to the last card in the current stack.
Lets you search for specific text.

Lets you navigate by typing commands in the
Message box.

Shows you all the cards in the stack, one after
the other.

@ Prev versus Back: The Prev command takes you to the previous
card in the current stack; Back takes you to the card you last
looked at, which might be in another stack. <

The Back and Recent commands are explained in more detail in
“Looking Through Cards You've Seen,” later in this chapter.
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The cards in a stack are arranged as if they were looped on a ring,
When you're looking at the last card in the stack, choosing Next
from the Go menu takes you back to the first card in the stack.
When you're looking at the first card, the Prev command takes
you to the last card of the stack.

_Second card

j___ First card
—— g ———
e —

Last card

Figure 1-24 A stack is structured like a circular card file

Using the alternate Go menu and Go palette

An alternate Go menu that contains icons instead of words appears
if you press and hold the ( key while you pull down the Go menu.
The icons are equivalent to the commands in the regular Go menuy,
You can choose any of these icons by dragging and releasing the

mouse button, the same way you choose a regular menu command.

You can also “tear off ” the alternate Go menu (as shown in the
following figure) to create a moveable Go palette that you can leave
open while you work, so you have easy access to all the navigation
commands. To do this, hold down the ¢ key and drag down
through the menu, past the bottom or beyond either side.
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Edit LM Tools Objects

You can close the
Go palette by
clicking here.

To move

Je] ? the palette,

k 16[E DD i
o=

To tear off the alternate Go menu, Click any icon to
drag beyond the bottom or side choose the command
of the menu. it represents.

Figure 1-25 Tearing off the alternate Go menu

Clicking an icon in the Go palette does the same thing as choosing
the corresponding command from the Go menu:

Home Help

SO T

Back | Gg E o e Eall— Recent
|

| Last

First
Prev _ﬁ/ E Eill__ Next

ind O, | ] [

Message ‘Sh()w All Cards

Figure 1-26  The Go palette

You can make the Go palette disappear by clicking its close box.
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Clicking buttons to move around

A stack can have lots of different kinds of buttons. Some buttons
take you to another place in the stack (or to another stack) when
you click them. Other buttons make things happen right where you
are—a button might make a sound, make a message appear, or
create an interesting visual effect.

w Where are the buttons? You can find all the buttons on a card
(except those that have been deliberately hidden) by holding
down the (s and Option keys at the same time. Gray or colored

O

rectangles appear around the buttons. <

Clicking buttons is one of the most effective ways to explore a stack.
Here are some buttons that are commonly used for moving arou‘
in stacks:

Ka & © ol < Mk

First Previous Next Last Return Home
card in card in card in card in
stack stack stack stack

Figure 1-27 Navigating with buttons

 You click only once: One click is enough to make a HyperCard
button work—don’t double-click it. When you double-click a
HyperCard button, sometimes HyperCard saves the second
click until another card appears. Then you might find you've
accidentally clicked a button you didn't mean to click.
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Clicking text to move around

In some stacks you can click text in fields to make things happen.
For example, you can click a topic on the first card of the
HyperCard Help stack to see a list of related subtopics, and

then click one of the subtopics to go to a card that contains
information about it. Clicking text can do the same kinds of
things that clicking buttons can do.

Stacks that take advantage of this feature of HyperCard will
contain information about which text in the stack you might want
to click and why. Clicking text will have no effect unless the stack
includes a script that tells HyperCard what to do when a particular
portion of text is clicked.

Using the arrow keys to move around

You can move from card to card by using the arrow keys on the
keyboard. The way you use arrow keys to move around in a stack
depends on whether the Text Arrows option is selected on the User
Preferences card in your Home stack.

When the Text Arrows option is turned on, you must press the
Option key along with the arrow keys to move through cards.
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When Text Arrows When Text Arrow:

Togo... is turned on, press is turned off, press

To the previous card in the
current stack

To the next card in the
current stack

Back through cards you've
seen

Forward through cards
you've reviewed

Figure 1-28 Navigating with arrow keys

P Secalso:  * “The Text Arrows Option” in this chapter
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Going to a specific card

If you know the name, number, or ID of a specific card in a stack,
you can go to the card directly by using the Go command in the
Message box. (You can use the Message box to send instructions to
HyperCard.)

You can find the name, number, or ID of the current card by
choosing Card Info from the Objects menu. (To see the Objects
menu, you must have your user level set to Authoring or Scripting.
“User Levels and Options,” earlier in this chapter, gives instructions
for changing your user level.)

The card’s name

yd

Card Nome: [JTITYRNS |

Card ID: 3046. Card number 1 out of 7

The card’s number

The card’s [D

Contains 0 card fields.
Contains 3 card buttons.
G2 Can't Delete
[JDon't Search

(Script...] (Colors...] ( 0K ]] [Cancel)

Figure 1-29  The Card Info dialog box

To get to a specific card from any other card in the same
stack (or from another stack, such as the Home stack), follow
these steps:

1. Open the Message box (if it isn’t already open).
Choose Message from the Go menu, or press C5-M.

2. Type any of the following, substituting the name, number, or
ID of the card you want to go to:
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D+ "To o to the card with the

go to card "card name" specified name in the
current stack

[ To go to the card with the

go tocard specified number in the

current stack

[T To go to the card with the
go to card ID 16724 specified 1D in the current

stack

D To go to the card with the

go to card "card name" in stack "stack name" —— specificd name in the

specified stack. (Specify
the stack name only when

the card you want to (‘

is in another stack.)

Figure 1-30  Going to a specific card

3. Press Return or Enter.

To hide the Message box, click its close box or press ~-M again.

Seeing all the cards in a stack

You can take a quick look at a stack by flipping through all of its
cards quickly. The easiest way to do this is to choose Show All
Cards from the Go menu. But you can also use the Message box
to flip through the cards in a stack. Follow these steps:

1. Open the Message box (if it isn't already open).
Choose Message from the Go menu, or press “-M.
2. Type show all cards and press Return.

HyperCard shows you all the stack’s cards quickly, one after
the other.
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Looking for specific text

To hide the Message box, click its close box or press . -M again.

[f you want to stop flipping through the cards, cither press the
mouse button or press - ((-period). (This will also stop the
action if you choose Show All Cards from the Go menu.)

Some stacks have a button you can click to see all the cards. It
usually looks something like this:

Figure 1-31 A button for flipping through the cards in a stack

You can also move around in a stack by asking HyperCard to find
specific field text. This makes it easy to find just the information
you need in a stack—no matter how large the stack is.

When HyperCard searches for specific text that you’ve asked it to
find, it pays no attention to case or to diacritical marks: “apple
Compiiter,” “apple computer,” and “Apple Computer” are all
considered the same.

You can search an entire stack for the text you want, or search only

in a specific background field.

Finding field text anywhere in a stack
1. Choose Find from the Go menu, or press _-E

HyperCard displays the Message box with the Find command
In it:

A 0
Find "' The insertion point

Figure 1-32  Searching for text
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2. Type the text you want to find.

Make sure the text you want to find is between the quotation

marks that appear after the word “Find” in the Message box.
3. Press the Return key or the Enter key.

HyperCard displays the first card containing a word or words
that begin with the specified text. (It looks for the first card with
a field that contains everything between the quotation marks,
even if the words are in a different order or in different fields).
HyperCard puts a box around the first word that starts with

the text you're looking for.

If HyperCard can't find the text, it beeps. If this happens, chec&
the text in the Message box for typos and spelling errors.

4. If you want to find the next occurrence of the same text, press
Return or Enter again.

You can repeat this step as many times as you like to find
additional occurrences of the same text.

To stop a search in progress, press C-. (C/-period).

+ Note: HyperCard won't look for text in fields for which the
option Don't Search is selected in the Field Info dialog box.
It will also exclude from the search all fields that belong to
backgrounds for which the Don’t Search oprion is selected in
the Bkgnd Info dialog box, and all fields on cards for which
Don't Search selected in the Card Info dialog box. < ‘

Once you're through with the Message box, you can close it by
clicking the close box in its upper-left corner. The next time you
choose Find, the Message box reappears with the Find command
in it—and the last text you typed between the quotation marks is
selected. You can search for the same text again by pressing Return
or Enter. To search for different text, just type the text you want to
find and press Return or Enter.
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10 speed your search: 1f you’re looking for specific text in a very
large stack, it’s best to give HyperCard a large enough portion of
the target text to distinguish it from other text in the stack’s
fields. This prevents HyperCard from displaying cards that don'’t
actually have the text you’re trying to find. HyperCard finds text
faster when you specify the target text in strings of three
characters or more, not counting spaces.

Finding text in a specific background field

[f you want to search for text only in a specific background field,
you need to know the name, number, or ID of the field. To find
out a field’s name, number, or ID, first choose the Field tool from
the Tools menu, and then double-click the field. (You must have
your user level set to Authoring or Scripting.)

Field Name: | } The field"s name
Bkgnd field number:1  Bkgnd field ID: Y4 The field’s ID
Olteoklert—\gete: (S

[JAuto Tab The field’s number
[JDon't Search [ Show Lines

[IShared Text [Iwide Margins

(Script.‘.] [Colors...] [[ 0K ]] [Cuncel]

Figure 1-33  Finding out a field’s name and number

To search for text only in a specific background field, follow
these steps:

1. Choose Find from the Go menu, or press -E
2. Type the text you want to find.
3. Click after the last quotation mark in the Message box.
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4. Type a space, then type in background field and the
name (in quotes), number, or ID of the field in which you
want to search.

If you type the field name, enclose it in quotes.

e
Find "Hong Kong" in background field "Headquarters"

Figure 1-34  Searching for text in a specific field

5. Press the Return key or the Enter key.

HyperCard displays the first card containing a word (or words,
in the specified background field that begins with the specified

text, and puts a box around that word.

If HyperCard can't find the text, it beeps. If this happens, check

the text in the Message box for typos and spelling errors.

6. To find the next occurrence of the same text, press Return or
Enter again.

You can repeat this step as many times as you like to see
additional occurrences of the same text.

To stop a search in progress, press -, (C-period).

s Note: HyperCard won't look for text in fields for which the
option Don’t Search is selected in the Field Info dialog box. ®
It will also exclude from the search all fields that belong to
backgrounds for which the Don't Search option is selected in
the Bkgnd Info dialog box, and all fields on cards for which

Don't Search is selected in the Card Info dialog box. <

Finding a whole word or phrase

To search for a specific whole word or phrase in any field in a stack,

follow these steps:

46 Chapter 1: Using HyperCard Stacks




1. Press ¢ (-Shift-E

The Message box appears with the Find Whole command in it

O 0
Find whole i

Figure 1-35  Scarching for a whole word or phrase

2. Type the word or phrase you want to find.
3. Press the Return key or the Enter key.

For the Find Whole command to find a match, all the characters
must be in the same field on a card, and they must be in the same
consecutive order as they appear between the quotation marks.
For example,

Find Whole "Apple Computer"

tells HyperCard to find cards that have the phrase “Apple
Computer” in a field—it won't find “Apple Computers” or
“This apple is a computer.” (The Find command without Whole

would find matches for all three cases.)

Find Whole won't stop on cards that have only partial matches. For
example,

F'ind Whole "kd"
won't find “Edward.”
To stop a search in progress, press - -, (' -period)

As with Find, you can use Find Whole to search for text in a
specific background field (as described in the previous section).

The HyperTalk Help stack describes other ways to search for text in
background fields, including searching for a specific string (that is, a
specitic sequence of characters, regardless of word breaks) and for
individual characters.
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Moving from one stack  You can move easily from one stack to another using any of the
to another  following techniques:

» Click a button that’s linked to the stack (if there is such
a button).

s Choose Message from the Go menu, type go " stack name",
and press Return. (Replace stack name with the name of
the stack.)

s Choose Open Stack from the File menu and use the directory
dialog box to locate and open the stack.

w [f the stack is represented by a button on one of the Home cards,
you can press ()-H to go to the Home stack, then go to the
Home card that contains the stack’s button and click the buttc‘

Looking through  As you go from card to card and stack to stack, HyperCard
cards you've visited  automatically keeps a record of where you've been. When you want
to back up and review the cards you've visited, you can do either of
the following:

» Choose Back from the Go menu, or press Tilde (-) or Esc, to
g0 to the last card you visited, no matter what stack it’s in. To
continue retracing your steps, choose Back (or press Tilde or
Esc) again. You can review up to the last 100 cards you visited,
in the reverse of the order in which you viewed them.

2w If the Tilde key doesn't take you back: Chances are you have
one of the Paint tools selected. While you're working with @)
the Paint tools, press (2~ Tilde to go back to the last card you
visited. (Pressing Tilde alone while using a Paint tool undoes

your last action.)

After you review the cards, you can press the Up Arrow key to
come forward again through the reviewed cards (or press
Option—Up Arrow, if Text Arrows is selected on your User
Preferences card).
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m  Choose Recent from the Go menu to see miniature versions of
the cards you’ve visited most recently—up to the last 18 cards
you looked at (as shown in the following figure). A card
miniature appears just once, even if you've visited the card more
than once. Click a miniature and then click OK (or double-click
a miniature) to go to the card it represents:

Double-click any miniature to go
to the card it represents.

This is the card you were looking at
when you chose Recent.

Figure 1-36  Using Recent to go back to cards you've visited

To return to the card you were looking at when you chose
Recent, double-click the miniature that has a box around it,
press Return, or click OK.,
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Returning Home  No matter where you are in HyperCard, you can always get back to
the Home stack. Here are four ways to do it:

Choose Home Press -H. Click any button Choose Message
from the Go with the house from the Go
menu. icon, or another menu, type
button that's Jo "Home",
linked to the and press
[Home stack. Return.
Figure 1-37  Returning to the Home stack ’

When you return to the standard Home stack (the one that comes
with HyperCard) using any of these methods, you return to the
Home card you visited most recently—that is, the last Home card
you saw the last time you were in the stack.

You can also go Home by choosing Open Stack from the File menu
and using the directory dialog box to locate and open the Home
stack. This method always brings you to the first Home card,
regardless of which Home card you visited most recently.

Eflt@ﬁﬂg {eX{ The most common way to add text to a card is by typing into ﬁch’

& Check your user level: 'To type and edit text in stacks, you must
have your user level set to Typing (2) or a higher level. If you
need instructions for changing your user level, see “User Levels
and Options,” earlier in this chapter. «
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If your user level is Painting (3) or higher, you must choose the
Browse tool () from the Tools menu (if it isn’t already selected)
before you can type text in fields.

Choose this tool (o
totype textin [

fields. .. |l-a |9 l'r?

i ||~

] o] [

O

- not this ool — A ] P

. Figure 1-38  Choosing the Browse tool

When your user level is Typing (or higher), the Browse tool
becomes an I-beam (1) when you move it over a field you can

type in:

The I-beam pointer over
an editable text field.

Company

Address |

Stacknfo  Calendsr  Home

Figure 1-39  The I-beam pointer for typing and editing text

To enter text in a field, just move the I-beam over the field, click in
the field, and type. You edit field text in HyperCard the same way
you edit any Apple IIGS text—you can click anywhere in the field
and begin typing, or drag to select text for copying, pasting,
deleting, or replacing.
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o

Opening
applications

To fix typing mistakes while you're editing text in a field, do one of
the following:

s DPress the Delete key to delete characters to the left of the
insertion point, one character at a time.

» Drag the [-beam over the incorrect text to select it, and then
retype or delete it.

While you're editing text in a field, choosing Undo undoes all the
changes you've made since the last time you clicked in the field to
edit. Therefore it’s not a good idea to use Undo to fix typing
mistakes, unless you want to retype everything you've typed since

you last clicked in the field. To fix editing mistakes, it’s better to use
the Delete key, or select the incorrect text and retype or delete it. o
To save the changes in a field (so that Undo can’'t undo them), click
anywhere outside the field.

You can launch an application from HyperCard by following
these steps:

—_—

Open the Message box (if it isn’t already open)

Ch()OSC MCSS&gG ﬁ‘om th@ Go menu, Or press ) -M.

N

Type one of the following messages in the Message box,

substituting the names of the application and document you

want to open: .

O

open "application” This launches the

specified application.

This launches the
0 specifie(l :lpplicu[ion

open "document" with "application" ———————and opens the
specified document,

Figure 1-40  Opening an application

Chapter 1: Using HyperCard Stacks




Getting help in
HyperCard

3. Press Return or Enter.

4. 1f HyperCard displays the directory dialog box and asks you
where one of these files is, use the dialog box to locate and
open the file.

When you quit the application you’ve opened, you return to the
card in HyperCard from which you launched the application.

You might encounter stacks with buttons that launch applications.
When you launch an application by clicking one of these buttons
on a card, you return to the same card in HyperCard after you quit
the application.

» Secalso: o “Customizing Your Home Stack” in Chapter 2

While you’re working in HyperCard, you can always get immediate
assistance from the HyperCard Help or HyperTalk Help stacks.
These stacks provide the following types of information:

= HyperCard Help covers HyperCard tasks through the
Authoring level.

s HyperTalk Help provides reference and conceptual information
about HyperTalk, HyperCard’s script language. (For
information about how you might want to use HyperTalk,
see the Hyperlalk Beginner's Guide.)

There are several ways to get to the HyperCard Help stack:

m  Choose Help from the Go menu.

m Press (-2,

m Iype Help in the Message box and press Return.

» Click the Help icon on the Home card called Welcome (in

the standard Home stack).
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Once you’ve opened the HyperCard Help stack, it shows you how

to find the information you need.

[f you need help using HyperTalk, click the HyperTalk button at
the bottom of any card in the HyperCard Help stack to go to the
HyperTalk Help stack.

Although there’s some overlap between the material covered in this
book and the information in the HyperCard Help stack, these two
sources of information give different kinds of help:

» This book gives more details on some topics than the
HyperCard Help stack does. Turn to this book when you need
a more thorough discussion of a topic. To find information
quickly in this book, look up the subject in the Index O

or Contents.

s The HyperCard Help stack provides immediate assistance on
your computer’s screen and gives concise instructions for tasks.
You can use HyperCard Help when you've forgotten some
procedure you read about in this book, or when you want a
quick overview of a feature that’s unfamiliar to you. The
HyperCard Help stack uses HyperCard’s features to explain
HyperCard and provides an excellent example of what
HyperCard can do.
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USIHg a stack [f your Apple 1IGs is part of a network that includes AppleShare file
on a ﬁ]e server servers, you can use HyperCard stacks stored on file server volumes.
/ However, you need to be aware of the following considerations

when you use stacks on a file server:

= Aswith any file on a file server, you must have the appropriate
access privileges to use the stack. For information about access
privileges, consult your network administrator.

s If the stack is on a locked medium—a locked disk, a CD-ROM,
or a locked folder on the file server—or if it’s locked in the
Finder (that is, if its Locked option is selected in the Icon Info
dialog box), any number of network users can use the stack at
the same time. However, no one can make changes to the stack.

@ = When a stack is unlocked on a file server, only one person can
use it at a time. This user can make changes to the stack, but
others cannot open the stack while it’s in use.

The AppleShare network software uses a lot of your computer’s
random-access memory (RAM), which means there is less memory
available for HyperCard to use. Depending on how much RAM
you have installed in your computer (and on several other factors,
such as the number of desk accessories installed in your system), you
may find that HyperCard behaves in unexpected ways while you're
using the Paint tools or playing complex sounds. For more
information about such symptoms and what to do about them, see
“HyperCard and Your Computer’s Memory,” earlier in this chapter.

J
S
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USlng A Stack  You can use any HyperCard stacks you have on a CD-ROM
on a CD-ROM (compact disc) just as you would other stacks. However, changes
you make to a stack on a CD-ROM won't be saved. If you want
your changes saved as you work, be sure to copy the stack to an
unlocked disk and open the stack from the unlocked disk.

I’s best not to run HyperCard itself from a CD-ROM (or from
any other locked medium), or use a Home stack that’s on a locked
disk. Although you can't damage anything by doing this, you might
encounter some annoying problems, like the following:

s [fyour Home stack is on a locked disk, HyperCard can't update
the Home stack’s Search Paths card when you tell it where to
find stacks via the directory dialog box. Therefore, it never learns
where your stacks are and has to keep asking you to locate stacifff)
when you want to open them.

»  When you’re running HyperCard from a locked disk and you
launch an application, HyperCard returns you to the first card of
the Home stack when you quit the application, instead of the
card from which you launched the application. This is because
HyperCard can’t mark your place when you leave, as it would if
it were on an unlocked disk.
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QUlttlng Hypel‘Cﬂl‘d "To quit HyperCard, choose Quit HyperCard from the File menu,

or press  -QQ.

HyperCard doesn’t ask whether you want to save changes, because
it saves your information automatically as you work.

New Stack...

Open Stack... &0
Save a Copy...

Compact Stack
. Protect Stack...
Delete Stack...

Page Setup...
Print Card aP
Print...

Quit HyperCard

Figure 1-41  Quitting HyperCard
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i Chapter 2

Creating and
Moditying Stacks

’I:lis chapter provides examples of the kinds of stacks you can
create, tips for modifying existing stacks, and instructions for
creating a new stack. This chapter also describes how to customize
the standard Home stack that comes with HyperCard.

To do the tasks in this chapter, you must have your user level set
to Authoring or higher. For a few of the tasks, your user level must
be set to Scripting. When a task requires the Scripting level, the
instructions say so. (For instructions on setting your user level,

see “User Levels and Options” in Chapter 1).
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Cr eatmg stacks  Once you've learned to get around in HyperCard, you can begin
thinking about the kinds of stacks you might want to create. You
don't need any programming experience to create stacks. Using
HyperCard’s tools, you can combine text, graphics, and numbers
according to your own specific needs; and you can add buttons to
link related pieces of information.

Figures 2-1 through 2-5 show cards from stacks people have created
with HyperCard. These cards give you an idea of the kinds of stacks
you can build:

You can type name, address, and
phone number information here.

You can click these
John 8. Bloom ~—T T b look f
Greenhouse Industries . u_ttons [,O voKtor
. information or to
§823 Quffodi] How Look For.. | add or delete
Weed Show Notes Cards
New Card
“ Delete Card
A | | 89647 .
g Teleon X — This button
0 . il elephone | | 555-9087 —————Sm — , .
This button dials i Telephone | | 395-9087 ‘E_ — L= takes you to the
the phOﬂC number “‘ ................................... ﬂ 55 % * Home S[aCk.
Sl]()wl] t() rh(‘ l(‘_‘ft‘ 1 ﬂ Stxklnfﬂ ulemr mm ﬁ
[ ——
This button This button
gives you takes you to
information the Calendar
about the stack.  stack. ‘

Figure 2-1 A stack that helps you keep track of phone numbers and addresses
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You can type |

information about the
catalog item here,

This button takes you —-l—ﬁm

to the Home stack.

This button allows you to
find time zone information
about a country by typing its
name in a dialog box.

This button allows you to
specify your own location and
other information needed to
calibrate the stack.

This button takes you __

to the Home stack.

The name of the
catalog item

A picture of the
catalog item

PN 456-A Sprocket

The 456-A sprocket is wsed
Jprisarily on bicyeles-specifically
on single-speed rear vheel types
of 10-speed bicycles.

This type of sprocket is
sanufactured in over 20 different
sizes for the bicycle industry.

i

This button This button | This button
takesyouto  takesyouto takes you to
the previous  the next card the last card
card in this in this stack.  you saw.
stack.

Figure 2-2 A stack that catalogs information about bicycle parts

You can click any country shown on this map to see information
about the time zone(s) and current time(s) for that country.

Select a country on this map

Figure 2-3 A stack that provides information about time zones
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The text for each part of | Stacks can be [protected] in several different ways:

a lesson appears here.

This area is used for
illustrations or as a |

workspace.

This button shows
you information
about using the stack

You can type information |

about the record here,

This button prints
all the text for the
current lesson.

These buttons take you forward and back
through the parts of the current lesson.

This indicates the
current lesson's
difficulty.

Working with stacks Rdvanced /

Protecting Stacks - Protected Stacks

i l Intermediate
Beginner

The disk may be locl Ked thh the little black

etMeTry |

This button allows
you to try the
techniques taught
in the current
lesson.

Examples l

This button starts

This disk (4
is write-
protected.

This disk is
not write-
protected,

™ Introduction

m-ﬁ: thms Slossary J1__ndex_ £

This button
takes you to
a glossary.

This button
provides
information for
the teacher
about the
current lesson.

This button takes
you back to the
current lesson
from any other
part of the stack.

a demonstration.

This button takes
you to an index of
key words and
related lessons.

Figure 2-4 A stack that teaches schoolchildren how to use HyperCard

_ CATEGORY |
I Rock

| BRIIST
[ No Sisters

LTITLE
I Sound Rdvice

NOTES ‘ Index Sound

1. Blueprint for Trouble 4:10 Sort Quit
2. Totally Great 2:15

3. Roscoe's Family 3:30

Y. Talk tome in French 2:33
5. 8ibling Revelry 5:10

About this stack

This button takes
you to the next
card in this stack.

This button takes you
to the previous card in
this stack.

Figure 2-5 A stack that catalogs a record collection
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The card layer versus
the background layer

The stacks that come with HyperCard are examples of the kinds of
stacks you can create with HyperCard. You can explore these stacks
to find out how they work by using the techniques described in the
section “Examining a Stack,” later in this chapter.

The way a stack works is determined by its seripzs, which contain
instructions that tell the parts of the stack what to do. The
instructions are written in HyperTalk, HyperCard’s English-like
programming language. However, you don't need to know
HyperTalk to create scripts. For example, you can link a button

to another card without writing a word of HyperTalk. The button
will contain a script that tells HyperCard which card to go to—but
you don't have to know anything about how the script works to
make the button act the way you want it to.

If you decide you want to learn how HyperTalk scripts work, go
through the exercises in the HyperTalk Beginner’s Guide.

When you look at a card, what you see is a composite of two
layers—a foreground layer, called the card layer, and a background
layer. Both layers can contain text, buttons, and graphics. You see
the elements of both layers when you look at a card, as if the card
layer were a transparent layer in front of the background.
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The background layer

. What you see when you
TR S S look at a card is a

composite of the card
The card layer layer and the

background layer.

Figure 2-6  The background layer and the card layer

Any number of cards can share the same background. Each
background serves as a template for the cards that share it. The
elements in a background (that is, the buttons, text, and graphics)
appear in the same location on all the cards associated with that
background. If you want a button, field, or graphic to appear ona
number of cards, you put it in the background layer. Together, the
elements in a background give a similar appearance and function to

the cards that share the background.

You can see just the elements that are in the current background
by pressing B to go to the background layer. (This is equivalent
to choosing Background from the Edit menu.) Pressing ~-B
repeatedly moves you back and forth between the card layer and

the background layer. O
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5 File Edit Go Tools Objects Addresses When you're in
| the background
layer, the word
Background
appears in the
menu bar.

Zip Code |

Telephone |

When you're in the background layer,
you see just the elements that are in the
background—the elements in the card
layer disappear temporarily.

Figure 2-7  The background layer

The elements in the card layer appear only on that card:

This text changes from card to card—it’s part of the card layer. |

John A, Bloom =y Roberto Ortiz

—Lompany | Loavang] | 9
Address | Address | | 9f
how Notes
City City] | Minneapo
State State | | WX

Zip Code | | 67542

Telephone | 35

Zip Code

Telephone |

L

R

Stakinfo  Calendar  Home

Stacklofo  Colendsr  Home
B I

lThc other elements appear on all the cards—they're in the background layer.

Figure 2-8  Background elements versus card elements
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What buttons, fields, The elements you add to the cards and backgrounds of a stack
and graphics can do  determine how people will use the stack.

for youl “slacks = You can add buttons, which are rectangular “hot spots” you click
to make things happen. Buttons often link related information.
When you click a button that’s linked to another card or stack,
that card or stack immediately appears. The ability to link
information with buttons creates all kinds of interesting
possibilities, such as stacks that teach, stacks that let you play
a game, and stacks that present a report or a story.

[n addition to linking information, buttons can also play songs,
launch applications, perform calculations, control videodisc
players, and much, much more.

= To put text on cards and backgrounds, you can add text ficlds @
You can set the style of the text in a field by choosing from a
variety of type styles. You edit the text in a field just as you
would in any Apple 11Gs word-processing program. You can also
search for specific text in background fields.

= Graphics can enhance the visual appeal of a stack and help
communicate its purpose. You can add pictures, charts,
drawings, and other graphics to stacks. Draw them yourself,
copy them from the stacks that come with HyperCard (or from
graphics applications), or scan them in.
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[ ndex | sore T vuit ] o Name means “toolhed —=——
|lllmut1;lnsstuc-k Card?7 lm ‘ .I fish.” F{iﬁfﬂ

Buttons for navigating

. Figure 2-9  Examples of buttons, fields, and graphics in a stack

HyperCard comes with stacks that contain readymade buttons
and graphics that you can copy and paste into your stacks. The
readymade buttons contain pre-programmed scripts that can make
your stacks more useful. You don't need to know HyperTalk to
make these buttons work—you just need to understand what they
do, so that you can use them appropriately in your stacks.

You can combine buttons, fields, and graphics in any number of
ways to create a stack that looks and works the way you want it to.
Chaprters 4, 5, and 6 give detailed instructions for adding buttons,
fields, and graphics.
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Using HyperCard’s tools  To create and work with buttons, text, and graphics in stacks, you
use the tools in the Tools menu. You can have only one tool selected
at a time, and one tool is always selected while you're using

HyperCard.

]_ The General tools

| The Paint tools

Figure 2-10  HyperCard’s tools

The Tools menu appears when your user level is Painting;,
Authoring, or Scripting,.

The Tools menu contains the General tools and the Paint tools, as
shown in Figure 2-10. The General rools are for browsing, text
editing, and working with buttons and fields. The Paint tools are for
creating and editing pictures. If you’ve used an Apple IIGS paint
program, you know more or less how the Paint tools work. In most
cases, you choose the Paint tool, then drag to make it work. (The
Paint Text tool is an exception. To make it work, you first choose it,

then click and type.) o
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Figure 2-11
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The Browse
tool is for
hrowsing
through stacks
and editing
text.

The Selection
tool is for
selecting
graphics.

The Brush
paints with
the current
pattern or

color,

The Spray tool
spritzes paint
onto the
screen in the
current pattern
or color.

The Bucket fills
enclosed areas
or one-color
arcas with the
current pattern
or color.

The Paint Text
tool is for
typing text
that’s part of
a graphic.

2

The Button tool
is for working
with buttons.

The Lasso is
for selecting
nonrectangular
graphics.

The Eraser
erases the part
of a graphic
you drag it
over.

The Rectangle
tool draws
rectangles and
squares.

The Oval tool
draws ovals
and circles.

The Regular
Polygon tool
creates
polygons with
regular sides.

What the tools are used for

i

[

The Field tool
is for working
with ficlds.

The Pencil
draws thin,
free-form
lines.

The Line tool
draws straight
lines.

The Rounded
Rectangle
tool draws
rectangles
with rounded
corners.

The Curve tool
draws free-form
lines and
shapes.

The Polygon
tool creates
polygons with
irregular sides.

69




You can “tear off” the Tools menu (as shown in the following
figure) to create a movable 7oo0ls palette. To do this, drag down
through the menu, past the bottom or beyond either side.

bo Objects
=
| & You can close the Tools
& 2|7 palette by clicking here.
| [ | [ Tolmg)vedthe
| palette, drag
i” g g rer g ? from here.
-
A & || S
][] s ®
O [
AlD|E
To tear off the Tools menu, drag beyond Click any tool
the bottom or side of the menu. to choose it.

Figure 2-12  Tearing off the Tools menu

< A shortcut: You can make a Tools palette appear or disappear
quickly by pressing Option-Tab. «

To choose any tool in the Tools palette, just click it. (Depending on
the ool you select, the shape of the pointer might change.) The
Tools palette remains visible on your screen until you click its clos @
box, or until you press Option-Tab to make the palette disappear.

0 Chapter 2: Creating and Modifying Stacks




Even if you have the Tools palette open, you can still choose a tool
from the Tools menu (in the menu bar)—the palette reflects your
menu choice. It’s a good idea to leave the Tools palette open while
you're working on a stack, so you can see which tool is selected.

When you choose one of the Paint tools, three new menus appear:
Paint, Options, and Patterns. (These menus are described in
Chapter 6.) The Objects menu disappears while you're using a
Paint tool. It reappears (and the Paint, Options, and Patterns menus
all go away again) when you choose any of the General tools.

These three menus appear when
you have one of the Paint tools

selected.
@ —+—

File Edit Go Tools Paint Opti tt

Home Stack / Deskset User Name

20

User Preferences

Calendar

Selected Paint tool

A

Addresses

[ Basement
Figure 2-13  Menus that accompany the Paint tools

Chapters 4, 5, and 6 give specific instructions for using
HyperCard’s tools to create buttons, fields, and graphics,
respectively.
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Selecting buttons, fields,
and graphics

To select and work with the different HyperCard elements—
buttons, fields, and graphics—you need to use different tools. And
you select and manipulate one element at a time. You can't select
multiple elements.

To select a button, choose the Button tool (@) from the Tools
menu and click the button:

Choose the ...and then click
Button Tool . .. the button to select it.

3
1l
H
et |
Pl
S8
——
s
H
i

A
:

o= S When a button
: is selected. it's

surrounded by

a moving

: dashed line.

'Addresses:

Welcome

|

Figure 2-14  Selecting a button

Whether the button is in the background layer or the card layer,
you can select it from the card layer. When the button is selected,
it’s surrounded by a moving dashed line.
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To select a field, choose the Field tool (&) from the Tools menu and

click the field:
Choose the ... and then click
Field tool . . . the field to select it.
Zip Code ||| [89647___
Telephone | |:555-0087 =y
b oo =y
S o B
E LML LI AL A I ol I AN LA A ek a: ﬂ

}When a field is selected,
it's surrounded by a
moving dashed line.

Figure 2-15  Selecting a field

Whether the field is in the background layer or the card layer,
you can select it from the card layer. When the field is selected,
it's surrounded by a moving dashed line.
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There are many different ways to select a graphic. Generally, you
choose either the Selection tool (:2) or the Lasso (+) from the Tools
menu and drag to select the graphic:

and then drag

diagonally with the

Selection tool Or drag around the
from here . .. graphic with the Lasso.

Choose the
Selection tool

orthelasso...__/__/

... to here.

Figure 2-16  Sclecting a graphic

P Seealso: “Selecting a Graphic” in Chapter 6
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Planning a stack

Before you begin building a stack, you should have a clear idea
of who will use the stack and what you want the stack to do.
Knowing your audience and the scope of your stack can help you
make decisions about the design of your stack—both before you
start and while you’re building it.

If you expect your stack to be used by other people, make sure you
know what they will use your stack for, and in what context. Find
out what your users already know, how much experience they have
with computers and HyperCard, and what their reading level and
attention span might be.

An understanding of the stack’s users can help you decide how to
present the information in the stack, how much text and how many
graphics to use, and how to structure the stack. For example, a stack
for teaching children geography skills might require lots of pictures,
a simple and consistent way to navigate through information, and
frequent reinforcement. Depending on your stack’s subject marter,
you can choose from a variety of presentation methods—including
a slide show, a tutorial, a game, or an interactive story.

Before you begin building a stack, it’s a good idea to draw a map
showing the structure of the stack, which cards are linked together,
and how users will move through the stack. If the map looks
confusing, it’s probably an indication that the resulting stack will
be confusing and difficult to use, and you might want to consider
simplifying the stack’s structure.

< Keep your stack simple: Adding lots of buttons and links in your
stack won't necessarily make information more accessible—
users can get lost or confused easily in a stack that has too
many links. «
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The stack-building
process

Building a stack involves deciding how to present and structure the
information (as discussed in the previous section, “Planning a
Stack”) and carrying out your design decisions by creating cards,
backgrounds, buttons, text fields, graphics, and links between
related pieces of information. (Chapter 3 explains how to create
cards and backgrounds; Chapters 4, 5, and 6 give details about
creating buttons, text fields, and graphics, respectively.) Most of
your stack-building time will be spent on the details of integrating
text and graphics, and making the stack easy to navigate.

As you build a stack, it’s important to evaluate it frequently, to

make sure it still does what you’ve designed it to do. To evaluate a
stack, try it out yourself. See if you can accomplish the tasks for
which the stack is designed without getting lost or feeling confused@

[f the stack will be used by others, show it to people who are similar
to your users in background and level of computer experience. Give
them specific tasks to perform, and watch and listen carefully—
without interfering—while they try the stack.

As you evaluate the stack (and watch others use it), keep the
following questions in mind:

m s it clear what the stack is for and how to use it? The text,
buttons, and visual images in the stack can communicate a lot
about the stack’s purpose. They should be understandable and
consistent (in appearance and behavior) and should clarify the
purpose of the stack. If the stack is confusing, think abour ways
in which the text, buttons, and visual images can be improved ()
create a clearer visual message. The stack should also give the
user appropriate feedback (for example, most buttons should

highlight when they’re clicked).
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= [siteasy to get around in the stack? Make sure that, as you use
the stack, you can tell where you are, how you gort there, how
to get back to where you came from, where to go next, and
how to leave. If it’s easy to get lost or trapped in the stack,
consider reducing the number of links, or simplifying or
clarifying the navigation scheme (for example, by using a
standard set of navigation buttons on each card).

= Do the features work correctly? Test the buttons to see if they
take you where they’re supposed to in all circumstances. Make
sure each field is visible and unlocked if the user needs to see it
and type in it, or locked if the user just needs to read or click
text in the field. The stack should prevent the user from
‘ losing information and make it clear when an action will
not be reversible.

m  Does the stack require a particular user level? The features
available to a user vary with the user level (as explained in
“User Levels and Options” in Chapter 1). Try using the stack
at every user level. If it has any features that require a certain
user level, make sure the stack either sets the appropriate user
level (through the stack script) or tells the user to set the
appropriate user level. (The HyperTalk Help stack describes

how to set the user level through a script.)

Obraining periodic evaluation and feedback from typical users is
an important part of building a stack. It’s a good idea to begin
evaluating a stack early in its development. HyperCard makes

O it easy to build a prototype of your stack that you can use for
gathering preliminary feedback from users. Be prepared to make
changes to the stack to fix problems and incorporate ideas that
grow out of your evaluation and user testing.

When you've finished building a stack, put it through a final test,
checking all of the points listed above.
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For more detailed information on designing a stack, consult
the HyperCard Stack Design Guidelines (available from
Addison-Wesley).

MOdlleng AN Modifying stacks created by others is not only a great way to learn

CXiSting stack ab'()ur HyperCard—it’s also a good way to get stacks that are
tailored to your needs. There are lots of ways to customize an
existing stack. You can add text and pictures and create new links
between pieces of information. You can make new cards and cards
with new backgrounds or change any of the elements of a stack in
any way you like. You can even delete any elements you don’t want.

This chapter includes the basic information you need to create anc’
modify stacks. Chapter 3 describes how to create and manipulate
cards and backgrounds. Chapters 4, 5, and 6 give details about
working with buttons, fields, and graphics, respectively.

If you want to modify stacks created by other people, you should be
aware of the following considerations:

a Each object in a stack—that is, each button, field, card, and
background, as well as the stack itself—can have a script
attached to it. Scripts contain instructions that tell the different
objects in a stack what to do. The scripts that belong to the
different objects in a stack often interact with other objects and
their scripts. When you delete any object that contains a script,
or move it to another part of the stack, its script goes with it. If ‘
other scripts rely on that object or its script (or vice versa), you
may find that your stack behaves unexpectedly after you've
moved the object. For example, you might see messages that
begin with “Never heard of . . .” or “Can’t understand. . . .”
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If you see such messages (or other strange behavior) in a stack
you're modifying, the stack’s scripts probably refer to objects
that you’ve changed in some way. If you're familiar with
HyperTalk, you might be able to fix or rewrite the scripts.
Otherwise, consider modifying a different stack or creating a
stack of your own. (If you want to learn HyperTalk, see the

Hyperlalk Beginner’s Guide.)

= Asyou modify a stack, HyperCard saves your changes

automatically—without asking. Therefore it’s a good idea to
make sure you have a backup copy of a stack before you begin
changing it, so that you can get back to the original if you need
to. It’s also a good idea to save a copy of your modified stack

O periodically while you’re working on it. That way, if you make
a mistake that “breaks” the stack, you can go back to a recent
version (rather than starting all over again).

= Some stacks are protected, which means you can’t change them.
A small padlock (a) appears in the menu bar when you’re in a
protected stack. In some cases you can remove a stack’s
protection by using the Protect Stack command in the File
menu. (“Protecting Your Stack,” later in this chapter, tells you
how.) However, in stacks that have a password, you can’t change
the stack’s protection setting unless you know the password.
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Examining a stack

Before you begin modifying a stack, you can find out what makes it
work by examining its parts. The Objects menu contains some
commands to help you do this—Button Info, Field Info, Card
[nfo, Bkgnd Info, and Stack Info. Each of these commands presents
a dialog box that shows the characteristics of the pertinent object
(the selected button or field, or the current card, background, or
stack)—including the object’s name, number, and attribute settings.
Through these dialog boxes, you can learn about the objects ina
stack, look at their scripts, and change their attributes.

% 10 look at scripts: You must have your user level set to Scripting.
“User Levels and Options” in Chapter 1 explains how to change
your user level. <

To locate and learn about the buttons in a stack, follow these step.
1. Choose the Button tool (=) from the Tools menu.

Rectangles appear around the buttons that don't already have

an outline:

When you
choose the ... rectangles appear
Button tool . . . around the buttons.

‘ references |

Picture Puzzler

T

Tour Story Board

Copyright © 1990 Apple Computer, Inc.

| ST [ Deskeer |[ ToolKit ][ Auic ][ Bosement |

Figure 2-17  Choosing the Button tool
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2. 'To get information about any button, click to select the
button, then choose Button Info from the Objects menu.

Or simply double-click the button. The Button Info dialog box
appears:

This option allows you to display
the button’s name on the button.

These options determine ~ The button’s name
the button's highlighting Button Name: [GTXTONT | The button's number
behavior. (The Share Hilite Bkgnd button number: 17 Bkgnd button ID: 2

~ The button’s ID

option is active only for [ Show Name Style:

background buttons.) [T P,
' Ruto Hilite AN The selected style
| | Clhucokilite he selected sty
This lets you assign an (< Share Hilite of the button
. icon to the button. Click here to set
This links the button @k To...] u""h ] the text format

to another card or stack.

for the button.
@ipt...] @10"5~-) (! 0K il | Cancel ) prihebution

Click here to close the
dialog box without
Click here to see This lets you assign saving any changes.
the button's script.  colors to different parts

of the button.

Figure 2-18  Getting information about a button
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To locate and learn about the fields in a stack, follow these steps:
1. Choose the Field tool (1) from the Tools menu.
Lines appear in all the fields:

When you choose ... lines appear
the Field tool . . . in the fields.

Figure 2-19  Choosing the Field tool
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2. 'To get information about any field, click the field to select it,
then choose Field Info from the Objects menu.

Or simply double-click the field. The Field Info dialog box

appears:
, The field’s name
These options allow you Field Name:  [FFTRNITIE | The field’s number
to lock the field, prevent Bkgnd field number: 2" Bkgnd field ID: 3\ The field’s ID
searching in the field, [ Lock Text Style: [_transparent § The selected
and more, (1 Auto Tab style of the field
[(—J0on't Search [ Show Lines
Click here 1o set H]x'.ln‘\\ [1Shared Text [ Jwide m,,»gm_sl 'l‘ilk‘.\k‘()[)li()ll«\ allow you
tormat for the field. to display lines in the
lick here to see : field and add margins.
‘ Q]hdf\“ hlglla o see (o) (Concel) g
the tield’s script.

This lets you assignl Click here to close the
colors to different  dialog box without
parts of the field. saving any changes.

Figure 2-20  Getting information about a field
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To get information about the current card, choose Card Info from
the Objects menu. The Card Info dialog box appears:

The card’s name

PRI Card Name: . .
The card’s ID N e cone y I [he card’s number
Card I1D: 3046. Card number 1 out of 7 The number of fields
Sele(‘[ [hlS ()P[i()n o Contains 0 card fle]ds\ in th€ Clll’d l'cl_\’t’f
Prf()[“[ ;hle (:"“'d Contains 5 cord buttons._ The number of
-om deletion. .
rom deletion B Can't Delete buttons in the
Select this option [J0on't Search card layer
to exclude the fields .
this card fir (Seript..) (Cotors.) ([ ok )} (Concel ) Click here to close the
on-this carctrom dialog box without
text searches. saving any changes. B

Click here to  IClick here to
see the card’s  see the card’s
script. color sets.

Figure 2-21  Getting information about a card

Chapter 2: Creating and Moditying Stacks




You can sce what's in the background layer of the current card by
choosing Background from the Edit menu, or pressing - -B. To get
information about the current background (whether or not you're
in the background layer), choose Bkgnd Info from the Objects
menu. The Bkgnd Info dialog box appears:

The background's ID - The background’s name
The number of

cards that share
Bkgnd N :I d .
\ nd Nome: [T | this background
Bkgnd ID: 2760. Shared by 5 cords.

Select this option

to protect the . ~
I'he number of

l)LlCl\'gl‘()Ulld Contains 3 background fields. welds in thi
from deletion. Contains 7 background buttons. fields in this
7 Can't Delet background
an't Delete
. Select this option [ JDon't Search The number of

to exclude the : K=B buttons in this
fields in this Cotors.) ) (concel ) background

background from

text searches.

Click here to  IClick here to Click here to close
see the see the the dialog box
background’s  background’s  without saving
script. color sets. any changes.

Figure 2-22  Getting information about a background
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To get information about the current stack, choose Stack Info from

the Objects menu. The Stack Info dialog box appears:

The stack’s name

Stack Name: | [T2N3 B

The disk and folder in Where: :HardDisk:HyperCard:
which the stack is stored

The number of cards

Stack contains 7 cards.

The number of Stack contains 2 backgrounds. in the stack
backgrounds in the stack Size of stack: 3K, The amount of disk space
The amount of free Free in stack: 0K, the stack requires
space in the stack
Click here to see the (SCFiDt..J [COlOI'S..J (( 0K ]] (CGDCEIJ
stack’s script. .
Click here to see Click here to close
the stack’s color the dialog box
sets. without saving

any changes.

Figure 2-23  Getting information about a stack
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Undoing your
mistakes

While you're working on a stack, you can usually undo your last
stack-editing action by immediately choosing Undo from the Edit
menu (or pressing - -Z). Choose Undo when you make a mistake,
or when you change your mind about your last action. (You must

choose Undo before doing anything else.)
Important: You can't undo the deletion of a button or field. 2

To undo typing mistakes while you're editing text in a field, do one
of the following:

= Press Delete to delete characters to the left of the insertion point,
one character at a time.

= Drag the I-beam over the incorrect text to select it, then retype
or delete it.

While you're editing text in a field, choosing Undo undoes all the
changes you’ve made since the last time you clicked in the field to
edit. Therefore it’s not a good idea to use Undo to fix typing
mistakes, unless you want to retype everything you've typed since
you last clicked in the field. To fix editing mistakes, it’s better to use
the Delete key, or select the incorrect text and retype or delete it.
To save the changes in a field (so that Undo can’t undo them),

click anywhere outside the field.

When you’re using one of the Paint tools, pressing the Tilde () or
Escape key is the same as choosing Undo. (The Paint tools are

described in Chapter 6.)
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M()dehng your StACK  You can model a new stack after a card or stack you like by copying
after an existing one its background. When you copy a background from an existing
o stack, you get the basic design of the original stack—that s, its
template—but not any of its data. For specific instructions on
creating a new stack that uses a background from an existing stack,
see the next section, “Making a New Stack.”

Before you decide whether to copy the background of an existing
card or stack, you can look at the background by going to that card
or stack and choosing Background from the Edit menu (or pressing
“_B). This takes you to the background layer and shows you just
the buttons, fields, and graphics that arc in the background.
(Pressing . -B repeatedly moves you back and forth between the

card layer and the background layer.) ®

& See the word Background in the menu bar? To make sure you're
looking at the background, check the menu bar. When you're in
the background layer, the word Background appears in the menu

The word
Background tells
you that you're
looking at the
hackground.

i Code | ;
Telephone | i ‘
— e |

G [ |

& 0 m

swki Gt tore

Figure 2-24  Looking at the background
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E\"Illking d NCwW S[Ll('l\' When you're ready to create a new stack, begin by following
these steps:

1. If you want your new stack to have the same background as an
existing card or stack, go to that card or stack.

The previous section, “Modeling Your Stack After an Existing
One,” discusses why you might want to copy a background
from another stack.

2. Choose New Stack from the File menu.

The New Stack dialog box appears.
3. Set up the New Stack dialog box for your new stack:
Your new stack will be stored in

this folder unless you choose
another folder.

~=2:HardDisk:HyperCard: ‘ .
1803 free of 20860 K. m Click here to view

New Folder the volumes that are

dhome currently available to
e HuperCordl 169 /
7 Stacks your computer.
% Your (lose

New Stack Name: q Create !)
Iype a name [HyStack ] ( Concel )

for your new [ICopy Current Background
stack here.

Click here if you want your new
‘ stack to have the same background
as the current card.

Figure 2-25  Creating a new stack

— Important: If you want your new stack to have the same
background as the current card, be sure you click the Copy
Current Background check box to select it. A
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4. Type a name for your new stack.
5. Click Create.

If you've selected the option Copy Current Background, your
new stack has all the same background elements as the card
you were looking at when you chose New Stack. Otherwise,
it’s blank.

As you build your new stack, your changes are saved automatically.

For instructions on adding cards and backgrounds to your stack, see
Chapter 3. For details about adding buttons, fields, and graphics,
see Chapters 4, 5, and 0, respectively.

Copying parts  Copying parts from other stacks can make stack building easier .

from other stacks  and save you a lot of time. If you see a button that does something
you like, or an attractive background picture, there’s no sense in
reinventing it—copy it and paste it into your stack. Two of the
stacks that come with HyperCard, Art Ideas and Button Ideas,
contain readymade parts you can copy and paste into your stacks.
The buttons in Button Ideas are designed to work independently in
a variety of stacks—they don't depend on your stack’s having any
particular characteristics. You can also paste fields, cards, and
backgrounds from any of the other stacks that comes with
HyperCard. (Chapter 3 gives instructions for copying cards and
backgrounds; Chapters 4, 5, and 6 explain how to copy buttons,
fields, and graphics, respectively.)

When you copy a button, field, card, or background from another
stack, its script comes with it (if it has a script). Scripts contain
instructions that tell the parts of a stack what to do. In most cases,
you want the script, because it makes the object work. (For more
information about HyperCard objects, see “Examining a Stack,”
earlier in this chapter.)
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However, the scripts that belong to the different objects in a stack
often interact with other objects and scripts. An object you copy
from another stack might have a script that relies on objects in its
original stack. Copying such an object can cause your stack to act
strangely. For example, you might see messages that begin with
“Never heard of . . .” or “Can’t understand. . . .”

If you're familiar with HyperTalk, you might be able to fix or
rewrite the object’s script. (The HyperTalk Beginner’s Guide teaches
HyperTalk at an introductory level.) Otherwise, consider deleting
the script (as described next), copying a different object, or creating
the object yourself. (For instructions on deleting and creating
buttons and fields, consult Chapters 4 and 5, respectively.)

If you copy a card or background that causes trouble in your stack,
and you can't fix the scripts, first try deleting the buttons and fields
on the card or background, one at a time. If the problem persists,
delete the script of the card or background by following

these steps:

1. Open the script.

To open the script of the current card, press (3-Option-C; to
open the background script, press (5-Option-B.

Select all the text in the script by pressing  "-A.

Press Delete to delete the script.

L

Press Enter.

+ Note: After you delete the buttons, fields, and scripts from a
card or background, you’re left with just the picture on that card
or background. Any functions associated with the card or
background are gone. <
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Getting information  You can use the Stack Info command to get information about the
about a stack  current stack and Change some of its characteristics.

Follow these steps to get information about the current stack:
1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (<), or the Field tool (£3)

will work.
2. Choose Stack Info from the Objects menu.
The following dialog box appears:

The disk and folder in

The stack’s name which the stack is stored .
Stack Name: |03 ]
The number of Where: :HardDisk:HyperCard: The number of
backgrounds Stack contains 7 cards. cards in the stack
in the stack Stack contains 2 backgrounds. The amount of disk space

The amount of free Size of stack: 43K, the stack requires

space in the stack Free in stack: OK.
Click here to close the
Click here to see (serint..) (Colors..) ok ) (Cancel) dialog box without
the stack’s script. saving any changes.

Click here to see or change
the color set specified for
the stack.

Figure 2-26  Getting information about a stack

3. When you’re finished, click OK.

% Another way to open the Stack Info dialog box: 1f you are using the
Home stack that comes with HyperCard, the following shortcut
opens the Stack Info dialog box for any stack you're working in:
While any General tool is selected, press ' '-M to open the
Message box, type s, and press Return. (This shortcut is built
into the standard HyperCard Home stack.)
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Numing astack  When you first create a stack, you type a name for it in the New
Stack dialog box. This is the name that appears for the stack in the
Stack Info dialog box and in the Finder.

HyperCard uses the stack name to identify the stack. You can use
the stack name in the Message box to navigate to the stack. (And
you use the stack name when you address the stack through scripts.)

You can change a stack’s name at any time (as long as the stack isn't
locked). Here’s one way:

1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (E2)
will work.

2. Choose Stack Info from the Objects menu.

3. Type a new name for the stack.

Stack Name: [T ] Type the stack name

here. (This name
also identifies the

Stack contains 1 cards. stack in the Finder.)
Stack contains 1 backgrounds.

Size of stack: 7K.
Free in stack: 0K.

[Scrim [Colors...) [L 0K j] Ll:uncelj

Where: :HardDisk:HyperCard:

Figure 2-27 Naming a stack

Follow the usual Apple IIGs naming rules for documents: Start
with a letter; use no more than 15 characters; don’t include
spaces; and don't use characters other than letters, numbers, or
periods. (If your Apple IIGs is part of an AppleShare network,
you have more choices. For more information, see the
documentation that came with your Apple 11Gs.)
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4. Click OK.

A Warning: Changing the name of a stack will break any links you've
made between a card in another stack and a card in the renamed
stack (it might even break links within the renamed stack itself).
When you change the name of a stack, be sure to redo all the links
to the stack. “Linking Information” in Chapter 4 gives instructions
for creating links. A

You can also change a stack’s name in the Finder:
1. In the Finder, locate the stack’s icon.

You might have to open folders or close windows to find O
the icon.

2. Click the icon once to select it.
3. Type a new name for the stack.

Changing the stack name here also changes it in the Stack Info
dialog box. Remember to follow the applicable naming rules.

4. Press the Return key.
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Changlng 4 Stack’s  The color set for a HyperCard stack determines the 16 colors
' color set currently available for use by the backgrounds, cards, buttons, ‘;md
tields in the stack. You can choose from among five color sets for
any given stack: the standard system color set, a gray scale color ser,
and three others.

When you change your stack’s color set, the colors of some or all
the graphics, buttons, and fields in the stack may change to reflect
the new colors. For example, these three images all make use of the
same graphic, but different color sets:

i
..ot
Ui

Gray scale color set

A pastel color set

Figure 2-28  The cffect of changing color sets
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If you wish, you can select color sets for the cards and backgrounds
in your stack that are different from the color set selected for the
stack as a whole. If a card’s color set has not been specified
individually, the card makes use of the color set currently selected
for its background. Similarly, if a background’s color set has not
been specified individually, the background makes use of the color

set currently selected for the stack.

For example, the cards in the Birds stack make use of several
different color sets so that the colors used in each drawing match
the bird’s true colors more closely. By carefully selecting the color
sets for cards and backgrounds in a stack, you can control the colors
in your stacks more precisely than would be possible with just one

color set. ‘

The instructions that follow describe how to change the color set
for a stack. You can follow the same basic steps to change the
color set for a card or a background from its Info dialog box (see
“Changing a Card’s Color Set” and “Changing a Background's
Color Set” in Chapter 3 for more details).

To change the color set for the stack you're working in, follow
these steps:

1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool ((3)

will work.
2. Choose Stack Info from the Objects menu. ®
3. Click Colors.

The Colors dialog box for the stack appears.
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4. Select the color set you want:

_ﬂispluy colors for stack "MyStack"
UIEHTEIY T 11 Stondord system colors
MY T 1 Gray scale

These are the l j ' Other color sets...
color sets that are i .
available for the .

TN T~ ]

current stack.
Click the one you
want to use . . .

When displaying this stack:

{_Use these colors ) ( ok ) (concel)

... then press and hold the mouse button here and drag to
choose “Use these colors” (if it's not already selected) from the
. pop-up menu. If you choose “Get standard system colors”
instead, your stack will use the standard system colors no
matter which color set is selected for the stack.

Figure 2-29  Changing a stack’s color set

5. When you’re finished, click OK.
The Colors dialog box disappears, and you see the Stack Info

dialog box again.
6. In the Stack Info dialog box, click OK.

If none of the five color sets for a given stack includes the colors you
want, you can add a sixth color set to a card or background in the

@ stack from any document in the Apple Preferred File Format.
“Importing a New Color Set for a Card or Background,” in
Chapter 6, describes how to do this.
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Saving a copy
of a stack

You can type a name
here for the copy of
the stack—otherwise,
HyperCard will save
the copy under the
name you see.

You can also add a sixth color set to a card or background by using a
desk accessory, an XCMD, or HyperTalk to specify the colors you
want. If you use a desk accessory or an XCMD to do this, the color
set you specify will be added automatically to the color sets for the
current card or background and will be selected. For instructions on
using HyperTalk to add a sixth color set to a card or background,
see the discussion of the colorset property in the HyperTalk
Help stack.

»  See also:

* “Changing Color Sets” in Chaprer 6

It’s a good idea to make a copy of a stack before you begin workin,
with it, and save a copy of the stack periodically as you make
changes to it. This is because HyperCard automatically saves the
stack as you work. (Your work is saved, and so are your mistakes.)

If you make a big mistake on your stack, you can recover from it
more easily if you have a recent, working version of the stack—

you won't have to start all over again.

Follow these steps to copy a stack from within HyperCard:

1. While the stack is open and active, choose Save a Copy from
the File menu.

The following dialog box appears:

[ '

~=:HardDisk:HyperCard:Stacks:
2545 free of 20860 k.

fief GE5

Your new stack
will be stored in
this folder unless
you choose
another folder.

( Voluwmes )
New Folder

{ oy
Save copy of stack in:

| | (Coneel )

Figure 2-30  Saving a copy of a stack
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2. Type a name for the copy of the stack, if you want to give it a
name that’s different from the one shown.

3. Click Save.

HyperCard saves a copy of the stack, but it leaves you in the
stack you’re working on.

You can also copy a stack in the Finder. Follow these steps:
1. In the Finder, locate the stack’s icon.

You might have to close windows or open folders to find the
icon.

2. Click the stack’s icon once to select it.
3. Choose Duplicate from the File menu, or press (*-D.

The Duplicate dialog box appears.
4. Click OK.

Redaiming free SPACE  Each time you delete a card, background, field, or button, free

in a stack  space gets introduced into a stack. As you work on a stack, it can
L .
accumulate a substantial amount of free space—and the more extra
space a stack has, the slower it runs and the larger it is.

Free space on a disk is available storage space. You can use it to store

@ information. But free space in a stack is like extra baggage in the
stack: It’s no longer useful, but it’s stored with the stack and it rakes
up disk space that you could be using to store other data. The more
free space you have in your stacks, the less disk storage you have for
your other files.
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The amount of disk
space the stack

is taking up
(including free
space)

To check the amount of free space in a stack, choose Stack Info
from the Objects menu. To see the Objects menu, you must have
one of the General tools selected.

Stack Name: | (ITERTN |

Where: :HardDisk:HyperCard:
Stack contains 1 cards.

Stack contains 1 backgrounds.

Size of stack: 7K. The amount of free space in the
stack. If you compact the stack,
this number will become 0
(Script..) (Colors.) (oK ) (Cancel) (zero), and the stack will get
smaller and run faster.

Free in stack: 0K.

Figure 2-31  Checking free space in a stack

You can get rid of free space in a stack by choosing Compact Stack
from the File menu. To use the Compact Stack command when
your user level is Painting (3) or higher, you must have one of the
General tools selected. (If your user level is set to Typing (2), hold
down the (" key while you pull down the File menu in order to see
the Compact Stack command. If your user level is set to Typing (1),
the Compact Stack command is not available.)

When you choose Stack Info after compacting the stack, the
“Free in stack” number (in the Stack Info dialog box) will be OK

(zero K), and the size of the stack will likely be smaller than it was @)
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Protecting your stack  When your stack is finished
it—you might want to protect the stack to keep others from using
or changing it. There are several different kinds of protection you
can set for a stack:

and perhaps while you're building

» You can keep a personal stack private by preventing others from
opening it.

= You can limit access to a stack’s protection settings (so that no
one else can change them).

= You can limit the way people use and change a stack.

Restricting access  To restrict access to a stack so that no one can open it without the
O to a stack  password, follow these steps:

1. Choose Protect Stack from the File menu.
The Protect Stack dialog box appears.

2. Click the Private Access check box to select it.

Protect Stack: Limit user level to:

. () Browsin
[C1can't modify stack !

(2 Typing
[JCan't delete stack (™) pginting
Click here . .. [ Private Access (Z) Ruthoring
(®) Scripting

... then click here, E 0K ]) (Cuncel)

. Lo restrict access to the stack.

Figure 2-32  Setting protection for a stack

3. Click Set Password, or click OK.

The dialog box for setting a password appears.
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4. Enter a password.

Type the password

Please enter a new password: once here
y L
I | ... and again here,
Please enter it again: for verification
y .
I | Then click OK.

/
( ok ) (concel) Clicking None or Cancel closes

D this dialog box without setting

AN AN a password.

Figure 2-33  Sctting a password for a stack
5. Click OK. O

A Warning: Once you've restricted access to a stack and set a
password, the stack can’t be opened without the password. There’s
no way to find out a password once it’s been set—so make a note
of the password, or use a password you won't forget. A

When you type the password to open the stack, it must match
character-for-character the one you set. (Uppercase and lowercase
letters don’t have to match.)

» Seealso: ¢ “Removing a Password” in this chapter
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P 1‘otec[ing a stack from  To prevent others from changing or deleting the current stack,
changes or deletion  follow these steps:

1. Choose Protect Stack from the File menu.
The Protect Stack dialog box appears.

2. Click “Can’t modify stack” or “Can’t delete stack.”
Click here to prevent changes to the stack.

Selecting just this option doesn't protect the
stack from deletion.

Protect Stack: Limit user level to:
\ .
. [T Can't modify stack g ?;zt;:;;ng
Qllck here to protect the [Icon't delete stack (> painting
stack from deletion. Selecting O Ruthorin
RO RTEN e - [CIPrivate Access uthoring
just this option doesn't protect @ Scripting
the stack from changes.
(| Set Password ) [[ 0K ]] [Cuncel]

Figure 2-34  Protecting a stack from changes or deletion

As long as the “Can’'t modify stack” option is turned on, no one
can make any changes to the stack. (Anyone can, however, copy
anything from the stack, or copy the stack itself.)

As long as “Can’t delete stack” is turned on, no one can delete
g

‘ the stack.

However, unless you set a password—as explained in the
following two steps—anyone can open the Protect Stack dialog
box and turn off these options.
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3. To prevent others from changing your protection settings, click
Set Password.

(This step is optional.)
The dialog box for setting a password appears.
4. Enter a password.

(This step is optional.)

Type the password
Please enter a new password: once here . . |

Please enter it again:

..and again here,
for veritication.

| ! Then click OK.

(( o« ) (concel) Clicking None or Cancel closes
— N\

this dialog box without setting

AN AN a password.

Figure 2-35  Setting a password

Setting a password for the stack prevents unauthorized users
from opening the Protect Stack dialog box, whether or not
Private Access is selected. If you've selected Private Access as well
as setting a password, the same password will be required to
open the stack itself.

5. Click OK.

After you've set a password, no one can change the settings in the.
Protect Stack dialog box without knowing the password, until you
remove it (as explained in “Removing a Password,” later in this
chapter). There’s no way to find out a password once it’s been
set—so make a note of the password, or use one you won't forget.
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When you're using a locked stack (that is, a stack for which the
“Can’'t modify stack” option is selected in the Protect Stack dialog
box), a padlock (a) appears in the menu bar, indicating that you
can’t make any changes in the stack. If you try to make changes to
a locked stack, you might see the following dialog box:

Can't modify this stack.

(%)

Figure 2-36  Trying to make changes to a protected stack

HyperCard automatically selects the “Can’t modify stack” check
box when the stack is on a locked medium (a locked disk,
CD-ROM, or locked folder on a file server)—you can't deselect it.
To make changes to such a stack, you first have to figure out why
it’s locked. If the “Can’t modify stack” check box is selected or the
Locked check box is selected in the stack’s Icon Info dialog box (in
the Finder), you have to deselect these options before you can make
changes to the stack. In many cases, copying the stack to an
unlocked disk makes the stack modifiable.

Warning: Some stacks are designed so that, when the stack is
locked, you can type into a field or paint a picture on a card or
background; but the changes disappear as soon as you leave the
current card. A
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Lill]ilillg the user level  You can limic the way people use and change a stack by limiting the
user level in the Protect Stack dialog box. Follow these steps:

1. Choose Protect Stack from the File menu.
The Protect Stack dialog box appears.

2. Click a user level.

Protect Stack: Linit user level to: Click one of these to choosg a user
O Browsing level. The user level determines the
[ICon't modify stack & Tuping commands and tools people can
[CJCon't delete stack (™ pginting usce in the current .s[;la"k. When this
[JPrivate Access O Authoring user leve.l is different from the user
@ Scripting level set in the Home stack, the
lower of the two levels takes ‘
Set Password l[ 0K D [Cuncel ] L
precedence. (Browsing is the

lowest level.)

Figure 2-37  Limiting the user level

The options available at the different user levels are described in
“User Levels and Options” in Chapter 1.

Unless you set a password—as explained in the following two
anyone can open the Protect Stack dialog box and

steps
change the user level you've set.

3. To prevent others from changing the stack’s user level setting,

click Set Password. .
(This step is optional.)

The dialog box for setting a password appears.
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4. Enter a password.

(This step is optional.)

Type the password

Please enter a new password: once here
y . .
[ | ... and again here,
Please enter it again: for verification
py, .
L ] Then click OK.

/
(( ok ) (concel) Clicking None or Cancel closes
\

this dialog box without setting

AN AN a password.

Figure 2-38  Setting a password

Setting a password for the stack prevents unauthorized users
from opening the Protect Stack dialog box and changing the
settings, whether or not Private Access is selected. If you've
selected Private Access as well as setting a password, the same
password will be required to open the stack itself.

5. Click OK.

The tools and commands a user has access to while using the stack
are determined by both the user level you set in the stack’s Protect
Stack dialog box and the user level selected on the Preferences card
of the user’s Home stack. When these two settings are different,
HyperCard uses the lower setting. (Lower means “closer to
Browsing.”)

After you've set a password, no one can change the user level setting
in the Protect Stack dialog box without knowing the password,
until you remove it (as explained in the next section, “Removing a
Password”). There’s no way to find out a password once it’s been
set—so make a note of the password, or use one you won't forget.
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A\ Important: When the user level is set to Browsing or Typing,
(either in the Protect Stack dialog box or on the User Preferences
card in the Home stack), the Protect Stack command doesn’t appear
in the File menu—which means you can’t change any of the
protection settings. To get the full File menu (so that you can
choose the Protect Stack command) no matter what the user level
is, press and hold the (¢ key while you open the File menu. 2

Removing a password  Any password you set in the Protect Stack dialog box remains in
effect for the stack until you remove it by following these steps:

1. Choose Protect Stack from the File menu.
You see a dialog box prompting you for the password. ®
2. Enter the password and click OK:

This stack requires a password:

[ |
(( 0K j] [Cuncel]

Figure 2-39  Entering a password to open the Protect Stack dialog box

'Hw Protect Sl;l(]\’ di;l]()g l)()x appears.
3. Click Set Password. ‘

The dialog box for setting a password appears.
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4. Click None to remove the password:

Please enter a new password:

l |

Please enter it again:

[ |
Clicking here removes |i 0K i] [ Cancel )

the password.

Figure 2-40  Removing a password

o The Set Password dialog box disappears—the password

protection is removed.

Setting user access for a  If you want to make a stack available to users on an AppleShare file
stack on a file server  server, you can protect it in various ways via the Protect Stack dialog
box, as described in the preceding sections. You should also be
aware of the following considerations:

= Aswith any file on a file server, you can make the stack available
to anyone who has access to the network, or only to people
who are registered users of the file server. For information on
setting file protection on a file server, consult your network
administrator.

S, m For a stack to be available to multiple users via a file server, the
stack must be either on a locked medium—a locked disk, a
CD-ROM, or a locked folder on the file server—or locked in
the Finder (that is, the Locked option is selected in its Icon Info
dialog box). When a stack is on a locked medium on a file server,
any number of network users can use the stack at the same time.
However, no one can make changes to the stack.
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Selecting the “Can’t modify stack” option in the Protect Stack
dialog box isn't sufficient to make a stack available to more than
one user on a file server.

»  When a stack is unlocked on a file server, only one person can
use it at a time. The user can make changes to the stack while
using it (unless changes are prohibited by the protection level set
in the Protect Stack dialog box), but other people cannot open
the stack while it’s in use.

Deleting a4 Stack  When you delete a stack, you remove all the stack’s cards,
backgrounds, and scripts. Delete a stack only when you have no O
further use for it.

To delete the current stack, choose Delete Stack from the File
menu. (The Delete Stack command is normally visible only when
one of the General tools is selected, and when your user level is
Painting, Authoring, or Scripting. When your user level is
Browsing, you can make the Delete command visible by holding
down the © key while you pull down the File menu.) Unless the
stack is protected from deletion, you see a dialog box like the
following;

Delete all 6 cards from this stack?

HardDisk:HyperCard:Stacks:Rddresses .

[Delete] (Cuncelﬁ

Figure 2-41  Confirmation dialog box for deleting a stack
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If the stack is protected from deletion, you see this dialog box
instead of the previous one:

Can't delete protected stack.

Figure 2-42  Trying to delete a protected stack

When you delete a stack with the Delete Stack command, it’s

as though you dragged the stack to the Trash in the Finder—the
O stack no longer exists on your hard disk. The stack disappears, and

HyperCard returns you to the Home stack.

CUStOmIZIHg YOUI'  You can customize your Home stack so that it’s tailored to the way
Home stack You work and the tasks you perform. With a few modifications,
your Home stack can even serve as the control center for all your
work on the Apple IIGs—a launching pad for the applications,
utilities, documents, and stacks you use regularly.

You can organize your Home cards in any way you wish. For
example, you can put all the buttons you use on one card; or you
can put buttons that open applications on one card, and buttons
@® that open stacks on another. Or you can rename the cards according
to the categories you find most useful, and keep buttons on all five
cards. You can rearrange the order of the Home cards and change

the way each card looks, if you like.

This section explains all the ways you can customize the standard
Home stack that comes with HyperCard.
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Adding buttons to
your Home cards

The standard Home stack that comes with HyperCard includes five
Home cards. The first three Home cards contain buttons that take
you to the stacks that come with HyperCard:

m The buttons on the first Home card (called Welcome) open
stacks that introduce you to HyperCard, including the
HyperCard Help stack and the Tour stack.

= The buttons on the second Home card (Deskset) open the
HyperCard equivalent of an address book and desk calendar.

» The buttons on the third Home card (Tool Kit) open stacks that
you will find uscful as you begin to create your own stacks.

As you become more comfortable with HyperCard, you can make
these three Home cards even more useful by adding buttons that &
are linked to each of your favorite stacks, applications, and docu-
ments. You can also add buttons to the other two Home cards.

Before you add a button to one of the Home cards, you need to
decide what you want the button to do and which Home card
you want to put it on. Buttons can take you to stacks, and they
can open other programs and documents, as described on the
following pages.

Adding a button that opens a stack

To add a button that takes you to another stack, follow
these steps:

1. Go to the Home card on which you want to place
the button.
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2. Click the Create QuickLink button near the upper-left corner.

A directory dialog box appears:

Create a QuickLink to which stack?

<3 HordDisk:HyperCard:Stacks: ‘
T Addresses
3 ArtIdeas
[3 Birds
3 Buttonldeas e
[ Calendar Lmj
3 Iconkditor
3 PicturePuzzler
(3 ScriptersTools

‘ Figure 2-43  Selecting a stack for your button to open

% Did you get a different dialog box? 1f your user level is set to
Painting (3) or lower, you will first see dialog box asking you
to confirm that you want to create a new button. You will
see the directory dialog box shown in Figure 2-43 after you
click OK. <

3. Using the directory dialog box, locate and double-click the

name of the stack you want your button to open.

A flashing button for the selected stack appears on the current
card.

4. Drag the flashing button to position it on the card.

When you release the mouse button, your new burton stops

flashing.

If you want to test your new button, click it. It should open the
stack you specified.

» Seealso: o “Changing the Appearance of a Button” in Chapter 4
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Adding a button that opens an application

To add a button that opens an application (or a specific document
with an application), you must write a simple script. You can use
the technique described in this section to add such a button to any
stack, not just the Home stack. Make sure your user level is set to

Scripting (5), then follow these steps:
1. Go to the Home card on which you want to place the button.

2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool ()

will work.
3. Choose New Button from the Objects menu. O

This automatically selects the Button tool, creates a button
named “New Button” in the center of the card window, and
selects the button.

+ New Button

L}
L]
----------- ol

Figure 2-44 A button created with the New Button command

4. While the button is still selected, choose Button Info from the

Objects menu.

Or double-click the button. The Button Info dialog box ‘

appears.
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If this option is selected
and the button has a
name, the name will

appear on the button,

5. Type a name for the button:

Button Name: |

] Type the name of the button

Card button number:1  Card button ID; 17

Rstorkme syt
<] Auto Hilite

Family:

I Y Share Bitive

(Link To..) (Font... )

(for example, the name of the
document or application you

[ﬁ:ript...) &olors...)

[( 0K ]] [Cuncel)

Figure 2-45  Typing the name for the button.

6. Make sure the Show Name check box is selected.

This option is automatically selected when you create a new
button with the New Button command.

7. Click Script.

The button’s script opens:

Script of Card button ID 17 = "New Button"
| it
O]
()  (Tancel)
Figure 2-46  Opening a button’s script
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8. Type one of the following, substituting the name of the
document or the name of the document and application you
want to open:

Script of Card button ID 17 = "New Button" T e ) .
[his script launches the
on mouselp

open "application” specified application.
end mouselp

This script launches the

Script of Card button 10 17 = "New Button specified application and opens

onmouselp o
open "document” with "application” —— the specified document.
end mouselp
Figure 2-47  Scripting a link to an application ‘

9. When you’re finished, press Enter.
10. Choose the Browse tool.

If you want to test your new button, click it—it should open the
document or application you specified. If something else happens,
check the spelling of the document and application names and
check the script for errors.

When you want to return to HyperCard, quit the application. You
return to the card from which you launched the application.

You might encounter other stacks with buttons that launch
applications. When you launch an application by clicking one of .
these buttons on a card, HyperCard takes you back to the same

card after you quit the application.

> Seealso: * “Changing the Appearance of a Button™ in Chapter 4
* “Linking Information” in Chapter 4
* “Opening Applications” in Chapter 1
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chuming a Home card  The name of a Home card usually characterizes the stacks,
applications, and documents that are represented on the card. For
example, the buttons on the card named "lool Kit open stacks that
contain tools and parts you can use to build new stacks.

You can rename any of the Home cards in the standard Home stack
at any time. When you rename a Home card, you automatically
change both the name that appears near the upper-left corner of the
card and the name of the button (at the bottom of each Home
card) that’s used for navigating to that card.

1 BORERRA 111582311111 1111111
‘ User Neme
' The name of this
Home card El S
K ﬁ' b .Hn!
Scripter's Tools Art ldeas
N ) Tcon Editor
[he button for __
navigating to n .
‘“ 1 o Welcome ][ Deskset | TSNS fttic || Basement
this card

Figure 2-48 The name of a Home card appears near the upper-left
corner of the card
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Changing the appearance
of the Home cards

Follow these steps to rename a Home card:
1. Make sure the Browse tool () is selected.

2. Click the name of the card (the name just to the right of the

words “Home Stack”).

The following dialog box appears:

Rename this card as:

I
([ 0K ]] [Cuncel]

Figure 2-49  Renaming a Home card
3. Type a new name for the card and click OK.

In addition to adding buttons to your Home cards, you can also
change the appearance of the Home cards by adding text and
pictures to them.

When you add text or a picture to the background layer of a Home
card, it appears on all the Home cards. When you add text or a
picture to the card layer of a Home card, it appears only on that

card.

For instructions on adding text to a card or background, see
Chapter 5. For instructions on adding pictures, see Chapter 6.
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Using the Home stack  Once you’ve added buttons to your Home stack for all the stacks,
as your control center  applications, and documents you use frequently, you might want to
use your Home stack as your control center—a jumping-off point

for all your work on the Apple TIGs.

To use the Home stack as your control center, you must tell your
computer to launch HyperCard at startup time. You can arrange
to do this only if your computer is connected to an AppleShare
network, and you normally launch HyperCard over the network.
Ask the AppleShare administrator for the network to follow
these steps:

1. Click the icon for the user (or group) who wants to use

HyperCard as the startup application.

2. Choose Startup Info from the Apple II menu.
The Startup Info dialog box appears.

3. Click Set Startup Application.

4. Select HyperCardIIGs.

5. Click OK.

When you restart your computer, HyperCard launches
automatically and your Home stack opens.
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Working With Cards
and Backgrounds

; ihen you build HyperCard stacks, you perform many tasks
that involve creating and manipulating cards and backgrounds.
For example, you might add cards to a stack, rearrange the cards
in a stack, or copy a background from one stack to another.

This chapter gives specific instructions for working with cards
and backgrounds. To do the tasks in this chapter, you must have
your user level set at least to Authoring. When a task requires the
Scripting level, the instructions say so. (For instructions on setting
your user level, see “User Levels and Options” in Chapter 1).




Working with cards A codisa rectangular area that can hold buttons, fields, and
graphics. All cards in a stack are the same size. Each card is a
composite of two layers—a foreground layer, called the card layer,
and a background layer. You see the elements of both layers when
you look at a card, as if the card layer were a transparent layer in
front of the background. Each layer can contain its own buttons,
fields, and graphics. (“The Card Layer Versus the Background
Layer” in Chapter 2 gives more details about the differences
between the two layers.)

Adding a new card  When you add a new card to a stack, HyperCard always puts the
to a stack  new card right after the current card. The new card automatically
acquires the background of the current card. If you want to add a O
new card with a blank background, you add a new background.
(“Creating a New Background,” later in this chapter, gives
instructions.)

Figure 3-1  Adding a new card to a stack
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'To add a new card to the current stack, follow these steps:
1. Go to the card you want the new card to follow.

[f you want to add a new card at the end of the stack, go to the
last card in the stack by choosing Last from the Go menu (or

pressing (-4 or (\—Right Arrow).
2. Choose New Card from the Edit menu, or press ' -N.

The new card is inserted immediately after the card you were
looking at when you chose New Card, and it has the same
background as that card (which is now the previous card).

'l‘I]C new Clll‘d appcars on your screen.

Figure 3-2  Adding a new card at the end of a stack

For information about adding buttons, fields, and graphics to
‘ your new card, see Chapters 4, 5, and 6, respectively.
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[f you want to create a new card as the first card in the stack, follow
these steps:

1. Choose First from the Go menu, or press  -1.

The first card in the stack
appears on the screen

2. Choose New Card from the Edit menu, or press -N.

g "/TZ»
New card ﬁ\i N

The new card is added after the

first card and has the same

background as the first card. .

The new card appears on the

screen.
I Ak
Current card _I_ Z % ;

3. Choose First from the Go menu, pr press -1, again.

The first card in che stack

B , appears on the screen again.

| ©

4. Choose Cut Card from the Edit menu.

This removes the first card in

the stack and puts a copy of it
onto the Clipboard. (The card
that was second in the stack is

now first.)
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If you want to put the former first card (the card you've cut) back
into the stack, you need to do two more things:

1. Go to the card you want the cut card to follow.

i

) 3R
Current card T 2 '

2. Choose Paste Card from the Edit menu, or press ( -V.

The pasted card is added
immediately after the card you

Pasted card _\__

Paste Card.

screen.

Current card «r b
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The pasted card appears on the
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Copying d card  You can copy a card into another stack, or to another location in the
same stack. When you copy a card, you copy everything associated
with it—its background, graphics, fields, text, buttons, and scripts.

Here’s how to make a copy of a card:
1. Go to the card you want to copy.
2. Choose Copy Card from the Edit menu.
This puts a copy of the current card onto the Clipboard.
3. Go to the card you want the copied card to follow.
It can be in the current stack or in any other stack.
4. Choose Paste Card from the Edit menu, or press C-V. @

The card is pasted immediately after the card you were looking
at when you chose Paste Card. The copied card becomes the
current card.

The copied card acquires the name of the original card (if the
original card has a name). This means that, if the copy and the
original are in the same stack, you have two cards in the stack with
the same name. You might want to consider renaming one of them,
so that each card in your stack has a unique name. (“Naming a
Card,” later in this chapter, gives instructions.)

\ Important: When you copy a card from one place to another,
you copy the card’s script, too (if it has one), and any scripts ©
associated with the buttons, fields, and background that are part
of the card. Since scripts sometimes rely on the characteristics of a
particular stack, you might encounter problems (such as unfamiliar
messages) after you copy a card. “Copying Parts From Other
Stacks” in Chapter 2 discusses this problem.
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Moving a card

You can move a card to a different place within the same stack, or to
a different stack. When you move a card, you also move everything
associated with it—its background, graphics, fields, text, buttons,
and scripts.

"To move a card, follow these steps:

1. Go to the card you want to move.
2. Choose Cut Card from the Edit menu.

This removes the current card and puts a copy of it onto

the Clipboard.
3. Go to the card you want the cut card to follow.
It can be in the current stack or in any other stack.
4. Choose Paste Card from the Edit menu, or press -V.

The pasted card is placed immediately after the card you were
looking at when you chose Paste Card. The pasted card appears
on the screen.

If you have pasted the card into a different stack than the stack from
which you cut it, pasting the card also adds the card’s background
to the stack (unless the stack already contains that background).

Important: When you move a card from one place to another, you
move the card’s script, too (if it has one), and any scripts associated
with the buttons, fields, and background that are part of the card.
Since scripts sometimes rely on the characteristics of a particular
stack, you might encounter problems (such as unfamiliar messages)
after you move a card. “Copying Parts From Other Stacks” in
Chapter 2 discusses this problem. 2

Chapter 3: Working With Cards and Backgrounds 127




Making a card the first card  Moving a card to the first position in the stack requires several steps.
in the stack  First you have to make the card the second one in the stack, and
then you have to move the first card out of the way.

To move a card so that it’s first in the stack, follow these steps:
1. Go to the card whose position you want to change.

2. Choose Cut Card from the Edit menu.

This removes the current card and puts a copy of it onto

the Clipboard.
3. Choose First from the Go menu, or press ( -1.
The first card in the stack appears.
4. Choose Paste Card from the Edit menu, or press  -V. O

The pasted card appears on the screen—it’s now the second card
in the stack.

5. Choose First from the Go menu again, or press (:-1.
The first card in the stack appears again.

6. Choose Cut Card from the Edit menu.

This removes the first card from the stack and puts a copy of it
onto the Clipboard. (The card that was second in the stack is
now first.)

7. Choose Paste Card from the Edit menu, or press ! 5V
The original first card is now the second card in the stack. ‘
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Gettin g information Using the Card Info command, you can get information about the
about a card  current card and change some of its properties. Follow these steps to
get information about a card:

1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (&)
will work.

2. Choose Card Info from the Objects menu.
The following dialog box appears:

= The card’s name
Cord Name: |[FYIRYIRITR | The card be
. y: e card’s number
Card ID: 2028 Cord number 1 out of 40 The card’s ID
Select this option Contains 2 cord fields.\ The number of fields
from deletion. . \
: L [JCan't Delete The number of buttons
Select this option [JDon't Search in the card layer
to exclude the card A
and background (L ) (concer)
fields on the e ‘
current card from N——— Click OK when you're
text searches.  If your user Click here to see through (or click Cancel
level is set to the card’s color sets. to close the dialog box
Scripting, you can without saving any
click here to see changes).

the card’s script.

’ Figure 3-3  Geltting information about a card

3. When you’re finished, click OK.

<+ Another way to open the Card Info dialog box: 1f you are using the
Home stack that comes with HyperCard, the following shortcut
opens the Card Info dialog box for the current card in any stack:
While any General tool is selected, press (3-M to open the
Message box; then type ¢ and press Return. (This shortcut
is built into the standard HyperCard Home stack.) «
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Naming a card Generally, a card doesn’t have a name unless you give it one
(or someone else does). The card name is one way HyperCard
identifies a card. You can use the card name in the Message box to
bring the card into view. And you can use the card name to address
the card through scripts.
To name a card or change its name, follow these steps:

1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (5)
will work.

2. Choose Card Info from the Objects menu.

3. Type or change the card’s name: o
tord Name: ) [he card’s name

Cord ID: 2928. Card number 1 out of 40
Contains 2 cord fields.

Contains 3 cord buttons.

[ICan't Delete

[JDon't Search

(Script...) [Colors...] (( 0K ) (Cuncel]

Figure 3-4 Naming a card

4. When you’re finished, click OK.

Important: Don’t use a number for the card name—otherwise
HyperCard might, for example, look for card number 12 when you
try to go to the card named “12.” 2
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Excluding card
and background fields
from text searches

Click here to exclude the card’s
fields from text searches. If you
click again, you open the card’s

fields to text searches.

The Find command (in the Go menu) allows you to search for
specific text in the fields of a stack. (“Looking for Specific Text” in
Chapter 1 explains how to search for text.) When you're searching
for specific text in a large stack, you can speed your search by
excluding any fields that you know don't contain the text you're

looking for.

To prevent HyperCard from searching in the card and background
fields that appear on any particular card, follow these steps:

1. Go to the card whose fields you want to exclude from text

searches.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (£3)
will work.

3. Choose Card Info from the Objects menu.
4. Click the Don’t Search check box to select it:

IR T I ntroduction
Card 1D: 2928. Card number 1 out of 40

Contains 2 card fields.
Contains 3 card buttons.
[TICan't Delete

[JDon't Search

[:Scrim...] [Colors...]

m 0K ]) (Cuncel)

Figure 3-5 Excluding a card’s fields from text searches

5. Click OK.

When you want to allow HyperCard to search in the card’s fields
again, click Don't Search to deselect it (as shown in Figure 3-5).
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» Secalo: e “Excluding Background Fields From Text Searches™ in this
chapter
* “Excluding a Field From Text Searches™ in Chapter 5

Protecting a card  You can protect a card from deletion, but you can’t prevent changes
to a card unless you protect the entire stack from modification (as
explained in “Protecting Your Stack” in Chapter 2).

To protect a card from deletion, follow these steps:
1. Go the card you want to protect.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (@), or the Field tool ({*

will work.
3. Choose Card Info from the Objects menu.
4. Click the Can’t Delete check box to select it:

T LY [Tntroduction) |
Card ID: 2928. Card number 1 out of 40

Contains 2 card fields.

Contains 3 card buttons.
(,hd}' here to protect the [JCan't Delete

card from deletion. If you []0on't Search
click again, you remove

the card’s protection. (Seript..) (Colors.) ( o ) ((concel ) .

Figure 3-6  Protecting a card

5. Click OK.
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You can’t remove the card from the stack while the Can’t Delete
option is turned on. (You can, however, delete the entire stack,

taking the protected card with it.)

When you want to delete the card, you can remove its protection by
clicking Can't Delete again in the Card Info dialog box to deselect it
(as shown in Figure 3-6).

Changing a card’s color set The color set for a card determines the 16 colors currently available
for use by buttons, fields, and graphics on that card. You can choose
from among at least five color sets for any given card: the standard
system color set, a gray scale color set, and three others. You can
also add a sixth color set to a card. And you can choose to have a

@ card make use of whatever color set is currently selected for its

background.

When you change a card’s color set, the colors of some or all the
graphics, buttons, and fields on the card may change to reflect the
new colors. See “Changing Color Sets” in Chapter 6 for more
information about the way the color sets for cards, backgrounds,
and stacks affect the colors displayed on a card.

To change the color set for a card, follow these steps:
1. Go to the card whose color set you want to change.
2. Make sure you have one of the General tools selected.

. The Browse tool (), the Button tool (=), or the Field tool (£3)

will work.
3. Choose Card Info from the Objects menu.
4. Click Colors.

The Colors dialog box for the card appears.
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These are the
color sets that are
available for the
current card.
Click the one you
want to use . . .

5. Select the color set you want:

__Display colors for card 1D 2928

T T AT [
AT MY "7 1 Gray scale
TR T WY1 T T 1 Other color sets...

Standard system colors

(000 IO 1
| ISSERITITAIONAIIN T WSTTTVITOONTY 1 |
When displaying this card:
[ Use these colors | ( ok ) (concel)

... then press and hold the mouse button here and drag to

choose “Use these colors” (if it’s not already selected) from the

pop-up menu. If you choose “Get colors from background” .
instead, the card will use the colors currently specified for the

background no matter which color set is selected for the card.

Figure 3-7 Changing a card’s color set

6. When you’re finished, click OK to confirm your selection.

You see the Card Info dialog box again.
7. In the Card Info dialog box, click OK.

If none of the five color sets for a given card includes the colors you
want, you can add a sixth color set to that card from any document

in the Apple Preferred File Format. “Importing a New Color Set fob
a Card or Background,” in Chapter 6, describes how to do this.

You can also add a sixth color set to a card by using a desk accessory,
an XCMD, or HyperTalk to specify the colors you want. If you use
a desk accessory or an XCMD to do this, any color set you specify
while you’re working in the card layer will be added automatically
to the color sets for the current card and will be selected. For
instructions on using HyperTalk to add a sixth color set to a card,
see the discussion of the colorset property in the HyperTalk
Help stack.
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Deleting a card

Working with
backgrounds

To remove the current card from the stack, choose Delete Card
from the Edit menu (or press ¢ I-Delete). The current card
disappears (unless it’s protected), and you sce the next card in
the stack.

Important: If you delete a card by mistake, you can bring it back
by immediately choosing Undo from the Edit menu, before you do
anything else. A

[f you try to delete a protected card, you see the following
dialog box:

Can't delete protected cord.

Figure 3-8 Trying to delete a protected card

“Protecting a Card,” earlier in this chapter, describes how to set and
remove card protection.

You can't delete the only card in a stack. If there’s only one card in
the stack and you want to delete it, choose Delete Stack from the
File menu.

A background serves as a template for a stack, or for some of the
cards in a stack. Whatever’s in a background is common to all cards
associated with that background. You place buttons, fields, and
graphics in the background when you want them to appear on all

the cards that share the background.
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There’s no limit (beyond disk space) to the number of backgrounds
a stack can have. In fact, every card in a stack could have its own
background—but that would defeat the purpose of backgrounds.
Together, the elements in a background help communicate the
purpose of the stack by giving a similar appearance and function to
the cards that share the background. This makes it much easier for
other people to figure out what the stack is for and how to use it—
and much easier for you to create and modify the stack. You can
make changes to many cards at once just by changing elements in
their common background.

“The Card Layer Versus the Background Layer” in Chapter 2
gives more information about the relationship between cards

and backgrounds. O

To see the background layer of the current card, choose Background
from the Edit menu, or press (4-B. If you choose Background (or
press (§-B) repeatedly, you move back and forth between the card
layer and the background layer. When you’re in the background
layer, the word Background appears in the menu bar, and a check
mark appears to the left of the Background command in the

Edit menu:

When you're in

% File [ Go Tools Objects Rddresses

Un 60 "32 L e I‘,Fi i [he ba CkgrOUl'ld
) |
— A i layer, the word
vt a3 i
— tomy i Background

...............

Paste Text 4V appears in the

’;1;‘ tea menu bar . .. ‘
a s |

New Cord
}‘ i Delete Cord

Lo e |
Copy Card

|

|

...and the Background 1 | Jext Stule.. ¢
command is checked. 81 1, pockground

] p——

Figure 3-9  The word Background appears in the menu bar while you're working in
a background
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While you're working in the background layer you can get back to
the card layer by choosing Background from the Edit menu again,

pressing (5-B, or choosing the Browse tool.

You can find out how many cards share the current background by
choosing Bkgnd Info from the Objects menu (while any of the

General tools is selected):

Bkgnd Name: |

Bkgnd 1D: 2760. Shared by 5cards.
Contains 3 background fields.
Contains 7 background buttens.
[Jcan't Delete

[J0on't Search

@cripﬂ @lora LOKj [Cuncelj

This number tells you
how many cards in the
stack share the current
background.

Figure 3-10  Seeing how many cards share a background

To see how many backgrounds there are in the current stack, choose
Stack Info from the Objects menu (while any of the General tools

is selected):

Stack Nome: [[TTN |

Where: :HardDisk:HyperCard:
Stack contains 7 cards.

Stack contains 2/back9rounds.
Size of stack: 43K.
Free in stack: OK.

&:ript..) Eolora

([ Uﬂ (Lancel)

This number tells
you how many
backgrounds are in
the current stack.

Figure 3-11  Checking the number of backgrounds in a stack
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Creating a new background

138

When you want some (but not all) of the cards in a stack to have a
similar appearance or contain the same elements, you can create a
new background to be shared by just those cards.

To add a new background to a stack, choose New Background from
the Objects menu. (You must have a General tool selected to see the
Objects menu.) This adds to your stack a new, empty card with a
blank background, and puts you in the background layer of that
card. The new, empty card is added immediately after the card

you're looking at when you choose New Background.

Button fnfa..,
Field into..
Card Info...

Bkgnd Info...
Stack Info...

New Button

New Field

New Background 54— The New Background
1 command

Figure 3-12  Creating a new background

For information about adding buttons, fields, and graphics to your
new background, see Chapters 4, 5, and 6, respectively.
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Moving between  While you're working with a stack that has more than one back-
backgrounds — ground, it’s useful to be able to move between the backgrounds
quickly. This can help you keep an eye on the developing stack,
and it makes stack building faster and easier.

When you're in a stack that has more than one background,
you can move between the different backgrounds by following
these steps:

1. Open the Message box.
2. Type any of the following:

e

—This takes you to the first card of
‘ g0 tD next buckgrnund ... the next background in the stack.

T
go to previous background

This takes you to the nearest card
of the previous background in
the stack.

OO

. " . n __ This takes you to the first card of
90 to background "Employees the background named Employees,

if there is such a background.

Figure 3-13  Moving between backgrounds
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3. Press Return or Enter.

You go immediately to the first card with the specified
background, if the stack has such a background.

If there’s no such background in the current stack, you see the

following dialog box:

No such card.

(=)

Figure 3-14 When HyperCard can't find a background .

For information on naming a background, see “Naming a
Background,” later in this chapter.

Copying a background — You can copy a background from one stack to another, or from one
place to another in the same stack. To copy an existing background,
you copy a card that has that background. (When you copy a card,
you copy everything associated with it, including its background.)

To copy a background, follow these steps:
1. Go to a card that has the background you want to copy.

You can see the contents of the card’s background by pressing ©
(5-B to go to the background layer.

2. Choose New Card from the Edit menu, or press -N.
3. Choose Cut Card from the Edit menu.
4. Move to the card you want the new background to follow.

It can be in the current stack or in another stack.
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5. Choose Paste Card from the Edit menu.
The pasted card becomes the current card.

6. To make another card with this background, choose New Card
from the Edit menu.

This creates a new card with the same background as the current
card (the card you've just pasted). This new card contains only
the background elements—the background buttons, fields,
graphics, and script—of the copied card.

You can create as many cards with this background as you like
by repeating this step.

If you try to copy a background into a stack that already has that
background, HyperCard won't make the copy. However, when
you're creating a large stack with different sections, you might want
the different sections to have backgrounds with different names
(and IDs) that are identical in every other respect. This way, you
can move quickly between the sections of the stack by moving from
one background to another, as explained in “Moving Between
Backgrounds,” earlier in this chapter.

You can get two identical backgrounds into a stack (with different
names and IDs) by first making a temporary alteration to the
background you want to copy. (For example, add a button to the
background temporarily). Then follow the procedure described in
this section to copy the background. After you’ve copied the
background, undo the alteration you made to it.

Important: When you copy a background from one place to
another, you copy the background’s script, too (if it has one), and
any scripts associated with the buttons and fields that are in the
background. Since scripts sometimes rely on the characteristics of a
particular stack, you might encounter problems (such as unfamiliar
messages) after you copy a background. “Copying Parts From
Other Stacks” in Chapter 2 discusses this problem.
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Gclling information Using the Bkgnd Info command, you can get information about
about a background  the current background and change some of its properties.
Here’s how:

1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (3)
will work.

2. Choose Bkgnd Info from the Objects menu.
The following dialog box appears:

The background’s The background's
D name
The number of ‘
] cards that share
this background

Bkgnd &lme: [Home Cards

Select this option Bkgnd 10: 2760. Shared by 5 cards.
to protect the Contains 3 background fields. The number of fields
background from Contains 7 background buttons. in this background
deletion. [ Can't Delete The number of buttons
Select this option to [ Don't Search in this background

fields from text searches.

exclude the background’s o) (Eotors.) EDK ) (Cuncel]
AN

N Click OK when you're
If your user Click here through (or click

level is set to to see the Cancel to close the
Scripting, you can  background’s dialog box without
click here to see the color sets. saving any changes).

background’s script. ‘

Figure 3-15  Getting information about a background

3. When you’re finished, click OK.
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Naming a background

@ | xcluding background
fields from text searches

- Another way to open the Bkgnd Info dialog box: If you are using
the Home stack that comes with HyperCard, the following
shortcut opens the Bkgnd Info dialog box for the current
background in any stack: While any General tool is selected,
press (3-M to open the Message box; then type b and press
Return. (This shortcut is built into the standard HyperCard
Home stack.)

Generally, a background doesn't have a name unless you give it
one (or someone else does). A background’s name is one way
HyperCard identifies the background. You can use the background
name in the Message box to bring the first card with that
background into view. And you can use a background’s name

to address the background through scripts.
To name a background or change its name, follow these steps:
1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool ()
will work.

2. Choose Bkgnd Info from the Objects menu.
3. Type or change the background’s name.
4. Click OK.

The Find command (in the Go menu) allows you to search for
specific text in the fields of a stack. (“Looking for Specific Text” in
Chaprer 1 explains how to search for text.) When you’re searching
for specific text in a large stack, you can speed your search by
excluding any fields that you know don't contain the text you're
looking for.
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Click here to exclude the
background’s fields from text
searches. If you click again, you
open the background’s fields to
text searches.

144

To prevent HyperCard from searching in the fields that belong to
any particular background, follow these steps:

1. Go to a card with the background whose fields you want to

exclude from text searches.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (), or the Field tool (£3)
will work.

3. Choose Bkgnd Info from the Objects menu.
4. Click the Don’t Search check box to select it:

Bkgnd Name: || |
Bkgnd ID: 2697. Shared by 33 cards.

Contains 3 background fields.
Contains 2 background buttons.
[CIcan't Delete

[J0on't Search

(Seript...) (Colors..) ( o } ((Cancel )

Figure 3-16  Excluding a background’s fields from text searches

5. Click OK. ‘

If you want to allow HyperCard to search in the background’s
fields, click Don't Search again to deselect it (as shown in

Figure 3-16).

P Seealso:  * “Excluding Card and Background Fields From Text
Searches” in this chapter

* “Excluding a Field From Text Searches” in Chapter 5
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Protecting a background  You can protect a background from deletion, but you can’t prevent
changes to a background unless you protect the entire stack
from modification (as explained in “Protecting Your Stack” in

Chapter 2).

When you protect a background from deletion, you tell HyperCard
not to allow the removal of the last card that has the background.

To protect a background from deletion, follow these steps:
1. Go to a card that has the background you want to protect.
2. Make sure you have one of the General tools selected.

The Browse tool (¥), the Button tool (=), or the Field tool (£3)
. will work.

3. Choose Bkgnd Info from the Objects menu.
4. Click the Can’t Delete check box to select it:

Click here to protect Bkgnd Nane: ]
the background from
deletion. If you click Bkgnd ID: 2760. Shared by 5 cards.
again, you remove Contains 3 background fields.
the background’s Contains 7 background buttons.
protection. [JCan't Delete

[1Don't Search

[Script.j (Colors...] LﬂK ] [Cuncen

Figure 3-17  Protecting a background

5. Click OK.

As long as the Can’t Delete option is turned on, you can't
remove the last card with that background from the stack.

(You can, however, delete the stack, taking the protected
background with it.)
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To remove the background’s protection, click Can't Delete in the
Bkgnd Info dialog box to deselect it (as shown in Figure 3-17).

Changing a background's  The color set for a background determines the 16 colors currently
color set  available for use by the cards that share the background and by the

background’s buttons, fields, and graphics. You can choose from
among at least five color sets for any given background: the
standard system color set, a gray scale color set, and three others.
You can also add a sixth color set to a background. And you can
choose to have a background make use of whatever color set is
currently selected for the stack.

If you wish, you can select a color set for a card that is different

from the color set selected for the card’s background. If a card’s @)
color set has not been selected individually, the card makes use of
the color set currently selected for its background.

When you change a background’s color set, the colors of some or
all the graphics, buttons, and fields in the background may change
to reflect the new colors. See “Changing Color Sets” in Chapter 6
for more information about the way the color sets for cards,
backgrounds, and stacks affect the colors displayed on a card.

To change the color set for a background, follow these steps:

1. Go to any card that has the background whose color set you
want to change.

2. Make sure you have one of the General tools selected. ‘

The Browse tool (), the Button tool (=), or the Field tool ()
will work.

3. Choose Bkgnd Info from the Objects menu.
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4. Click Colors.
The Colors dialog box for the background appears.

5. Select the color set you want:

_Display colors for background ID 2697
(NN, T WM T ]] Stondord system colors
ST 1 ] Gray scale
These are the SRR T W1 T WAL T Other color sets...
color sets that are 050 L
wm‘:l‘il‘ii’ifﬁ;:}; B O
: When displaying this bkgnd:
levi;?foogsey?u_ | Use these colors | l[ 0K ]] [Cunca]
O

... then press and hold the mouse button here and drag to
choose “Use these colors” (if it’s not already selected) from the
pop-up menu. If you choose “Get colors from stack” instead,
your stack will use the colors currently specified for the stack
no matter which color set is selected for the background.

Figure 3-18 Changing a background’s color set

6. When you’re finished, click OK to confirm your selection.
You see the Bkgnd Info dialog box again.
7. In the Bkgnd Info dialog box, click OK.

o If you’re working in the card layer of a card for which a color set
is selected that’s different from the background’s color set, you
must choose (3-B to see the effect of the color set you just
selected.

If none of the five color sets for a given background includes

the colors you want, you can add a sixth color set to that
background from any document in the Apple Preferred File
Format. “Importing a New Color Set for a Card or Background,”
in Chapter 6, describes how to do this.
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You can also add a sixth color set to a background by using a desk
accessory, an XCMD, or HyperTalk to specify the colors you want.
If you use a desk accessory or an XCMD to do this, any color set
you specify while you’re working in the background layer will be
added automatically to the color sets for the current background
and will be selected. For instructions on using HyperTalk to add

a sixth color set to a card, see the discussion of the colorset
property in the HyperTalk Help stack.

Deleting a background  You can’t delete a background directly. To remove a background
from a stack, you must delete every card that uses the background.
Or, if the stack contains only one background, you can simply
delete the whole stack, as described in “Deleting a Stack” in O
Chapter 2.

Follow these steps to remove a background from a stack without
deleting the whole stack:

1. Go to a card that has the background you want to delete.
2. Choose Delete Card from the Edit menu (or press “-Delete).

The card disappears unless it’s protected. If the card is protected,

the following dialog box appears:

Can't delete protected card.

Figure 3-19  Trying to delete a protected card

»
’

See “Protecting a Card carlier in this chapter, for instructions

on removing card protection.
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2 Important: If you delete a card by mistake, you can bring it back
by immediately choosing Undo from the Edit menu, before you do
anything else.

3. Repeat steps 1 and 2 until you’ve removed from the stack
every card that has the background you want to delete.

When Can't Delete is selected in the Bkgnd Info dialog box for a
background, you can't delete the last card with this background.
(You can, however, delete the stack—including the protected
background.)

“Protecting a Background,” earlier in this chapter, gives information
® on setting and removing a background’s protection.
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Chapter 4

Working With Buttons

Buttons are rectangular “hot spots” you can click to make
things happen in stacks. For example, a button might take you to
another card, show you a picture, launch an application, or run an
animation sequence.

This chapter explains how to do the following:

= Create and modify buttons

» Use the readymade buttons that come with HyperCard
m  Use buttons to link information

To do the tasks in this chapter, you must have your user level set at
least to Authoring. For some of the tasks, your user level must be
Scripting. When a task requires the Scripting level, the instructions
say so. (The section “User Levels and Options” in Chapter 1 tells

you how to set your user level.)




A khng d bUtt()n {Oa Buttons allow you to link any piece of information—a card, an
Card Or backgl-()und idea, a picture, an address—to any other piece of information. You

can use buttons to link related information in any way you like.

But buttons have powers beyond linking—they can play sounds,
dial a phone, produce interesting visual effects, or even show you
a video sequence.

Behind every button is a seript that tells HyperCard what to do
when you click the button. You can create or change a script using
HyperTalk, HyperCard’s English-like programming language.
However, you don't need to learn HyperTalk to create interesting
and powerful buttons. You can create a link without writing

the script that makes it work. You can also copy buttons (with
pre-programmed scripts) from other stacks—including the Butto)
Ideas stack that comes with HyperCard. When you copy a button,
you also copy its script.

Whenever you add a button to a stack, you need to decide whether
you want it in the card layer or the background layer. To decide
where to put the button, consider where you want it to appear:

» Ifyou want the button to appear on only one card, put it in the
card layer.

a If you want the button to appear on every card in the stack, put

it in the background layer.

= [f you want the button to appear on some of the cards in the
stack (but not all of them), consider creating a different ‘
background for those cards and putting the button in that
background only. (“Creating a New Background” in Chapter 3
explains how to add a background to a stack.)

A background button appears in the same location on all the cards

that share the bad\'ground.
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To add a button to a background, you must be in the background
layer; to add a button to a card, you must be in the card layer. To
go to the background layer, press (-B. When you're in the
background layer, the word Background appears in the menu bar,
[f you press  -B repeatedly, you move back and forth between the
card layer and the background layer.

> See also:  * “The Card Layer Versus the Background Layer” in
Chapter 2
* “Creating a Button” in this chapter

Th€ tOOlS fOf To work with buttons, you need the Button tool, the Browse tool,
W’Ql‘king Wlth bU[[OﬂS and perhaps some of the Paint tools.

Use the Browse tool __|

to click buttons.

Use the Button

Vs tool to create and

_ modify buttons.

| Use the Paint
tools when you
want to create
a graphic to
display through
a button.

Figure 4-1  The tools for working with buttons

To make it easy to alternate between the tools, you can “tear off” the
Tools menu to create a movable Tools palette. To do this, drag
down through the menu and past the bottom or beyond either side.
(For an illustration of this, see Figure 2-12.)
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You can use the following ¢ ‘-key shortcuts to choose the tools you
need for working with buttons:

To choose this tool . . . Press
The Browse tool “-Tab
The Button tool -Tab-Tab

» Secalso: “Using HyperCard’s Tools™ in Chapter 2

L()})Ylng I'Céidynl'dd.c HyperCard comes with a stack called Button Ideas that contains
buttons buttons you can copy and paste into your stacks. Some of these
buttons have pre-programmed scripts that can help you develop @)
your own stacks. The Button Ideas stack includes buttons that
launch applications, play sounds, make pictures disappear and
reappear, and play animation sequences.

You don’t need to know HyperTalk to make the buttons with
pre-programmed scripts work—you just need to understand what
they do, so that you can use them appropriately in your stacks.
These buttons are designed to work in virtually any stack. They
dor’t depend on your stack’s structure in any way.

You can copy buttons that you like from other stacks as well as from
the Button Ideas stack. However, unlike the buttons in Button

[deas, buttons from other stacks may not work the way you expect

in your own stack. See the section “Copying Parts From Other o
Stacks” in Chapter 2 for information about the factors you need

to consider.
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Buttons for opening stacks that

come with HyperCard:

Addresses

A button that plays
a sound:

A button that

quickly shows you
all the cards in the

b

n A

Calendar

An animated

button:
'%% d]) {w(m’r"
< IS
il T,

A button that lets
you search for text
in a stack:

Buttons that hide and
show the card picture:

( Hide Picture)
(Show Picture)

Show Picture

A button that opens
an application:

O,

Applellorks

A button that takes
you to the HyperCard
Help stack:

stack:

O Q

Some readymade buttons

Figure 4-2

Copying buttons from the Button Ideas stack can make stack
building easier and save you a lot of time. If you see a button you
like, copy it and paste it into your stack. Note that in the Button
[deas stack, only buttons inside red borders include scripts. If you
copy a button that doesn’t include a script, you must write a script
for it before it will do anything,

Follow these steps to copy one of the buttons in the Button Ideas
stack:

1. Open the Button Ideas stack.
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2. Go to the card that has the button you want to copy.

3. Choose the Button tool (=) from the Tools menu (or click it

on the Tools palette).
4. Click the button you want to copy to select it.
A moving dashed line surrounds the selected button.
5. Choose Copy Button from the Edit menu, or press ~~-C.

This puts a copy of the selected button (including its scripr,
if it has one) on the Clipboard. (This button replaces the last
item you cut or copied; the Clipboard can only hold one item
at a time.)

6. Go to the card or background where you want to put the ‘
copied button.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Button tool is selected.

If you're not sure whether to put the button in the card layer
or the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chapter.

7. Choose Paste Button from the Edit menu, or press -V.

This takes a copy of the button that’s on the Clipboard, puts it
on the current card or background, and selects it.

8. While the button is still selected, drag it to where you want it'
on the card.

Important: The most common mistake in copying a button is
putting it in the card layer when you want it in the background
layer. (To find out whether a button is in the background, press

-B to see just the background elements.) If you put a button in
the card layer by mistake, see “Moving a Button From the Card
to the Background,” later in this chaprer.
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Buttons for opening stacks that Buttons that hide and
come with HyperCard: show the card picture:

i

Addresses Calendar

A button that plays  An animated A button that opens
a sound: button: an application:

e A,
< il
il U,

il ﬂ]ﬁ O AppleWorks

A button that A button that lets A button that takes
quickly shows you  you search for text  you to the HyperCard
all the cards inthe  in a stack: Help stack:

stack:

= Lh
Figure 4-2  Some readymade buttons

Copying buttons from the Button Ideas stack can make stack
building easier and save you a lot of time. If you see a button you
like, copy it and paste it into your stack. Note that in the Button
[deas stack, only buttons inside red borders include scripts. If you
copy a button that doesn’t include a script, you must write a script
for it before it will do anything,

Follow these steps to copy one of the buttons in the Button Ideas
stack:

1. Open the Button Ideas stack.
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2. Go to the card that has the button you want to copy.

3. Choose the Button tool (=) from the Tools menu (or click it

on the Tools palette).
4. Click the button you want to copy to select it.
A moving dashed line surrounds the selected button.
5. Choose Copy Button from the Edit menu, or press " ~-C.

This puts a copy of the selected button (including its script,

if it has one) on the Clipboard. (This button replaces the last
item you cut or copied; the Clipboard can only hold one item
at a time.)

6. Go to the card or background where you want to put the ®
copied button.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Button tool is selected.

If you’re not sure whether to put the button in the card layer
or the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chaprer.

7. Choose Paste Button from the Edit menu, or press -V.

This takes a copy of the button that’s on the Clipboard, puts it
on the current card or background, and selects it.

8. While the button is still selected, drag it to where you want it.
on the card.

/\ Important: The most common mistake in copying a button is
putting it in the card layer when you want it in the background
layer. (To find out whether a button is in the background, press

-B to see just the background elements.) If you put a button in
the card layer by mistake, see “Moving a Button From the Card

to the Background,” later in this chapter.
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® Creating a button

Hold down the

key while

If the button you copied includes a script, you can test it after you
copy it—ijust choose the Browse tool and click the button.

You can see the HyperTalk commands that make the button work
by opening the button’s script, as explained in “Opening a Button’s
Script,” later in this chapter. If the button doesn’t have a script, you
can learn how to write one for it by working through the exercises

in the HyperTalk Beginner’s Guide.

» Seealso: “Changing the Appearance of a Button” in this chapter

Buttons come in many different styles and sizes. A button can be
blank; it can have text, an icon, or both; or it be placed over a
graphic, so that the graphic appears to be part of the button.

You can create a blank, transparent button on a card or background
by following these steps:

1. Go to the card or background where you want the button.

If you're not sure whether to put the button in the card layer or
the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chapter.

2. Choose the Button tool (=) from the Tools menu.
The pointer changes to an arrow (»).
3. Hold down the (3 key and drag diagonally.

This creates a blank, transparent button and leaves the button
selected:

__________________ to here.

Figure 4-3  Creating a blank button
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Creating a button
with text

You can bring the button to life by linking it to another card or
writing a script for it (if you're familiar with HyperTalk). “Linking
Information,” later in this chapter, gives instructions for linking,
For information on scripting, see the HyperTalk Beginners Guide.

The sections that follow explain how to create new buttons with

text, icons, and graphics.

P Seealso:  * “Changing the Appearance of a Button” in this chapter

Displaying text on a button is one good way to indicate what the
button does.

Creating a text button is also a useful way to add a short text label
to a card or background—whether or not the button does anythh.’
dynamic. Button text is easy to move around on the card, because it
moves when you move the button.

Follow these steps to create a new button with text:
1. Go to the card or background where you want the button.

If you’re not sure whether to put the button in the card layer or
the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chapter.

2. Make sure you have one of the General tools selected.

The Browse tool (¥), the Button tool (=), or the Field tool (E3)
will work. ‘
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The text you type here is
displayed on the button . . .

... if Show Name is selected.

3. Choose New Button from the Objects menu.

This automatically selects the Button tool, creates a button
named New Button in the center of the card window, and selects

the button.

.......... , — The moving dashed
New Buttor ' line indicates that the

-
1
1 ] N

------------ button is selected.

Figure 4-4 A button created with the New Button command

< Another method: You can create a blank, transparent button
by choosing the Button tool, then pressing and holding the
key while you drag diagonally (as shown in Figure 4-3). %

4. While the button is still selected, choose Button Info from the
Objects menu.

Or double-click the button. The Button Info dialog box

appears.

5. Type the text you want to display on the button:

N
(IXT Y YRR [Shov the Topics |

Card button number: 2 Card button ID: 2

Sstonkme  suyle
Auto Hilite
& Fomily:

{4 Share Bitite

(Link To..) ( Font... )
(Script...) [Colors...)

[[ 0K ]] [Cuncel]

Figure 4-5 Typing the text you want to display on the button
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6. Click the Show Name check box to select it, if it isn't already

selected.
7. Click OK.

The text you've typed appears on the button. (A button can
display only one line of text.) To see all the text, you might have
to enlarge the button:

/ ot}
nowt the Topie 1o resize the bution,
drag from any corner.

Figure 4-6  Resizing a button

If the button is no longer selected, you can select it by choosing
the Button tool and then clicking the button.

8. While the button is selected, drag it to where you want it on

the card.

/A Important: The most common mistake in creating a button is
putting it in the card layer when you want it in the background
layer. (To find out whether a button is in the background, press

1-B to view just the background elements.) If you put a button in
the card layer by mistake, see “Moving a Button From the Card to
the Background,” later in this chapter. A

®

You can bring the button to life by linking it to another card or
writing a script for it (if you're familiar with HyperTalk). “Linking
Information,” later in this chapter, gives instructions for linking,
For information on scripting, see the HyperTalk Beginner s Guide.

< Another kind of text button: Another way to make a burton
with text is to create a transparent button and place it over
some Paint text. The advantages and disadvantages of this
method are described in “Creating a Button with a Graphic,”
later in this chapter. %
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» Secalso: “Changing the Appearance of a Button” in this chaprer

e “When Elements Owverlap™ in this chaprer

Creating a button  HyperCard comes with a collection of icons you can assign to
with anicon  buttons. Displaying an icon on a button is one good way to indicate
graphically what the button does.

Creating a button with an icon is also a useful way to add a graphic
element to a card or background, whether or not the burton is
dynamic. Since the icon is attached to the button, you can move

i[ ill‘()ll”d CilSiIY***il IMmoves Wh(‘n y()ll move d](' l)ll[[()n.
Follow these steps to create a new button with an icon:
1. Go to the card or background where you want the button.

If you’re not sure whether to put the button in the card layer
or the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chapter.

2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (E2)
will work.

3. Choose New Button from the Objects menu.

This automatically selects the Button tool, creates a button
named New Button in the center of the card window, and selects

. the button.

O .— The moving dashed
' New Button | line indicates that the
----------- *  button is selected.

Figure 4-7  Making a new button

% Another method: You can create a blank, transparent button
by choosing the Button tool, then pressing and holding the
1 key while you drag diagonally (as shown in Figure 4-3). #
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4. While the button is selected, choose Button Info from the
Objects menu.

Or double-click the button. The Button Info dialog box

appears:

[f this option is selected

and the button has a Button Name: |[TXTETTXYTY |
name, the button name Bkgnd button number: 8 Bkgnd button ID: 50

} will ;l}ppc;u (.)i] 1}}' 5] Show Name Style:

)U[t(-m along with the 2] Auto Hilite _

icon you choose. . Family: {_0 (none)
/ ["1Share Hilite

Click here to see a

collection of icons

you can choose from. (Link To..) (_Font... ) .
[Script...) [Color...) '! 0K l’ ( Cancel }

Figure 4-8 The Button Info dialog box

5. Click Icon.

The Icon dialog box appears:

10: 0 (none)
ml@&@m@ o
Q E% ﬁm’u‘s Gy ﬁ%,z H5 O | Scroll, if

necessary, to

m e = @9 ¢ L iy find the icon you
) Gt vant to display
) (done ) (toneel) (X ) (\m Irhc(;wti[?}nf

If the icon you select isn't entirely visible, press
and hold the mouse button here to see what the
whole icon looks like.

Figure 4-9  Choosing an icon
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6. Click the icon you want to display on your button.
7. Click OK.

The Icon dialog box disappears and you see the Button Info
dialog box again.

8. In the Button Info dialog box, click OK.

The icon you’ve selected appears on the button. To see the
whole icon, you might have to enlarge the button:

EEEE ---
!
[ ﬂl\b To resize the button,

dx \g from any corner.

"-

Figure 4-10  Resizing a button

9. While it’s still selected, drag the button to where you want it
on the card.

2 Important: The most common mistake in creating a button is
putting it in the card layer when you want it in the background
layer. (To find out whether a button is in the background, press

-B to view just the background elements.) If you put a button in
the card layer by mistake, see “Moving a Button From the Card to
the Background,” later in this chapter. A

If you don't want to use any of the icons shown in the Icon dialog
box, you can copy a button with an icon you like from the Button
[deas stack or create your own icon using the Icon Editor stack.

[t you want to change the colors of the icon displayed on your
button, see “Changing a Button’s Colors,” later in this chaprer.
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You can bring the button to life by linking it to another card or
writing a script for it (if you're familiar with HyperTalk). “Linking
Information,” later in this chapter, gives instructions for linking.
For information on scripting, see the Hyperlalk Beginner’s Guide.

» Seealso: * “Managing Icons” in this chapter
¢ “Changing the Appearance of a Button” in this chapter
 “When Elements Overlap” in this chapter

Combining text with an icon

You can add text to a button that already has an icon. Follow

these steps:
1. Choose the Button tool (=) from the Tools menu. O
2. Double-click the button.
The Button Info dialog box appears.
3. Type the text you want to add to the button.
4. Click the Show Name check box to select it.
5. Click OK.

The text appears along with the icon on your button. To see all
the text, you might have to enlarge the button:

R -

h

; R
dome Sweet Homé
e ' To resize the button,

drag from any corner.

-

[

'

[

[

[

1

1

1

[

1

1
™

Figure 4-11  An icon with text

164 Chapter 4: Working With Buttons




Creating a button
with a graphic

You can make a button with a graphic by placing a transparent
button over a graphic. Use this technique when you want to make
a graphic dynamic—so that something happens when you click it.
(Since a graphic can’t have a script, overlaying a button is the only
way to do this.)

Important: Buttons with graphics are difficult to move and copy,
because buttons and graphics are different kinds of elements. They
have to be manipulated separately, with different tools—you use
the Paint tools to manipulate the graphic and the Button tool to
manipulate the button—and they’re in different layers (as explained
in “When Elements Overlap,” later in this chapter). It’s better to
use a button with an icon (if possible), because an icon is attached
to the button and moves easily with the button. A

Follow these steps to create a button with a graphic:
1. Go to the card or background where you want the graphic.

[f you're not sure whether you want the graphic in the card layer
or the background layer, see “Adding Graphics to a Card or
Background” in Chapter 6.

2. Create the graphic.

You can create it with the Paint tools, scan it in, bring it in from
a document in the Apple Preferred File Format, or copy and
paste it from another stack. The graphic can include some Paint
text, or it can be entirely Paint text. Chapter 6 gives instructions
for creating graphics.

3. Choose the Button tool (=) from the Tools menu.
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While holding down the ©* key, —.,

drag from the upper-left corner
of the graphic . . .

Managing icons

4. Press and hold the key while you drag diagonally to create a

button around the graphic:

eeeeeeeeemeeeneeeeni— . .. to the lower-right corner.

Figure 4-12  Placing a transparent button over a graphic

You can bring the button to life by linking it to another card or
writing a script for it (if you're familiar with HyperTalk). (“Linking
[nformation,” later in this chapter, gives instructions for linking. For
information on writing scripts, see the HyperTalk Beginner’s Guide.)

HyperCard comes with a collection of icons you can assign to
buttons. Assigning an icon to a button is an easy way to add a
graphic element to a card or background. You simply select the
button and choose an icon from the Icon dialog box. (“Creating ®
a Butron With an Icon,” earlier in this chapter, gives specific
instructions.)

An icon you assign to a button is associated with that button until
you specifically change it in the Icon dialog box. When you select
the button and drag it around on a card, the icon moves with it.

But the icon is not actually stored in the button.
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Each icon that appears in the Icon dialog box is stored in a special
part of the HyperCard program file (or a HyperCard stack) called a
resource fork. Most Apple 11Gs files—including the Home stack and
any other HyperCard stack—have a resource fork, where resources
like icons, sounds, and so on are stored. The icons that appear in
the Icon dialog box include the standard icons that are stored in the
HyperCard IIGS program file, any icons that are stored in your
Home stack, and any additional icons stored in the current stack.

Using HyperCard’s Icon Editor stack, you can modify an icon
that’s displayed on a button, create icons of your own, and add
icons to your stacks. The Icon Editor stack tells you how. Once you
have created or modified an icon, you need to consider where you
want to store it so that it will be available to the stacks in which
you want to use it.

For example, if you create an icon and install it in any stack other
than Home, it will appear in the Icon dialog box for buttons in that
stack, but it will not appear in the Icon dialog box for buttons in
any other stacks. If you expect to use a particular icon in several
different stacks, install it in your Home stack. That way it will
always show up in the Icon dialog box no marter which stack
you're working in.

If your Apple IIGS is part of a network, you may want to consider

a different strategy. Each person using HyperCard over a network
uses a different Home stack. This means that any custom icons
you've installed in your own Home stack won't be available to other
people on the network. If you’re creating a stack that you want
everyone on the network to be able to use, make sure that any
custom icons assigned to buttons in that stack are stored in the stack
itself as well as in your Home stack. That way your custom icons
will be available to everyone who uses your stack, even if they don't
have them installed in their own Home stacks.

The Icon Editor stack allows you to install icons you’ve created
with the Icon Editor in any other stack. You can also install an
icon by copying and pasting a button, or by using the Import
button in the Icon dialog box. The sections that follow explain
these two methods.
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IHS[’dHiﬂg an icon To copy an icon from any stack other than the Home stack into
by pasting a button another stack, follow these steps:

Click the icon to select it
(if it's not already selected) . . .

If the Import button is
dimmed, the icon is stored
in the current stack.

1. Go to a stack that contains a button with the icon you want to

install.

2. Choose the Button tool (=) from the Tools menu.

3. Double-click the button.

The Button Info dialog box appears.
4. Click Icon.

The Icon dialog box appears.

5. Make sure the icon you want to copy is installed in the currexb

stack:

10: 1370 "Sun1" from "ANIMATIONSTACK"

Figure 4-13  Finding out where anicon is stored

6. Click Cancel.

. and make sure the
name shown here is the
name of the current stack.
If itisnt, go to the stack
with the name shown and
begin again with step 1.

Scroll, if necessary, to locate
the icon you want to copy.

The Icon dialog box disappears and you see the Button Info

dialog box again.

Chapter 4: Working With Buttons




7. Click Cancel again.

10.

11.

The Button Info dialog box disappears. A moving dashed
line surrounds the button you want to copy, indicating that it
is selected. (If you deselect it by accident, just click it again to
select it.)

Choose Copy Button from the Edit menu, or press _-C.

This makes a copy of the selected button (including its icon) and
puts it on the Clipboard. (This button replaces the last item you
cut or copied; the Clipboard can only hold one item at a time.)

Go to the stack in which you want to install the icon.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Button tool is selected.

If you just want to install the icon, you can go to any card or
background in your stack. If you want to use the button (and its
script) as well as the icon, go to the card or background where
you want the button to appear. (If you’re not sure whether to
put the button in the card layer or the background layer, see
“Adding a Button to a Card or Background” at the beginning
of this chapter.)

Choose Paste Button from the Edit menu, or press = -V.

This takes a copy of the button that’s on the Clipboard, puts it
on the current card or background, and selects it. At the same
time, pasting the button installs the button’s icon in the current
stack’s resource fork.

If you want to keep the button, drag the button to where you
want it.

[f you don’t need the button, press Delete to delete it. The icon
remains in the stack and will appear in the Icon dialog box for
any button in that stack.

The icon you've installed will now appear in every copy of the stack,
even if the icon is not installed in the current Home stack.
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Installing an icon with the To copy an icon from your Home stack into another stack, follow
Icon dialog box  these steps:

1. Go to the stack in which you want to install the icon.
2. Choose the Button tool (=) from the Tools menu.

3. Double-click the button on which you want to display
the icon.

The Button Info dialog box appears.(You must follow this step
and the steps that follow even if the button already displays the
icon you want.)

4. Click Icon.
The lcon dialog box appears. ®
Install the icon as shown in this figure:

N

Click the icon to select it
(if it's not already selected) . . .

... then click here to import
the icon into the current stack.
(If the Import button is

dimmed. the icon is already
|

TOre v T DN ’
stored in the current stack and iy C« o

you don't need to import it.)

(Rone ) (Cancel) (k)
Figure 4-14  Installing an icon with the Icon dialog box .

The icon is now installed in the current stack.

6. Click OK.

The Icon dialog box disappears and you see the Button Info
dialog box again.
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7. Click Cancel again.

10.

11.

The Button Info dialog box disappears. A moving dashed
line surrounds the button you want to copy, indicating that it
is selected. (If you deselect it by accident, just click it again to
select it.)

Choose Copy Button from the Edit menu, or press ~"-C.

This makes a copy of the selected button (including its icon) and
puts it on the Clipboard. (This button replaces the last item you
cut or copied; the Clipboard can only hold one item at a time.)

Go to the stack in which you want to install the icon.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Button tool is selected.

If you just want to install the icon, you can go to any card or
background in your stack. If you want to use the button (and its
script) as well as the icon, go to the card or background where
you want the button to appear. (If you’re not sure whether to
put the button in the card layer or the background layer, see
“Adding a Button to a Card or Background” at the beginning
of this chapter.)

Choose Paste Button from the Edit menu, or press = -V.

This takes a copy of the button that’s on the Clipboard, puts it
on the current card or background, and selects it. At the same
time, pasting the button installs the button’s icon in the current
stack’s resource fork.

If you want to keep the button, drag the button to where you
want it.

[f you don’t need the button, press Delete to delete it. The icon
remains in the stack and will appear in the Icon dialog box for
any button in that stack.

The icon you've installed will now appear in every copy of the stack,
even if the icon is not installed in the current Home stack.
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Installing an icon with the  To copy an icon from your Home stack into another stack, follow
[con dialog box  these steps:

1. Go to the stack in which you want to install the icon.
2. Choose the Button tool (=) from the Tools menu.

3. Double-click the button on which you want to display
the icon.

The Button Info dialog box appears.(You must follow this step
and the steps that follow even if the button already displays the
icon you want.)

4. Click Icon.
The Icon dialog box appears. O
. Install the icon as shown in this figure:

\N

Click the icon to select it ID: 1370 “tual” frem "H"

(if it's not already selected) . . .

.. then click here to import
the icon into the current stack.
(If the Import button is
dimmed. the icon is already
stored in the current stack and
you don't need to import i)

(“Twone ) (Concel) {0k )
Figure 4-14 Installing an icon with the Icon dialog box .

The icon is now installed in the current stack.

6. Click OK.

The Icon dialog box disappears and you see the Button Info
dialog box again.

170 Chapter 4: Working With Buttons




7. In the Button Info dialog box, click OK.

The icon you've installed will always appear in the Icon dialog box
for your stack, even if the icon is not installed in the current

Home stack.

LOC’dting buttons Many of the buttons in stacks are easy to locate right away. But

some buttons are harder to find—particularly transparent ones.

You can locate the buttons on the current card and background
using any of the following methods:

® » While the Browse tool is selected, you can “peek” at the buttons
by pressing and holding the (3 and Option keys. Gray or colored

rectangles appear around the buttons:

Thin rectangles outline the
buttons in the card layer.

l

(O Keep Score

2| E2] [ change Colors | qu

Thick rectangles outline the buttons in thel
background layer.

‘ Figure 4-15 Peeking at buttons
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s When you choose the Button tool from the Tools menu,
rectangles appear around the buttons that don't already have

an outline:

When you
choose the .. . rectangles appear
Button Tool . . . around the buttons.

User Name

oe tack / Welcome

l |
ps

Help Picture Puzzler

= ([
Tour Story Board

Copyright © 1990 Apple Computer, Inc.
BT [ esors ][ Toolki ][ Attic ][ Bosenent |

'

Figure 4-16  Locating buttons with the Button tool

» Some stacks have hidden buttons. To “peek” at all the burtons
on the current card and background—including any hidden
buttons—choose the Button tool from the Tools menu, then
press and hold the ( and Option keys. Gray rectangles appear
around all the buttons:

When you choose the Button tool
and press (-Option, rectangles ...and the .
outline the visible buttons . . . hidden buttons.

AMANASA

‘O Keep Scor; Ik

[@ Practice i Colorsj ] ’ ‘

Fieure 4-17 Peeking at all the buttons—both visible and hidden
gL 8
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Changing Once you've created or copied a button, you can change its
the appearance appearance by resizing it, changing its style, adding text or an

icon to It, Changing or removing its text or icon, or changing its
of a button color. This section explains how to make a button look the way you

want it to.

< Note: You can change the appearance of both card buttons and
background buttons while you’re working in the card layer. You
don’t have to be in the background layer to modify background

buttons. «

Changing the size  To resize a button, follow these steps:
. of a button 1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to resize to select it.

A moving dashed line surrounds the selected button.

3. Drag from any corner of the button:

: k_— Drag [rom any corner
to resize the button.

. Figure 4-18  Changing a button’s size

To resize the button in one dimension only—either horizontally
or vertically—hold down the Shift key while you drag from a

corner.

< If you move the button instead of resizing it: Choose Undo
from the File menu to return the button to its original
position and try again. Make sure you drag from a point
close to a corner of the button. «
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Ch()()sing a button's slylc A button can have any one of seven styles. Examples of the seven
button styles are shown in the following figure, along with the

names of the styles:

oociofFansparent ———. 1 The background shows
ceriiiiiiiiiiiiii ] through transparent buttons,
opaque
v rectangle e .
- = - - | L These kinds of buttons
shadow are all opaque.

.......

| The background shows through

i) radio button: il the text part of these buttons, but
ciitoererioiiioiii ey notthrough the button part.

Figure 4-19  The button styles

To set the style for a button, follow these steps:
1. Choose the Button tool (=) from the Tools menu.

2. Click the button to select it.
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Makes the button an opaque (white)
rectangle, with no visible border.

Makes the button an opaque
(white) rectangle, with a shadow
along the right side and bottom.

Makes a small square button
with an opaque interior.

3. Choose Button Info from the Objects menu.

The Button Info dialog box appears:

Button Name: ||

Card button number: 6 Card button ID; 7

(=] Show Name Style:
=] Auto Hili
Ru OHIIIFE Family:

Y

&ink To.A.] [ Fontj

(Scripm [Colors...] (( 0K ]) [Cunce

1)

Card buf

Figure 4-20  The Button Info dialog box

4. Press and hold the mouse button over the pop-up Style menu

and drag to choose a style:

Stule:
— shadow
round rect
_ check box
radio button

Family:

|i 0K i' [Cuncel]

. |

| Makes the button transparent,
with no visible border.

| Makes the button an opaque (white)
rectangle with a thick black border.

| Makes an opaque (white)
rounded rectangular button.

| Makes a small round button
with an opaque interior.

Figure 4-21  Choosing a button’s style
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Adding, changing,
Or removing
button text

Setting the format
for button text

For a button with an icon, don’t choose either the check box or
the radio button style—if you do, you won't see the icon.

5. Click OK.

To add, change, or remove button text, follow these steps:
1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to change to select it.

A moving dashed line surrounds the selected button.

3. Choose Button Info from the Objects menu while the button
is selected. .

The Button Info dialog box appears.

4. Type the text you want to display on the button; or press
Delete, if you want to delete the text.

You can also remove the text from the button by clicking the
Show Name check box to deselect it.

5. Click OK.

[f you want to change the colors of the text displayed on your
button, see “Changing a Button’s Colors,” later in this chapter.

To change the font, style, size, or alignment of the text that’s

displayed on a button, follow these steps: O
1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to change to select it.
A moving dashed line surrounds the selected butron.
3. Choose Text Style from the Edit menu, or press =~ -T.

The Text Style dialog box appears.
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4. Choose from the options in the Text Style dialog box:

Click to select a font
Click to select the size (measured in
font you want. points).

Click to select or deselect one or

. o, Style: - - ; 5
more text styles. (Select nothing for l:IBa!;d Courier g ¢ I
2in text ) y 2 text af the . Geneva 1 | 16 i
plain text.) The sample text at the | T 1talic Helveti
bottom of the dialog box shows the {Yinderline e
effect of the selected styles. ] Outline Times ||
(] Shadow Venice O O To use a font size not

Press and hold the mouse button here ClignLeft | LineHeight: [0 | Font Size: [§_ listed, type it here.

to see a pop-up menu for choosing This number does not
the alignment of text « b , The quick brown fox jumps over the lazy dog. '
ignment of text on the button q Jump y dog affect the way the text

looks on a button. (Only

. T . , one line of text can show
I'his shows what the text on
, : : on a button.)
your button will look like.

Figure 4-22  The Text Style dialog box

5. Click OK.

The butron’s text is displayed in the formart you've specified.

Assigning, changing, To assign a new icon to a button, assign a different icon to a button,
Or removing an icon  or remove a button’s icon, follow these steps:

1. Choose the Button tool (=) from the Tools menu.
@ 2. Double-click the button you want to change.
The Button Info dialog box appears.
3. In the Button Info dialog box, click Icon.

The Icon dialog box appears.
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To display an icon

on the button (or

assign the button a
different icon),
click to select the
icon you want.

4. Select an icon for the button, or remove the icon, as shown in

the following figure:

1D: 0 (none)

27 . DE G D o
& & @h &5 0 M seroll, if
£

necessary, to
e 2 @ ¢ I find the icon vou

Q
st

want to display

Yiew Bpayt None Cancel 0K

Clie) Qo) C ) ( )L ) on the button.
If the icon you select isn't  1Click here if you want ‘
entirely visible, press and - to remove the button's
hold the mouse button icon,

here to see what the
whole icon looks like.

Figure 4-23 Setting and removing an icon

5. Click OK.

The Icon dialog box disappears and you see the Button Info
dialog box again.

6. In the Button Info dialog box, click OK.
Your button displays the icon you've chosen.

If you don't want to use any of the icons shown in the Icon dialog
box, you can either copy a button with an icon you like from the
Button Ideas stack or create your own icon using the Icon Editor
stack.

If you want to change the colors of the icon displayed on your
button, see the next section, “Changing a Button’s Colors.”

»  Secalso: “Managing lcons” in this chaprer
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(Jllllﬂglﬂg 4 button'’s  You can choose the colors for four different parts of a button: the
colors  icon front, icon back, button frame, and button text. Fach part is a
different color in the button shown here:

ﬁ" ol
Front __| I—_ Back

lext ——— Home

___ Frame

Figure 4-24  The four parts of a button

o To change a button’s colors, follow these steps:
1. Choose the Button tool (=) from the Tools menu.
2. Double-click the button you want to change.
The Button Info dialog box appears.
3. In the Button Info dialog box, click Colors.
The Colors dialog box appears.

4. Select the colors you want:

Click the colors
you want for each IconFront  IconBack
part of the icon.

ﬁzﬂ This shows how

sample the colors you
select affect the
way the icon

looks.

'E‘
-

Figure 4-25  The Colors dialog box for the button shown in Figure 4-24
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5. Click OK.
The Icon dialog box disappears and you see the Button Info
dialog box again.

6. In the Button Info dialog box, click OK.

The button displays the colors you have chosen.

Lmkmg information o create a link between relaced pieces of information, you create

a button and link it to another card or stack. When you click a
button that’s linked to another card, that card appears immediately.
Links are one way. To move back and forth between two cards, '@
need two links—one in each direction:

‘l - . e
i

Hote Stack / Deskset perLard ] I

Create QuickLink..
User Preferences

Ty

Figure 4-26 Two links that take you from one stack to another and back again
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Using the Link To method

You can close the Link To
box without creating a link
by clicking the close box or

the Cancel button.

You can link a button to a card or stack using any of the following

methods:
m  Use the Link To box.
s Write a short script.

m  Use the Create QuickLink button in the standard Home
stack (as described in “Customizing Your Home Stack” in
Chapter 2).

Important: If you use the Link To method o link a button
that already has a link, the new link completely replaces the
previous one. A

To use the Link To method for linking a button to any card or
stack, follow these steps:

1. Choose the Button tool (=) from the Tools menu.
2. Double-click the button you want to link.

The Button Info dialog box appears.
3. In the Button Info dialog box, click Link To.

The Link To box appears:

Link to: \

(This Card ) (This Stack) (" Cancel )

Figure 4-27  Using the Link To box to create a link

< Note: The Link To box works differently than a standard
Apple IIGS dialog box. You don’t respond right away when
you see the Link To box. First you use HyperCard’s
navigation methods (such as the Go menu commands)
to locate the card or stack to which you want your
button linked. «
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4. Before you click a button in the Link To box, go to the card
you want to link the button to.

The Link To box doesn’t disappear—it stays on the screen while
you move from card to card.

If the Link To box gets in your way, you can move it:

5 | You can move the
Link to: Link To box b

ANK 10 DOX DY
(This Card ) (This Stack) (_Cancel ) dragging from here.

Figure 4-28 Moving the Link To box

5. When you’re looking at the card or stack you want to link the
button to, click the option in the Link To box that reflects
where you want the button to take you.

Click This Card if you want to link the button to the current
card.

Or click This Stack to link the button to the first card in the
current stack (no matter which card you’re looking at).

After you click one of these options, HyperCard returns you to
the card that contains the button you’ve just linked. The button

is still selected.

[f you want to test your new link, choose the Browse tool from the.
Tools menu and click the button. It should take you to the card or

y
stack you've just linked it to. If it doesn’t, repeat the Link To
procedure or try the scripting procedure described in the next
section, “Scripting a Link.”
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Scripting a link — As an alternative to using the Link To box, you can write a script
that links a button to another card or stack. (To do this, you must
have your user level set to Scripting, as explained in “User Levels

and Options” in Chapter 1).

Once you know the steps involved in scripting a link, this method
can be faster and more straightforward than using the Link To box
to create a link.

Follow these steps to seript a link:

1. If you’re linking the button to a specific card, find out the

card’s name, number, or ID.

To find the card’s name, number, or ID, go to the card and

® choose Card Info from the Objects menu.
The Card Info dialog box appears. Make a note of the card’s

name, number, and ID:

The card’s name

/e

Cord Name: | IFTYWEEY I

The card’s number

The card’s ID

Card 10: 4670, Card number 3%ut of 7

Contains 0 card fields.
Contains 5 card buttons.
G Can't Delete
[10on't Search

ok ) (concel)

Figure 4-29  Finding out a card’s name, number, and 1D
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2. Go to the card that contains the button for which you're

creating a link.

3. Press and hold the and Option keys while you click the

button once.

The button’s script opens. It should look like this:

Script of Card button ID 1

| it
3

( Find ) ( Print ) (0K ) (Cancel)

Figure 4-30  Opening a button’s script

4. If there’s any text in the script, don’t go any further.

The text indicates that the button is designed for another
purpose. Unless you're familiar with HyperTalk, it’s best to
close the script by clicking Cancel, and create or find another o

button to link.
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5. If the script is empty (like the one shown in Figure 4-30), type
any of the following, substituting the card name, card number,
card 1D, or stack name for the card or stack you want to link
the button to:

Seript of Card button ID 1 Takes you to the card with
onmouselp ’

g0 to card "eard name" the specified name.
end mouselp

foript of Cord button 101 Takes you to the card with
on mouselp T bt

g0 tocard the specificd number.

end mouselp

. Script of Card button ID 1

Takes you to the card with
onmouselp ‘

g0 to card ID 8 the specified ID.
end mouselp

Script of Card button 101 Takes you to the stack with
on mouselp i

90 to stack "stack name" the specified name.
end mouselp

Takes you to the card with

Script of Card button ID 1 the specified card name in

onmouselp he stack with the specified
g0 to card “card name™ 1n stack “stack name* — LNE SLACK with the specifiec
end mouselp stack name.

Figure 4-31  Scripting a link

6. When you're finished, press Enter.

If you want to test your new link, choose the Browse tool (")
from the Tools menu (if it isn’t already selected) and click the
button. It should take you to the card you’ve just linked it to.

If it doesn’t, check your script for typos and make sure the card
name, number, or ID matches the one you’ve typed in the script.
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Mélking d bUtt()ﬂ You can design a button so that it highlights momentarily when
' : lick it. Such a button is helpful when you’re using a stack
l]lo 11()— you ¢ ) p y g )
Oh , E?ht lwieg because it provides visual feedback that you've clicked the button.
1US CliICKe
Follow these steps to create a button that highlights when you
click it:

1. Choose the Button tool (=) from the Tools menu.

2. Double-click the button.

The Button Info dialog box appears.

3. In the Button Info dialog box, click the Auto Hilite check box
to select it.

4. Click OK. O

Auto Hilite works as just described for all buttons except check box
and radio buttons and buttons that are part of a family. When Auto
Hilite is selected for a check box or radio button, clicking the
button once highlights it and leaves it highlighted. Clicking the
button again removes the highlight. When Auto Hilite is selected
for a button that is part of a family, clicking the button once
highlights it and removes the highlights, if any, from other buttons
that belong to the same family. (For more information about button
families, see “Making a Group of Buttons Highlight As a Family,”
later in this chapter.)

With the Auto Hilite option turned off, you receive no visual
feedback when you click a burtton. ‘
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These highlight |

for only a
moment when
you click them,

Making a button

appear highlighted

on certain cards

The figure that follows shows how the different kinds of buttons
highlight when Auro Hilite is turned on.

transparent @ check box
These stay highlighted
until you click them again.
opaque C?, radio button
m fectangle

m

Figure 4-32 Highlighting buttons of different styles

Background buttons have an additional option available (in the
Button Info dialog box) called Share Hilite. When you click a
background button for which both Auto Hilite and Share Hilite are
turned on, the button becomes highlighted on every card with that
background. If the button is a radio button or check box, it stays
highlighted; if it is any other kind of button, it highlights only
momentarily. (To make a button that is not a radio button or a
check box remain highlighted after it’s clicked, rather than high-
lighting for only a moment, you must use HyperTalk to change
the button’s hilite property. See the HyperTalk Help stack

for details.)
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However, when Auto Hilite is turned on and Share Hilite is turned
off, the highlight of the button can vary from card to card. This
allows the button to appear highlighted on some cards, and not on
others—which can be useful for signifying that something is true
for some cards but not for others. (Check boxes and radio buttons
are particularly useful for this purpose.)

To allow a background button’s highlight to vary from card to card,
follow these steps:

1. Choose the Button tool (=) from the Tools menu.

2. Click the button whose highlighting you want to vary from
card to card to select it.

3. Choose Button Info from the Objects menu. ®
The Button Info dialog box appears.
4. Click the Share Hilite check box to deselect it, if it’s selected.

When a background button is first created, this option is
turned off. If it has been turned on, click it to turn it off again.

Button Nome: | ]
Click Auto Hilite to Bkgnd button number: 2 Bkgnd button ID: 2

\‘CI(‘(.[l 1L, ltl 1l 15“[[ D Show Name StUIE transparent

dlready selectec .

‘ ) E<) Auto Hilite . - -
Family: | 0 Cnone)

Click Share Hilite [ Share Hilite
to deselect it, if it’s ‘
selected.
(LinkTo..) ( Font... )

(Script...) ﬁolors..) ((T) (Cuncel]

Figure 4-33  Varying a button’s highlighting from card to card

5. Click the Auto Hilite check box to select it, if it isn’t
already selected.
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6. Click OK.

[f you want the button to appear highlighted on any particular
card, you have to go to that card and click the button.

Making d group of Normally, when you click a radio button or check box for which
buttons hlghhght Auto Hilite is turned on (in the Button Info dialog box), the button

highlights; and when you click it again, the button changes back to

dS d féllnlly Its ()riginnl appearance.

Sometimes you may want a group of buttons to work together as a
family, so that only one button in the group can highlight at one

@) time. For example, you can use a group of radio buttons on one
card to choose between several different options; the radio button
that is highlighted indicates which of the options you have selected.
You could do this by means of a script that automatically turns off
the highlighting for the other radio buttons when one radio button
is clicked. But there’s an easier way.

The Button Info dialog box includes a pop-up Family menu that
allows you to assign any button a family number from 0 to 9.

A family number of 0 means the button does not belong to a
family. If the family number is any number from 1 through 9, it
will highlight as part of the family composed of all other buttons

in the same layer with the same family number.

O Only one button in a button family can be highlighted at any one
time. When you click another button in the family, the button you
clicked becomes highlighted, and the button that was originally
highlighted changes back to its normal appearance:

QO Level 1 QO Level 1
@ Level 2 @ Level 2 it becomes the

When you click one only highlighted

button in a family _D Level 3 O Leye] 3— buttonin that family.

Figure 4-34  The effect of clicking a button that is part of a family
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1o assign a family number to a button, follow these steps:
1. Choose the Button tool (=) from the Tools menu.

2. Click the button to which you want to assign a family number
to select it.

3. Choose Button Info from the Objects menu.
The Button Info dialog box appears.

4. Click the Auto Hilite check box to select it, if it’s not already
selected.

5. Choose the family number you want:

Button Name: I

Card button number:3  Card button ID: Y4

[Z=] Show Name Style: 0 (sone) Eﬂ

] Auto Hilite Family: ' Press and hold the
[ Share Bilite ¥ mouse button here

and drag to choose
the family number
you want.

(Link To..) ( Font... )
(Script...) (Colors...) C

o)

‘\lc'ﬂt.ﬂ.:w'\.’

Figure 4-35  Assigning a family number to a button

6. Click OK.

You must repeat this procedure to assign the same family number to
each button you want to highlight as part of the same family. All
buttons in the same family must be in the same layer.

P Seealso: * “The Card Layer Versus the Background Layer” in

Chaprer 2
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N dming d button  You can give a button a name when you want to display text on i,
or if you want to be able to address the button by name through
scripts or the Message box.

Follow these steps to name a button:

1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to name to select it.

3. Choose Button Info from the Objects menu.

Or double-click the button. The Button Info dialog

box appears.

‘ 4. 'Type a name for the button:

lype the button

name here. Button Name: |XTEITEITIS |

Bkgnd button number:1 Bkgnd button ID: 1

To diSpl:l}' the ] Show Name Style:

name on the [T Auto Hilite
button, click Family:
[1Share Hilite

here to select
Show Name.
(Link To..) ( Font... )

[Script...] [Colors...] ([_ 0K )] [Cuncel)

Figure 4-36  Naming a button

[t’s best to give the button a name that communicates

Its purpose.

5. If you want the button’s name to appear on the button,
click the Show Name check box to select it.

6. Click OK.
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®,

<+ Script writers take note: 1f you change the name of a button, be
sure to change its name everywhere you refer to it in a script,
too. For example, if you rename a butcon “Today™ and you use
the old name “Yesterday” in a script, the script won't work
properly—it won't be able to find the button it needs. «

MOVing a button  You can place a button wherever you like on the card or
around on a card background. To reposition a button on the card or background,

follow these steps:

or background
1. Choose the Button tool (=) from the Tools menu.

2. Click the button you want to move to select it. ®

Whether the button is in the card layer or the background layer,
C Y g y
you can select it from the card layer.

A moving dashed line surrounds the selected button.

3. Drag from the middle of the button, or from one of its edges

(not a corner):

Drag from the
........... “ =1 middle to move
- - the button.

Figure 4-37  Repositioning a button on the card

To constrain the button’s movement to horizontal or vertical
directions only, hold down the Shift key while you drag from
the middle of the button.

You can select and move only one button at a time.
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/N Important: After you reposition a background button, it’s a good
idea to look through the cards on which the burtton appears, to sce
how the cards look. A

When elements HyperCard puts different kinds of elements in different layers, as
OVCI'l'clp shown in the following figure. Together, all these layers make up the

card you see.

Background picture
Background
buttons and fields

---- Card picture .
P Card buttons

and fields

: e What you see

SR I when you look

: ..-""r' H )

v " at the card
‘ 1\ | : ﬁy :
| The background picture : l
is fixedina layerby ¢ | r'_:'-:;
itself—it’s always T ..'-*""'".I -. j
behind the background : % Il { 7
buttons and fields and . P :
all the card elements. The card picture is also

oo
fixed in a layer by I QA=
itself—it's always -
behind the card buttons
and fields, and in front
‘ of the background
buttons and fields.

Figure 4-38 HyperCard'’s layers

As shown in Figure 4-38, background buttons and fields go in a
different layer than card buttons and fields. Within each of these
layers, HyperCard places each new button or field you add
(whether you've created it or copied it) in front of the element
added before it. (7n front of means “closer to you.”)
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HyperCard also assigns numbers to the buttons and ficlds as you
add them. The first field you add is field number 1, the second is
field number 2, and so on. Likewise, the first button you add is
button number 1, the second is button number 2, and so on. The
numbers reflect how far away the elements are from you—the
farther away an element is, the lower its number. (These numbers

appear in the Button Info and Field Info dialog boxes.)

Although HyperCard numbers the buttons and fields separately, it
places each new element immediately in front of the previous
clement (within the same layer), whether it’s a button or a field.

This was added first.
This was added second. .

Field 1

Field 2

This was added third.

This was added fourth.

This was added fifth.

This was added sixth.

Figure 4-39  Background button and field layers and numbers

HyperCard numbers the card buttons and fields separately from the
background buttons and fields. The card elements are always in ‘
front of all the background elements (as shown in Figure 4-38).

This layering of buttons and fields becomes evident when the
elements overlap. Elements that are closer to you can obscure
clements that are farther away. If this happens, you can either
move the elements apart so they don't overlap, or you can try
either of the following:
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= Reorder the buttons and fields. (You can move any button or
field closer or farther, within its layer).

»  Make some of the elements transparent, so you can see other
elements through them. (Buttons, fields, and graphics can all be
made transparent or opaque.)

The fbl]()wing sections describe these solutions.

Reordering buttons  Overlapping buttons and fields can cause visual and functional
problems in your stack. For example, a button that’s completely
covered by a field (or another button) won't respond when you try
to click it. To solve the problem of overlapping buttons and fields,

O you can reorder them to bring the ones you need to see and use into
full view.

A Important: The buttons and fields in the card layer are always in
front of the background buttons and fields. Although you can
reorder the background buttons and fields relative to one another,
you can never move them closer to you than any of the card
elements. (You can, however, make card elements transparent so
you can see through them to the background elements, as explained
in the next section.) A

To move a button closer or farther (relative to the other buttons and
fields in the same layer), follow these steps:

1. Choose the Button tool (<) from the Tools menu.
2. Click the button you want to move closer or farther to select it.

A moving dashed line surrounds the selected button.
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3. Choose Bring Closer from the Objects menu to move the
button forward one position, or choose Send Farther to move
it back one position.

Fach time you move a button back one position relative to
another button in the same layer, its number (in the Button Info
dialog box) decreases by 1. Each time you move a button
forward one position relative to another button in the same
layer, its number increases by 1.

Note that a button's number may not change every time you use
the Bring Closer or Send Farther commands to change its
position. For example, if a field lies between button 3 and

button 4, you’d have to move button 4 back two positions (wit%
the Send Farther command) before it would become button 3.

You can also move the selected button all the way to the front or
all the way back using these " -key shortcuts:

To do this.. . . Press
Send the button to the back -Shift- = (minus)
Bring the button to the front -Shift-+ (plus)

4. Repeat step 3 until the button is where you want it.
5. Choose the Browse tool (¥) to deselect the button.

As you reorder burttons, the numbers of all the affected buttons
change to reflect their new positions. Each button’'s number ‘
(shown in the Button Info dialog box) reflects its front-to-back
position, relative to the other buttons in the same layer. (The

button that’s farthest away is button number 1. The closer a

button is to the front relative to other buttons in the same layer,

the higher its number.)

The commands Bring Closer and Send Farther work the same way
on a selected field, as described in “Reordering Fields” in Chapter 5.
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i\]Ll]\'ing 4 button opaque  When you want to be able to see background or card clements
or transparent  through a button that covers them, you can make the button
transparent. Conversely, when you want to give a button more

prominence, you can make it opaque.

Follow these steps to make a button opaque or transparent:
1. Choose the Button tool (=) from the Tools menu.

2. Click the button you want to change to select it.

3. Choose Button Info from the Objects menu.

Or double-click the button. The Button Info dialog box
appears.

@ 4. Choose an appropriate button style to make the button

opaque or transparent:

ButtonMame: [| | transparent | Choosing this style makes

Cord button number: 1 Card bu} 5500y the button transparent.

Show Name Style:

B2 Auto Hilite ., | shodow Choosing one of these styles

oy . Fomily: | round rect ) :

{1 Share Ritite makes the button opaque.
check box

radio button
(Link To..) ( Font... )
(Script...) (Colors...] ([ 0K J] [Cancel)

Figure 4-40 Making a button opaque or transparent

5. Click OK.
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COleng 2 button  You can duplicate a button on the same card, or copy a button to
another card, background, or stack. When you copy a button, you
also copy its attributes—it’s style, name, icon, script, and so on.

/\ Important: To copy a button and a graphic that shows through it
you have to copy the picture and the button separately. (This is not
the case for a button with an icon.) Follow the instructions given
here to copy the button. See Chapter 6 for instructions on copying

a graphic. A

Copying 4 button  ‘lo duplicate a button on the same card or background, follow
on the same card  these steps:

1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to copy to select it.

You can select the button from the card layer, whether it’s a card
button or a background button.

A moving dashed line surrounds the selected button.
3. Press and hold the Option key while you drag the button.

As you drag, you create an exact duplicate of the button. If the
original is a background button, the duplicate is a background
button. If the original is a card button, the duplicate is a card
button.

To constrain the new button's movement to horizontal or (@)
vertical directions only, hold down the Shift key while you
drag from the middle of the button.
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Copying a button to another  To copy a button to another card or background, follow these steps:

card or hdckground 1. Choose the Button tool (<) from the Tools menu.

2. Click the button you want to copy to select it.
3. Choose Copy Button from the Edit menu, or press -C.

This makes a copy of the selected button (including its script)
and puts it on the Clipboard. (This button replaces the last
item you cut or copied; the Clipboard can only hold one item
at a time.)

4. Go to the card or background where you want the button
to appear.

& Use the arrow keys or commands in the Go menu to navigate
between cards while the Button tool is selected.

If you’re not sure whether to put the button in the card layer
or the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chapter.

5. Choose Paste Button from the Edit menu, or press C-V.

This takes a copy of the button that’s on the Clipboard, puts it

on the current card or background, and selects it.

It you've copied a background button to the card layer of the
same card, the copy is pasted directly over the original. To see
the original, you have to drag the copy to move it.

. 6. While it’s still selected, drag the button to where you want it.

A\ Important: The most common mistake in copying a button is
putting it in the card layer when you want it in the background
layer. (To find out whether the button is in the background layer,
press _5-B to see just the background elements.) If you put a button
in the card layer by mistake, see the next section, “Moving a Button
From the Card to the Background.” A
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After you copy a button from another card or stack, it’s a good idea

to test the button to make sure it works properly. To test the button,

choose the Browse tool and click the button. If clicking the button
oo produces an unfamiliar message (for example, a message that

begins with “Can’t Understand . . .” or “Never heard of . . .”),

see “Copying Parts From Other Stacks” in Chapter 2 for advice

on how to proceed.

MOVing d bUtt()n [t’s easy to put a button in the card layer by mistake when you

fI'OIn the card intend to put it in the background. If this happens, you can move
the button from the card layer to the background layer (of the same

to the b’degf ound card) by following these steps: @

1. Choose the Button tool (=) from the Tools menu.
2. Click the button you want to move to select it.
A moving dashed line surrounds the selected button.
3. Choose Cut Button from the Edit menu, or press C5-X.

This removes the button from the card and puts it on

the Clipboard.
4. Go to the background layer.
Choose Background from the Edit menu, or press C:-B.
5. Choose Paste Button from the Edit menu, or press -V, ‘

This takes a copy of the button that’s on the Clipboard, puts it
in the current background, and selects it. The pasted button
appears in the same position from which it was cut.
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6. While it’s still selected, drag the button to where you want it.

Since you can’t see the elements in the card layer while you're
working in the background, you might not be able to tell -
whether you're putting the button in the right place. If this
happens, you can press (I-B again to go back to the card layer,
and then select and drag the button from the card layer.

MOVlng a button  Follow these steps to move a button from the background layer to

from the baCkgrOUIld the card layer of the same card:
S tO the Card . Choose the Button tool (=) from the Tools menu.

[—y

2. Click the button you want to move to select it.
A moving dashed line surrounds the selected button.
3. Choose Cut Button from the Edit menu, or press C3-X.

This removes the button from the background and puts it on
the Clipboard.

4. If you’re in the background layer, go to the card layer by
pressing (3-B.

If you’re already in the card layer, skip this step.
5. Choose Paste Button from the Edit menu, or press C-V.

This takes a copy of the button that’s on the Clipboard, puts‘it
© | | on the current card, and selects it. The pasted button appears in
the same position from which it was cut.

6. While it’s still selected, drag the button to where you want it.
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MOVng 2 button  You can move a button to another card in the same stack, or to a
to another card or card in another stack. When you move a button, its attributes—

it’s style, name, icon, scripts, and so on—move with it.

background

A\ Important: To move a button and a graphic that shows through it,
you have to move the picture and the button separately. (This is
not the case for a button with an icon.) Follow the instructions

: given here to move the button. See Chapter 6 for instructions on
moving graphics. A

Follow these steps to move a button to another card or background:

1. Choose the Button tool (=) from fhe Tools menu.

2. Click the button you want to move to select it. ®
A moving dashed line surrounds the selected button.

3. Choose Cut Button from the Edit menu, or press ©-X.

This removes the selected button from the current card and puts

it on the Clipboard.

4. Go to the card or background where you want to put
the button.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Button tool is selected.

If you're not sure whether to put the button in the card layer or
the background layer, see “Adding a Button to a Card or
Background” at the beginning of this chapter.

5. Choose Paste Button or from the Edit menu, or press C:-V.

This takes a copy of the button on the Clipboard, puts it on the
current card or background, and selects it.

6. While the button is still selected, drag it to where you want it
on the card.
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N\ Important: The most common mistake in moving a button is

Opening a
button's script

putting it in the card layer when you want it in the background
layer. (To find out whether a button is in the background, press

—B to see just the background elements.) If you put a button in
the card layer by mistake, see “Moving a Button From the Card to
the Background,” earlier in this chapter. A

After you move a button from another card or stack, it’s a good idea
to test the button to make sure it works properly. To test the button,
choose the Browse tool and click the button. If clicking the button
produces an unfamiliar message (for example, a message that begins
with “Can’t understand . . .” or “Never heard of . . .”), see “Copying
Parts From Other Stacks” in Chapter 2 for advice on how to
proceed.

Looking at the script of a button (if it has a script) is a good way to
learn about how the button works. (To look at a button’s script, you
must have your user level set to Scripting.)

Here are four ways to open a button’s script:

»  With the Browse tool or Button tool selected, press and hold the
(% key and the Option key while you click the button.

= With the Button tool selected, press and hold the Shift key while
you double-click the button.

s Choose the Button tool from the Tools menu, click the button
to select it, and hold down the Shift key while you choose
Button Info from the Objects menu.

m  Choose the Button tool from the Tools menu, double-click the
button to open the Button Info dialog box, then click Script.

To close a script without saving any changes, click Cancel.

To learn about HyperCard scripts, read the HyperZalk Beginner’s
Guide.
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Deleting 2 button  You can remove a button from a stack by following these steps:

1. Choose the Button tool (=) from the Tools menu.

2. Click the button you want to delete to select it.

3. Choose Clear Button from the Edit menu, or press Delete.

A Warning: Once you've deleted a button with the Clear Button
command (or with the Delete key), the button’s gone for good—

you can't undo the deletion. A
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Chapter 5

Working With Text
and Fields

T:Xt is an important component of HyperCard stacks. In most
stacks, text is used to communicate the function of the stack, either
alone or in combination with graphics. Text is also the primary
content of many stacks—particularly stacks designed for managing
large amounts of information.

Most of the text in stacks is contained in fields, which are
rectangular areas on a card where you can type and edit text easily.
This chapter gives instructions for working with fields. To do the
tasks in this chapter, you must have your user level set at least to
Authoring. (The section “User Levels and Options” in Chapter 1

tells you how to set your user level.)




Addlﬁg {€Xt When you want to add a text element to a stack, you can choose

from three different kinds of text:
» Text that’s stored in a field

m Text that’s attached to a button
s Paint text

For most purposes, it’s best to use fields to add text to a stack. Field
text is easy to edit—you can select any part of the text in a field and
change it, move it, copy it, or delete it. You can move field. text
around on a card by selecting and dragging the field. And you can
search for specific text in fields.

The Shared Text option allows you to create a background field th?.
displays the same text on every card, which means you can create

text labels made up of editable (field) text. If you are familiar with
HyperTalk, you can write a script for a field, so that clicking text

in the field can make something happen—much like clicking a
button.

Sometimes buttons can be useful for adding text labels to a card
or background. A button can’t hold much text, and you can't
edit button text from the card. (To change the text on a button,
you have to rename the button.) But button text is easy to move
around on the card, because it moves when you move the button.
Chapter 4 tells you how to create a button with text.

Paint text can’t be edited. Once you finish typing Paint text, it
“dries.” To change it, you have to erase it and retype it. Paint text
is useful for adding a permanent label to a graphic. And you can
create special effects with Paint text using commands in the Paint
menu (such as Invert and Trace Edges), which appears whenever a
Paint tool is selected. Chapter 6 describes Paint text.
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Paint text in the background layer

W % W‘"’”m PR 0T oo Yo
REUR  RHH 1|l.l‘l”|'|'; ‘P"'ﬂnhﬁ :
- ' g e
| Serrasslmas sploplewra — Field text that
changes from

Habitat | card to card
| Amazon river ] !

Notes

NI o Grows to 15 inches. i}

Background buttons |

that display text

[ tndex | sort | uit | o Name means “toothed
lﬂbout this stack] Card 7 g ‘ ‘ fish.” Ik

Adding a field
to a card
or background

Figure 5-1 Different kinds of text

To create a place for text, you can add a field to a card or back-
ground. Whenever you add a field, you need to decide whether
you want to put it in the card layer or the background layer.

To decide where to put the field, consider where you want the
field to appear, and where you want its text to appear:

» [f you want the field and its text to appear only on one card, put
the field in the card layer.

» If you want the field to appear on every card in the stack, but
you want to be able to type different text into the field on each
card, put the field in the background layer.

= [fyou want the field to appear on every card in the stack, and
you want it to display the same text on each card, put the field in
the background layer and turn on the Shared Text option in the
Field Info dialog box.
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= Ifyou want a field to appear on some of the cards in the stack,
but not all of them, consider creating a different background
for those cards and putting the field in that background only.
(“Creating a New Background” in Chapter 3 explains how to
add a background to a stack.)

A background field appears in the same location on all the cards
that share the background.

To add a field to a background, you must be in the background
layer; to add a field to a card, you must be in the card layer. To go to
the background layer, press (3-B. When you’re in the background
layer, the word Background appears in the menu bar. If you press
(5-B repeatedly, you move back and forth between the card layer

and the background layer. o

You can enter or edit text in a field only while you're in the card
layer. If you’re in the background layer, you won't see the
[-beam pointer when you move the Browse tool over a field.

»  Seealso:  * “The Card Layer Versus the Background Layer” in
Chapter 2
* “Creating a Field” in this chapter

The tools for wor klﬂg To work with fields and field text, you need both the Field tool and

Wlth fl@ld% the Browse tool.

Tools Jse the Field tool for
t{h) E TR creating and
; manipulating fields.

Use the Browse tool for entering and
editing text (in addition to browsing).

Figure 5-2  The tools for working with fields
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Creating a field

'To make it easy to alternate between the tools, you can “tear off”
the Tools menu to create a movable Tools palette. To do this, drag
down through the menu and past the bottom or beyond either side.
(For an illustration of this, see Figure 2-12.)

You can use the following (3-key shortcuts to choose the tools you

need for working with fields:

To choose this tool . . . Press
The Browse tool (9-Tab
The Field tool (5-Tab-Tab-Tab

» Secalso: o “Using HyperCard’s Tools” in Chapter 2

To create a new field, follow these steps:
1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (z2)
will work.

2. Go to the card or background where you want to put the field.

If you're not sure whether to put the field in the card layer or the
background layer, see “Adding a Field to a Card or Background”
near the beginning of this chapter.

3. Choose New Field from the Objects menu.

This automatically selects the Field tool and creates a new,
transparent field. The field appears in the center of the card
window and is selected, so you can move it or resize it easily.
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Figure 5-3 A field created with the New Field command

% Another method: You can also create a new, transparent field by

choosing the Field tool, then pressing and holding the T key .
while you drag diagonally.

Choose the Field t00], . o o e e e e cceccmcne

holddownthe Cikey, v e, :

and drag from here ... :
.10 here.

Figure 5-4 Dragging to create a new field

You can have as many fields on a card or background as will fit.
Fields can overlap to any depth.

/A Important: The most common mistake in creating a field is putting
it in the card layer when you want it in the background layer. (To
find out whether a field is in the background, press (3-B to view just
the background elements.) If you put a field in the card layer by
mistake, see “Moving a Field From the Card to the Background,”
later in this chapter. &

» Seealso: “Changing the Appearance of a Field” in this chapter
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Enter lng and edltlﬂg Entering and editing text in a HyperCard field is just like working
text in a fi with any other Apple IIGS text. You can click anywhere in the field
¢ eld and begin typing, delete text with the Delete key, and drag to select
text for copying, cutting, or clearing. You can also copy text to and
from a field via the Clipboard. This allows you to move text
between fields and to and from other applications.

@ Where’s the field? A transparent, empty field is invisible when the
Field tool isn't selected. This makes it difficult to locate the field
when you’re ready to enter text into it. One way to locate the
field is to move the Browse tool around—the pointer turns into
an I-beam when it’s over an editable field. Another way to locate
a transparent field is to press Tab repeatedly. This highlights the
S editable fields (or, if a field is empty, places an insertion point at
' the upper-left corner) on the current card and background, one
atatme.

To enter and edit field text, follow these steps:
1. Choose the Browse tool (¥2) from the Tools menu.
2. Move the Browse tool over the field you want to edit.

The Browse tool pointer turns into an I-beam () when it’s over
an editable field. If you don'’t see the I-beam pointer, read the
next section, “Where’s the [-Beam Pointer?”

3. Click inside the field to position the insertion point where you
want to enter or edit text.

© Or, if you want to replace existing text in the field, select the text
you want to replace.

If you click in an empty field, the insertion point appears at the

upper-left corner of the field.
4. Start typing.

Chapter 5: Working With Text and Fields 211




If you type more text than will fit in a non-scrolling field, the
remaining text goes off the bottom of the field. But this text isn't
lost, it’s just hidden from view. To see the hidden text, make the

field bigger:
oo TTTTTommEememmem T !
If you type more text | ¢ 1f you type more text thon
thanwill fiting rwill fit in g field wou .
field, youcon't see | ‘con'tseeituntilyou . ¢
it until uouanlacaa  ‘enlarge the field ... o
e e e e e e e e !
To see text you've ... enlarge the field by choosing the
typed beyond the Field tool from the Tools menu and
borders of a field . . . then dragging from any corner. .

Figure 5-5 Revealing hidden text

Where’s the If the Browse tool doesn’t turn into an I-beam (1) when you move
[-beam pointer? it over a field, the reason could be any of the following:

s The field is locked. To unlock the field, follow the instructions
in “Locking and Unlocking a Field,” later in this chapter.

» You're working in the background layer rather than the card
layer. Press (3-B to return to the card layer.

= Your user level is set to Browsing. For instructions on changing

the user level, see “User Levels and Options” in Chapter 1. O
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= The text you're trying to edit is either Paint text or button
text—not field text. To see whether it’s field text, choose the
Field tool from the Tools menu and click the text. If the area
becomes selected (surrounded by a moving dashed line), it’s field
text—otherwise, it’s not. See Chapter 4 for information about
changing the text on a button, or Chapter 6 for information on
changing Paint text.

Using the arrow keys  Normally, the arrow keys move you through cards. However,

to move through text  when the Text Arrows option is selected (on the User Preferences
card in your Home stack), you can use the arrow keys to move
the insertion point through text while you’re typing in fields.

® This makes text editing easier.
Moves the insertion point
Moves the ' down through lines in a field,
Insertion point or to the end of the line in the
right through text

Message box

Moves the insertion
point left through text

Moves the insertion point
up through lines in a field,
or to the beginning of the
line in the Message box

Figure 5-6  Moving through text when Text Arrows is turned on

e When Text Arrows is turned on, you use the Option key with the
arrow keys to move through cards in a stack.

» Seealso:  * “The Text Arrows Option” in Chapter 1
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Moving from one field While you're entering text into fields, you can move from one
to another editable field to the next by pressing Tab. When you press Tab,

HyperCard takes you to the field with the next higher field number.
(Field numbers are assigned to fields in the order you add them.
The first field you add is field 1, the second is field 2, and so on.)
If the insertion point is in field 3 and you press Tab, the insertion
point moves to field number 4; if there are only three fields, the
insertion point moves from field 3 to field 1:

to here . . .

Pressing Tab takes
you from here

o
()
i
o
................. & wvesaes ‘

... and finally
back to here.

Figure 5-7 Tabbing order

Pressing Shift-Tab moves you backward through the fields. Locked
fields are excluded—you can't Tab to a locked field.

A Warning: When you tab to a field that already contains text, all the
text is selected. Typing at this point will erase all the old text in the
field and replace it with what you type. To preserve the old text and
add new text to it, click in the field where you want to type. A
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A field’s number (which determines the field’s position in the

tabbing order) appears in the Field Info dialog box. Choose the
Field tool from the Tools menu and double-click the field to see
the Field Info dialog box:

Bkgnd field number: 8+

FOUT I TS [Personal Infdq |

Bkgnd field ID: 11

[CJLock Text
[Jfuto Tab
[1Don't Search
[1Shared Text

Style:

[1Show Lines
[CIwide Margins

[Script...] [Colora

[[ 0K ]] (Cuncen

Figure 5-8 Checking a field's number

This number
determines the
field’s position in
the tabbing order.

If you have both card fields and background fields on the card,
pressing Tab takes you from one field to the next, according to
the following sequence:
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Figure 5-9  Tabbing through background fields and card fields

For an explanation of how fields get numbered, or if you want to
change the order in which the Tab key moves the cursor from field
to field, see “Reordering Fields,” later in this chapter.

If the Auto Tab option is selected in the Field Info dialog box, you
can press Return (instead of Tab) when the insertion point is in the

last line of the field to go the next field.

To select the Auto Tab option for a field, follow these steps:

1. Choose the Field tool (&) from the Tools menu. D)
2. Double-click the field.

3. Click Auto Tab to select it.

4. Click OK.

)
0'0

Note: Auto Tab doesn’t work for a scrolling field. «
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Undoing your typing

Setting the text format
for a field

To undo typing mistakes while you’re editing field text, you can do
any of the following:

m Erase text to the left of the insertion point, one character at a
time, by pressing Delete.

» Drag (or double-click one word) to select the incorrect text and
retype it, or press Delete to erase it.

While you're editing text in a field, choosing Undo undoes all the
changes you’ve made since the last time you clicked in the field to
edit. Therefore, it’s not a good idea to use Undo to fix typing
mistakes, unless you want to retype everything you’ve typed since
you last clicked in the field. To fix editing mistakes, it’s better to use
the Delete key or to select the incorrect text and retype or delete it.
To save the changes in a field (so that Undo can’t undo them), click
anywhere outside the field.

You can set the text format—including the font, size, style,
alignment, and line spacing—for a field by following the
instructions in this section. If you want to change the color of the
text in a field, see “Changing a Field’s Colors,” later in this chapter.

To choose the text format for a field, follow these steps:
1. Choose the Field tool (&) from the Tools menu.
2. Select the field by clicking it.
3. Choose Field Info from the Objects menu.
Or double-click the field. The Field Info dialog box appears.
4. Click Font.
The Text Style dialog box appears.

%+ Another method: Alternatively, you can open the Text Style
dialog box by clicking to select the field (with either the Field
tool or the Browse tool), then choosing Text Style from the Edit
menu (or pressing ( T, %
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5. Choose from the options in the Text Style dialog box to set the
default text format for the field:

Click to select the Click to select a font size
font you want. (measured in points).
Click to select or deselect one or Stals Touse a font size not
more text styles. (Select nothing for ElBoul de' ' Courier & S o ) listed, type it here. Then, if
plain text.) The sample textat the 4 |} | 1¢alic Geneva. ]| 18 P you want to adjust the line
bottom of the dialog box shows T inderine \'geﬁeﬂcu— height to the new type size.
the effect of the selected styles. [ Outline Times || press Enter. (If you don't
[ Shadow Venice I Iy press Enter, the line height

Press and hold the mouse Align Left Line Height: m Font Size: E} will remain the same).

button here to see a pop-up .
menu for choosing the The quick brown fox jumps over the loz{ dog. This 51‘10“’5 “hu[ your
alignment for text in the field. text will look like,

This number determines the space ‘
between lines. HyperCard sets this number

automatically when you click one of the

standard font sizes, but you can change it.

Figure 5-10  Setting the text format for a field

6. When you’re finished, click OK.

The Text Style dialog box disappears and you see the Button
Info dialog box again.

7. In the Button Info dialog box, click OK.

The text in the field appears in the new format, and any new text
you type in the field acquires the same format. O
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Maklng field text You can create a background field that displays the same text on
) N1 every card by using the Shared Text option in the Field Info dialo
dp p cdron box. (This option %s available only in tphe Field Info dialog box forg
CVEry Car d background fields.) This allows you to create an editable text label
that appears on every card in the background. Because it can be
edited so easily, a field text label is easier to manage than a Paint
text label.

To get the same field text to appear on every card, follow these steps:
1. Create a background field.
See “Creating a Field,” earlier in this chapter, for instructions.
2. Choose the Field tool (£2) from the Tools menu.
‘ 3. Double-click the field.
The Field Info dialog box appears.
4. Click the Shared Text check box to select it.
5. Click OK.
6. Choose the Browse tool (¥) from the Tools menu.

You return to the card layer (if you’re not already there). The
word Background should not appear in the menu bar. If it does,
press (35-B.

7. Click in the field and type the text you want to display on

every card.

If you turn off Shared Text, the text you’ve entered in the
background field disappears from view.
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You can think of background fields as having (potentially) two
different layers of text, which appear and disappear as you change
the Shared Text setting:

s When you turn on Shared Text, any text you've entered in the
field while the option was turned on appears, and text you've
entered while the option was turned off disappears.

s When you turn off Shared Text, any text you've entered in the
field while the option was turned on disappears, and text you've
entered while the option was turned off appears.

% Note: 1f the Shared Text option is turned on for a field, the
Dor't Search option is turned on automatically. This means that
HyperCard won't search in the field when you ask it to look for.

specific text.

Locating fields Many of the fields in stacks are easy to locate right away—Dbut some .
are harder to find. You can use either of the following methods to
locate all the fields on the current card and background:

a Choose the Field tool from the Tools menu. Lines appear in all

the fields:
When you choose ... lines appear
the Field tool . . . in the fields.

Figure 5-11  Locating fields with the Field tool
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. Thin rectangles
outline the fields
in the card layer.

Changing
° the appearance
of a field

= While the Browse tool is selected, you can “peek™ at both
buttons and fields by pressing and holding the ¢, Shift, and
Option keys. (Gray or colored rectangles appear around the
buttons and fields.) Then, while you’re still holding down the

" and Option keys, release the Shift key—the rectangles

around the fields disappear. Pressing and releasing the Shift key
repeatedly (while holding down the © and Option keys) makes
the field rectangles appear and disappear.

ﬂm“;re“r" T B8 Thick rectangles
| Il

arp, buitar, Banjo

outline the fields
in the background
layer.

Note: Use this
harp for music
report

|WH|J fi

Figure 5-12  Peeking at fields

Once you've created or copied a field, you can change its
appearance by resizing it, changing its style, adding margins,
displaying lines in it, or changing its colors. This section explains
how to make a field look the way you want it to.

% Note: You can change the appearance of both card fields and
background fields while you’re in the card layer. You don't have
to be in the background layer to modify background fields. <

P> Seealso:  * “Setting the Text Format for a Field” in this chapter
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Changing the size  You can change the size of a field whether or not it has text in it.

of a field

When you change a field’s size, any text in it wraps appropriately
to conform to the new size.

To resize a field, follow these steps:
1. Choose the Field tool (1) from the Tools menu.
2. Click the field you want to resize to select it.

A moving dashed line surrounds the selected field.

3. Drag from any corner of the field:

-..; --------------------------------------- s-..— Dlilg fl.()nl an)} CO!.!]er
‘ K region to resize the field.

Figure 5-13  Changing a field’s size

To resize the field in one dimension only—either horizontally or
vertically—hold down the Shift key while you drag from a
corner.

2 Ifyou move the field instead of resizing it: Choose Undo from
the File menu to return the field to its original position, ancb
try again. Make sure you drag from a point close to a corne

of the field. «

If you shrink a non-scrolling field so that there’s not enough room
for all the text, the text at the bottom of the field disappears from
view. However, the text is still there—if you enlarge the field, the
text becomes visible again.
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A\ Important: After you've resized a background field, you should
look through any cards affected by the field change to see how the
text looks. A

Choosing a field’s style A field can have any one of five styles: transparent, opaque,
rectangle, shadow, or scrolling. (The style of a field has no bearing
on the style of its text.) Examples of the five field styles are shown in
the following figure, along with the names of the styles:

The background
shows through
transparent fields.

e 77F:|  The scroll bar
rectangle el scrolling —1-1__ becomes gray when
.. s T3|::|  the text runs past the
bottom of the field.

Figure 5-14  The field styles

To set the style for a field, follow these steps:
1. Choose the Field tool (=) from the Tools menu.
@ 2. Click the field to select it.
3. Choose Field Info from the Objects menu.
Or just double-click the field. The Field Info dialog box appears.
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4. Move the pointer over the pop-up Style menu, press and hold
the mouse button, and drag to select a field style:

Makes the field transparent,
with no visible border.

Makes the field opaque (white),

field None. | | RIAEHL trunspure/ - without a visible border.
Bkgnd field number: 1 Bkgnd f opague
[JLock Text Style: Makes the field opaque
JAuto Tab shadow (white), with a thin border.
! scrolli . :
g gzn t:?urih %ah: — = Makes the field opaque
e e Haraips (white), with a shadow along

the right side and bottom.
[Script...] @lors...) [[ 0K 1] (Cuncel] .

Makes the field opaque, with a
border and a scroll bar along the
right side.

Figure 5-15  Choosing a field style

5. Click OK.

= About scrolling: Choosing the Scrolling option adds a vertical
scroll bar to the selected field. You view text in a field with a
scroll bar the same way you view text in any scrollable
Apple 11Gs window. (For details about scrolling in windows,
see the documentation that came with your Apple 1IGs.) # @

You can use this procedure to change any field’s style, even after
you've typed text into the field.
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Adding margins  Adding margins to a field makes the text easier to read. When
you add margins to a field, you get extra space on the right and
left sides of the text in the field. (As a result, text takes up more
vertical space.)

To add margins to a field, follow these steps:
1. Choose the Field tool (&) from the Tools menu.
2. Click the field to select it.
3. Choose Field Info from the Objects menu.
Or just double-click the field. The Field Info dialog box appears.
4. Click the Wide Margins check box to select it:

Field Name: [(TI3TTE |

Bkgnd field number: 2 Bkgnd field ID: 13

[JLock Text Style:
[JAuto Tab

[JDon't Search [1Show Lines
[JShared Text B Wide Margins

AN Click here to add

margins. Click
(Seript..) (Colors.) ([ ok ) (concel) again to remove
e = - the margins.

Figure 5-16  Adding margins to a field
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5. Click OK.

Wide Margins is selected
in the Field Info dialog
box for this field.

Wide Margins is not
selected in the Field Info
dialog box for this field.

Figure 5-17  Shadow ficlds with and without margins

Displaying lines  You can display lines in a field. This is useful for making a ®

in a field transparent field visible so you can see where to type in it.

To display lines in a field, follow these steps:

1. Choose the Field tool (£3) from the Tools menu.
2. Click the field to select it.
3. Choose Field Info from the Objects menu.

Or just double-click the field. The Field Info dialog box appears.

4. Click the Show Lines check box to select it:

Field Name: Im

| O

Bkgnd field number: 1

[JLock Text
[JAuto Tab
[JDon't Search
[—JShared Text

Bkand field ID: 1

. | rectangle :
Swt Click here to see
AN the lines in a

[Jwide Margins

field. Click again
to hide the lines.

(Script.l.J EolorsJ

( ok ) (concel)

Figure 5-18  Displaying lines in a field
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Changing a field’s colors

5. Click OK.

show Lines is selected in Show Lines is not selected
the Field Info dialog box in the Field Info dialog
for this field. . . box for this field.

Figure 5-19  Rectangle fields with and without lines
% Note: You can't display lines in a scrolling field.

You can choose the colors for two parts of a field: its frame and
1ts text:

Frame

Merrily, merrily, shall I livenow, . %lj

--------------------------------------------------------------------------

Under the blossom that hangs on the buugh.l——Tﬁ‘“

Figure 5-20  The parts of a field that can be different colors

1. Choose the Field tool (=) from the Tools menu.
2. Double-click the field you want to change.

The Field Info dialog box appears.
3. In the Field Info dialog box, click Colors.

The Colors dialog box appears.
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4. Choose the colors you want:

This shows what the
field will look like.

Click the frame color
and text color you want.
The sample field at the
top of this dialog box
shows how the selected
colors will look.

Frame Text

diin Il
1 M éilllllll ]

L LI
O 1/ I
< N

Figure 5-21  The Colors dialog box for a field ‘

5. Click OK.

6. In the Field Info dialog box, click OK to accept the changes
you have made to the field. .

The field displays the colors you have chosen.

N aming a4 field  Each field can have a name associated with it. You use field names
mostly for referring to fields through scripts or the Message box.

A field name can have up to 31 characters in it, and you can use any
character in a field’s name.

Follow these steps to name a field:

1. Choose the Field tool (1) from the Tools menu.

2. Click the field you want to name to select it.

o
Do
(o
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Choose Field Info from the Objects menu.

Or double-click the field. The Field Info dialog box appears.

4. Type a name for the field:

Field Name: | ZIEXII@INL) ]
Bkand field number: 8 Bkgnd field ID: 11
[JLock Text Style:
[JAuto Tab

[1Don't Search [1Show Lines
[IShared Text [Iwide Margins

[{ 0K D [Cu_ncel]

Figure 5-22  Naming a field

5. Click OK.

*

Type the field
name here.

<« Script writers take note: If you change the name of a field, be sure

to change its name everywhere you refer to it in a script, too. For
example, if you rename a field “Wrigley” and you use the old
name “Chester” in a script, the script won't work properly—it

won't be able to find the field it needs.
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MOVing a field  You can place a field wherever you like on the card or background.
arOU.nd on a Card To reposition a field on the card or background, follow these steps:

or background 1. Choose the Field tool (£2) from the Tools menu.
2. Click the field you want to move to select it.

Whether the field is in the card layer or the background layer,

you can select it from the card layer.
A moving dashed line surrounds the selected field.

3. Drag from the middle of the field, or from one of its edges

(not a corner).

.......................
...............................................

Drag from the
....................... N middle region to

".E ....................................... E". meve Khﬁ flCld

Figure 5-23  Repositioning a field on the card

To constrain the field’s movement to horizontal or vertical

directions only, hold down the Shift key while you drag from
the middle of the field.

4. Click anywhere outside the field to deselect it. @

You can select and move only one field at a time.

/\ Important: After you reposition a background field, i’s a good idea
to look through the cards on which the field appears, to see how the
cards look. A
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When elements HyperCard puts different kinds of elements in different layers, as
OV@l‘lap shown in the following figure. Together, all these layers make up the
card you see.

Background picture
Background
buttons and fields

F e Card picture
e & P Card buttons

. 3 "";-;.“' : e and fields ,

{ A What you see
. Doty DL ‘ Feet : when you look
J’ it : : at the card

‘ | The background picture : )

is fixed in a layer by : g
itself—it's always G - =
behind the background P BN e
buttons and fields and =
all the card elements. The card picture is also ﬁ"": ﬂ_.f"

-
fixed in a layer by I@ (-
itself—it’s always -

behind the card buttons

and fields, and in front

of the background

buttons and fields.

Figure 5-24 HyperCard’s layers

As shown in Figure 5-24, background buttons and fields go in a

© different layer from the card buttons and fields. Within each of
these layers, HyperCard places each new button or field you add
(whether you've created it or copied it) in front of the element
added before it. (/n front of means “closer to you.”)
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HyperCard also assigns numbers to the buttons and fields as you
add them. The first field you add is field number 1, the second is
field number 2, and so on. Likewise, the first button you add is
button number 1, the second is button number 2, and so on. The
numbers reflect how far away the elements are from you—the
farther away an element is, the lower its number. (These numbers

appear in the Button Info and Field Info dialog boxes.)

Although HyperCard numbers the buttons and fields separately, it
places each new element immediately in front of the previous
element (within the same layer), whether it’s a button or field.

This was added first.
This was added second. .

Field 1

This was added third.
This was added fourth.

This was added fifth.
This was added sixth.

Figure 5-25  Background button and field layers and numbers

HyperCard numbers the card buttons and fields separately from the
background buttons and fields. The card elements are always in @
front of all the background elements (as shown in Figure 5-24).
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This layering of buttons and fields becomes evident when the
elements overlap. Elements that are closer to you can obscure
elements that are farther away. If this happens, you can either move
the elements apart so they don't overlap, or you can try either of the
following:

= Reorder the fields and buttons. (You can move any field or
button closer or farther, within its layer).

» Make some of the elements transparent, so you can see other
elements through them. (Buttons, fields, and graphics can all be
made transparent or opaque.)

The following sections describe these solutions.

®
Reordering fields Overlapping fields and buttons can cause visual and functional
problems in your stack. For example, you can’t edit the text in a
field that’s completely covered by a button (or another field).
To solve the problem of overlapping fields and buttons, you
can reorder them to bring the ones you need to see and use
into full view.

A TImportant: The fields and buttons in the card layer are always in
front of the background fields and buttons. Although you can
reorder the background fields and buttons relative to one another,
you can never move them closer to you than any of the card
clements. (You can, however, make card elements transparent

@ s0 you can see through them to the background elements, as
‘ explained in the next section.) A

‘To move a field closer or farther (relative to the other fields and
buttons in the same layer) follow these steps:

1. Choose the Field tool (;3) from the Tools menu.
2. Click the field you want to move closer or farther to select it.

A moving dashed line surrounds the selected field.
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3. Choose Bring Closer from the Objects menu to move the field
forward one position, or choose Send Farther to move it back
one position.

Each time you move a field back one position relative to
another field in the same layer, its number (in the Field Info
dialog box) decreases by 1. Each time you move a field forward
one position relative to another field in the same layer, its
number increases by 1.

Note that a field’s number may not change every time you use

the Bring Closer or Send Farther commands to change its
position. For example, if a button lies between field 4 and

field 3, you'd have to move field 4 back two positions (with

the Send Farther command) before it would become field 3. ‘

You can also move the selected field all the way to the front or
all the way back using these ("-key shortcuts:

To do this . . . Press
Send the field to the back _-Shift- — (minus)
Bring the field to the front {-Shift- + (plus)

4. Repeat step 3 until the field is where you want it.
5. Choose the Browse tool () to deselect the field.

As you reorder fields, the numbers of all the affected fields change

to reflect their new positions. Each field’s number (shown in the .
Field Info dialog box) reflects its front-to-back position, relative to
the other fields in the same layer. (The field that’s farthest away is
field number 1. The closer a field is to the front relative to the other
fields in the same layer, the higher its number.)

% Tabbing order is affected: As the fields’ numbers change, so does
the tabbing order—that is, the order in which you move
through the fields when you press Tab—because the tabbing
order depends on the field’s numbers. (See “Moving From One
Field to Another,” earlier in this chapter, for more information

about the tabbing order.)
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The commands Bring Closer and Send Farther work the same way
on a selected button, as described in “Reordering Buttons” in

Chapter 4.

-Making a field opaque  When you want to be able to see background or card elements
Or transparent through a field that covers them, you can make the field
transparent. Conversely, when you want to give a field more
prominence, you can make it opaque.

Follow these steps to make a field opaque or transparent:
1. Choose the Field tool () from the Tools menu.
2. Click the field you want to change to select it.
3. Choose Field Info from the Objects menu.
Or double-click the field. The Field Info dialog box appears.

4. Move the pointer over the pop-up Style menu, press and
hold the mouse button, and drag to select the opaque or
transparent style:

Field Name: Cord Title

Bkand field number: 1 Bkgnd f

[CJLock Text Style:
[JAuto Tab shadow
[J0on't Search B2 Sha scrolling
. [IShared Text [Iwide Margins

li 0K i’ ICuncell

| Choosing this style makes the
field transparent,

transparent
opaque
rectangle

Choosing any of these styles
makes the field opaque.
(See Figure 5-15.)

Figure 5-26  Making a ficld opaque or transparent

5. Click OK.
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Copying a field

Copying a field
on the same card

Copying a field
to another card or
background

230

You can duplicate a field on the same card, or copy it to another
card, background, or stack. When you copy a field, you also copy its
attributes—its name, style, script, text format settings, and so on.
You can copy a field either with or without its contents.

Follow these steps to duplicate a field without its text on the
same card:

1. Choose the Field tool (1) from the Tools menu.
2. Click the field you want to copy to select it.

You can select the field from the card layer, whether the field is in
the card layer or the background layer.

A moving dashed line surrounds the selected field.
3. Press and hold the Option key while you drag the field.

As you drag, you create an exact duplicate of the field. If the
original is a background field, the duplicate is a background
field. If the original is a card field, the duplicate is a card field.
However, you can't duplicate the field’s text using this method.
You have to use the procedure described in the next section to
copy the text along with the field.

To constrain the new field’s movement to horizontal or vertical
directions only, hold down the Shift key while you drag from
the middle of the field.

To copy a field with or without its text to another card or
background, follow these steps:

1. Choose the Field tool (i3) from the Tools menu.

2. Click the field you want to copy to select it.
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3. Choose Copy Field from the Edit menu, or press ' 5-C.

This makes a copy of the selected field (including its text) and
puts it on the Clipboard. (This field replaces the last item you
cut or copied; the Clipboard can only hold one item at a time.)

4. Go to the card or background where you want to put the field.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Field tool is selected.

If you’re not sure whether to put the field in the card layer or the
background layer, see “Adding a Field to a Card or Background”
near the beginning of this chapter.

O 5. If you want to paste both the field and the text that was visible
when you copied the field, press and hold the Shift key and
choose Paste Field from the Edit menu, or press -Shift-V.

To copy just the field without its text, choose Paste Field from
the Edit menu, or press C-V.

This takes a copy of the field that’s on the Clipboard, puts it on
the current card or background, and selects it. If you've copied
the field and its text from the card layer to the background layer,
you won't see the text until you return to the card layer (at the
end of this procedure).

If you’ve copied a background field to the card layer of the same
card, the copy is pasted directly over the original. To see the
O original, you have to drag the copy to move it.

6. While it’s still selected, drag the field to where you want it.

7. If you’ve copied the field and its text from the card layer to the
background layer, choose Background from the Edit menu, or
press (1-B, to return to the card layer and see the text.
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/N Important: The most common mistake in copying a field is
putting it in the card layer when you want it in the background
layer. (To find out whether a field is in the background, press -B
to view just the background elements.) If you put a field in the card
layer by mistake, see the next section, “Moving a Field From the
Card to the Background.” A

M()Ving a field 1es easy to put a field in the card layer by mistake when you intend

fr()m the Cafd to put it in the background. If this happcns, you can move the field

i from the card layer to the background layer (of the same card) by
o the bﬂ(kground following these steps: @)

1. Choose the Field tool (1) from the Tools menu.
2. Click the field you want to move to select it.
A moving dashed line surrounds the selected field.
3. Choose Cut Field from the Edit menu, or press —-X.

This removes the field from the card and puts it on

the Clipboard.
4. Go to the background layer.

Choose Background from the Edit menu, or press —-B.

5. If you want to move the field and its text, press and hold the
Shift Key and choose Paste Field from the Edit menu, or prel)
-Shift-V.

To move just the field without its text, choose Paste Field trom
the Edit menu, or press C3-V.

This takes a copy of the field that’s on the Clipboard, puts it in
the current background, and selects it. The pasted field appears
at the same position from which it was cut. If you've pasted the
text along with the field, you won't be able to see the text until
you return to the card layer (at the end of this procedure).
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6. While it’s still selected, drag the field to where you want it.

Since you can't see the elements in the card layer while you’re
working in the background, you might not be able to tell
whether you’re putting the field in the right place. If this
happens, you can press (3-B again to go back to the card layer,
then select and drag the field from the card layer.

7. If you've pasted the text along with the field, choose
Background from the Edit menu, or press ~-B, to return to
the card layer and see the text.

.OVing a field from  Follow these steps to move a field from the background layer to the

the baCkngUﬂd card layer of the same card:
tO the s U~d 1. Choose the Field tool (Z7) from the Tools menu.

2. Click the field you want to move to select it.
A moving dashed line surrounds the selected field.

3. Choose Cut Field from the Edit menu, or press C:-X.

A dialog box like this appears:

Delete this field and all its text from all 2 _ .
cards of this background? Click Delete to confirm that

/ , . ¥
you want to cut the field.
‘ [Delete] [[Cuncelﬁ

Figure 5-27  Confirmation dialog box for cutting a background field

Click Delete in the dialog box to remove the field from the
background and put it on the Clipboard.
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4. If you're in the background layer, go to the card layer by
pressing ( (-B.

If you're already in the card layer, skip this step.

5. If you want to move the field and its text, press and hold the
Shift Key and choose Paste Field from the Edit menu, or press
(-Shift-V.

To move just the field without its text, choose Paste Field from
the Edit menu, or press « -V.

This takes a copy of the field that’s on the Clipboard, puts it on
the current card, and selects it. The pasted field appears at the
same position from which it was cut.

6. While it’s still selected, drag the field to where you want it.

MOVing d f leld fO  You can move a field to another card in the same stack, or to a card
another Card or in another stack. When you move a field, its attributes—its style,

name, scripts, and so on—move with it. You can move a field either

baCkgf Ound with or without its text.
Follow these steps to move a field to another card or background:
1. Choose the Field tool () from the Tools menu.

2. Click the field you want to move to select it.

A moving dashed line surrounds the selected field. .
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3. Choose Cut Field from the Edit menu, or press . -X.

If the field is a background field, a dialog box like this appears:

Delete this field and all its text from all 2 N
cards of this background? Click Delete to confirm that

/ , . .
you want to cut the field.
[Delete] (Cuncel]) ’

Figure 5-28  Confirmation dialog box for cutting a background field

Click Delete to remove the selected field from the current card

‘ and put it on the Clipboard.
4. Go to the card or background where you want to put the field.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Field tool is selected.

If you're not sure whether to put the field in the card layer or the
background layer, see “Adding a Field to a Card or Background”
near the beginning of this chapter.

5. If you want to move the field and its text, press and hold the
Shift Key and choose Paste Field from the Edit menu, or press
1-Shift-V.

"To move just the field without its text, choose Paste Field from

‘ the Edit menu, or press ( -V,

This takes a copy of the field that’s on the Clipboard, puts it
on the current card or background, and selects it. The pasted
field appears at the same position from which it was cut. If
you’ve moved the field and its text from the card layer to the
background layer, you won't see the text until you return to
the card layer (at the end of this procedure).
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6. While the field is still selected, drag it to where you want it.

7. If you've moved a field and its text from the card layer to the
background layer, choose Background from the Edit menu, or
press (I-B, to return to the card layer and see the text.

/\ Important: The most common mistake in copying a field is
putting it in the card layer when you want it in the background
layer. (To find out whether a field is in the background, press ~-B
to view just the background elements.) If you put a field in the card
layer by mistake, see “Moving a Field From the Card to the
Background,” earlier in this chapter. A

LOCking and  You can lock a field to prevent content changes to its text. Locking
UnlOCking 1 ﬁeld a field does not, however, prevent changes to the text format of
the field.

To lock a field, follow these steps:
1. Choose the Field tool ((7]) from the Tools menu.
2. Click the field to select it.
3. Choose Field Info from the Objects menu.
Or just double-click the field. The Field Info dialog box appears.

o
o
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3. Choose Cut Field from the Edit menu, or press . -X.

[f the field is a background field, a dialog box like this appears:

Delete this field and all its text from all 2 )
cards of this background? Click Delete to confirm that

you want to cut the field.
(Delete] ECuncel]] ’

Figure 5-28  Confirmation dialog box for cutting a background field

Click Delete to remove the selected field from the current card

O and put it on the Clipboard.
4. Go to the card or background where you want to put the field.

Use the arrow keys or commands in the Go menu to navigate
between cards while the Field tool is selected.

If you're not sure whether to put the field in the card layer or the
background layer, see “Adding a Field to a Card or Background”
near the beginning of this chapter.

5. If you want to move the field and its text, press and hold the
Shift Key and choose Paste Field from the Edit menu, or press
$-Shift-V.

"To move just the field without its text, choose Paste Field from

‘ the Edit menu, or press ¢ (-V.

This takes a copy of the field that’s on the Clipboard, puts it
on the current card or background, and selects it. The pasted
field appears at the same position from which it was cut. If
you've moved the field and its text from the card layer to the
background layer, you won't see the text until you return to
the card layer (at the end of this procedure).
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6. While the field is still selected, drag it to where you want it.

7. If you’ve moved a field and its text from the card layer to the
background layer, choose Background from the Edit menu, or
press (/-B, to return to the card layer and see the text.

/\ Important: The most common mistake in copying a field is
putting it in the card layer when you want it in the background
layer. (To find out whether a field is in the background, press ~-B
to view just the background elements.) If you put a field in the card
layer by mistake, see “Moving a Field From the Card to the
Background,” earlier in this chapter. A

LOCking and  You can lock a field to prevent content changes to its text. Locking
UﬂlOCkiﬂg 1 ﬁeld a field does not, however, prevent changes to the text format of
the field.

To lock a field, follow these steps:
1. Choose the Field tool (77) from the Tools menu.
2. Click the field to select it.
3. Choose Field Info from the Objects menu.
Or just double-click the field. The Field Info dialog box appears.

o
B
[ S
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4. Click Lock Text to select it:

BEIGNL T Personal Info ]
. Bkgnd field number: 8 Bkgnd field ID: 11
Click here to prevent T Lock Text Style:
changes to the text in [T Auto Tab
’thc ﬁeldj Click Lock [ 0on't Search [ Show Lines
Text again to unlock [ Shared Text C]wide Margins

the field, making the
text editable.
@cripﬂ @ora ([ 0K ]] @nm

Figure 5-29  Locking a field

5. Click OK.

When the Browse tool passes over a locked field, it doesn’t change
to the I-beam pointer (). This lets you know that you can't edit

the field.

If you want to unlock a field to allow text changes, click Lock
Text again in the Field Info dialog box to deselect it (as shown
in Figure 5-29).
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EXCIUding d f 161(] The Find command (in the Go menu) allows you to search for
from text searches specific text in the fields of a stack. You can prevent HyperCard

from searching in any particular field during text searches.
Follow these steps:

1. Choose the Field tool () from the Tools menu.

2. Click the field to select it.

3. Choose Field Info from the Objects menu.

4. Click the Don’t Search check box to select it.
Clicking Don't Search again deselects 1[

5. Click OK.

[f you want to turn off the Dont Search option to allow
HyperCard to search in the field, simply deselect the option

(as explained in step 4).

P Seealso:  * “Excluding Card and Background Fields From Text Searches”
in Chapter 3 |
* “Excluding Background Fields From Text Searches” in

Chapter 3
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Deleting d ﬁeld You can delete a field whether or not it has text in it. When you

delete a field, any text contained in the field is deleted too.

Follow these steps to delete a field:

1. Choose the Field tool (£3) from the Tools menu.

2. Click the field you want to delete to select it.

3. Choose Clear Field from the Edit menu, or press Delete.

[f the field is a background field, a dialog box like this appears:

Delete this field and all its text fromall 2
cards of this background?

7
(Belete] [[Cuncel]]

Click Delete to confirm that
you want to cut the field.

Figure 5-30  Confirmation dialog box for deleting a background field

A Warning: Once you've deleted the field with the Clear Field
command (or with the Delete key), the field and all its text
are gone for good—you can’'t undo the deletion. Deleting a
background field also deletes all text in that field on all cards

sharing that background. A
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| Chapter 6

Working With Graphics

Graphics help communicate what a stack is for and how it
works. The graphics described in this chapter include lines, shapes,
patterns, pictures, and Paint text—any graphic element that you
create or manipulate with the Paint tools.

This chapter explains how to do the following:
» Create graphics yourself using the Paint tools.
= Copy graphics from another stack (or the same one).

» Import graphics from any document in the Apple Preferred
File Format.

O To do the tasks in this chapter, you must have your user level set
at least to Painting. (The section “User Levels and Options” in
Chapter 1 explains how to set your user level.)




Addlng gr aphICS Each card can have its own unique graphics in the card layer in
to a Card addition to the background graphics it shares with other cards.
Whenever you add a graphic element to a stack, you need to decide
Or baCkgf ound whether you want it in the card layer or the background layer.
To decide where to put the graphic, consider where you want it
to appear:

s Ifyou want the graphic to appear on every card in the stack, put -
it in the background layer. A background graphic appears in the
same location on all the cards that share the background.

» [f you want the graphic to appear on only one card, add it to the
card layer.

s Ifyou want the graphic to appear on some but not all of the
cards in the stack, consider creating a different background for ‘
those cards and putting the graphic in that background only.
(“Creating a New Background” in Chapter 3 explains how to
add a background to a stack.)

To add a graphic to a background, you must be in the background
layer; to add a graphic to a card, you must be in the card layer.

To go to the background layer, press ""-B. When you're in the
background layer, the word Background appears in the menu bar.
If you press « -B repeatedly, you move back and forth between the
card layer and the background layer.

»  Seealso: * “The Card Layer Versus the Background Layer”

in Chapter 2
* “When Elements Overlap” in this chapter .
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Th@ [OOIS lo create and work with graphics, you use the Paint tools in the
: Tools menu.
for working

- with graphics

| The Paint tools

. Figure 6-1 HyperCard’s tools

The functions of the Paint tools are described briefly in the figure
that follows. This chapter provides detailed instructions for using
these tools.
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The Browse
tool is for
hrowsing
through stacks
and editing
text.

The Selection
tool is for
selecting
graphics.

The Brush
paints with
the current
pattern or

color.

The Spray tool
spritzes paint
onto the
screen in the
current pattern
or color.

The Bucket fills
enclosed areas
or one-color
areas with the
current pattern
or color.

The Paint Text
tool is for
typing text
that's part of
a graphic.

oadl

The Button tool
is for working
with buttons.

The Lasso is
for selecting
nonrectangular
graphics.

The Eraser
erases the part
of a graphic
you drag it
OVver.

The Rectangle
tool draws
rectangles and
squares.

The Oval tool
draws ovals
and circles.

The Regular
Polygon tool
creates
polygons with
regular sides.

Figure 6-2  What the tools are used for
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The Field tool
is for working
with fields.

The Pencil
draws thin,
free-form
lines.

The Line tool
draws straight

lines. ‘

The Rounded
Rectangle
tool draws
rectangles
with rounded
corners.

The Curve tool
draws free-form
lines and
shapes.

The Polygon
tool creates
polygons with
irregular sides.




"To make it easy to alternate between the tools, you can “tear off”
the Tools menu to create a movable Tools palette. To do this, drag
down through the menu past the bottom or beyond either side.
(For an illustration of this, see Figure 2-12.) While you have the
"Tools palette open, you can select a tool just by clicking it on the
palette. This makes it easy to switch back and forth between
different Paint tools.

When you choose one of the Paint tools, three new menus appear:
Paint, Options, and Patterns. (The Objects menu disappears
temporarily while you’re working with the Paint tools.)

These three menus appear when you
‘ have one of the Paint tools selected. l

|
¢% File Edit Go Tools|Paint Options Patterns|

This stack contains clip art you
con copy into your own stacks.

Cli

RGO\ | E

=)
. A i
Selected Paint tool =]
[
o
2

' Figure 6-3  Mcnus that accompany the Paint tools

The Paint and Options menus contain commands for creating and
manipulating graphics. These commands are described throughout
this chapter.

o
I
—
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The Patterns menu contains patterns and colors you can use to fill
shapes and draw with. For easy access to the patterns and colors,
you can tear off the Patterns menu the same way you tear oft the
Tools menu—drag down through the menu past the bottom or
beyond either side.

You can close the
b SN Patterns palette
RN . .
: by clicking here.

Options L

ey To move the
palette, drag
from here.

- A
- A
sy
X

nogh
SR

- SSRNY
SN
=~

i
i
il
i
it

To tear off the Patterns menu, Click any pattern
drag beyond the bottom or or color to select .
either side of the menu.

Figure 6-4 Tearing off the Patterns menu

s A shortcut: Whenever you have a Paint tool selected, you &
can make the Patterns palette appear and disappear quickly
by pressing Tab or double-clicking the Bucket on the
Tools palette. «
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Selecting a graphic

I'he Patterns palette works like the “Tools palette—to select a pattern
or color, just click it. “Creating Your Own Patterns,” later in this
chaprer, explains how you can add your own patterns to this palette.

» Seealso: “Using HyperCard’s Tools” in Chapter 2
“Using Power Keys” in this chapter
“Using Modifier Keys With Paint Tools” in this chaprer

* “Double-Clicking Paint Tools, Patterns, and Colors” in this
chapter

Before you can modify, move, or copy a graphic, you must first
select it. There are many different ways to select a graphic. The
method you use depends on the shape and size of the particular
graphic element(s) you want to select. The sections that follow

explain all the methods for selecting graphics.

To select a graphic, you must be working in the same layer as the
graphic. If the graphic is in the background layer, you can select

it only from the background layer. If it’s in the card layer, you

can select it only from the card layer. If you try to select a graphic
and it doesn’t become selected, chances are the graphic is in the
background layer and you’re working in the card layer. (It’s also
possible that the element you're trying to select is actually a button
or field. Chapters 4 and 5 explain how to select buttons and fields.)

% Blank space vs. white paint: A white area on a card or
background is not necessarily blank, transparent space—it can
also be white paint or an opaque area. White paint can be useful
for hiding background elements and for graphic effects such as
painting in white over a color or pattern. In most respects, white
paint is the same as any other paint: You can fill selections and
draw with it, and you can erase it. However, not all the methods
of selecting a graphic work for white paint. Each of the following
sections explains how the selection of white paint differs from

0,

the selection of a color.

Chapter 0: Working With Graphics 253




Once you've selected a graphic, it stays selected until you choose a
tool or click outside the selection.

< lcons are selected differently than graphics: Remember that an
icon is part of a button. To select an icon, you have to select the
button that displays it. If you’re not sure whether a particular
element is an icon or a graphic, choose the Button tool (=) from
the Tools menu, click the element, and drag it. If a moving
dashed line appears around the element and you can move it by
dragging, it’s an icon. Chapter 4 gives instructions for working
with buttons and icons. <

Selecting a rectangular area  To select a rectangular graphic element or a rectangular area of a
picture, follow these steps:

1. Go to the card or background that contains the graphic

element or the area you want to select.

Pressing (3-B takes you to the background layer. (When you're
in the background layer, the word Background appears in the
menu bar.) If you press (3-B repeatedly, you move back and
forth between the card layer and the background layer. If you
don’t see the graphic you want while you're in the background
layer, the graphic is in the card layer.

2. Choose the Selection tool (::2) from the Tools menu.

Or click it on the Tools palette. The pointer changes to a

crosshair (+-). .
3. Move the crosshair pointer to one corner of the area you want
to select.

4. Drag diagonally to the opposite corner of the area.

A moving dashed line surrounds the selected area. If the area
includes white paint, the white paint is included in the selection.
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Press and hold the __
7 key and drag
diagonally with

the Selection tool
from here . . .

Selecting a
nonrectangular area

... to here. |

% [For a tighter selection: To eliminate extra blank space from
the selection, press the (9 key while you drag; when you
release the mouse button, the moving dashed line snaps
in to select the smallest rectangular area surrounding the
graphic. Any white paint that lies outside the rectangular
area will also be eliminated.

L=l s U
- -

The moving dashed line
snaps around the graphic
to eliminate extra blank
space from the selection.

Figure 6-5 Eliminating extra blank space in a rectangular selection

[f you select too much or not enough, deselect the graphic by
clicking on the card outside the selection, then select the

graphic again.

To select a nonrectangular graphic element or a nonrectangular area
of a picture, follow these steps:

1. Go to the card or background that contains the graphic

element or the area you want to select.

Pressing (-B takes you to the background layer. (When you're
in the background layer, the word Background appears in the
menu bar.) If you press (3-B repeatedly, you move back and
forth between the card layer and the background layer. If you
don’t see the graphic you want while you’re in the background

layer, the graphic is in the card layer.
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2. Choose the Lasso (+°) from the Tools menu.
Or click it on the Tools palette. The pointer turns into a lasso.

3. Drag around the graphic you want to select:

umﬂi;;},{'!l o

The tip of the line
trailing out of the
Lasso determines
what you select.

i

Figure 6-6  Selecting a nonrectangular area

You don’t need to drag completely around the graphic;
HyperCard will complete the selection by drawing a straight line
between the point where you start dragging and the point where
you stop. (But if you stop too soon, you might miss part of the
graphic you want to select.)

When you release the mouse button, the edges of the selected
graphic shimmer. If there was any white paint or blank space
surrounding the graphic, it’s eliminated from the selection:

4 Illlil

|III|I

'ﬂ; ) The edges of the
\ selected graphic
shimmer.

Figure 6-7  Only the lassoed graphic is selected
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Selecting an individual
graphic element

+ If you want to include the surrounding blank space: To lasso a
graphic without eliminating any surrounding blank space or
white paint, press the Option key while you drag with the lasso.
This selects exactly the area you drag around. +

If you select too much or not enough, deselect the graphic by
clicking on the card outside the selection, then select the
graphic again.

There are several ways to select a single graphic element without
any of the blank space or white paint that surrounds it—including
the method described in the preceding section, “Selecting a
Nonrectangular Area.” This section describes two additional
methods.

Use the following technique when you want to select a specific
graphic element quickly and exclude the surrounding blank space
and white paint, or if your hand isn't steady enough to use the Lasso
with precision:

1. Go to the card or background that contains the graphic you
want to select.

Pressing  -B takes you to the background layer. (When you’re
in the background layer, the word Background appears in the
menu bar.) If you press -B repeatedly, you move back and
forth between the card layer and the background layer. If you
don't see the graphic you want while you're in the background
layer, the graphic is in the card layer.

2. Choose the Selection tool (:73) from the Tools menu.

Or click it on the Tools palette. The pointer changes to a
crosshair (--).

3. Move the crosshair pointer to one corner of the graphic.
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4. Press the Option key while you drag diagonally to the opposite

corner of the graphic.

Or choose Select from the Paint menu (or press C3-S) after you
drag to the opposite corner. This automatically chooses the Lasso
and selects the graphic.

Press and hold the __,
Option key and drag
diagonally with

the Selection tool
from here . . .

T TR R R TR W

The selected graphic .

shimmers.

Figure 6-8  Selecting an individual graphic element

[f you select too much or not enough, click on the card outside the
selection to deselect the graphic, then select it again.

You can use the following technique to select a one-color graphic
element that has no breaks in it—that is, one that’s composed
entirely of connected dots of the same color. This technique s
useful for selecting small graphic elements of one solid color.

1. Go to the card or background that contains the graphic
element you want to select.

2. Choose the Lasso from the Tools menu.

3. Move the Lasso’s tip into the graphic.
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Selecting the graphic
you've just created

4. Press the (* key while you click the graphic.

“”Iw“l“llll"I"""l"l'lm e 'J',,'"'””“”I

"Naannamnil]

L

Select a one-color graphic The edges of the selected
element by < “-clicking it with graphic shimmer.
the tip ol the Lasso.

Figure 6-9  Selecting a one-color graphic element

Immediately after you draw a single graphic element (and before you
click anywhere), you can select the element you’ve just created by
choosing Select from the Paint menu or pressing (3-S. The Select
command selects on/y the graphic element (including white paint)
you've created since the last time you pressed the mouse button. (If
you haven't just created a new graphic, the Select command selects
all the graphics in the layer in which you’re working.)

This technique is particularly useful if you’ve just drawn a shape
very close to or actually touching another shape, and you need to
move the new shape. You can even draw a new shape on top of an
old one, choose Select, and then drag the new shape away without

changing the old shape.

You can also use the Select command to select an area you've
just erased. (The erased area becomes opaque after you select and
move it.)

If the Power Keys option is turned on (and the Message box is
hidden), you can press S instead of choosing Select. (“Using Power
Keys,” later in this chapter, explains the Power Keys option.)
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Selecting all the
graphic elements on a card
or background

When vou're in the
card layer and you
choose Select from
the Paint menu, all
the card graphics
become selected
(their edges
shimmer) . ..

200

When your card or background picture is made up of several
individual graphic elements, you might want to select them all at
once to make changes to them or to copy or move them. This
section explains how to select all the graphic elements in the current
layer, excluding any blank space or white paint between them.

To select all the individual graphic elements on the card or
background, first make sure you're in the layer that contains

the graphics you want to select. Pressing .~ -B takes you to the
background layer. (When you’re in the background layer, the word
Background appears in the menu bar.) If you press ~ -B repeatedly,
you move back and forth between the card layer and the
background layer. If you don't see the graphics you want while
you're in the background layer, they’re in the card layer. O

Select all the graphic elements in the current card layer or
background layer by using one of these methods:

» Choose Select from the Paint menu, or press .~ -S.
» Double-click the Lasso on the Tools palette.

s If the Power Keys option is turned on (and the Message box
is hidden), press S. (“Using Power Keys,” later in this chapter,
explains the Power Keys option.)

Scenery 2
Sun, Pot of Gold, Clouds, Rocks, Trees

... but the
background
graphics don'.

Figure 6-10  Selecting all the graphic elements in the current layer
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Selecting the  When you want to copy, delete, or change the entire card picture
entire card picture  or background picture (for example, by filling it with a pattern),
or background picture you can select the whole picture at once in one rectangular selection
the size of the card. This section explains how to select the whole
picture in the current layer, including all the graphic elements and
the blank space between them.

To select an entire picture, first make sure you're in the layer that
contains the picture. Pressing -B takes you to the background
layer. (When you're in the background layer, the word Background
appears in the menu bar.) If you press ( -B repeatedly, you move
back and forth between the card layer and the background layer.
If you don't see the picture you want while you're in the

& background layer, it’s in the card layer.

Select the entire picture by using one of these methods:
s Choose Select All from the Paint menu, or press ~-A.
» Double-click the Selection tool on the Tools palette.

» If the Power Keys option is turned on (and the Message box is
hidden), press A. (“Using Power Keys,” later in this chapter,
explains the Power Keys option.)

»  Choose the Selection tool (:2) from the Tools menu and drag
diagonally from one corner of the card or background to the
opposite corner.

. A moving dashed line surrounds the selected card or background
picture. To deselect the picture, click anywhere on the card or

background, or choose a tool from the Tools menu.
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| COleng glﬂpthS I'he easiest way to get art into your stacks is to copy graphics that
that come with already exist. Copying graphics can simplify the stack-building
process. HyperCard comes with a stack called Art Ideas that
HYpef Card contains all kinds of illustrations you can copy and paste into your
stacks. The first card in this stack lists categories of graphic images.
To see graphics in a particular category, click the category name.

%MD@’W
T
aﬂg}ﬂh .

Figure 6-11  Some graphics from the Art Ideas stack

When you see a graphic you like in Art Ideas or any other stack that
comes with HyperCard, copy it and paste it into your stack. Follow

these steps:

1. Open the Art Ideas stack (or any other stack that comes with
HyperCard).

2. Go to the card that has the graphic you want to copy. &
3. Select the graphic you want.

For instructions on selecting a graphic, see “Selecting a Graphic,”
earlier in this chapter.

4. Choose Copy Picture from the Edit menu, or press -C.
This puts a copy of the selected graphic on the Clipboard.
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5. Go to the card or background where you want to put the
graphic.

You can use the arrow keys or commands in the Go menu to
navigate between cards or stacks while you have the Selection

tool or Lasso selected.

[t you're not sure whether to put the graphic in the card layer
or the background layer, see “Adding Graphics to a Card or
Background™ at the beginning of this chaprer.

6. Choose Paste Picture from the Edit menu, or press ' -V.

This takes a copy of the graphic that’s on the Clipboard, puts it
on the current card or background, and selects it.

7. While the graphic is still selected, drag it to where you want it
on the card or background.

The graphic becomes opaque after you paste it. If you want to be
able to see through the graphic to the elements behind it, select it
and choose Transparent from the Paint menu.

> Seealso: o “Changing the Appearance of a Graphic” in this chapter

UﬂdOing YOUI  If you make a mistake while you’re working with the Paint tools
mi and commands, you can undo your last operation by choosing
Stakes Undo from the Edit menu (or pressing (-7, Esc, or Tilde) before
p g

you do anything else.

% If Undo doesn’t work: 1f Undo doesn’t work consistently, it’s a
sign that HyperCard is running low on memory. For more
information about low-memory situations, see “Working With
Paint Tools When Memory Is Low,” later in this chapter. %
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You can erase a mistake by choosing the Eraser from the Tools
menu and dragging over the graphic. You must be working in the
background layer to erase a background graphic and in the card
layer to erase a card graphic. To erase in a straight horizontal or

. vertical line, press Shift while you drag the Eraser.

» Seealso: “Reverting to the Last Version of a Graphic” in this chapter
* “Saving the Graphics on a Card or Background” in
this chapter

* “Deleting a Graphic” in this chapter

Painting With the  Three of the tools in the Tools menu are analogous to everyday
BI‘USh, Spray tOOl, painting implements. These tools work much like the implements

7 they represent:
and Bucket

w The Brush (&) works like a paint brush.
» The Spray tool (&) works like a can of spray paint.
» The Bucket (&) works like a bucket full of paint.

You can use these tools in conjunction with patterns and colors in
the Patterns menu. This section explains how.

Yainting with the Brush  The Brush works like a paint brush—it leaves a swath of “paint” in
its path. You can use the Brush to paint an area with a pattern or

color. (HyperCard’s default color is black.) .

Follow these steps to paint with the Brush:
1. Go to the card or background where you want the paint.

[f you're not sure whether to put the paint in the card layer
or the background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.
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2. Choose the Brush (#) from the Tools menu.

Or click it on the Tools palette. The pointer changes to the
current Brush shape.

3. Drag where you want to paint.

Paint (in the current pattern or color) appears where you drag,
To paint in a straight horizontal or vertical line, press and hold

the Shift key while you drag.

% 1o erase with the Brush: You can erase any existing paint in
the path of the Brush by pressing and h()lding the " key

while you drag. <

O [f you want to paint with a different pattern or color, choose the
one you want from the Patterns menu (or click it on the Patterns
palette) before you drag with the Brush.

If you want to paint (or erase) with a different brush shape, choose
Brush Shape from the Options menu or double-click the Brush on
the Tools palette. The Brush Shape dialog box appears:

Click a brush shape to
me . N - select it. After you select
e N a brush shape, this
dialog box disappears.
» The pointer changes
fe to the brush shape
you select.

N

‘ A box appears around the
selected brush shape.

Figure 6-12  The different brush shapes
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The different brush shapes create different effects when you paint.
The following figure shows some examples:

Brush shape | L Effect

Figure 6-13  The different brush shapes create different effects

Painting with  The Spray tool works like a can of spray paint—it sprltzes pamt
the Spray tool  onto the screen in the selected pattern.

Follow these steps to paint with the Spray tool:
1. Go to the card or background where you want the paint.

[f you're not sure whether to put the paint in the card layer
or the background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

2. Choose the Spray tool (&) from the Tools menu. ‘

Or click it on the Tools palette. The pointer changes to the
Spray tool ().
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3. Drag where you want to paint.

Spray paint, in the current pattern or color, appears where you
drag. The more you spray back and forth over the same area, the
more the pattern or color becomes apparent. (Some patterns
don’t show up until you've thoroughly covered an area.)

To paint in a straight horizontal or vertical line, press and hold
the Shift key while you drag.

%+ 10 erase with the Spray tool: You can erase any existing paint
in the path of the Spray tool by pressing and holding the 7

key while you drag. «

If you want to spray with a different pattern or color, choose the
‘ one you want from the Patterns menu or click it on the Patterns

palette before you drag with the Spray tool.

Filling an area with ~ You can fill any area on a card or background with a pattern or
a pattern or color  color by using either the Bucket (in the Tools menu) or the Fill
command (in the Paint menu). Before you fill an area, you can

choose the pattern or color you want to fill it with.

This section describes two different methods for filling an area.
The method you use depends on whether the area you want to fill
is completely enclosed.

% Filling shapes: 1f you know before creating a shape that you
want to fill it with a pattern or color, you can fill the shape
@ automatically as you draw it. For instructions, see “Drawing a
Shape Filled With a Pattern or Color,” later in this chapter.
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Filling an enclosed area

When you want to fill an area that’s completely enclosed—that is,
completely surrounded by an outline—follow these steps:

1.

!\J

Figure 6-14  Positioning the Bucket pointer to fill an arca
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Go to the card or background that contains the enclosed area

you want to fill.

If the outline enclosing the area is in the background layer, go to
the background layer. If it’s in the card layer, make sure you're in
the card layer. If the outline is composed of several different
graphic elements, they must all be in one layer.

Pressing -B takes you to the background layer. (When you're
in the background layer, the word Background appears in the
menu bar.) If you press - -B repeatedly, you move back and o

forth between the card layer and the background layer.
Choose the pattern you want from the Patterns menu.
Or click it on the Patterns palette.

Choose the Bucket (&) from the Tools menu.

Or click it on the Tools palette. The pointer changes to the
Bucket.

Move the Bucket so that the tip of the stream pouring from it
is within the enclosed space you want to fill, then click:

This is the part of the Bucket ‘
that dispenses paint.




If there are any gaps in the outline that encloses the arca you want
to fill, paint will spill out and fill the surrounding area, too. If this
happens, immediately choose Undo from the Edit menu, or press

1-Z, Tilde, Esc, or Delete. Then check carefully for gaps in the

outline before using the Bucket again.

Enclosed arca Gap

Figure 6-15 Paint spills out of an unenclosed area

% 10 check for gaps: You can magnify the graphic to check for gaps
in its outline by using the technique described in “Magnifying a
Graphic for Editing,” later in this chapter.

Filling an unenclosed area

To fill an area that’s not completely enclosed by an outline or other
graphics, follow these steps:

1. Go to the card or background that contains the area you want

. to fill.

Pressing (*I-B takes you to the background layer. (When you’re
in the background layer, the word Background appears in the
menu bar.) If you press C-B repeatedly, you move back and
forth between the card layer and the background layer.

2. Choose the pattern you want from the Patterns menu.

Or click it on the Patterns palette.
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Creating your
own patterns

3. Select the graphic element or the area you want to fill.

If you want to fill a specific graphic element, you can select

it with either the Selection tool or the Lasso, as explained in |
“Selecting an Individual Graphic Element,” earlier in this
chapter. If you want to fill a blank area, select it with the
Selection tool, as explained in “Selecting a Rectangular Area,”
earlier in this chapter.

4. Choose Fill from the Paint menu.

The selected area fills with the current pattern or color.

iﬂl

Select the graphic you want to fill . . . ... and choose Fill
from the Paint menu.

Figure 6-16  Using the Fill command

If the Power Keys option is turned on, you can press F instead of
choosing Fill. (“Using Power Keys,” later in this chapter, explains @)
the Power Keys option.)

You can change any pattern in the third or fourth column of the
Patterns menu or replace it with a pattern of your own creation.
When you change or create a pattern, the new pattern is saved with
the stack you’re working in. It appears in the Patterns menu every
time that stack is active.
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To change or create a pattern, follow these steps:

1. Choose the pattern you want to change from the third or
fourth column of the Patterns menu.

Or click it on the Patterns palette. You cannot change any of the
individual colors in the first or second columns.

2. Choose Edit Pattern from the Options menu.

Or double-click the pattern you want to change on the Patterns
palette. The Edit Pattern dialog box appears.

3. Edit the pattern.

This is the editing As you edit the pattern
area. You can click to in the editing area to
draw and erase the the left, this shows
little squares that you how the pattern
make up the pattern. will look.

Click here to fill the
pattern with the
selected color.

Click here to mix the
the selected color
into the pattern.

Click the color you want
to use to select it.

Figure 6-17  Editing a pattern

4. Click OK to save the new pattern.

The new pattern takes the place of the one that was selected in
the Patterns menu.
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Changlng color SetS  The color set for a HyperCard stack determines the 16 colors
available for use by the backgrounds, cards, buttons, and fields
in the stack. You can choose from among five color sets for any
given stack: the standard system color set, a gray scale color set,
and three others.

When you change your stack’s color set, the colors of some or all
the graphics, buttons, and fields in the stack may change to reflect
the new colors. For example, these three images all make use of the
same graphic, but different color sets:

Gray scale color set

A pastel color set

Figure 6-18  Changing color sets
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[f you wish, you can sclect color sets for the cards and backgrounds
in your stack that are different from the color set selected for the
stack as a whole. If a card’s color set has not been specified
. individually, the card uses the color set currently selected for its
Sy g background. Similarly, if a background’s color set has not been
specified individually, the background uses the color set currently
selected for the stack.

For example, the cards in the Birds stack use several different color
scets so that the colors in cach drawing match the bird’s true colors
more closely. By carefully selecting the color sets for cards and
backgrounds in a stack, you can control the colors in your stacks
more precisely than would be possible with just one color set.

O If none of the five color sets available for a card or background
includes the colors you want, you can add a sixth color set to a card
or background in the stack from any document in the Apple
Preferred File Format, the standard format for Apple I1GS graphics
documents. For instructions on how to do this, see “Importing a
New Color Set for a Card or Background,” later in this chapter.

You can also add a sixth color set to a card or background by using a
desk accessory, an XCMD, or HyperTalk to specify the colors you
want. If you use a desk accessory or an XCMD to do this, the color
set you specify will be added automatically to the color sets for the
current card or background and will be selected. For instructions on
using HyperTalk to add a sixth color set to a card or background,
see the discussion of the colorset property in the HyperTalk
@ Help stack.

The sections that follow describe how to change the color set for a
stack, a card, and a background.

Chapter 6: Working With Graphics 273




Chzmging a stack’s color set  To change the color set for the stack you're working in, follow
these steps:

1. Make sure you have one of the General tools selected. -

. The Browse tool (), the Button tool (<), or the Field tool (£3)
L will work.

2. Choose Stack Info from the Objects menu.
3. Click Colors.
The Colors dialog box for the stack appears.

4. Select the color set you want:

_Display colors for stack "MyStack"

AT T Il 1T T 1) Stondard system colors

ST T T T 1 Groy scale

111 A0 O O 65 [ 1] Other color sets...

" : [TTITTEEREY ™ 1 ESEESSNTTITTINNT 1
o illln‘i)i;tffﬁe 11
L - When displaying this stack:

Cll\t\i]{]}:i?ﬁ:{\?g [ Use these colors [ ( ok ] (concel)

These are the
color sets that are

... then press and hold the mouse button here and drag to
choose “Use these colors” (if it's not already selected) from the
pop-up menu. If you choose “Get standard system colors”
instead, your stack will use the standard system colors no
matter which color set is selected for the stack.

Figure 6-19  Changing a stack’s color set

5. When you’re finished, click OK.

The Colors dialog box disappears, and you see the Stack Info

dialog box again.
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Changing a card’s color set

These are the
color sets that are
available for the
current card.

. Click the one you
want to use . . .

6. In the Stack Info dialog box, click OK.

The colors displayed in the stack now match the color set you
selected (unless different color sets have been selected for

individual cards or backgrounds).

You can easily tell which colors are in the color set for the current
card by checking the Patterns menu while you’re working in the
card layer. The first and second columns in the Patterns menu show
the colors currently being used by the card.

To change the color set for a card, follow these steps:

1. Go to the card whose color set you want to change.
2. Make sure you have one of the Paint tools selected.
3. Choose “Choose ColorSet” from the Options menu.

Or double-click any color in the first or second column of the

Patterns palette. The Colors dialog box for the card appears.

4. Select the color set you want:

_ Display colors for card 1D 2928
I O A SO
(OO O O 5 R O

Standard system colors

Groy scale
Other color sets...

When displaying this card:

[ Use these colors 1 ( ok ) (cancel)

... then press and hold the mouse button here and drag to
choose “Use these colors” (if it's not already selected) from the
pop-up menu. If you choose “Get colors from background”
instead, the card will use the colors currently specified for the
background no matter which color set is selected for the card.

Figure 6-20 Changing a card’s color set
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5. When you’re finished, click OK.

The colors displayed on the card now match the color set you
selected.

You can also change a card’s color set when you have one of the
General tools selected, as described in “Changing a Card’s Color
Set” in Chapter 3.

If none of the five color sets for a card include the colors you want,
you can add a sixth color set to a card from any document in the
Apple Preferred File Format, the standard format for Apple IIGS
graphics documents. For instructions on how to do this, see
“Importing a New Color Set for a Card or Background,” later in
this chapter.

You can also add a sixth color set to a card by using a desk accessory,
an XCMD, or HyperTalk to specify the colors you want. If you use
a desk accessory or an XCMD to do this while you’re working in
the card layer, the color set you specify will be added automatically
to the color sets for the current card and will be selected. For
instructions on using HyperTalk to add a sixth color set to a card,
see the discussion of the colorset property in the HyperTalk
Help stack.

Changing a background’s  You can easily tell which colors are in the color set for the current
color set  background by checking the Patterns menu while you’re working in
the background layer. The first and second columns in the Patterns
menu display the colors currently being used by the background. &

To change the color set for a background, follow these steps:

1. Go to any card that has the background whose color set you
want to change.

2. Make sure you have one of the Paint tools selected.
3. Go to the background layer.

Choose B;lcl(gl'ound from the Edit menu, or press “-B.
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4. Choose “Choose ColorSet” from the Options menu.

Or double-click any color in the first or second column of the

Patterns palette. The Colors dialog box for the background
appears.

5. Select the color set you want:

Display colors for background 1D 2697

Standard system colors

Gray scale
These are the

color sets that are
available for the

Other color sets...

[ ‘ D00 O
current background. e T T
Click the one you When displaying this bkgnd:
want to use . . | Use these colors | LOK ]] LCancelj

... then press and hold the mouse button here and drag to
choose “Use these colors” (if it’s not already selected) from the
pop-up menu. If you choose “Get colors from stack” instead,
your stack will use the colors currently specified for the stack
no matter which color set is selected for the background.

Figure 6-21  Changing a background’s color set

6. When you’re finished, click OK.

"The colors displayed in the background now match the color set
you selected (unless different color sets have been selected for

individual cards in the background).

You can also change a background’s color set when you have
one of the General tools selected, as described in “Changing a
Background’s Color Set” in Chapter 3.
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[mporting a new color set
for a card or background

If none of the five color sets for a background include the colors
you want, you can add a sixth color set to a background from any
document in the Apple Preferred File Format, the standard format
for Apple 11GS graphics documents. For instructions on how to do
this, see the next section, “Importing a New Color Set for a Card
or Background.”

You can also add a sixth color set to a background by using a desk
accessory, an XCMD, or HyperTalk to specify the colors you want.
If you use a desk accessory or an XCMD to do this while you're
working in the background layer, the color set you specify will be
added automatically to the color sets for the current background

and will be selected. For instructions on using HyperTalk to add a
sixth color set to a background, see the discussion of the colorSe’
property in the HyperTalk Help stack.

The Colors dialog box for a card or background normally allows
you to choose from only five color sets. However, you can add a
sixth color set to a card or background from any document in the
Apple Preferred File Format by following these steps:

1. Go to the card or background where you want the new
color set.

Important: If there are any graphics on the card or background

that you want to keep, make a copy of them for temporary
safekeeping as described in “Copying a Graphic to Another Card ¢
Background,” later in this chapter, before you import the new color
set. Otherwise, you will lose the graphics permanently. A

2. Make sure you have one of the Paint tools selected.
3. Choose Import Paint from the File menu.

A directory dialog box appears.
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4. Use the directory dialog box to locate and open the Paint file
that contains the color set you want to import.

The upper-left portion of the imported picture appears.
o e 5. Choose Keep from the Paint menu.

HyperCard adds the color set from the imported picture’s
original Paint file below the color sets in the current card or
background’s Colors dialog box, and selects it.

If you want to keep the new color set but not the imported picture,
erase the picture and replace it with your original graphics or any
other graphics you want to use. For more information about
importing graphics, see “Importing a Graphic,” later in this chapter.

Dr aWing [in€S  The Tools menu includes tools for drawing lines and shapes—
n including circles, ovals, rectangles, polygons, and free-form
and Shapes shapes. This section explains how to create lines and shapes with
these tools.

e

—
m=EE
& || /
‘ | [ | [ 1 | These tools are
for drawing lines
iﬁ’g g g ?Z:} and shapes.
Figure 6-22  “Tools for drawing lines and shapes

» Secalso: o “Drawing With Patterns, Colors, and Different Line Widths”
in this chapter
* “Creating Special Graphic Effects” in this chapter
* “Changing the Appearance of a Graphic” in this chapter
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Drawing a line  "To draw a straight line or a free-form line or shape, follow
or a free-form shape  these steps:
1. Go to the card or background where you want the line

or shape.

If you’re not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or

Background™ at the beginning of this chapter.

2. If you want to draw a straight line, choose the Line tool ()
from the Tools menu.

Or, to draw a free-form line or shape, choose the Curve tool (©)
from the Tools menu. The pointer changes to a crosshair (+).

3. Drag where you want to draw the line or shape.

-y
. )

Figure 6-23  Lines and free-form shapes

If you’re using the Line tool, you can draw a straight line ata 15
angle from horizontal, or at an angle that’s a multiple of 15°, by.
pressing the Shift key while you drag. To change the angle of a
straight line while you’re drawing it, change the direction of the
mouse as you drag.
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Drawing circles, ovals,
and rectangles

When you use the Line tool, you can draw a straight line from its
center point by first turning on the Draw Centered option. To turn
on Draw Centered, choose it from the Options menu. When Draw
Centered is turned on, a check mark appears next to it in the menu.
To turn off Draw Centered, choose it again. (If the Power Keys
option is turned on and the Message box is hidden, you can also
press C to turn Draw Centered on or off. “Using Power Keys,” later
in this chapter, explains the Power Keys option.)

% Using the Pencil: The Pencil allows you to draw thin lines
and free-form shapes, too. For a discussion of the special
characteristics of the Pencil, see “Drawing With the Pencil,” later
in this chapter.

To draw a circle, oval, or rectangle, follow these steps:
1. Go to the card or background where you want the shape.

If you're not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background™ at the beginning of this chaprter.

2. If you want to draw an oval or circle, choose the Oval tool (O)
from the Tools menu.

Or, to draw a rectangle or square, choose either the Rectangle
tool (J) or the Rounded Rectangle tool (3) from the Tools
menu. (The Rounded Rectangle tool draws rectangles and
squares with rounded corners.)

The pointer changes to a crosshair (+).
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3. Drag diagonally to draw the shape.

1o draw a circle, oval or

rectangle, select the

appropriate tool, then
drag diagonally from " ————rr
one corner . . . —_— —
-

... tothe C

e, et

opposite
corner.

Figure 6-24  Drawing circles, ovals, and rectangles

To draw an oval or rectangle that is the same number of pixels ®
wide as it is high (that is, an approximate circle or square), press

the Shift key while you drag.

To move the shape around on the card while you're drawing it,
press (¢ before you release the mouse button. This allows you to
drag the shape anywhere on the card. You can release the ~ key
to continue creating the shape, then press the * key again to
move the shape. Once you've released the mouse button, you
have to select the shape before you can move it. (“Selecting a
Graphic,” earlier in this chapter, explains how.)

To draw a shape from the center outward, first turn on the Draw
Centered option by choosing it from the Options menu. When
Draw Centered is turned on, a check mark appears next to it in the
menu. To turn off Draw Centered, choose it again. (If the Power .
Keys option is turned on and the Message box is hidden, you can

also press C to turn Draw Centered on or off. “Using Power Keys,”
later in this chapter, explains the Power Keys option.)
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To draw a shape in outline—so that only its outline appears on the
screen while you’re drawing it—first turn on the Draw Outlined
option by choosing it from the Options menu. When Draw
Outlined is turned on, a check mark appears next to it in the menu.
This option allows you to draw a shape more quickly and smoothly.
The entire shape appears after you release the mouse button.

Drzlwing d l‘cgular p()]yg()ﬂ To draw a regular polygon (one that is the same number of pixels
wide as it is high), follow these steps:

1. Go to the card or background where you want the polygon.

If you're not sure whether to put it in the card layer or the
O background layer, see “Adding Graphics to a Card or
Background™ at the beginning of this chapter.

2. Choose the Regular Polygon tool (O) from the Tools menu.

The pointer changes to a crosshair (+).

3. If you want to select the number of sides for your polygon,
choose Polygon Sides from the Options menu.

Or double-click the Regular Polygon tool on the Tools palette.
The Polygon Sides dialog box appears.

This step and the next step are optional. If you don't select the
number of sides before you draw the polygon, it will be either an
approximate square (the default shape) or the last shape you

‘ selected in the Polygon Sides dialog box.
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4. Click the shape that corresponds to the polygon you want
to draw:

Click a shape to indicate how many sides you
want the polygon to have. (The shape you
select will remain in effect until you change it
by selecting a different shape.) After you click
a shape, this dialog box disappears.

A box appears around

A OO Q@ @) the selected shape.

Figure 6-25 Choosing the number of sides for a polygon

5. Drag diagonally to draw the polygon.

The polygon is
drawn from the
center . . . T ...outward.

Figure 6-26  Drawing a regular polygon

To move the polygon around on the card while you're drawing

it, press  before you release the mouse button. This allows you

to drag the shape anywhere on the card. You can release the @)
* key to continue creating the polygon, then press the  key

again to move the shape. Once you've released the mouse

button, you need to select the shape before you can move it.
<« M . ”» . . . .

(“Selecting a Graphic,” earlier in this chapter, explains how.)

To rotate the polygon while you're drawing it, drag with a
circular motion. If you press Shift while you drag with a circular
motion, the polygon rotates only in 15° increments, which
makes it easier to position at exactly the angle you want.
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To draw a shape in outline—so that only its outline appears on the
screen while you’re drawing it—first turn on the Draw Outlined
option by choosing it from the Options menu. When Draw
Outlined is turned on, a check mark appears next to it in the menu.
This option allows you to draw a shape more quickly and smoothly.
The entire shape appears after you release the mouse button.

Dl'leiﬂg d l‘cgulzlr p()lyg(m To draw a regular polygon (one that is the same number of pixels
wide as it is high), follow these steps:

1. Go to the card or background where you want the polygon.

If you're not sure whether to put it in the card layer or the
O background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

2. Choose the Regular Polygon tool (O) from the Tools menu.
The pointer changes to a crosshair (+).

3. If you want to select the number of sides for your polygon,
choose Polygon Sides from the Options menu.

Or double-click the Regular Polygon tool on the Tools palette.
The Polygon Sides dialog box appears.

This step and the next step are optional. If you don't select the
number of sides before you draw the polygon, it will be either an
approximare square (the default shape) or the last shape you

’ sclected in the Polygon Sides dialog box.
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4. Click the shape that corresponds to the polygon you want
to draw:

Click a shape to indicate how many sides you
want the polygon to have. (The shape you
select will remain in effect until you change it
by selecting a different shape.) After you click
a shape, this dialog box disappears.

A box appears around

A O O Q[_@] @) the selected shape.

Figure 6-25 Choosing the number of sides for a polygon

5. Drag diagonally to draw the polygon.

The polygon is
drawn from the

center . . . ... outward.

Figure 6-26  Drawing a regular polygon

To move the polygon around on the card while you're drawing
it, press  before you release the mouse button. This allows you
to drag the shape anywhere on the card. You can release the
key to continue creating the polygon, then press the C key
again to move the shape. Once you've released the mouse
button, you need to select the shape before you can move it.
(“Selecting a Graphic,” earlier in this chapter, explains how.)

To rotate the polygon while you're drawing it, drag with a
circular motion. If you press Shift while you drag with a circular
motion, the polygon rotates only in 15° increments, which
makes it easier to position at exactly the angle you want.
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With the Regular Polygon tool, the shape is always drawn from the
center outward, whether or not Draw Centered is checked in the
Options menu.

!

Drawing an  To draw a polygon whose sides arer’t necessarily the same length,
irregular polygon  follow these steps:

1. Go to the card or background where you want the polygon.
[f you're not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chaprter.
2. Choose the Polygon tool (<) from the Tools menu.
‘ The pointer changes to a crosshair (+).

3. Click at the point where you want to begin the first side of the
polygon. :

The Polygon tool works differently from the other tools—you
don’t hold down the mouse button to draw.

4. Without holding down the mouse button, move the crosshair
pointer to draw one side of the polygon.

You can draw the side of the polygon at a 15° angle from

horizontal, or at an angle that’s a multiple of 15° by pressing

the Shift key while you move the mouse. To change the angle

of the side while you’re drawing it, change the direction of the
® mouse as you drag.
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5. When the side of the polygon is the length you want it, click to

fix it in place.
6. Repeat steps 4 and 5 for each additional side of the polygon.
7. To finish the shape, click on the starting point.

Alternatively, you can double-click or press (!-Z at any point to
stop drawing, whether or not the shape is complete. (Pressing
-7 also deletes the line that was drawn since you last clicked.)

8. Draw this side
by moving the
pointer without

9. Click here to holding down the 6. Draw this side by
| Click here finish the shape. mouse button, 7. Click here.  moving the p()m[cr.
CWLHICK . .
, without holding
Lo start the ‘

shape. __ down the mouse
button.

2. Draw this sideby ™ — 5. Click here.

moving the pointer

without holding

down the mouse

button.

3. Click here. 4. Draw this side by
moving the pointer
without holding down

the mouse button.

Figure 6-27 Drawing an irregular polygon
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Drawing with the Pencil

You can use the Pencil to create free-form lines and shapes and

touch up graphics.

To draw with the Pencil, just choose it from the Tools menu and
drag where you want to draw. The Pencil draws in the color
currently selected in the Patterns palette, unless you begin to drag
from a place that is the same color as the color you are drawing
with. In this case, the Pencil draws in white:

If you start dragging  If you start dragging on
ona color that's the  white (or on any color

same as the color other than the one you're
you're drawing drawing with), the Pencil
with, the Pencil draws in the currently
draws in white. selected color.

Figure 6-28 Drawing in the selected color and drawing in white

The Pencil also draws in white if you are drawing while a pattern is

selected in the Patterns palette and you begin to drag from a place
that is filled with any pattern.

To draw a straight horizontal or vertical line with the Pencil, press
the Shift key while you drag.
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Dl’uWiﬂg With  This section explains how o create lines and shapes that have
pﬂtt@fﬂS, COIOTS, and pacterns and colors, and lines and shape borders in varying line

. ! i widths.
different line widths

| You can use these tools to draw
shapes and lines with patterns,
(Z colors, and different line widths.

P[0 =] [

&
o (o] [m] (¥

£1010
&

Figure 6-29  The tools for drawing with patterns, colors, and different line widths

Drawing a shape  When you know before creating a shape that you’ll want it filled
filled with a pattern  with a pattern or color, you can fill the shape automatically as you
or color draw it. Follow these steps:

1. Choose the pattern or color you want the shape to have from
the Patterns menu.

Or click it on the Patterns palette.
2. Choose Draw Filled from the Options menu to turn it on.

When Draw Filled is turned on, a check mark appears next to it

in the menu. (Choosing Draw Filled again turns it off.) ‘

@ A shortcut: You can also turn Draw Filled on or off by
double-clicking any of the shape tools on the Tools palette
(except the Regular Polygon tool). «
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The Tools menu looks different when Draw Filled is turned on:

J
[ =) ]

[4] ]l

The Tools menu The Tools menu
when Draw Filled when Draw Filled
is turned off is turned on

Figure 6-30  The Tools menu with Draw Filled turned off and turned on

3. Draw the shape.

Choose the tool for the shape you want to draw from the Tools
menu, then drag to draw the shape. (See “Drawing Lines and
Shapes,” earlier in this chapter, if you want more detailed
instructions.)

When you finish drawing the shape, it automatically fills with
the selected pattern.

*  Draw Filled with the Curve tool and Polygon tool- If Draw Filled
is turned on while you’re using the Curve tool or the Polygon
tool, HyperCard draws a straight line connecting your starting
and ending points when you finish drawing; then it fills the

®,

shape with the selected pattern.
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Drawing with
difterent line widths

p

- — HyperCard draws
¥  this line.

Using the Curve Using the Curve
tool with Draw tool with Draw
Filled turned off Filled turned on

Figure 6-31  Creating a filled, curved shape

HyperCard draws
this line.

Using the Polygon  Using the Polygon
tool with Draw tool with Draw .
Filled turned off Filled turned on

Figure 6-32  Creating an enclosed, filled polygon

2 Filled shapes without borders: To draw a filled, borderless shape,
turn on Draw Filled, then hold down the Option key while you
draw the shape. <

Before you draw a line or shape, you can select the thickness of the
line or the shape’s border (unless you’re using the Pencil, which
draws in only one thickness). Follow these steps:

1. Choose Line Size from the Options menu. O

Or double-click the Line tool on the Tools palette. The Line Size

dialog box appears.
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Drawing borders with
patterns and colors

2. To select a line thickness, click it:

Click the line that represents the line

m I 1108 width you want. After you click a line

width, this dialog box disappears.

A box appears around
the selected line width.

Figure 6-33  Line widths

3. Draw the line or shape.

Choose the tool for the line or shape from the Tools menu, then
drag to draw the shape. (See “Drawing Lines and Shapes,” earlier
in this chapter, if you want more detailed instructions.)

+ A shorteut for selecting line widths: When the Power Keys option
is turned on (and the Message box is hidden), you can type a
number from 1 to 8 to select a line width while any Paint tool is
selected. (“Using Power Keys,” later in this chapter, explains the
Power Keys option.) «

12 3 4or560r7 8__Powerkeys

Note: These power keys don't work when
the Line Size dialog box is open.

Figure 6-34  The power keys for choosing line widths

"To draw a shape with a patterned or colored border, follow these
steps:

1. Choose the pattern or color you want from the Patterns menu.

Or click it on the Patterns palette.
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Moving a graphic
around on a card
or background

BESRERERENRNRRRERRRERRRRNERERELN
ll[ “ Ja—

2. Choose the tool for the shape you want to draw.
Any of the shape tools will work.
3. Press and hold the Option key while you draw the shape.

See “Drawing Lines and Shapes,” earlier in this chapter, if you
want more detailed instructions.

{
th’utzmﬂ’*

Figure 6-35  Shape borders with patterns and colors

% Filled shapes without borders: 1f the Draw Filled option is turned
on and you press the Option key while you draw a shape, you
create a filled, borderless shape. <

You can place a graphic wherever you like on a card or background.
To reposition a graphic on a card or background, follow these steps:

e

. Go to the card or background that has the graphic you want

to move. .

Pressing ( -B takes you to the background layer. (When you're
in the background layer, the word Background appears in the
menu bar.) If you press (i-B repeatedly, you move back and
forth between the card layer and the background layer.

2. Select the graphic.
e . ~ - » . - - - . .
Selecting a Graphic, carlier in this chapter, gives instructions.

3. Position the pointer over the selected graphic so that it changes
to the arrow pointer.
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4. Drag the selected graphic.

"lo move the graphic straight horizontally or vertically, press and

hold Shift while you drag.

+  Cant drag the graphic? 1f you think you’ve selected a graphic
but you can’t drag it, you might be trying to move a
background graphic from the card layer. Press (“-B and
try again. If you still can’t drag it, it’s either a button or a

field. (Chapters 4 and 5 explain how to move buttons
and fields.) «

/A Important: After you reposition a background graphic, it’s a good
O idea to look through the cards on which the graphic appears, to see
how the cards look. A

Cr eating SpGCial You can use the Paint tools in combination with one or more of
graphiC effects the commands in the Options menu to create a variety of special

effects. This section shows examples of the effects you can create.

Drawing in multiples  You can draw multiple lines or shapes using the Draw Multiple
option in the Options menu.

| F _
i |2 s
g ][] o B | praw Multiple
9‘) |02 - works with
A .::::, (z .::::, these tools.

Figure 6-36  The tools you can use with the Draw Multiple option
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'lo draw multiple lines or shapes in a single stroke, follow
these steps:

1. Choose Draw Multiple from the Options menu to turn it on.

When Draw Multiple is turned on, a check mark appears next
to it in the Options menu. (Choosing Draw Multiple again
turns it off.)

2. Draw a line or shape.

Choose the tool for the line or shape you want from the Tools
menu, then drag to draw the shape. (See “Drawing Lines and
Shapes,” earlier in this chapter, if you want more detailed
instructions.)

Rounded Regular

Line tool Rectangle ool Rectangle tool  Oval tool Polygon tool

Draw Multiple |
turned off
Draw Multiple @. % | | I
turned on I m @
Draw Multiple

and Draw Centered "E“ : _)

turned on

Figure 6-37  Drawing shapes with and without Draw Multiple
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To control the spacing between the multiple images, press the
Option key in combination with a number from 1 to 9 before you

drag. The higher the number you type, the farther apart the images

, will be.
Option-3 Option-5 Option-7 Option-9
ET] ===,
Figure 6-38  Varying the spacing between images for the Draw Multiple option
@ If the Power Keys option is turned on (and the Message box is

hidden), you can press M to turn Draw Multiple on or off. (The
Power Keys option is explained in “Using Power Keys,” later in

this chapter.)

Aligning graphics  You can use HyperCard’s Grid option to help you line up graphic
elements and position them more precisely. To turn on the Grid
option, choose it from the Options menu. (When Grid is turned
on, a check mark appears next to it in the menu. Choosing Grid
again turns it off.)

When Grid is turned on, the movement of the pointer is
constrained to an invisible grid whose lines are 8 pixels apart

) (just under one-quarter of an inch). As you draw graphics with the
Line tool and shape tools, or drag graphics to move them around,
they’ll be aligned to this invisible grid. The grid also constrains
the movement of the Selection tool as you select graphics and the
movement of the I-beam as you try to position the insertion point
to type Paint text.
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The Grid option is most helpful for aligning graphics that were
created with the Grid option turned on. If you create graphics with
Grid turned off and then turn Grid on, HyperCard will have a
difficult time aligning the graphics because their sizes and positions
won't conform to the grid’s intervals.

-1 If the grid were visible,
it would look like this.
o The graphics you

__l N | create \'\’hllC the Grid
option is turned on are
L_

I aligned to the grid.
PR

Figure 6-39  Aligning graphics with the grid

= .
W=
h | S s
| ] (] || | The Grid option
works with these
SO Ci) tools.
Al |E AlO|E
Figure 6-40 The tools affected by the Grid option ‘

You can use Grid in combination with other options in the Options
menu to create a variety of effects, as shown in the next section,
“Combining Options for Unique Effects.”

If the Power Keys option is turned on (and the Message box is
hidden), you can press G to turn Grid on or off. (*Using Power
Keys,” later in this chapter, explains the Power Keys option.)
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C()mbining ()pti()ns You can create some interesting visual images when several options
for Unique effects in the Options menu are turned on at the same time. And you can
add to the variety by holding down various modifier keys while you
draw with different options turned on. Experiment with different
combinations to see what happens.

Regular Polygon Oval tool, Shift key ~ Oval tool, Grid turned

. tool, Draw Filled pressed, Grid turned on, Draw Centered
turned on, Draw on, Draw Centered  turned on, Draw
Multiple turned on  turned on, Draw Multiple turned on

Multiple turned on

Line tool, Shiftkey  Rectangle tool, Grid  Line tool, Grid

pressed, Draw turned on, Draw turned on, Draw

Multiple turned on  Centered turned on,  Multiple turned on
Draw Multiple

. turned on

Figure 6-41  Special effects
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Addlng Paint texXt  Painc text is text you create with the Paint Text tool. It looks like
the text you type in fields, but you use the Paint tools to create,
move, copy, and change Paint text, just as you would with any

other graphic.

Paint text is especially useful when you need to include text as part
of a picture—for example, as a picture title or labels—or whenever
you want text to behave more like a picture than text. You can select
both a picture and Paint text at once with the same tool and use the
same commands on them. And you can create special effects with
Paint text by using commands in the Paint menu (for example,
Invert or Trace Edges). To add Paint text to a card or background,
follow these steps:

1. Go to the card or background where you want the Paint text. ®

If you're not sure whether to put it in the card layer or the
background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

2. Choose the Paint Text tool (A) from the Tools menu.
The pointer changes to an I-beam (1).

3. To select a font and style for the text, choose Text Style from
the Edit menu, or press < - T.

Or double-click the Paint Text tool in the Tools palette. You see
the Text Style dialog box.

The preset format for Paint text is 8-point plain Shaston with &
line height of 9 points.
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Click to select or deselect one or

4. Choose from the options in the Text Style dialog box:

Click to select the

font you want.

Click to select a font size
(measured in points).

To use a font size not

more text styles. (Select nothing for D%?ite ( Courier g listed, type it here. Then, if
plain text.) The sample text at the | T Italic Geneva you want to adjust the
bottom of the dialog box shows ™} inder} m\ Helvetica height to the new type size,
the effect of the selected styles. [J0utline Times press Enter. (If you don't
] Shadow Venice press Enter, the line height

Press and hold the mouse
button here to see a pop-up
menu for choosing the
alignment of Paint text.

will remain the same).

:Hllgn Left i Line Height: | l Font Size:

The quick brown fox jumps over the lazu dog.

This shows what your
text will look like.

This number determines the space
l)u[\\un lines. HyperCard sets this number
automatically when you click one of the

standard font sizes, but you can change it.

Figure 6-42  Selecting a font, style, and size for Paint text

The choices you make in this dialog box stay in effect for the
Paint Text tool until you change them, or until you restart
HyperCard. (The preset format is restored when you restart
HyperCard.)

5. Click where you want to position the insertion point and begin
typing.

While you're typing, you can press Delete to delete one character
to the left of the insertion point. And you can press Return to
start a new line of text.
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As long as the insertion point is still blinking, you can change
the font, style, and size of the text you're typing by choosing
Text Style from the Edit menu and changing the settings in the
Text Style dialog box. All the text you've typed since you last
clicked (or since you last pressed Enter) is changed to the new
font, style, and size.

Similarly, you can change the pattern or color of the text you're
typing by choosing a different one from the Patterns menu. All
the text you’ve typed since you last clicked or pressed Enter is
changed to the new pattern or color.

As soon as you click anywhere, choose another tool, choose Keep
from the Paint menu, switch into or out of the background, or

move to another card, the text becomes part of the picture—its '
attributes become fixed. To change the text or its attributes, you

have to erase it and start again.

@ Quick text pickup tip: To select Paint text you've just finished
typing, press (-S immediately, before you click anywhere. %

A\ Important: You can't use the Find command to search for Paint
text. To HyperCard, Paint text is just another graphic. If you think
that you’ll want to search later for what you’re typing now, create a
field and enter the text in the field using the Browse tool. (See
Chapter 5 for instructions on entering field text.) A

Turning field text  You can turn existing field text into Paint text, if you decide that &
into Paint text  you'd like to make it part of a picture. Follow these steps:

1. Choose the Browse tool from the Tools menu.

The pointer becomes an I-beam (T) when you move it over the
field. (If you don't see the [-beam, consult “Where’s the I-beam

Pointer” in Chapter 5.)
p
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2. Drag (with the I-beam) to select the field text you want
to change.

3. Choose Copy Text from the Edit menu, or press C3-C.

Or, if want to remove the text from the field, choose Cut Text
from the Edit menu, or press (3-X.

4. Choose any Paint tool from the Tools menu.
5. Go to the card or background where you want the text.

If you’re not sure whether to put it in the card layer or the
background layer, sce “Adding Graphics to a Card or
Background” at the beginning of this chapter.

6. Choose Paste Text from the Edit menu, or press 3-VL

The copied text appears in the center of the card, surrounded by
a moving dashed line:

This text fas been changed from field fext into Paint texi,

.................................................... k

To move the selected You can change the shape of the selection I

text, drag any part of it. by pressing the 3 key and dragging from
a corner. (The text wraps at the right
border of the selection.)

Figure 6-43 Turning field text into Paint text

While the text is still selected, you can format it by choosing Text
Style from the Edit menu (or pressing ¢ -T) and changing the
settings in the Text Style dialog box. The text becomes part of the
picture after you click outside the selected area.
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When elements HyperCard puts different kinds of elements in different layers, as
p P y
Overlap shown in the following figure. Together, all these layers make up the

card you see.

Background picture
Background
buttons and fields

Card picture .
Card buttons

and fields

vy What you see
Lt when you look
at the card

| The background picture Y
is fixed in a layer by
itself—it’s always ! iy 4
behind the background ‘ : " » '
buttons and fields and Faent

all the card elements.

| The card picture is also
fixed in a layer by
itself—it’s always
behind the card buttons
and fields, and in front
of the background
buttons and fields.

Figure 6-44 HyperCard's layers
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Making a graphic opaque

or transparent

As shown in Figure 6-44, the graphics in the card layer (referred to
collectively as the card picture) are behind all the buttons and fields
in the card layer, but they’re in front of all the elements in the
background layer. This means graphics in the card layer can obscure
the background elements, but they can be obscured by the buttons

and fields in the card layer.

Graphics can also obscure one another. Graphics in the background
layer (referred to collectively as the background picture) can get lost
behind graphics in the card layer, and a graphic that you’ve created
recently can cover graphics that were drawn earlier in the same layer.

When elements overlap so that some graphics obscure, or are
obscured by, other elements, you can either rearrange the elements
so they don’t overlap, or you can make some of the elements
transparent so you can see other elements through them. “Moving a
Graphic Around on a Card or Background,” earlier in this chapter,
explains how to reposition graphics on the card or background. The
next section explains how to make graphics opaque or transparent.
(Chapters 4 and 5 give instructions for rearranging buttons and
fields and making them opaque or transparent.)

When you want to be able to see elements that are obscured by a
graphic, you can make the graphic transparent. Conversely, when
you want to make a graphic more prominent, you can make it
opaque.

Follow these steps to make a graphic opaque or transparent:
1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.
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2. Choose Transparent from the Paint menu to make any blank
space or white paint within the graphic transparent.

Or choose Opaque from the Paint menu to make the entire

graphic opaque.

A graphic ... made opaque and
clement ... moved over a color

Figure 6-45 Making a graphic opaque .

'l

il
A graphic ... made transparent
element . . . and moved over a color

Figure 6-46  Making a graphic transparent

% Making the entire graphic transparent: 1f you want to make the
entire graphic transparent—including blank space, white paint,‘
and colors—hold down the Option key while you choose
‘Transparent from the Paint menu. (Note that placing a
transparent color over another color sometimes leads to
unexpected results, such as black.) <
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Changing
the appearance
of a graphic

Magnitying a graphic
for editing

When you first create or paste a graphic, it’s opaque—that s, it
covers the graphics beneath it. You can make the new graphic
transparent by choosing Transparent immediately after you create it
(before you click anywhere)—or, if you've pasted it, by choosing
Transparent while it’s still selected. Transparent will affect just the
graphic you've created since the last time you pressed the mouse
button if nothing else is selected.

If the Power Keys option is turned on, you can also press O to make
the selected graphic opaque, or T to make it transparent. (“Using
Power Keys,” later in this chapter, explains the Power Keys option.)

To identify which areas on a card or background are opaque and
which are transparent, hold down the Option key and press O. The
opaque areas will appear white and the transparent areas black until
you release the keys.

HyperCard includes many commands and options for changing the
look of an existing graphic—including commands that let you edit
a picture pixel by pixel and commands for flipping a graphic upside
down or backward. This section describes all the ways you can
modify graphics and Paint text.

» Seealso: o “Using Power Keys” in this chaprer
* “Using Modifier Keys With Paint Tools” in this chapter
* “Double-Clicking Paint Tools, Patterns, and Colors” in this
chapter

You can zoom in on a section of a picture to do close-in finish
work and edit your picture one dot (two pixels) at a time. Follow

these steps:

1. If you want to work on a particular part of the picture, select
that part of the picture.

“Selecting a Graphic,” earlier in this chapter, gives instructions.
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When the Pencil is |

selected, you can
add or remove a
single pixel ata
time just by
clicking.

2. Choose FatBits from the Options menu.

Or double-click the Pencil on the Tools palette. (Or press
Option-E)

Alternatively, you can zoom in on a particular part of the picture
by choosing the Pencil and pressing the * key while you click
on the part of the graphic you want to edit.

HyperCard zooms in on the part of the graphic you've selected
(or (3-clicked with the Pencil) and magnifies it. (If nothing is
selected and you haven't (i-clicked anything with the Pencil,
HyperCard zooms in on the graphic you were just working with,
or on the center of the card, if you weren't working on any

graphics.)

3. Edit the graphic.

You can close this window by clicking its

close box. (This doesn't turn off FatBits.) You can move

this window by

N EENEE dragging from
EE N ] 88INg
EEE BB [ : here.
M T
N mEEEE EE N
N mEHEEENE N N
B R \
O N\_ This window
R e .
LW T displays an actual-
8, Y O A L "
' O O 5 size version of the
A 1 0 A O 0 W 0 T A 1 MR
N 0 0 5 1 5 A 5 G T W graphic. As you
T O O O i R
1 05 O O O O make changes to
A O A ) O h ified
T 1 0 A O GO O O R O the magniiie
0 D O 1 O aohic. this shows
A 1 0 D 0 0 0 1 0 R O 5 O I O graphic, this shows
5 1 5 G O 0 o o O how the
Y 0 ) 0 1 0 5 1 0 O you how the
EEEEEEEEEEEEEEEEEEENEEE NN aphic wil
0 [ B EEOHEENREEE N EEEEN grapnic wi

— actually look.

Figure 6-47  Editing a graphic with FatBits turned on

You can use any of the Paint tools to modify the graphic—they
all work at the magnified scale.
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To see a different
section of the card,
press Option while

you drag the card

with the hand
pointer.

To see individual pixels, hold down the Caps Lock key. When
the Caps Lock key is up, you see colors more accurately; when
it's down, you see details more accurately and you can read Paint
text, which otherwise is not legible when FatBits is turned on.

If you want to edit a different part of the picture, press Option
and drag the magnified graphic with the hand pointer (£7):

- L As you drag the
) -. card with the
-H%EE&EEE%HE hand pointer,

My NN EEEEEEEERE G this window shows
E E EUEGENEEESEEEEGE you the actual-size
§ | pEmnasssssecescs e e o
EEH BRI of the card you're
B 1 O 0 0 0 O looking at
R E AP S ECIS R sidey o E gat.
RN MM M W SR
BTN W W W W N
DN R W o o o e
L T T T T
OO RO TR W MW W W W

Figure 6-48 Moving to a different section of the magnified picture

4. When you’re finished editing the graphic, turn off FatBits by

choosing it again from the Options menu.
You can also turn off FatBits by doing any of the following;

s Click in the little window that shows the actual-size version

of the graphic.
» Double-click the Pencil on the Tools palette.
m Press Option-E
»  With the Pencil selected, ¢ ~click on the magnified picture.

»  Choose the Browse tool (), the Button tool (=), or the
Field tool (£3) from the Tools menu.
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Changing the size o resize a graphic, follow these steps:

of a graphic :
SHAPHIC 1 Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.

2. Press the \  key while you drag from a corner or an edge of the
selected graphic to resize it:

PR —— . S P .
' 1 / P ' /
' 1 / | ' ¢
' [ / / ! !
! ! / / ' k
[ ! / t
. v ol /
1 / / ! /
: | ] ¢ / ' !
1 ] ! ? 1 ]
B B ' : : ! P
The original » ' ! : ‘
. 1
gr;[phlc - -- k- ' i
/ t '
! /
o o wmhe d
To resize it
proportionately,
press ¢ -Shift and To make it wider, narrower, taller, or
drag from a corner. shorter, press ~ and drag from an edge.

Figure 6-49 Resizing a graphic

& Can’t drag the graphic? 1f you think you’ve selected a graphic
but you can't drag it, you might be trying to resize a
background graphic from the card layer. Press 2-B and try
again. If you still can’t drag it, it’s either a button or a field.

(Chapters 4 and 5 explain how to move buttons and fields. €
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Changing the pattern or - There are three ways to change the pattern or color of a graphic:

color of a graphic . . o .
grap m  Use the Fill command to fill the graphic with a different pattern
or color.

s Use the Bucket to “pour” a different pattern or color into the

graphic.

= Use the Pickup command to give the graphic the same patterns
and colors as another graphic on the card.

Using the Fill command to change a graphic’s pattern or color

Using the Fill command is the most reliable way to change the
® pattern or color of an entire graphic. Follow these steps:

1. Select the graphic.
“Selecting a Graphic,” earlier in this chapter, gives instructions.
2. Choose the pattern or color you want from the Patterns menu.
Or click it on the Patterns palette.
3. Choose Fill from the Paint menu.

The selected graphic acquires the selected pattern or color.

ARARAARARARARS

......
------
......

The original 1. Select the 2. Choose a pattern 3. Choose Fill from
graphic graphic. or color. the Paint menu.

Figure 6-50  Assigning a new pattern or color to a graphic
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If you've just created a graphic element and you haven't clicked
anywhere, the Fill command works on the new element (that is, just
the element you’ve created since you last pressed the mouse button)
if you haven't selected anything else.

If the Power Keys option is turned on, you can press F instead of
choosing Fill. (“Using Power Keys,” later in this chapter, explains
the Power Keys option.)

Using the Bucket to change a graphic’s pattern or color

You can use the Bucket to change the pattern or color of a graphic.
However, this technique works best when you want to fill a solid
area of color with another color or a pattern. If you try to use this
technique to fill a patterned area with another pattern or a color, th
results will be unpredictable; the pattern might change in different
ways than you expect, or you may be able to change only a few
pixels at a time.

Important: Use the Bucket to change a graphic’s pattern or
color only if the graphic is a solid color or completely enclosed.
Otherwise, paint might spill out and fill the surrounding area. A

To change a graphic’s pattern or color with the Bucket, follow these
steps:

1. Go to the card or background that contains the graphic. ®

Pressing (3-B takes you to the background layer. (When you're
in the background layer, the word Background appears in the
menu bar.) If you press (i-B repeatedly, you move back and
forth between the card layer and the background layer.

2. Choose the pattern or color you want from the Patterns menu.

Or click it on the Patterns palette.
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3. Choose the Bucket (#) from the Tools menu.

Or click it on the Tools palette. The pointer changes to the
Bucket.

4. Move the Bucket so that the tip of the stream pouring from it
is within the graphic, then click:

l

If paint spills out into the surrounding area, immediately choose
Undo from the Edit menu, or press (3-Z, Tilde, Esc, or Delete.

5
This is the part of the /" ‘ﬂﬁﬁ

Bucket that dispenses paint.

Figure 6-51 Positioning the Bucket to fill a graphic

Using the Pickup command to change a graphic’s pattern or color

To give a graphic the same patterns and colors as another graphic on
the card, follow these steps:

1. Select the graphic.
“Selecting a Graphic,” carlier in this chapter, gives instructions.

2. Drag the selected graphic to the part of the card that has the

pattern or color you want to give the graphic.

See Figure 6-52.
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3. While the graphic is still selected, choose Pickup from the

Paint menu.

The selected graphic picks up the image of whatever Paint image
is behind it in the same layer, including any areas that are blank,
with no paint.

Leave the graphic selected. Don click outside the selection.

4. Drag the selected graphic away.

L Select the graphic 2. Move the selected 3. Choose Pickup 4. Drag the graphic

(its edges will graphic over the from the Paint away.
shimmer). pattern you want menu.
to give it.

|||||||""|. .I.ﬂ .I[""'

k!

Figure 6-52  Using the Pickup command to change a graphic’s pattern

< If it doesn’t work: 1f you've selected a graphic in the card layer &
and it doesn't acquire the pattern that’s behind it when you
choose Pickup (or if it disappears), the pattern is probably in the
background layer. A graphic can only pick up a pattern that’s in
the same layer. If there’s no pattern behind the graphic in the

*,

same layer, the graphic turns white. <
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It the Power Keys option is turned on, you can press P instead of
choosing Pickup. (“Using Power Keys,” later in this chapter,
explains the Power Keys option.)

!

Inverting a graphic  To reverse the colors of a graphic so that they become the inverse
video of the original colors—that is, so that black becomes white,
white becomes black, red becomes green, green becomes red, and
so on—follow these steps:

1. Select the graphic.
“Selecting a Graphic,” earlier in this chapter, gives instructions.

‘ 2. Choose Invert from the Paint menu.

!_-u_-l|_-n_'wu;|1.-u;tun;nqu;u;wuuu;u_'u_-ll

ittt it il

. Select the graphic. 2. Choose Invert from the Paint menu.

Figure 6-53  Inverting a graphic

If you’ve just created a graphic element and you haven't clicked

® anywhere, the Invert command works on the new element (that is,
just the element you've created since you last pressed the mouse
button) if you haven't selected anything else.

[f the Power Keys option is turned on, you can press I instead of
choosing Invert. (“Using Power Keys,” later in this chaprter explains
the Power Keys option.)
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Outlining a graphic

'lo oudine a graphic, follow these steps:
1. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.
2. Choose Trace Edges from the Paint menu.

An outline appears around the parts of the selected graphic that
were originally a solid color. Each time you choose Trace Edges,
another outline is added.

<« Note: If the graphic is mostly a solid color, the solid areas
turn white except for their edges. Each subsequent time
you choose Trace Edges, an outline is added around each

solid edge. < .
The original Trace Edges Trace Edges Trace Edges
graphic once twice three times

Figure 6-54 Repeated use of the Trace Edges command

If you've just created a graphic element and you haven't clicked
anywhere, the Trace Edges command works on the new element
(that is, just the element you’ve created since you last pressed the
mouse button) if you haven't selected anything else.

[f the Power Keys option is turned on, you can press E instead of
choosing Trace Edges. Pressing and holding E keeps adding
outlines. (“Using Power Keys,” later in this chapter, explains the
Power Keys option.)
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Rotating a graphic 90°

To rotate a graphic 90°, follow these steps:
1. Select the graphic.
“Selecting a Graphic,” earlier in this chapter, gives instructions.

2. Choose Rotate Left from the Paint menu to rotate the selected
graphic 90° to the left, or choose Rotate Right to rotate it 90°
to the right.

qu"
| hlllll Iv

I

Figure 6-56  Rotating a graphic to the right 90°
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[f you've just created a graphic clement and you haven't clicked
anywhere, the Rotate Left and Rotate Right commands work on the
new element (that is, just the element you’ve created since you last
pressed the mouse button) if you haven't selected anything else. -

If the Power Keys option is turned on, you can press [ (the left
bracket key) instead of choosing Rotate Left, or ] (the right bracket
key) instead of choosing Rotate Right. If you press and hold one of
these power keys, the graphic keeps rotating. (“Using Power Keys,”
later in this chapter, explains the Power Keys option.)

Flipping a graphic  To flip a graphic vertically or horizontally, follow these steps:

vertically or horizontally | ¢« 4 graphic

“Selecting a Graphic,” earlier in this chapter, gives instructions.

2. Choose Flip Vertical from the Paint menu to flip the selected
graphic vertically, or choose Flip Horizontal to flip it
horizontally.
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Figure 6-57  Flipping a graphic vertically

Figure 6-58  Flipping a graphic horizontally

[f you've just created a graphic element and you haven't clicked
anywhere, the Flip Vertical and Flip Horizontal commands work on
the new element (that is, just the element you've created since you
last pressed the mouse button) if you haven't selected anything else.

If the Power Keys option is turned on, you can type V instead of
choosing Flip Vertical, or type H instead of choosing Flip

O Horizontal. If you press and hold one of these power keys, the
graphic keeps flipping. (“Using Power Keys,” later in this chapter,

explains the Power Keys option.)
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W()rkmg W]th If your computer has close to the minimum amount of memory
int tools when you need to run Hypcr(hrd, you may find that Hypcr(:ard’?‘
: ~ Paint tools sometimes behave differently than you expect. (If you're
memory IS 1()W not sure how much memory is installed in your computer, see
“Checking Your Computer’s Memory” in Chapter 1.) This is most
likely to happen if your computer is part of an AppleShare network.
When you’re using any of the Paint tools, the following symptoms
indicate that HyperCard is running out of memory:

= Fields and buttons in the card layer disappear when you're using
the Paint tools in the card layer.

» Fields and buttons in the background layer disappear when
you're using the Paint tools in the background layer.

= You can't choose Undo from the Edit menu to undo any action,
that involve selecting a graphic first, such as filling, rotating, or
moving it. (Undo still works for other actions, such as drawing a
line or shape.)

s When you add or alter paint on a card or background and then
choose Keep from the Paint menu, switch to a different layer, go
to another card or background, or choose one of the General
tools, the changes you made disappear and the message “Failed
to save new picture” appears.

HyperCard’s use of memory depends on many factors, including

the number of desk accessories you have installed in your system,

the network software you’re using, and the complexity of the card

or stack you're currently working with. The symptoms listed abovdf)
may not occur consistently, since the total amount of memory
available for HyperCard’s use can vary from moment to moment.
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Using power keys

The best way to avoid low-memory conditions and to improve
HyperCard’s speed and general performance is to install additional
RAM in your computer. However, it may help to remove some of
the desk accessories you have installed in your system; avoid using
a RAM disk; and lower the RAM cache to 32K (or, if all else fails,
to 0K).

[f you can't obtain additional memory and you still want to use the
Paint tools, you can usually work around low-memory conditions

by following these guidelines:

= Work slowly and carefully. Remember that you can’t choose
Undo to undo individual actions that first involve selecting a

graphic.

= Ifyou need to correct a mistake, use the Revert command.
Choosing Revert from the Paint menu restores the version of the
graphics you had on the current card or background before you
last saved them (by using the Keep command, leaving the card,
or switching to or from the background layer.)

» Seeabo: e “HyperCard and Your Computer’s Memory” in Chapter 1
* “Reverting to the Last Version of a Graphic” in this chapter

The Power Keys option lets you use specific keys on the keyboard to
modify the selected graphic or turn options on and off—pressing a
single key does the work of choosing a menu command.

To turn on the Power Keys option, click the Power Keys check box
on the User Preferences card in the Home stack. (The Power Keys
option is available at the Painting level and higher user levels.) You
can also turn on Power Keys by choosing it from the Options
menu, which is visible whenever a Paint tool is selected.
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When Power Keys is turned on, a check mark appears nexe to it in
the menu. To turn off Power Keys, choose it again. You'll find
examples of the use of the power keys in earlier sections of this
chapter. All the power keys and their effects are shown in the
following table:

Command Power key Menu

Black pattern B Patterns

Draw Centered (on/off) C Options

Draw Multiple (on/off) M Options

Fill F Paint

Flip Horizontal H Paint

Flip Vertical \Y Paint .
Grid (on/off) G Options

Invert I Paint

Line Size 14, 6, 8* Options

Opaque ) Paint

Pickup P Paint

Revert R Paint

Rotate Left ( Paint

Rotate Right | Paint

Select S Paint

Select All A Paint

Trace Edges E Paint

Transparent T Paint

White pattern W Patterns .

*Press these keys to choose thinner or thicker line widths.

% Note: When you’re using the Paint Text tool, the power keys are
temporarily disabled. <
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Using moditier keys
with Paint tools

When you hold down modifier keys—Command, Shift, or

Option—while you drag with different Paint tools, you aleer

the effects of some of the tools, as shown in the following table.

Modificer key

Rounded Rectangle

Polygon

Oval

Regular Polygon

spray over

Reposition
rectangle

No effect

Reposition oval

Reposition polygon

Draw an approximate rounded square
(equal number of pixels on each side)

Draw at 15 angles

Draw an approximate circle
(equal number of pixels
vertically and horizontally)

Rotate m 157 increments

Tool Shift Option
Selection Select tightly Move selection horizontally or Select like Lasso
vertically™
Duplicate selection®
Lasso Lasso all adjacent Move selection horizontally or Duplicate selection®
dots of the same vertically*
color as the dot
. you click
Line No effect Draw at 15° angles No effect
Eraser Draw in white Erase straight horizontally or vertically No effect
Pencil Enter/leave FatBits ~ Draw straight horizontally or vertically No effect
Rectangle Reposition Draw an approximate square Patterned border
rectangle (equal number of pixels on each side)
Curve No effect No effect Patterned border
Brush Erase what you Paint straight horizontally or vertically No effect
paint over
Spray Lrase what you Spray straight horizontally or vertically No cffect

Patterned border

Patterned border

Patterned border

Paterned border

*These effects occur only when you drag a selected object or graphic with the tool.
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DOUble-Cthlng You can double-click certain Paint tools on the Tools palette (and
patterns on the Patterns palette) as a shortcut for choosing menu
commands. The following table shows the effects of double-clicking
Paint tools and the colors and patterns in the Patterns palette.

“Paint tools, patterns,
and colors

Double-click . . .
Any pattern

Any solid color

Brush
Bucket
Curve tool
Eraser

Lasso

Line tool

Oval tool

Paint Text tool

Pencil

Polygon tool

Regular Polygon tool
Rectangle tool

Rounded Rectangle tool

Selection tool
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To do this
Bring up Edit Pattern dialog box

Bring up Colors dialog box for
current card/background

Bring up Brush Shape dialog box
Hide/show Patterns menu

Turn on/off Draw Filled option

Erase entire picture ‘

Lasso every element on current

card/background

Bring up Line Size dialog box
Turn on/off Draw Filled option
Bring up Text Style dialog box
Turn on/off FatBits

Turn on/off Draw Filled option
Bring up Polygon Sides dialog box
Turn on/off Draw Filled option
Turn on/off Draw Filled option

Select entire picture




Saving the graphics
| on a card
- or background

Reverting to the last
version of a graphic

While you're working on the graphics on a particular card or
background, the changes you make to the graphics are stored in a
temporary location—they’re not automatically saved on your disk,
as are your other changes. (HyperCard assumes that you might
decide to throw away your graphics changes, so it doesnt save
them automatically along with everything else. This gives you the
freedom to experiment with the Paint tools and then get back your
original graphics.)

To save all the graphics on the current card or background, choose

Keep from the Paint menu (or press  -K).

There are two other ways to save all the graphics on the current card

or background:
s Switch to or from the background layer by pressing “-B.
s  Go to another card.

When you leave the card or switch to or from the background
layer, HyperCard saves the graphics on the card or background
you're leaving.

While you're working with graphics, you can get back the last saved
version of the graphics on the current card or background by
choosing Revert from the Paint menu. Choosing Revert restores the
version of the graphics you had on the current card or background
before you last saved them (by using the Keep command, leaving
the card, or switching to or from the background layer, as explained
in the preceding section, “Saving the Graphics on a Card or

Background”).

% Revert is different from Undo: Revert undoes all the changes
you’ve made to the graphics on the current card or background
since they were last saved, whereas Undo undoes only the most
recent unsaved change.

Chapter 6: Working With Graphics 323




You can also restore a portion of the last saved version of the picture
on the current card or background by selecting the part you want to
restore and choosing Revert. (“Selecting a Graphic,” earlier in this
chaprer, includes instructions for selecting part of a picture.)

The Revert command is most useful when you're creating graphics
in stages. Once you complete a stage and it’s just the way you want
it, you can “freeze” it with the Keep command. Then you can begin
work on the next stage, confident that your last stage is saved and
that you can start over from that point, if necessary.

If the Power Keys option is turned on (and the Message box is
hidden), you can press R instead of choosing Revert. (“Using Power
Keys,” earlier in this chapter, explains the Power Keys option.)

COPYlng d gr lehic This section explains how to duplicate a graphic on the same card

and how to copy a graphic to another card, background, or stack.

Copying a graphic = To make a copy of a graphic on the same card or background,
on the same card  follow these steps:

1. Go to the card or background that has the graphic you want
to duplicate.

Pressing ¢ {-B takes you to the background layer. (When you're

in the background layer, the word Background appears in the
menu bar.) If you press ($-B repeatedly, you move back and O
forth between the card layer and the background layer. If you
don’t see the graphic you want to copy while you're in the
background layer, the graphic is in the card layer.
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2. Select the graphic.
“Selecting a Graphic,” earlier in this chapter, gives instructions.

! 3. Position the pointer over the selected graphic so that it
becomes the arrow pointer.

4. Press and hold the Option key while you drag the selected
graphic.

As you drag, you create an exact duplicate of the graphic. To
move the copy straight horizontally or vertically, press and hold
Shift while you drag,

+ Can't drag the graphic? 1f you think you've selected a graphic
o but you can’t drag it, you might be trying to duplicate a
background graphic from the card layer. Press ©“-B and
try again. If you still can't drag it, it’s either a button or a
field. (Chapters 4 and 5 explain how to move buttons and
fields.) «

Copying a graphic ~ To copy a graphic to a different card or background, follow
to another card or  these steps:

background 1. Go to the card or background that has the graphic you want
to copy.

Pressing (i-B takes you to the background layer. (When you’re
in the background layer, the word Background appears in the

O menu bar.) If you press (I-B repeatedly, you move back and
forth between the card layer and the background layer. If you
don't see the graphic you want while you’re in the background
layer, the graphic is in the card layer.

2. Select the graphic.

“Selecting a Graphic,” earlier in this chapter, gives instructions.
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3. Choose Copy Picture from the Edit menu, or press . -C.
This puts a copy of the selected graphic on the Clipboard.

4. Go to the card or background where you want to put the
graphic.

Use the arrow keys, the Go palette, or commands in the Go
menu to navigate between cards while the Selection tool or the
Lasso is selected.

If you’re not sure whether to put the graphic in the card layer
or the background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter.

5. Choose Paste Picture from the Edit menu, or press G-V ®
This takes a copy of the graphic that’s on the Clipboard, puts it

on the current card or background, and selects it.

The graphic is pasted in the same position it was copied from. If
there’s a button or field in the same location, the pasted graphic
will be hidden behind it (as explained in “When Elements
Overlap,” earlier in this chapter). You might have to move the
button or field to see the graphic.

6. If you want to reposition the graphic, drag it to where you
want it while it’s still selected.

The graphic becomes opaque after you paste it. If you want to be
able to see through the graphic to the elements behind it, select it ‘

and choose Transparent from the Paint menu.

Important: The most common mistake in copying a graphic is
putting it in the card layer when you want it in the background
layer. (To find out whether the graphic is in the background layer,
press I-B to see just the background elements.) If you put a graphic
in the card layer by mistake, see the next section, “Moving a
Graphic from the Card to the Background.” A
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MOVing d gr dpth It’s easy to put a graphic in the card layer by mistake when you
from the card to ntendto putitin the background. If this happens, you can move
‘ ¢ the graphic from the card layer to the background layer (of the same

the baCkgf ound card) by following these steps:
1. Go to the card that has the graphic you want to move.

You must be in the card layer to move a card graphic. (If you see
the word Background in the menu bar, you’re in the background
layer. Press (5-B to go to the card layer.)

2. Select the graphic.
“Selecting a Graphic,” earlier in this chapter, gives instructions.
. 3. Choose Cut Picture from the Edit menu, or press - -X.

This removes the graphic from the card and puts it on the
Clipboard.

4. Go to the background layer.
Choose Background from the Edit menu, or press “-B.
5. Choose Paste Picture from the Edit menu, or press _-V.

This takes a copy of the graphic that’s on the Clipboard, puts it

in the current background, and selects it.

The graphic is pasted in the same position it was copied from. If
there’s a button or field in the same location on the background
layer, the pasted graphic will be hidden behind it (as explained in

. “When Elements Overlap,” earlier in this chapter). You might
have to move the button or field to see the graphic.

6. If you want to reposition the graphic, drag it to where you
want it while it’s still selected.
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M’OVing d graphic To move a graphic to a different card or background, follow
to another card  these steps:
or background 1. Go to the card or background that has the graphic you want

to move.

Pressing ( -B takes you to the background layer. (When you’re
in the background layer, the word Background appears in the
menu bar.) If you press | “-B repeatedly, you move back and
forth between the card layer and the background layer. If you
don’t see the graphic you want while you’re in the background
layer, the graphic is in the card layer.

2. Select the graphic.
“Selecting a Graphic,” earlier in this chapter, gives instructions.@)
3. Choose Cut Picture from the Edit menu, or press (-X.

This removes the graphic from the card and puts it on the

Clipboard.
4. Go to the card or background where you want to put the
graphic.

Use the arrow keys, the Go palette, or commands in the Go
menu to navigate between cards while the Selection tool or the
Lasso is selected.

If you're not sure whether to put the graphic in the card layer
or the background layer, see “Adding Graphics to a Card or
Background” at the beginning of this chapter. S

5. Choose Paste Picture from the Edit menu, or press -V.

This takes a copy of the graphic that’s on the Clipboard, puts it

on the current card or background, and selects it.
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Importing a graphic

"The graphic is pasted in the same position it was copied from. If
there’s a button or field in the same location, the pasted graphic
will be hidden behind it (as explained in “When Elements
Overlap,” earlier in this chapter). You might have to move the
button or field to see the graphic.

6. If you want to reposition the graphic, drag it to where you
want it while it’s still selected.

The graphic becomes opaque after you paste it. If you want to be
able to see through the graphic to the elements behind it, select it
and choose Transparent from the Paint menu.

Important: The most common mistake in moving a graphic is
putting it in the card layer when you want it in the background
layer. (To find out whether the graphic is in the background layer,
press . '-B to see just the background elements.) If you put a graphic
in the card layer by mistake, see “Moving a Graphic from the Card
to the Background,” earlier in this chapter. A

There are many products you can use to create pictures that are
compatible with the Apple Preferred File Format. Some products let
you create pictures in this standard Apple IIGs format from scratch;
others let you digitize images using a scanner attached directly to
your Apple IIGs. However you create it, you can bring any picture
in the Apple Preferred File Format into HyperCard by following
these steps:

1. Make sure you have one of the Paint tools selected.
2. Choose Import Paint from the File menu.

A directory dialog box appears.
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Exporting a
snapshot of a card
or background

3. Use the directory dialog box to locate and open the file
containing the picture you want to import.

HyperCard pastes the imported picture onto the current card or
background, starting with the upper-left corner of the imported
picture.

< Preparing to import a picture: Before you import a picture,
make sure the part of the picture you want to paste is in the
document’s upper-left corner; or make sure the picture is small
enough to fit on a HyperCard card, including any blank space
that’s in the upper-left corner of the picture. <

Once you've imported a picture, you can work with it just as if

you’d created it in HyperCard. @

When you import a picture into HyperCard, you also import the
color set used by the original document. The imported color set
becomes the sixth color set in the Colors dialog box for the current
card (or the current background, if you're working in the
background layer).

» Seealso: “Importing a New Color Set for a Card or Background” in
this chapter

You can take a snapshot of the current card or background and save
it as a document in the Apple Preferred File Format by using the
Export Paint command in the File menu. (This command is ®
available only when a Paint tool is selected.) Follow these steps:

1. Choose Export Paint from the File menu.
A directory dialog box for saving a file appears.

2. Use the directory dialog box to specify where you want the
Apple Preferred File Format document saved and type a name

for the file.
3. Click OK.

Chapter 6: Working With Graphics




Creating a miniature
picture of a card

Export Paint creates a document in the Apple Preferred File Format
that contains the image of the current card and background (and all
their elements) and saves it on a disk under the name you give it.

The image of the full-sized card gets saved, even if you're using
FatBits.

If you're in the background layer, HyperCard saves only the image
of the background.

HyperCard exports only a picture of the card and background
information. The saved picture has none of the functional attributes
of the card—for example, the scripts aren’t saved with the picture. If
you have a palette, the Message box, or the FatBits window open on
the screen, their images aren’t included with the exported picture.

You can create a miniature picture of a card, like the miniatures you
see when you choose Recent from the Go menu. Follow these steps:

1. Go to the card you want a miniature picture of.
2. Choose Copy Card from the Edit menu.

3. Go to the card or background where you want to put the
miniature picture.

4. Press and hold the Shift key while you choose Paste Card from
the Edit menu.

Or press (-Shift-V.
The miniature appears selected in the center of the card window.

Note that this is just a picture of a card—none of the normal card
attributes or scripts from the original card are pasted with the
miniature.
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Deletlﬂg d gl‘aphic 1o delete a graphic, you can use any of the following techniques:

= To delete a new graphic just after you add it (before you click
anywhere else), press the Delete key or choose Clear Picture
from the Edit menu. This is not reversible; you can't bring back
a graphic that was deleted immediately after it was added.

s To delete any graphic, first select it (by using one of the
techniques described in “Selecting a Graphic,” earlier in this
chapter). Then press the Delete key or choose Clear Picture
from the Edit menu. If you delete a selected graphic by mistake,
you can bring it back by immediately choosing Undo from the
Edit menu or pressing (3-Z, Tilde, Esc, or Delete.

= To erase any graphic, choose the Eraser () from the Tools .
menu and drag over the graphic. (To erase a background
graphic, you must be working in the background layer. To erase
a card graphic, you have to be in the card layer.) To erase in a
straight horizontal or vertical line, press Shift while you drag. To
erase in white paint, press the . * key while you drag.

s The background revealed: 1f you see a picture appearing under
the Eraser as you drag it over a card picture, you're exposing
part of the background that was covered by an opaque card
picture. If you don’t want the background elements to show,
you can cover them by pressing the (* key as you drag with
the Eraser. (This “erases” with white paint.) Of course, you
can go to the background layer and delete the elements, but
first check to make sure they aren’t needed on the other card.
that share the background. <

= 10 erase the entire picture on the current card or background,
double-click the Eraser on the Tools palette. This wipes out
the picture on the current card or background, then selects the
tool you were using just before you double-clicked the Eraser.
This technique is useful for cleaning up your screen after you've
been experimenting with the Paint tools. (If you double-click
the Eraser by accident, choose Undo from the Edit menu
immediately, or press  -Z, Tilde, or Esc.)
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Printing

T)is chapter explains how to print the information in a stack. You
can print a single card, a range of cards, an entire stack, or a report
that displays the contents of specific background fields. You can also
create different templates for a stack and export templates from one
stack to another.

If you're familiar with HyperTalk, you have even more printing
options—for example, you can print the contents of a specific field
or a document from another application. 'T'he Hyperlalk Help
stack describes these options. (They aren’t covered in this chapter.)

To do all the tasks in this chapter, you must have your user level set
at least to Authoring. However, you can print cards, stacks, and
reports no matter what your user level s set to, as long as you don'’t
need to create or change any templates. (For instructions on setting
your user level, see “User Levels and Options” in Chapter 1.)




Pl‘@p’dl‘lng (O pl’mt Betore printing with HyperCard, you must have the appropriate
printer driver for your printer in the Drivers folder, which in turn
must be in your System folder when you start your computer. You
must also make sure your printer port and driver are correctly
configured in the Control Panel desk accessory. The documentation
that came with your computer describes how to install printer
drivers and how to use the Control Panel.

Once you have the appropriate printer driver installed and the
printer selected, you can give HyperCard information about your
paper and printing preferences before you print by using the Page
Setup command.

+ Note: You don't need to use the Page Setup command each
time you print. If the settings in the Page Setup dialog box o
reflect your paper size and printing preferences, you don't need
to use the Page Setup command until you want to change
the settings. <

To change the settings in the Page Setup dialog box, follow these
steps:
1. Make sure you have one of the General tools selected.

The Browse tool (%), the Button tool (=), or the Field tool (CJ)

will work.
2. Choose Page Setup from the File menu.

I'he Page Setup dialog box appears. The options in this dialog
box vary, depending on the kind of printer and the version of
system software you have.
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Print horizontally.
Print vertically.
This is a fine-tuning option that can

make some text and hit-mapped
graphics look better.

Select this option to substitute Times
for New York, Helvetica for Geneva,
Courier for Monaco, and a special
form of Helvetica for Shaston.

Select this option to make the
top margin of your printout as
small as possible.

This option has no effect on
the way HyperCard prints.

Print vertically.

3. Select the options you want in the Page Setup dialog box:

Laserlriter vi.0

Paper: @ US Letter (O AY Letter |

(OUS Legal OBS Letter |

Orientation: Vertical Sizing:
e @ Normal _]
(O Intermediate
(O Condensed

Printer Effects:

trlorge, [

Smoothing?

<] Font Substitution? ) i
()

Imageblriter/Printer vi.0

Paper Type: | USLetter... 8.5"xI1"

Reduction: | Full Size

—~
[ No Vertical Gaps

Height:
[JVertical Condense
Orientation:
_. Cancel
S— (
Figure 7-1

4. Click OK.

Click the option that describes
the size of your paper.

These options have no effect
on the way HyperCard prints.

Type a percentage here to
reduce or enlarge the entire
image on each page.

Press and hold the mouse
button here to see the
Paper Type pop-up menu.
Drag to choose the option
that describes the size of

your paper.

Print horizontally.

Selecting options in the Page Setup dialog box

The options you select in the Page Setup dialog box are saved
with the current stack (unless the stack is locked). They're in
effect when you print the stack (or any part of it) using the
Print command.
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Printing a single card

330

Printing the cards
in a stack

& Ifthe stack is locked: Changes you make in the Page Setup
dialog box for a locked stack will not be saved after you leave
the stack, and may not remain in effect for the entire time
you're working in the stack. <

You can change the Page Setup settings at any time by repeating this
procedure.

To print a single card in a stack, follow these steps:
1. Go to the card you want to print.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (£2)
will work.

3. Choose Print Card from the File menu, or press '-I.
HyperCard prints the current card.

HyperCard allows you to prepare card templates that allow you to
print out all the cards or a range of cards in the current stack in a
variety of ways. You can create and save up to 32 templates for a
stack (including both card templates and report templates). For
example, you could create one card template that prints out the

cards at full size, just the way they appear on the screen, and anoth’
that prints eight reduced card images on a page—both for the same
stack. You can also export card templates from one stack to another.
For more information about templates, see “Creating Templates,”
later in this chapter.
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To print all the cards or a range of cards in the current stack, follow
these steps:

1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool ()
will work.

2. Choose Print from the File menu.
The Print Stack dialog box appears.

3. If a card template is not already selected, select one in the Print

dialog box:

Print... - =
o (options... ) (“Cancel ) (_Print ) Before you can
—— print the cards in

the current stack,
you must select a
template with this
icon. To select a
\ template, click it.

Select o template:
== Labels 3 by 7
== Report

=

Figure 7-2  Selecting a card template

If you want to create your own card template now, click Cancel
and go to the section “Creating a Card Template,” later in this
chapter. If you want to print a report that displays the contents
of specific background fields, click Cancel and go to the next
section, “Printing a Report.”
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4. Press and hold the mouse button over the pop-up Templates
menu and choose Edit Template.

You can also double-click the name of the template or press
Enter to edit it. The Template dialog box appears.

< Ifyou can’t see the pop-up Templates menu: The pop-up
Templates menu appears only if your user level is set to
Authoring (4) or higher. If you can't see it, you must either
click Cancel and change your user level, or skip to step 7.
(For instructions on setting your user level, see “User Levels
and Options” in Chapter 1.)

5. To print all the cards in the stack, click All.
Or, to print only a specific range of cards, click From and typ)

the range of cards you want to print.

To print all the o TR BT :
cards in the stack, enplate "lntitled (
click here. . | N
Cards: @ARll
. From: :
To print a range o [ -
of cards, click here Layout: | Spread out 1
and type in the <] Card Names
card numbers for the Scaling: [ Full sizecards )
range of cards you Order:
want o print. |} 4——— brog scale
( Header... ) ( Footer... ) |@Fi91d5 B Pictures |

Figure 7-3  Indicating which cards you want to print ‘

6. Click OK, or press Return or Enter.

The Template dialog box disappears, and you see the Print
dialog box again.
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7. If you want to adjust any of the standard print options, click
Options.

The standard Options dialog box for your printer appears. The
options in this dialog box vary, depending on what kind of
printer and which version of system software you have. These
options are described in the documentation that came with
your computer.

LaserWriter vi.0
Pages: @l

() From: D To: I—_—]
Copies:

Paper Source:

@ Paper Tray
(O Manual Feed

ImageWriter/AppleTalk vi.0

Copies: IE

Pages: @Al O Range
From
To

Quality:

Chroma: Black/White

Sheet Feed: | ﬂutomatich
€K )

Figure 7-4  Examples of the Options dialog box for different printers

8. Select the options you want in the Options dialog box and
click OK.

The Options dialog box disappears, and you see the Print dialog

box again.
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Printing a report

9. Click Print.

HyperCard prints the cards in the current stack according to the
settings in the Page Setup dialog box, the Template dialog box
for the template selected in the Print dialog box, and the
Options dialog box for your printer.

HyperCard allows you to prepare custom report templates that
display a background’s field text and card pictures in any way you
like. You can create and save up to 32 templates for a stack
(including both card templates and report templates). For example,
you can create a table-style report template, a template for printin
the results of calculations, and a template for printing labels—all
the same stack. You can also export report templates from one stack

to another.

You can control the appearance and placement of each elementin a
report template—including the font, size, and style of the text. You
can also insert pictures into a report. For more information about
templates, see “Creating Templates,” later in this chapter.

To print a report from the current stack, follow these steps:
1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool ()
will work.

2. Choose Print from the File menu. ®
The Print dialog box appears.
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3. If you've created a report template you want to use, select it in

the Print dialog box:
Print... (0ptions.. ) (_Cancel ) (( Print )
} ’ | Templates .
‘ i] Select a template:

== Labels 3 by 7

= Untitled

Before you can print a
report, you must select a
. template with this icon. To
select a template, click it.

Figure 7-5  Selecting a report template

If you want to create your own report template now, click
Cancel and go to the section “Creating a Report Template,” later
in this chapter.

4. Press and hold the mouse button over the pop-up Templates
menu and choose Edit Template.

You can also double-click the name of the template or press
Enter to edit it. The Template dialog box appears.

[ < If you can’t see the pop-up Templates menu: The pop-up
Templates menu appears only if your user level is set to
Authoring (4) or higher. If you can't see it, you must either
click Cancel and change your user level, or skip to step 7.
(For instructions on setting your user level, see “User Levels

and Options” in Chapter 1.)
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Do

Only cards with the
selected background will
be included in the report.

It a background has no
name, its I[D number

appears in this list instead.

5. To print a report based on all the cards in the stack with the
selected background, click All.

Or, to print only a range of cards with the selected background,
click From and type in the range of cards you want.

To print a report based on all the cards with the

selected background, click here.

== Template "Report”

| |

\mncel J( )
Cards: @ A1l

C:)&nn [:' To: I !

Select a background:

Info Cards

To print a report
based on a range
of cards with the
selected background,
click here and type in

the card numbers fo.
the range of cards

you want to print.

Introduction
Bk #3690
Bk #5602

( Content... )

Footer...

Figure 7-6  Indicating which cards you want to print

6. Click OK.

The Template dialog box disappears, and you see the Print
dialog box again.

7. If you want to adjust any of the standard print options, click
Options.

The standard Options dialog box for your printer appears (as
shown in Figure 7-4). The options in this dialog box vary, ®
depending on what kind of printer and which version of system
software you have. These options are described in the
documentation that came with your computer.
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®cating templates

@:cating a card template

8. Select the options you want in the Options dialog box and
click OK.

The Options dialog box disappears, and you see the Print dialog

box again.
9. Click Print.

HyperCard prints information from cards in the current stack
according to the settings in the Page Setup dialog box, the Template
dialog box for the template selected in the Print dialog box, and the
Options dialog box for your printer.

You can create two types of templates for printing the information
in a stack: card templates, which print some or all of the cards in a
stack as they appear on the screen; and repors templates, which print
reports that display a background’s field text and card pictures. If
you want to create a template for printing the cards in a stack,
follow the instructions in the next section, “Creating a Card
Template.” If you want to create a template for printing a report,
follow the instructions in the section “Creating a Report Template,”
later in this chapter.

You can create and save up to 32 templates (including both card
templates and report templates) for a stack.

1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (<), or the Field tool (=)
will work.

2. Choose Print from the File menu.

The Print dialog box appears.
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3. Choose New Template from the pop-up Templates menu:

Print... (Coptions... ) (_Concel ) ([ Print_))

Press and hold the

Edit Template...

i

mouse button here . . .

.and drag down to

Export...
Rename...

Duplicate A

&

Delete...

choose New Template.

Figure 7-7 Creating a new card template

A dialog box for naming the template appears. ®

4. Type a name for the new card template:

New template... ( Cancel )lﬂ 0K D

Current name:  Untitled

New name: |Uﬂﬂﬂm T

Template style: (@ =P Cards

(O == Report

Figure 7-8  Naming a new card template

5. Click OK.

Type a name for your new
card template here.

The default setting for the
template’s style is Cards.

You see the Print dialog box again. The name of your new
template appears in the list of templates and is selected.

6. Press and hold the mouse button over the Templates pop-up

menu and choose Edit Template.

You can also double-click the name of the new template or press
Enter to edit it. The Template dialog box appears.
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If you don't want your template
to print all the cards in the stack,
click this button and enter a
range of cards.

Press and hold the mouse
button here to see a pop-up
menu for choosing the size of
the printed cards.

Press and hold the mouse
button here to see a pop-up
menu for choosing the order in
which successive cards will
appear on the page.

7. Select the options you want in the Template dialog box:

This shows you the layout of the printed page.

=P Template|"My Card Template"

I

((Cancel J(C ok )

Cards: @ A11

Ofron: [ Jre[]

Layout: [ Spread out §

\ Card Names
Scaling: | Full sizecards

Order:

((Header... )

( Footer... )

Gray scale: . ’

Fields B Pictures

When you're printing in black and white with zll
LaserWriter or ImageWriter, these options allow you to
print field text or pictures using a gray scale. If you are
using an ImageWriter for which Chroma is set to Color in
the Options dialog box (see Figure 7-4), these options
allow you to print field text or pictures in color.

Figure 7-9  The Template dialog box for a card template

Press and hold the
mouse button here to
see a pop-up menu that
lets you adjust the space
between the cards on a
page. “Spread out”
leaves space between
each card. “Adjacent”
butts each card up
against the next. "One
card per page” prints
one card per page, no
matter what size you've
chosen for the cards.

8. To adjust the header for your card template, click Header in
the Template dialog box.

The Header dialog box appears. Even if you don't plan to use a
header, you may want to use this dialog box to eliminate the
space the header would normally occupy, so that printing can
start as high as possible on each page. (If you don't want to
adjust the header, go to step 11.)
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Press and hold the mouse
button here to see a pop-up
menu for inserting the date,
time, page number, or stack

name into the header
automatically.

If the header contains a
graphic, it appears here and
prints out just below the
header’s text.

9. Specify the header you want:

To prevent the header from occupying any space
at the top of each page, click here to deselect the

Show Header option.

= Header of template "|ly Card Template (Toncel ) k)
(53] Show Header
I ! To add
(P—umj text to the
header,
type here.
=
To paste a graphic into the Drag from this corner to .
header, click this button. (The adjust the height of the
button is active only when the portion of the header that
Clipboard contains a graphic.) contains a graphic.
Figure 7-10  The Header dialog box

To reposition a graphic after you’ve pasted it into the header,
drag with the crosshair pointer to select the graphic, then drag
with the arrow pointer to move it. (Hold down the Shift key
while you drag to move the graphic one pixel at a time.) To
duplicate the currently selected graphic, hold down the Option
key while you drag the graphic.

. Click OK. .

The Header dialog box disappears, and you see the Template
dialog box again. (To return immediately to the Print dialog box
without seeing the Template dialog box, hold down the Option
key while you click OK or Cancel.)
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To paste a graphic into the
footer, click this button. (The
button is active only when the
Clipboard contains a graphic.)

If the footer contains a graphic,
it appears here and prints out
just above the footer's text.

To add text o the
footer, type here.

11. If you want to add a footer to your card template, click Footer

in the Template dialog box.

The dialog box for the footer appears. (If you don’t want to add
a footer, go to step 14.)

12. Specify the footer you want:

To make the footer show up in the printout,
click here to select the Show Footer option.

( Paste Picture ) [1Show Footer

=¥ Footer of template "Mjy Card Template" LCuncel j (( K )]

[&]

/

Text Insert

= |

Press and hold the mouse button here  Drag from this corner

to see a pop-up menu for inserting to adjust the height of the

the date, time, page number, or stack  portion of the footer that

name into the footer automatically. contains a graphic.
Figure 7-11  The Footer dialog box

13.

To reposition a graphic after you've pasted it into the footer, drag
with the crosshair pointer to select the graphic, then drag with
the arrow pointer to move it. (Hold down the Shift key while
you drag to move the graphic one pixel at a time.) To duplicate
the currently selected graphic, hold down the Option key while

you drag the graphic.
Click OK.

The dialog box for the footer disappears, and you see the
Template dialog box again. (To return immediately to the Print
dialog box without secing the Template dialog box, hold down
the Option key while you click OK or Cancel.)
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14. In the Template dialog box, click OK.

The Template dialog box disappears, and you see the Print
dialog box again. Your new template is now saved with the stack.

15. If you want to print the stack now (using the current
template), click Print in the Print dialog box.

Otherwise, click Cancel in the Print dialog box.

HyperCard prints the cards in the current stack (either all the
cards or just the range of cards specified in the Template dialog
box) according to the settings in the Page Setup dialog box, the
Options dialog box for your printer, and the Template, Header,
and Footer dialog boxes for your new card template. o

Creating a report templzlte 1. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (&)
will work.

2. Choose Print from the File menu.
The Print dialog box appears.

3. Choose New Template from the pop-up Templates menu:

Print... (ontions... ) ( Cancel ) ([ Print )
: ! Templates Press and hold the

Edit Template... mouse button here . . . .
New Template... ifi ... and drag down to
Duplicate k!H choose New Template.
Export...
Rename... iy
Delete...

Figure 7-12  Creating a4 new report template

A dialog box for naming the template appears.

348 Chapter 7: Printing
| 8




This shows you the layout
of the printed page.

4. Type a name for the new report template and select the

Report style:

New template...

Clancel ) ok )

Current name:  Untitled

Type a name for your new

New name: |[Immm :

Template style: (@ =P Cards
(== Report

report template here . . .

... then click here to select

the Report template style.

Figure 7-13  Naming a new report template

5. Click OK.

You see the Print dialog box again. Your new template appears in
the list of templates and is selected.

6. Press and hold the mouse button over the Templates pop-up
menu and choose Edit Template.

You can also double-click the name of the new template or press

Enter to edit it. The Template dialog box appears.

7. In the Template dialog box, select the background on which

you want to base your report.

=== Template "My Report Template"

( Footer.. )

( Cancel ) ((

If the background on

0K )

Cards: @ A1l
Otron: e[

Select a background:

which you want to
base your report is not
already selected, click
its name or ID in this

Info Cards

Bk #3690
Bk #5602

Introduction

list to select it. (If a
background has no
name, its ID number

appears here instead.)

Figure 7-14

The Template dialog box for a report template

Only information from cards with the selected background will

print.
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This represents the area
reserved for a cell (the

information from one card).

The spaces to the right of and _I

below the cell indicate the
amount of space between cells.

These measurements reflect the
size and positioning of the cell.

350

8. Click Content, or press Enter.

The Content dialog box for the report template appears:

The spaces to the left of and above the cell indicate the left
and top margins for the body of your report. The top margin
is measured from the bottom of the header.
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(Cancel J{ 0K )

(Preview... ) { Bdjust.. )

Picture & Bkgnd fields:
1 Picture Insert 4
Name
Notes

: : - Spacing:-
4k 0.95 4 3.2y P 0.25 ‘
& 058 £ 11 & 028

Y s §i ae
Arrange: [ Left toright § Dimensions: [ inches § {7 Show Fiedd Rome

This area lists the picture insert and background
fields that are available for the background selected
in the Template dialog box. The picture insert
consists of the card picture,

Figure 7-15  The Content dialog box

This dialog box allows you to specify what text you want in your
report by adding report items to a report cell. You can also add a
report item called a picture insert that consists of the card picture.
The report items you specify will print for each card.
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9. Set up the layout for the cells in your report:

When you move the pointer over
the cell’s lower-right corner or its
bottom or right edge, it becomes a
double-headed arrow. To adjust the
size of the cell in any direction, drag

(Concel )@ o0k )

(Preview... ) ( fdjust... )

Picture & Bkgnd fields:

from the corner with this arrow. ;N e ir
T . . . £ Name

) > size of the ce :
[0 adjust the size of the cell only Bbain £ Notes

vertically or horizontally, drag ’ iyt

Any changes you make to the b 09 b 32 P02
margins, size, and spacing of the cell v 03 v 173 > 028
are reflected here. You can also click Arrange: [_Left toright § Dimensions: [ inches k
the arrows to make fine adjustments.

from its bottom or right edge. F'Mm‘gin: “““““ Sm — Spucmg

Press and hold the mouse Press and hold the mouse
. button here to see a menu for button here to see a menu

choosing the order in which the for choosing the units of

report will print successive cards. measurement for the

You can also choose Full Width to dimensions given above,

extend the cell across the entire page.

When you move the pointer over this
line, it becomes a double-headed

arrow. Drag with this arrow to adjust
the vertical space between each cell.

= Content of template "My | When you move the pointer over this
line, it becomes a double-headed arrow.
Drag with this arrow to adjust the
horizontal space between each cell.

=== Content of template "Myl When you move the pointer over the

s top edge of the cell) it becomes a four-
headed arrow. Drag with this arrow to
adjust the left and top margins of the
body of your report.

Figure 7-16  Adjusting the size, spacing, and margins for the cells in a report
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If the lower-right corner of the cell coincides with the
intersection of the two lines that control the spacing between
cells, you can adjust one of those lines rather than the cell itself
by holding down the (! key while you drag from the corner.

10. Drag the picture insert or background field you want to
display in your report into position:

Press and hold the mouse button over the
picture insert or background field in this list
that you want to add to your report . . .

Content of template "My Report Template" ( Cancel ) [( 0K ])

.and drag it into position
inside the cell. To move the item
around after you've released the

mouse button, drag it from its
center. Hold down the Shift key
while you drag to align the
item to an invisible grid.

(Preview... )|( &djust. )

, Picture & Blegnd fields:
3 Picture Insert

b 065 b 730 4 035
& 080 & 34 & 033

frrange: [ Left toright | Dimensions: [ inches J {3 Show field Rome

Figure 7-17  Dragging a picture or background field into position

A small rectangle appears in the place where you release the
mouse button. This rectangle represents one item in your

report. A rectangle filled with a diagonal pattern represents a
picture insert, which consists of the portion of the card picture.
(starting at the upper-right corner of the card) that will fit in the
rectangle. A rectangle filled with a crosshatch pattern represents

a background field.

(S
A
o
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To resize an item within a
cell, drag the item from its
lower-right corner . . .

-or double-click the item

to see a window like this.
You can then drag the lower-
right corner of the window
to resize the item.

11. Adjust the size of the item as necessary:

To close the Adjust window,
click here or click anywhere
outside the window.

To move the Adjust
window, drag it from here.

=== Content of templutﬂhu Report Template"

( Concet JE o )

=l:l Picture Insert

%

Lo2ap

i “M“
i

(Preview.. ) ( Rdjust.. =

Picture & Bkgnd fields:
2 Picture Insert
Name
Notes

1

e G187 o

---------- Margin: - w §PACING:
4p 0.65 @ 7 30 <1t> 0.3
S 080 S 3ul 0.33

frronge: | Left 1o right |

Bimensions: § 1o

y {73 Shows f1etd Nome

l(,

Figure 7-18  Adjusting the size of a rep

ort item

You can
also open
the Adjust
window by
clicking the
Adjust
button or
pressing
Enter while
the item is
selected.

If the lower—right corner of an item coincides with the lower-
right corner of the cell, you can adjust the item rather than the

cell by holding down the

key while you drag from the corner.

[f the item is a picture insert, the pointer turns into a hand when
it’s over the Adjust window. To bring the desired portion of the
card picture into view, drag with the hand.

To make the size box in the lower-right corner of the Adjust
window disappear temporarily (so you can see whatever it’s
covering), press and hold the mouse button. This works for both

picture inserts and text items.

To save your changes and return immediately to the Print dialog
box, hold down the Option key and press Return. This works

whether or not the Adjust window is open.
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12. If the item represents a background field and you want your
report to display its text in a format that’s different from
the text format used in the stack itself, choose Other from the
pop-up Font menu:

If the item whose text format you want to change is
not selected, click it to select it.

== Content of template "My Report

Template” (Concel J_0K )
Preview... ) ( Adjust... )
Picture & Bkgnd fields:

Size: o Spaging: e
Then press and hold the & 065 db 730 035
mouse button here . . . = 080 T 3 s 033

firrange: | Left toright § Dimensions:

. and drag to choose Other from the pop-up menu.
(If you choose Field Font, the item will appear in your
report in the same text format selected for the field in
the stack itself.)

Figure 7-19  Changing the text format for a report item

The Text Style dialog box appears. (If the Font menu is dimmed,
click the item to select it. The Font menu is active only when an

item representing a background field is selected.) ®
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13. Specify a text format for the item:

Click to select a

Click the font font size
you want to (measured in
N select it points).
Click to select or deselect one
or more text styles. (Select To use a font size not
nothing for plain text.) The D%“i:f "1 [Tourier 'm) listed, type it t here. (If you
sample text at the bottom of 0 I:mc Geneva. — use a size that's different
the dialog box shows the | £ inder ] ine Hef"ef“‘“ t_lom the sizes listed above
cllectof the selected styles, 1 0utline Tines for ['h'c font, ”.1%' [CX} imuy
1 Shadow Venice o Sm = look rough or jagged.)
Press and hold the mouse [(MlignLert_§ [® Click the color you
button here to see a pop-up want to use for text in
menu for choosing the The quick brown fox jumps over the lazy dog. the report item.
alignment for text in the

. report item.

This shows what the text will look like.
Figure 7-20  Specifying the text format for a report item
14. Click OK.

You return to the Content dialog box.

15. Repeat steps 10 through 14 if you want to add more items to
your report.
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16. Click Preview.

The Preview dialog box appears:

Click these buttons to preview the report cell
for the previous or next card in the report.

Click Done
when you're
finished.

il

|'§f|||
f Born in 1774, died in 1845. Plonted a lot
of apple trees.

Loy o thaemer
-

Figure 7-21  The Preview dialog box

17. When you’re finished looking at the preview, click Done to
return to the Content dialog box.

If you're not satisfied with the layout of the report cell, adjust the
report items as necessary in the Content dialog box. (To save
your changes and return immediately to the Print dialog box
from the Preview dialog box, hold down the Option key and

press Return or Enter.)

18. When you’re satisfied with the layout of your report items in
the Content dialog box, click OK. ®
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19. To adjust the header for your report template, click Header in
the Template dialog box.

The Header dialog box appears. Even if you don't plan to use a
header, you may want to use this dialog box to eliminate the
space the header would normally occupy, so that printing can
start as high as possible on each page. (If you don’t want to
adjust the header, go to step 22.)

20. Specify the header you want:
1o prevent the header from occupying any space

at the top of each page, click here to deselect the
Show Header option.

‘ Press and hold the mouse
button here to see a pop-up e
) o« == Header of template "Ifly Report Template"
menu for inserting the date, (Concel ) (__0K_)
; , e At el i Text Insert I (=] Show Header
time, page number, or stack - To add
" name into the header [ ' .

text to the
: atically. ( Pi )
wtomatically Paste Picture header,

type here.

If the header contains a

graphic, it appears here and
prints out just below the =
header’s text.
To paste a graphic into the Drag from this corner to
header, click this button. (The adjust the height of the
button is active only when the portion of the header that
Clipboard contains a graphic.) contains a graphic.

Figure 7-22  The Header dialog box

To reposition a graphic after you've pasted it into the header,
drag with the crosshair pointer to select the graphic, then drag
with the arrow pointer to move it. (Hold down the Shift key
while you drag to move the graphic one pixel at a time.) To
duplicate the currently selected graphic, hold down the Option
key while you drag the graphic.

357
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21. Click OK.

The Header dialog box disappears, and you see the T emplate
dialog box again. (To return immediately to the Print dialog box
without seeing the Template dialog box, hold down the Option
key while you click OK or Cancel.)

22. If you want to add a footer to your report template, click
Footer.

The Footer dialog box appears. (If you don't want to add a
footer, go to step 25.)

23. Specity the footer you want:

To make the footer show up in the printout,
click here to select the Show Footer option.
To paste a graphic into the

footer, click this button. (The === Footer of template "Hls Report Template” Craee ) C o)

button is active only when the |
’ ( Paste Picture ) [1Show Footer ‘

Clipboard contains a graphic.)

If the footer contains a graphic, pa FﬁJ
it appears here and prints out /

just above the footer’s text.
Text Insert

To add text to the M
footer, type here,

Press and hold the mouse button here  Drag from this corner

10 see a pop-up menu for inserting to adjust the height of the
the date, time, page number, or stack — portion of the footer that
name into the footer automatically. contains a graphic.

Figure 7-23  The Footer dialog box

To reposition a graphic after you’ve pasted it into the footer, drag
with the crosshair pointer to select the graphic, then drag with
the arrow pointer to move it. (Hold down the Shift key while
you drag to move the graphic one pixel at a time.) To duplicate
the currently selected graphic, hold down the Option key while

you drag the graphic.
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24.

25.

20.

Click OK.

The Footer dialog box disappears, and you see the Template
dialog box again. (To return immediately to the Print dialog box
without seeing the Template dialog box, hold down the Option
key while you click OK or Cancel.)

In the Template dialog box, click OK.

The Template dialog box disappears, and you see the Print
dialog box again. Your new template is now saved with the stack.

[f you want to print a report now (using the current template),
select the standard print options you want (as described earlier
in the section “Printing a Report”) and click Print in the Print
dialog box.

Otherwise, click Cancel in the Print dialog box.

HyperCard prints information from the cards in the current
stack (either all the cards or just the range of cards specified in
the Template dialog box) according to the settings in the Page
Setup dialog box, the Options dialog box for your printer, and
the Template, Content, and Header and Footer dialog boxes for
your new report template.

1o print mailing labels: 1f you want to print mailing labels, you
can use the Labels 3 by 7 template in the Addresses stack (which
comes with HyperCard). If you want to print mailing labels
from a stack other than the Addresses stack, copy the Labels 3 by
7 template using the procedure described in the next section,
“Exporting a Template to Another Stack.” If you like, you can
customize this template by selecting it in the Print dialog box
and following steps 6 through 25 in this section. If you're
printing on a LaserWriter, be sure to use o7y labels made

®,

especially for LaserWriters or photocopiers.
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EXpOI’[ng d template If you have a template for one stack that you think would work well
to another stack i another stack, you can export it to another stack by following

these steps:
1. Go to the stack that has the template you want to copy.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (<), or the Field tool ()
will work.

3. Choose Print from the File menu.
The Princ dialog box appears (see Figure 7-2).
4. Click the template you want to export to select it.

5. Press and hold the mouse button over the pop-up Templates.
menu and drag to choose Export.

The directory dialog box for exporting a template appears.

6. In the directory dialog box, find and select the stack to which

you want to export the current template.
7. Click Open.

Or double-click the name of the stack. You see the Print dialog
box again. The template is now saved in the stack you selected
in step 6 as well as the current stack.

8. Click Cancel to close the Print dialog box.

[f you want to print from the stack to which you exported the .
template, go to that stack and follow the instructions in the section
“Printing the Cards in a Stack” or “Printing a Report,” earlier in

this chapter.
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Copying a template
within the same stack

Renaming a template

You may sometimes find it useful to make a copy of a template
within the same stack as the original—for example, so that you can
use the template as the basis of a new template without changing
the original.

To make a copy of a template within the same stack as the original
template, follow these steps:

1. Go to the stack that has the template you want to copy.
2. Make sure you have one of the General tools selected.

"The Browse tool (), the Button tool (=), or the Field tool ()
will work.

3. Choose Print from the File menu.
The Print dialog box appears (see Figure 7-2).
4. Click the template you want to copy to select it.

5. Press and hold the mouse button over the pop-up Templates
menu and drag to choose Duplicate.

A copy of the template appears in the list of templates. You can
make any changes you want to the copy without changing the
original.

To rename a card or report template, follow these steps:
1. Go to the stack that has the template you want to rename.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool (E2)
will work.

3. Choose Print from the File menu.

The Print dialog box appears (see Figure 7-2).
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4. Click the template you want to rename to select it.

5. Press and hold the mouse button over the pop-up Templates
menu and drag to choose Rename.

A dialog box like the following appears:

Rename template... ( Cancel J (( 0K _))

Current name: Untitled

New nome: Iummm 1 Type the new name for

your template here.

Figure 7-24  Renaming a template

6. After you've typed a new name for the template, click OK.

D@leting d ttjmplate 1o delete a template from a stack, follow these steps:
1. Go to the stack that has the template you want to delete.
2. Make sure you have one of the General tools selected.

The Browse tool (), the Button tool (=), or the Field tool ()
will work.

3. Choose Print from the File menu.
The Print dialog box appears (see Figure 7-2). ‘
4. Click the template you want to delete to select it.

5. Press and hold the mouse button over the pop-up Templates
menu and drag to choose Delete.

A confirmation dialog box appears for deleting the report
template.

6. Click Yes to delete the template.
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A bzlckground field A field that is common to all cards
sharing a background; its size, position, and text
format remain constant on all cards associated
with that background, but its text can change
from card to card. Compare with card field.

application program A program that helps you
perform a specific task, such as word processing,
database management, or creating graphics.

authoring Creating or modifying buttons, links,
fields, cards, backgrounds, and stacks using the
Button tool, the Field tool, and commands in
the Objects menu. Also refers to the user level
that allows you to use the Button Tool, the Field
tool, and the Objects menu.

background layer The layer behind the card layer,
containing all the elements of the background.
You see the elements of both layers when you
look at a card, as if the card layer were a
transparent layer in front of the background

layer. The background button or background

field created most recently is the topmost object

B in the background layer (that is, closest within
‘ the background layer to the front of the screen).
background A type of HyperCard object; a The background picture is behind (farther from
template shared by a number of cards. Fach the front of the screen) the objects in the
card with the same background has the same background layer.
background picture, background fields,
background buttons, and background script background picture  The graphics in the
in its background layer. background layer; the entire picture that is
common to all cards sharing a background.
background button A button that is common to You can see and edit the background picture
all cards sharing a background. Compare with by choosing Background from the Edit menu.

card button. Compare with card picture.




browse  To explore HyperCard stacks by clicking
buttons and using the Go menu.

Browse tool (§9)  The ool you usc to click buttons
and to position the insertion point in fields.

button A type of HyperCard object; a “hot spot” on
a card or background that responds when you
click it according to the instructions in its script.
For example, clicking a right arrow button with
the Browse tool takes you to the next card.

Button tool (&) The tool you use to create, change,
and select buttons.

C,DE

card A type of HyperCard object; a rectangular area
that can hold buttons, fields, and graphics. All
cards in a stack are the same size. Each card is a
composite of two layers—a foreground layer,
called the card layer, and a background layer.
You see the elements of both layers when you
look at a card, as if the card layer were a
transparent layer in front of the background
layer. Each layer can contain its own buttons,

fields, and graphics.

card button A button in the card layer of a specific
card. Compare with background button.

card field A field in the card layer of a specific card;
its size, position, text attributes, and contents are
limited to the card on which the field is created.

Compare with background field.

card l:lyCl' The layer in front of the background

layer. You see the elements of both layers when
you look at a card, as if the card layer were a
transparent layer in front of the background
layer. The card button or card field created
most recently is the topmost object in the card
layer (that is, closest within the card layer to the
front of the screen). The card picture is behind
(farther from the front of the screen) the objects
in the card layer and in front of all the elements
in the background layer.

card picture The graphics in the card layer of a

specific card. Compare with background

picture.

card template A template for printing the cards in a

color

stack (or a range of cards) as they appear on the
screen. You can create your own card templates
or use ones that already exist in a stack.
Compare with report template.

set A set of 16 colors that appears in the
Colors dialog box for a stack, a background, ora
card. Color sets are used to specify the colors
available to buttons, fields, and graphics in a
stack. You can choose from at least five color sets
for any stack, background, or card: the standard
system color set, a gray color set, and three
others. You can also add a sixth color set to the
Colors dialog boxes for cards and backgrounds.
When you select a different color set, the ‘
buttons, fields, and graphics that are affected by

it reflect the new colors.

current (adj.) The card, background, or stack

you're looking at now. For example, the current
card is the one you see on your screen.
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field A type of HyperCard object; a container in
which you type field text. HyperCard has two
kinds of fields—card fields and background
fields.

field text Texr that appears in a field. Field text can
be edited and searched, while Paint text cannot.

Field tool (E3)  The tool you use to create, change,
and select fields.

~
J

(}cn. tools The tools that appear in the top row
of the Tools menu: the Browse tool (), the

Button tool (@), and the Field tool ().

GO palette  The palette that you can “tear off” the
alternate Go menu. To see the alternate Go
menu, hold down the 3 key while you pull

down the Go menu.

1,1],K

fome cards The first five cards in the standard
Home stack, designed to hold buttons that take
you to stacks, applications, and documents.

i lypq"dlk HyperCard’s built-in script language for
yperCard users.

}

ink A short script, usually in a button but
potentially in any HyperCard object, that allows
you to move immediately to a specific card in a
stack, to an application, or to a document. For
example, clicking a button that contains a link
to your Addresses stack takes you immediately
to the first card of that stack.

locked stack A stack for which “Can’t modify stack”
is selected in the Protect Stack dialog box; a
stack for which Tocked is selected in the stack’s
Icon Info box in the Finder; or a stack on a
locked medium—a locked disk, a CD-ROM,
or a locked folder on a file server. A padlock
appears after the last menu title in the menu bar
of a locked stack.

M N

message A string of characters sent to an object
from a script or the Message box, or that
HyperCard sends in response to an event.
Messages that come from the system—from
events such as mouse clicks, keyboard actions, or
menu commands—are called system messages.
Examples of messages are help and
mouseUp.

Message box A special window that you use to send
messages to HyperCard.

O

object  An element of the HyperCard environment
that can have a script associated with it and that
can send and receive messages. There are five

kinds of HyperCard objects: buttons, fields,

cards, backgrounds, and stacks.

PQ

Paint text Text you type using the Paint Text tool.
Paint text can appear anywhere, while field text
must appear in a field created with the Field
tool. When you finalize Paint text by clicking, it
becomes part of a card or background picture
and cannot be edited except by erasing it and
starting over. Unlike field text, Paint text can’t
be searched.
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Paint tools - Any of the HyperCard tools you use to
create graphics. The Paint tools are all the tools
below the top row in the Tools menu.

palette A small window that displays icons or
patterns you can select by clicking. You can
open three of HyperCard’s palettes—the Go
palette, the Tools palette, and the Patterns
palette—by “tearing off” their respective menus.
See also Go palette and tear-off menu.

Patterns palette The palette that you can “tear off”
the Patterns menu.

picture Any graphic or part of a graphic, created
with a Paint tool or imported from an external
file, that is part of a card or background.

picture insert An item in the Content dialog box for
a report template that consists of the card
picture.

pixel Short for “picture element”; a single dot on the
screen.

point The unit of measurement of the height of a
text character; one point is approximately equal
to one pixel. When you select a font, you can
also select a point size, such as 10-point,
12-point, and so on. (Note that a point on
the Apple IIGS is larger than the point used

in typography.)

power kC_\" One of a number of keys on the Apple
IIGs keyboard that you can press to invoke a
menu command when a Paint tool is active and
the Message box is closed. To turn on the power
keys, choose Power Keys from the Options
menu or select the Power Keys option on the
User Preferences card in the Home stack.

366

program A set of coded instructions describing
actions for a computer to perform. This general
term includes programs such as HyperCard and
system software files as well as application
programs.

R

Recent A special dialog box that holds miniature
representations of up to the last 18 unique cards
viewed. Choose Recent from the Go menu to
get the dialog box.

report template A template for printing the
contents of specific background fields in a stack.
You can create your own report templates 01‘*
ones that already exist in a stack. Compare with
card template.

resource fork The part of a file that contains
resources such as icons and sounds.

S

script - A collection of instructions written in
HyperTalk and associated with a particular
object. You use the script editor to add to and
revise an object’s script. Every object has a script,
even though some scripts are empty (that is, they
contain nothing).

script editor A special dialog box in which you can
type and edit a script. The title at the top of the
script editor describes the object to which the
script belongs. You can use keyboard commands
to edit text in the script editor. See also object.

scripting  The act of writing scripts; writing
programs in HyperTalk. Also refers to the user
level that allows you to look at and change
objects’ scripts.
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search path  When you open a file from within T
HyperCard, HyperCard attempts to locate the

C ar-off men ‘ < ve from
stack, document, or application you want by tear-off menu- A menu that you can remove i

searching the folders listed in the appropriate the menu bar by dragging the pointer beyond
field on the Search Paths card in the Home the side or bottom edge of the menu.

stack. Each line in a Search Paths field indicates HyperCard has three menus that can be torn
the location of a folder, including the disk name off: the alternate Go menu, the Tools menu, and
(and folder and subfolder names, if any). This the Patterns menu. When torn off, these menus
information is called a search path. Items in a are called palettes.

search path are separated by colons, like this:

:MyDisk:HyperCard:MyStacks: Tools palette  The palette that you can “tear off” the

Tools menu.

earch Paths card A card in the Home stack used

to store information about the location of 7
stacks, documents, and applications that you U’ V. W, XY, Z
en while Hypercard is r unning. See also user level A HyperCard setting, ranging from
scarch path. 1 to 5, that determines which of HyperCard’s
capabilities are available. You can select the user
hared text  Field text that appears on every card level on the User Preferences card in the Home
with the same background. Shared text can be stack. Each user level makes all the options from
edited only from the card layer. Text in shared the lower levels available, and also gives you
text fields can't be searched. additional capabilities. The five user levels are
Browsing, Typing, Painting, Authoring, and
tack A type of HyperCard object that consists of Scripting,

one or more cards; a HyperCard document.
User Preferences card  The last card in the Home

ystem message A message sent by HyperCard to stack, where you can set your user level and
an object in response to an event such as a select or deselect the Blind Typing, Power Keys,
mouse click, keyboard action, or menu and Text Arrows options.

command. Examples of HyperCard system
messages are mouseUp and doMenu.
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A

access. See protecting a stack
adding buttons 157-166
to a card or background 152-153
to Home cards 112-116
adding button text 176
adding cards to stacks 122-125
adding fields 207-210
adding graphics 248-292
adding margins to fields 263-264
adding Paint text 298-301
adding search paths 26
adding text 206-207
to button 176
i@eld 50-52
with Paint Text tool 298-301
aligning graphics 295-296
alignment in fields, setting 217-218

Apple Preferred File Format, documents in

adding color sets from 273

importing color sets from 278-279

importing graphics from 329-330
AppleShare network

custom icons and 167

launching HyperCard over 119

using stacks on 55
setting user access for 109-110
applications
adding buttons that open 154-157
adding Home card buttons for 114-116
importing graphics from 329-330
opening from HyperCard 52-53
quitting 53
Search Paths card for 24-26
Arrow Keys in Text option. See Text Arrows option
Art Ideas stack 262-263
Authoring level, defined 19
Auto Hilite option 186-187
Auto Tab option 216

B

Back command (Go menu)
Prev command vs. 35-36
for reviewing cards 48
background(s) 135-136. See also background
buttons; background fields; background layer
adding buttons to 152-153
adding fields to 207-208
adding graphics to 248-292
adding Paint text to 298-300




background(s) (continued)

changing color set for 146-148
checking number of 137

color sets for 96

adding 97-98, 273

changing 146-148, 273, 276-278
copying 140-141

when making new stack 88-90
copying buttons on the same 198
copying buttons to 199-200
copying ficlds on the same 236
copying fields to 236-238
copying graphics on the same 324-325
copying graphics to 325-326
creating new 138
exporting a snapshot of 330-331
getting information about 85, 142-143
locating fields on 220-221
moving between 139-140
moving buttons between 202-203
moving buttons from card to 200-201
moving fields between 240-242
moving fields from card to 238-239
moving graphics between 328-329
moving graphics from card to 327
naming or renaming 143
number of cards in 137
protecting 145-146
for report, selecting 349, 350
repositioning buttons on 192-193
repositioning fields on 230
repositioning graphics on 327, 329
saving graphics on 323
selecting all graphics on 260
white area on, blank space vs. white paint 253

working with 136-149

background buttons. See also buttons

3

-

numbering of 194

and overlapping elements 193-197
reordering 195-196

Share Hilite option 187-189

0

Background command (Edit menu) 136
background fields. See also fields
changing appearance of 221-228
numbering of 232
and overlapping elements 231-235
placing in report template 352-355
reordering 233-235
Shared Text option for 219-220
tabbing through 215-216
background layer. See also background(s)
card layer vs. 63-65, 122, 193
when adding buttons 152-153
when adding fields 207-208, 209, 210
when adding graphics 248
when entering or editing text 219
when selecting graphics 253, 260
moving between card layer and 136-137
overlapping buttons in 195-197 '
overlapping fields in 231-235
overlapping graphics in 302-305
viewing 136
background picture 302-303
selecting 261
background script, viewing 85
backing up
importance of 10
when modifying stacks 79
Bkgnd Info command. See Bkgnd Info dialog box
Bkgnd Info dialog box 85, 142
Can’t Delete option 145-146
changing color set with 146147
checking number of backgrounds with 137
Don't Search option 144
excludmg backgrounds from searches with 144
nammg or renaming a background with 143
protecting a background with 145-146
shortcut for choosing 143
blank space
selecting graphic without 255, 257-259, 260
white paint vs. 253
Blind Typing option 24

Index




©

A
access. See protecting a stack
adding buttons 157-166

to a card or background 152-153

to Home cards 112-116
adding button text 176
adding cards to stacks 122-125
adding fields 207-210
adding graphics 248-292
adding margins to fields 263-264
adding Paint text 298-301
adding search paths 26
adding text 206-207

to button 176

i@ld 50-52

with Paint Text tool 298-301
aligning graphics 295-296
alignment in fields, setting 217-218

Apple Preferred File Format, documents in

adding color sets from 273

importing color sets from 278-279

importing graphics from 329-330
AppleShare network

custom icons and 167

launching HyperCard over 119

using stacks on 55
setting user access for 109-110
applications
adding buttons that open 154-157
adding Home card buttons for 114-116
importing graphics from 329-330
opening from HyperCard 52-53
quitting 53
Search Paths card for 24-26
Arrow Keys in Text option. See Text Arrows option
Art Ideas stack 262-263
Authoring level, defined 19
Auto Hilite option 186-187
Auto Tab option 216

B

Back command (Go menu)
Prev command vs. 35-36
for reviewing cards 48
background(s) 135-136. See also background
buttons; background fields; background layer
adding buttons to 152-153
adding fields to 207-208
adding graphics to 248-292
adding Paint text to 298-300




background(s) (continued) Background command (Edit menu) 136

changing color set for 146-148 background fields. See also fields
checking number of 137 changing appearance of 221-228
color sets for 96 numbering of 232
adding  97-98, 273 and overlapping elements 231-235
changing 146-148, 273, 276-278 placing in report template 352-355
copying 140-141 reordering 233-235
when making new stack 88-90 Shared Text option for 219-220
copying buttons on the same 198 tabbing through 215-216
copying buttons to 199-200 background layer. See also background(s)
copying fields on the same 236 card layer vs. 63-65, 122, 193
copying fields to 236-238 when adding buttons 152-153
copying graphics on the same 324-325 when adding fields 207-208, 209, 210
copying graphics to 325-326 when adding graphics 248
creating new 138 when entering or editing text 219
exporting a snapshot of 330-331 when selecting graphics 253, 260 .
getting information about 85, 142-143 moving between card layer and 136-137
locating fields on 220-221 overlapping buttons in 195-197 '
moving between 139-140 overlapping fields in 231-235
moving buttons between 202-203 overlapping graphics in 302-305
moving buttons from card to 200-201 viewing 136
moving fields between 240-242 background picture 302-303
moving fields from card to 238-239 selecting 261
moving graphics between 328-329 background script, viewing 85
moving graphics from card to 327 backing up
naming or renaming 143 importance of 10
number of cards in 137 when modifying stacks 79
protecting 145-146 Bkgnd Info command. See Bkgnd Info dialog box
for report, selecting 349, 350 Bkgnd Info dialog box 85, 142
repositioning buttons on 192-193 Can't Delete option 145-146
repositioning fields on 230 changing color set with 146147
repositioning graphics on 327, 329 checking number of backgrounds with 137 ’
saving graphics on 323 Don’t Search option 144
selecting all graphics on 260 excludmg backgrounds from searches with 144
white area on, blank space vs. white paint 253 naming or renaming a background with 143
working with 136-149 protecting a background with 145-146
background buttons. See also buttons shortcut for choosing 143
numbering of 194 blank space
and overlapping elements 193-197 selecting graphic without 255, 257-259, 260
reordering 195-196 white paint vs. 253
Share Hilite option 187-189 Blind Typing option 24
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borders, drawing with patterns 291-292
Bring Closer command (Objects menu)
reordering a button with 195
reordering a field with 234
Browse tool
choosing 33
shortcut for 154
editing shared text with 219
editing text with 51, 211-213
locating buttons with 171
locating fields with 211, 221
locked field and 243
3rowsing level, defined 19
rowsing methods 32-50
S rushg®64—266
Srushhape dialog box 265
ducket 264
changing a graphic’s pattern or color with
310-311
positioning 268-269, 311
jutton Ideas stack 154-155
utton Info command. See Button Info dialog box
utton Info dialog box 81
adding text and icon with 164
assigning icon to button with 162
Auto Hilite option 186-187
button numbers in 194
changing button color with 179-180
changing button style with 175
changing button text with 176
C ing or removing an icon with 177-178
choosing button style with 175
copying an icon with 168-169, 170-171
creating link with 181
creating text button with 159
Family menu, highlighting buttons with 189-190
highlighting button with 186-190
installing an icon with 168-171
making button opaque or transparent with 197
naming button with 191
opening a script with 203

Share Hilite option 187-189
Show Name option 191
varying highlighting among cards with 187-190
button names, Finder stack names vs. 27-28
button numbers 194
button(s) 66, 151, 152. See also background buttons;
card buttons
adding to card vs. background 152-153
adding to Home cards 112-116
assigning an icon to 177-178
changing colors for 179-180
changing an icon for 177-178
copying 198-200
from Button Ideas stack 154—157
creating 157-166
blank and transparent 157-158
with a graphic 165-166
with an icon 161-164
with icon and text 164
opaque or transparent 197
with text 158-161
deleting 204
disappearing 9
getting information about 80-81
highlighting 186190
on Home cards 15-16, 112-116
linking to cards or stacks 112-116, 180-185
locating 171-172
making transparent or opaque 197
managing icons of 166171
modifying 173-180
by adding, changing, or removing text 176
by choosing style 174-176
by resizing 160
moving to another card or background 202-203
moving from background to card 201
moving from card to background 200-201
moving through stacks with 38
naming or renaming 191-192

for opening applications 114-116




button(s) (continued)
for opening cards or stacks 180-185
from Home cards 112-113
for opening documents 114-116
opening scripts of 203
overlapping, solutions to 195-197
readymade 67, 154-155
copying 154-157
removing an icon from 177-178
reordering 195-196
repositioning 192193
resizing 173
selecting 72
styles for 174-176
text on. See button text
tools for working with 153-154
viewing 171-172
button text 206
adding, changing, or removing 176
combining with button icon 164
creating 158-161
setting or changing style of 176-177
Button tool 153
locating buttons with 80, 171-172
opening a script with 203
repositioning a button with 192-193
resizing a button with 173
shortcut for choosing 154, 209

C
card(s) 4. See also card fields; card layer
adding buttons to 152-153
adding fields to 207-208
adding graphics to 248-292
adding Paint text to 298-300
adding to stacks 122-125
color sets for 96
adding 98, 273
changing 133-134, 273, 275-276
copying 126
copying buttons on the same 198

372

copying buttons to 199-200
copying ficlds on the same 236
copying fields to 236-238
copying graphics on the same 324-325
copying graphics to 325-326
deleting 135
exporting a snapshot of 330-331
flipping through 4243
getting information about 84, 129
going back to 48-49
going to specific 41-43
Home 15-16. See also Home cards
linking buttons to 180-185
locating fields on 220-221
moving. See cards, repositioning
moving buttons to background from 200-201
moving buttons from background to 201
moving buttons between 202-203
moving buttons on 192-193
moving field to background from 238-239
moving field from background to 239-240
moving fields between 240-242
moving fields on 230
moving graphics to background from 327
moving graphics between 328-329
moving graphics on 292-293
naming 130
printing 336-340

creating template for 343-348

from current card template 348
protecting from deletion 132-133
repositioning 127-128 ‘
repositioning graphics on 329
saving graphics on 323
viewing quickly 42—43
white area on, blank space vs. white paint 253
working with 122-135

card buttons. See also buttons

numbering of 194
and overlapping elements 193-197
recordering 195-196

Index




card fields

changing appearance of 221-228
numbering of 232
and overlapping elements 231-235
reordering 233-235
tabbing through 215-216
Card Info command. See Card Info dialog box
Card Info dialog box 84, 129
Can't Delete option 132-133
changing color set with 133-134
Don't Search option 131
excluding fields from searches with 131
naming or renaming a card with 130
protecting a card with 132-133
scripting a link with 183
ortcut for choosing 129
1d layer. See also card fields; card(s)
background layer vs. 63-65, 122, 193
when adding buttons 152-153
when adding fields 207-208, 209, 210
when adding graphics 248
when entering or editing text 219
when selecting graphics 253, 260
moving between background layer and 136-137
overlapping buttons in 194—197
overlapping fields in 231-235
ovuhppmg sraphics in 302-305

card picture 302-303

adding to report template 350, 352-355
printing in report 340-343
selecting 261
cript, viewing 84
card template(s) 336
copying within the same stack 361
creating 343-348
deleting 362
editing 338
exporting to another stack 360
footer for 347
header for 345-346
naming 344
renaming 361-362
selecting 337-338

changes, protecting a stack from 103-105
changing a button’s icon 177-178
changing button text 176
changing colors

for a button 179-180

for a field 227-228
changing color sets 272-279

for a background 146-148, 276-278

fora card 133-134, 275-276

for a stack 95-98, 274-275
changing a field’s appearance 221-228
chqngmg a graphic’s appearance 305-317
changing a Home card’s appearance 118
check box button

Auto Hilite and 186

Share Hilite and 187
Choose ColorSet (Options menu) 275, 277
circles, drawing 281-283
Clear Button command (Edit menu) 204
Clear Field command (Edit menu) 245
Clear Picture command (Edit menu) 332
clicking buttons to move around 38
clicking text 39
Clipboard operations

copying a button 169, 199

copying a card 126

copying a field 237

copying a graphic 326

moving a button 200-202

moving a card 127, 128

moving a field 238-241

moving a graphic 327, 328
closing a stack 31
color (Patterns palette)

changing 309-313

double-clicking, effects of 322
Colors dialog box

changing button colors with 179-180

changing background colors with 146148,

276278
changing card colors with 133—134, 275, 277
changing field colors with 227-228

changing stack colors with 96-97, 147-148, 274




color set 95, 272
adding 273
changing 272-279
for a background 146-148, 273
fora card 133-134, 273, 275-276, 276-278
for a stack 95-98, 274-275
for imported graphics 330
importing from a document 278-279
Command key, using with Paint tools 321
Compact Stack command (File menu) 31, 100
Content dialog box, for report template 350-356
Copy Button command (Edit menu) 169, 199
Copy Card command (Edit menu) 126
for creating miniature card 331
Copy Field command (Edit menu) 237
copying a background 88-90, 140141
copying a button 198-200
from Button Ideas stack 154-157
copying a card 126
copying a field 236-238
copying a graphic 324-326
that comes with HyperCard 262-263
copying an icon 167, 168-171
copying a stack 98-99
copying a template
to another stack 360
within the same stack 361
Copy Picture command (Edit menu) 262, 326
Copy Text command (Edit menu) 301
correcting mistakes 87
with Brush 265
with Bucket 269
with Eraser 264, 332
in graphics operations 263-264, 332
in low-memory conditions 319
with Spray tool 267
in text entry 52, 217
undeleting a card 135
Create QuickLink button 113
creating a background 138
creating a button. See buttons, creating

creating a card template 343-348
creating a field 209-210
creating a graphic 248-292
opaque or transparent 303-305
creating an icon 167
creating links 180-185
with Link To method 181-182
by scripting 183-185
creating a miniature picture of a card 331
creating Paint text 298-300
creating stacks. See stacks, creating
crosshair pointer
drawing circles, ovals, or rectangles with 281-282
drawing an irregular polygon with 285-286
drawing lines or free-form shapes with 280
drawing polygons with 283-285 ‘
selecting a graphic with 254-255, 257-258
Curve tool
Draw Filled option with 289-290
drawing with 280
customizing the Home stack 111-119
Cut Button command (Edit menu) 200, 201, 202
Cut Card command (Edit menu)
adding new first card with 124-125
copying a background with 140
moving a card with 127, 128
Cut Field command (Edit menu) 238, 239, 241
Cut Picture command (Edit menu) 327, 328

D
Delete Card command (Edit menu) 135 ‘
deleting a background with 148-149
Delete command (Templates menu) 362
Delete key, correcting mistakes with 87
Delete Stack command (File menu) 110-111
deleting. See also correcting mistakes; removing
a background 148-149
a button 204
button text 176
acard 135

a card lcmpl;u‘c 362




deleting (continued)
a field 245
a graphic 332
with Brush 265
with Eraser 264, 332
with Spray tool 267
a report template 362
scripts 91
search paths 26
astack 110-111
text 217
deletion
protecting a background from 145-146
protecting a card from 132-133
protecting a stack from 104-105
desk @¥essory, adding a color set with 273
to a background 148
to a card 134, 276, 278
to a stack 98
directory, Home cards as 15
directory dialog box 11, 25
Don't Search option 46
louble-clicking, as error 38
louble-clicking Paint tools, patterns, or colors 322
Draw Centered option (Options menu)
circles, ovals, or rectangles with 282
lines or free-form shapes with 281
Draw Filled option (Options menu) 288-290
for filled shapes without borders 292
drawing, using pencil for 287
drawing lines and shapes 279-292
ci@@s, ovals, and rectangles 281-283
with different line widths 290-291
filled with patterns 288-290
line or free-form shape 280-281
in multiples 293-295
polygons 283-286
Draw Multiple option (Options menu) 293-294
Draw Outlined option (Options menu) 283
luplicating. See copying

editing a graphic 305-317
editing an icon 167
editing text 52,211-218

correcting mistakes 87

Edit menu commands

Background 64-65, 136

Clear Button 204

Clear Field 245

Clear Picture 332

Copy Button 169, 199

Copy Card 126
for miniature picture of card 331

Copy Field 237

Copy Picture 262, 326

Copy Text 301

Cut Button 200, 201, 202

Cut Card
adding new first card with 124-125
copying a background with 140
moving a card with 127, 128

Cut Field 238, 239, 241

Cut Picture 327, 328

Delete Card 135
for deleting a background 148-149

New Card
adding card with 123, 124
copying a background with 140, 141

Paste Button 169, 199-202

Paste Card
adding new first card with 125
copying a background with 141
copying a card with 126
creating miniature card with 331
making card first in stack with 128
moving a card with 127, 128

Paste Field 237, 240, 241

Paste Picture 263, 326, 327, 328-329

Paste Text 301




Edit menu commands (continued)
Text Style
choosing button text formar with 176-177
choosing field text format with 217-218
with Paint text 298-299
Undo 87
low memory and 318
Revert command vs. 323
undeleting a card with 135
undeleting field text with 217
undeleting a graphic with 263, 332
user level and 20
Edit Pattern dialog box 271
Edit Template command (Templates menu)
modifying a card template with 344-348
modifying a report template with 349, 357-359
selecting cards for printing 338
selecting cards for report 341-342
elements, overlapping
buttons 194-197
fields 231-235
graphics 302-305
entering and editing text in fields 50-52, 211-218
and Text Arrows option 213
Eraser, deleting a graphic with 264, 332
error correction; erasing. See correcting mistakes;
deleting
error messages 78-79
Esc key
going to last card seen with 48
for Undo command, with Paint tools 87, 263, 332
evaluating stacks 76-77
Export command (Templates menu) 360
Export Paint command (File menu) 330-331

F
Family menu, highlighting buttons with 189-190
FatBits option (Options menu) 306-307
field(s) 66, 205, 206
adding to card or background 207-210
adding margins to 263-264

changing appearance of 221-228
changing colors for 227-228
copying 236-238
creating 209-210
deleting 245
disappearing 9
displaying lines in 226-227
entering and editing text in 50-52, 211-218
getting information about 83
locating 220-221
locking and unlocking 242-243
making opaque or transparent 235
moving to another card or background 240-242
moving from background to card 239-240
moving between 214-216
moving from card to background 238-239 ’
naming 228-229
numbering of. See field numbers
overlapping of, solutions to 233-235
peeking at 221
preventing word wrap in 212
printing text in 340-343
protecting 242-244
reordering 233-235
repositioning 230
resizing 222-223
for viewing hidden text 212
searching for text in 4546, 47
exclusions when 46, 131-132, 244
selecting 73
styles for 223-224
tabbing through 214-216 ‘
tools for working with 208-209

Field Info command. See Field Info dialog box
Field Info dialog box 83

adding margins with 225-226
Auto Tab option 216

changing field colors with 227-228
changing field style with 223-224
checking field number with 215
choosing text format with 217

displaying lines in field with 226-227




Field Info dialog box (continued)
Don't Search option 244
‘Shared Text option and 220
Lock Text option 242-243
making a field opaque or transparent with 235
naming a field 229
protecting field from search with 244
Shared Text option 219-220
Show Lines option 226-227
Wide Margins option 225-226
field names, choosing 228-229
field numbers 194
reordering fields and 234
tabbing order and 215
field size, changing 222-223
ﬁelc’.le, changing 223-224
field text 206
adding to cards 50-52
changing to Paint text 300-301
choosing look of 217-218
clicking 39
copying a field with 236-238
copying a field without 236
correcting mistakes in 87, 217
creating fields for 209-210
entering and editing 50-52, 222-218
and Text Arrows option 213
on every card 219-220
hidden, viewing 212
moving through 21-22
placing in report template 354-355
‘ing reports using 340-343
Shared Text option, for background fields
219-220 -
Field tool 208-209
locating fields with 82, 220
repositioning a field with 230, 233
resizing a field with 222
File menu commands
Compact Stack 31, 100
Delete Stack 110-111
Export Paint 330-331

Import Paint 278-279, 329
New Stack 89
Open Stack
closing a stack with 31
getting to Home stack with 26
moving to another stack with 48
opening a stack with 27, 28-29
Print
copying a template with 361
creating a card template with 343
creating a report template with 348
deleting a template with 362
exporting a template with 360
renaming a template with 361-362
report from current stack 340
Print Card 336
Protect Stack. See Protect Stack dialog box
Quit HyperCard 31, 57
Save A Copy 98-99
user level and 20
files, finding 10-11, 24-26
file server
setting user access for stacks on 109-110
using stacks on 55
Fill command (Paint menu)
changing a graphic’s pattern or color 309-310
filling arca with pattern or color 269-270
filled shapes, drawing 288-290
without borders 292
Find command (Go menu)
finding text with 43—46
searching a specific field with 45-46
Finder
changing stack name in 94
copying a stack in 99
HyperCard icons and 13-14
finding buttons 171-172
finding a file
directory dialog box for 11, 25
Search Paths cards for 24-26
finding text. See searching for text
finding a transparent field 211
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Find Whole command 4647
First command (Go menu) 35

making card first in stack with 124, 128
Flip Horizontal command (Paint menu) 316-317
flipping a graphic 316-317
flipping through cards 4243
Flip Vertical command (Paint menu) 316-317
font, setting 217-218
Font menu, for report template 354-355
font size, choosing 217-218
Footer dialog box

for card template 347

for report template 358-359
FTYPE.HyperCard 13

G
General tools 68, 69
Go menu commands 34-36
Back
Prev vs. 35-36
reviewing cards with 48
Find 43-46
searching a specific background field with
4546
searching for a whole word or phrase with
4647
First 35
making card first in stack with 124, 128
Help 53
Home 26, 50
icons for 36-37
Last 35
Message. See Message box
Next 35
Prev, Back vs. 35-36
Recent 49
Show All Cards 42
Go palette, moving through stacks with 36-37
graphic(s) 66
adding to card or background 248-292
adding to card template header or footer 346, 347

adding to Home cards 118
adding to report template 350, 352-355
in header or footer 357, 358
aligning 295-296
changing appearance of 305-317
by changing pattern or color 309-313
by flipping vertically or horizontally 316-317
by inverting 313
by outlining 314
by rotating 90° 315-316
changing color of 309-313
changing pattern of 309-313
changing size of 308
color sets and 95, 272
changing 272-279
with imported picture 330 ‘
combining options for 297
copying 324-326
to another card or background 325-326
readymade graphics 262-263
on same card 324-325
creating 248-292
opaque or transparent 303-305
creating buttons with 165-166
creating your own patterns for 270-271
deleting 332 ’
drawing lines and shapes 279-292
circles, ovals, and rectangles 281-283
with different line widths 290-291
filled with patterns or colors 288-290
line or free-form shape 280-281
in multiples 293-295 ‘
polygons 283-286
drawing patterned or colored borders 291-292
editing 305-317
filling with patterns or colors 267-270, 288-290
flipping 316-317
importing 329-330
magnifying for editing 305-307
making opaque or transparent 303-305
miniature pictures of cards 331




graphic(s) (continued)
moving 292-293

to another card or background 328-329

from card to background 327
outlining 314
overlapping, solutions to 303-305
painting with Brush 264-266
painting with Bucket 267-269, 310-311
painting with Spray tool 266-267
with Paint text. See Paint text
readymade 67, 262-263
repositioning 263, 292-293, 303, 326
reverting to last version of 323-324
rotating 315-316
saging on card or background 323
sating 74, 253-261
all in current layer 260
after creation 259
entire card or background picture 261
nonrectangular area 255-257
rectangular area 254-255
without white space 255, 257-259, 260
special effects with 293-297
text with. See Paint text
tools for working with 249-253
using modifier keys for 321
using power keys for 319-320
white paint for 253
working with 247-332
Grid option (Options menu) 295-296

®
H

hardware requirements 6-7
Header dialog box
for card template 345-346
for report template 357-358
help, getting 53-54
Help command (Go menu) 53
hidden buttons, locating 172
hidden field text, viewing 212
hidden menu bar, viewing 32

highlighting, adding to buttons 186-190

on specific cards 187-189

Home cards 15-16

adding buttons to 112-116
buttons on 15-16, 112-116
changing appearance of 118
renaming 117-118
returning to 50

Home command (Go menu) 26, 50
Home stack 14-26

as Apple IIGS control center 119
copying a button from 170-171
customizing 111-119

deletion warning 15

going to (Home command) 26, 50
installing an icon in 167, 168-169
locating 11

Search Paths card 24-26

startup and 10-11, 119

User Preferences card 17-24

house icon, getting to Home stack with 26, 50

HyperCard

with CD-ROM 56
getting help in 53-54
hardware requirements for 6-7
help sources. See HyperCard Help stack
Home stack required for 14-15
installing 9-10
Finder and 13-14
introduction to 1-6
layers of elements in 193-194
in network environment 55
opening applications from 52-53
quitting 57
readymade elements in 67. See also specific elements
running from locked disk 56
software requirements for 7
starting 10-13
starting Apple IIGS with 119

uses for 2-3

HyperCard Help stack 53-54

HyperCard 11Gs Reference vs. 54
readymade button for 155
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HyperCard.Icons file 13
HyperTalk 2, 63
“adding a color set with 273
Ay, 19 backerpund 148
toacard 134,276,278
to a stack 98
help sources 53-54
printing options with 333

L]
icon(s)
assigning to buttons 161-164, 177-178
copying 167, 168-171
creating 167
creating buttons with 161-164
Finder and 13-14
installing
.. by c:opying”apd pasting a button 168-170
managing 166=171
removing from buttons 177-178
selecting, selecting graphic vs. 254
Icon dialog box 162-163
changing or removing an icon with 177-178
copying a button with 168, 170
Icon Editor stack, role of 167
ImageWriter, Print dialog box for 339
importing a graphic 329-330
Import Paint command (File menu) 278-279, 329
installing HyperCard 9-10
Finder and 13-14
installing an icon
by copying and pasting a button 168-170
with Icon dialog box 170-171
Invert command (Paint menu) 313

K

Keep command (Paint menu), 323
low memory and 318

keyboard shortcuts. See also specific rasks
for dl()()sing tools 209

380

for Go menu 36-37
Power Keys option 319-320
for reordering fields 234

L
labels, printing 359
LaserWriter
Print dialog box for 339
printing labels on 359
Lasso, selecting graphics with 74, 256-260
all in current layer 260
entire card or background picture 261
Last command (Go menu) 35
layers. See background layer; card layer
layout for report 351-352 ‘
previewing 356
lines
displaying in a field 226-227
drawing 280-281
patterned, drawing 291-292
varying width of 290-291
Line Size dialog box (Options menu) 290-291
line spacing, setting 217-218
Line tool
choosing 280
drawing with 280-281
line width, selecting 290-291
linking information 6
creating buttons for 180-185
by Link To method 181-182
by scripting 183-185 ‘
using Create QuickLink button for 113
stack renaming and 94
Link To box 181-182
locating buttons 171172
locating fields 220-221
locked disk, running HyperCard from 56
locked stacks 13
making changes to 105
using on file server 55, 109-110
locking and unlocking fields 242-243

Index




looking back through cards seen recently 4849
looking at scripts 203
looking through stacks. See moving through stacks

M
magnifying a graphic for editing 305-307
mailing labels, printing 359
managing icons 166—171
margins
adding to fields 263-264
adjusting for report 351
memory
checking 7-8
low
aint tools and 318-319
symptoms of 8-9, 318
working with 9, 319
requirements 6, 7
menu bar
in background layer 136
viewing hidden 32
menus. See also specific menus
hidden 32
with Paint tools 251-253
stack 32
Message box
and Find command 43-44, 45-46
and Find Whole command 47
getting help with 53
getting to Home stack with 26
g to card with 4143
moving to another stack with 48
moving between backgrounds with 139-140
moving through stacks with 4243
opening an application from 52-53
opening a stack from 27, 28
returning to Home stack with 50
miniature picture of card, creating 331
mistakes. See correcting mistakes
modifier keys, using with Paint tools 321

modifying a button’s appearance 173-180
modifying an icon 167
modifying stacks 78-87
protection from 103-105
moving back through cards seen recently 48-49
moving between backgrounds 139-140
moving a button 200-203
to another card or background 202-203
from background to card 201
from card to background 200-201
moving a card 127-128
moving a field 230
to another card or background 240-242
from background to card 239-240
from card to background 238-239
moving a graphic 292-293
to another card or background 328-329
from card to background 327
moving a template 360
moving through fields 214-216
moving through stacks 21-23, 32-50
with arrow keys 39-40
by clicking buttons 38
by clicking text 39
by flipping through cards 42-43
with Go menu 34-36
with Go palette 36-37
with Message box 42-43
reviewing cards viewed 48-49
by searching for text 43-47
moving through text 21-22
from one field to another 214-216
Text Arrows option for 213
multiple lines or shapes, drawing 293-295

N

naming a button 191-192
naming a card 130
naming a field 228-229

naming or renaming a background 143
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naming a stack 93-94
network
custom icons and 167
launching HyperCard over 119
low-memory symptoms with 8-9, 318
using stacks on 55
New Background command (Objects menu) 138
New Button command (Objects menu)
creating a button with an icon 161
creating a button with text 159
New Button (Objects menu) 114-116
New Card command (Edit menu) 123, 124
copying a background with 140, 141
New Field command (Objects menu) 209-210
New Stack command (File menu) 89
New Stack dialog box 89-90
New Template command (Templates menu) 344,
348-349
Next command (Go menu) 35
nonrectangular graphic, selecting 255-257

O
Objects menu commands
Bkgnd Info dialog box 85, 142
changing color set with 146-147
checking number of cards that share
background 137
naming or renaming a background with 143
protecting a background with 145
search exclusions with 144
Bring Closer command
reordering a button with 195
reordering a field with 234
Button Info dialog box 81
changing button style with 175
changing button text with 176
creating a text button with 159
installing an icon with 168-171

making button opaque or transparent with 197

naming a button with 191
opening a script with 203

Card Info dialog box 84, 129
changing color set with 133-134
naming or renaming a card with 130
protecting a card with 132-133
scripting a link with 183
search exclusions with 131
examining stacks with 80
Field Info dialog box 83
adding margins with 225-226
changing field style with 223-224
choosing text format with 217
displaying lines in field with 226-227
locking a field with 242-243
making a field opaque or transparent with 235
naming a field with 229
protecting field from search with 244 .
New Background command 138
New Button command 114-116
creating a button with an icon 161
creating a button with text 159
New Field command, for creating a field 209-210
Send Farther command
reordering buttons with 195
reordering fields with 234
Stack Info dialog box 86, 92
changing color set with 96-97, 274-275
checking free space with 100
checking number of backgrounds with 137
opaque buttons, changing to transparent 197
opaque fields, creating 235
opaque graphics, creating 303-305
opening an application program 52-53 ‘
adding a button to Home card for 114-116
opening a button’s script 203
opening a document 52-53
adding a button to Home card for 114-116
opening HyperCard 10-13
at startup 119
opening a stack 27-30
adding button to Home card for 112-113
closing old stack and 31
locked 30
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opening a stack (continued)
with a password 29
readymade buttons for 155
Open Stack command (File menu) 27, 28-29
closing a stack with 31
getting to Home stack with 26
moving to another stack with 48
Option key
copying a button with 198
copying a field with 236
using with Paint tools 321
Options dialog box, adjusting printing options in
339, 342-343
Options menu
Brush Shape command 265

mSG ColorSet 275,277
C ining options in 297

Draw Centered option 281, 282
Draw Filled option 288-290
Draw Multiple option 293-294
Draw Outlined option 283
Edit Pattern command 271
FatBits option 306-307
Grid option 295-296
Line Size command 290-291
Polygon Sides command 283-284
Power Keys option 319-320
outlining a graphic 314
ovals, drawing 281-283
Oval tool 281

ovcrl;lpping elements, solutions to

b,)ns 195-197
fields 233-235

graphics 303-305

P

padlock in menu bar, for locked stacks 30, 79, 105

Page Setup dialog box, selecting printing options in
334-336

Paint file, importing a color set from 278-279

Painting level, defined 19
and Power Keys option 24
Paint menu commands
Fill 269-270
changing a pattern with 309-310
Flip Horizontal 316-317
Flip Vertical 316-317
Invert 313
Keep 323
low memory and 318
Opaque 304
Pickup 311-313
Revert 319, 323-324
Rotate Left 315-316
Rortate Right 315-316
Select 258, 259, 260
Select All 261
Trace Edges 314
Transparent 304
Paint text 206, 298
adding 298-301
changing field text to 300-301
choosing a format for 298-299
preset format for 298
Paint Text tool
choosing 298
power keys disabled with 320
Paint tools 68, 69, 249-251. See also specific tools
choosing 71
double-clicking, effects of 322
Grid option and 296
low-memory conditions and 9, 318
menus with 71, 251-253
for special effects 293-297
Tilde () key with, 263, 332
using modifier keys with 321
password
opening a stack with 29
removing 108-109
setting 101-102

user level setting and 106, 107
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Paste Button command (Edit menu) 169, 199-202
Paste Card command (Edit menu)
adding new first card with 125
copying a background with 141
copying card with 126
creating miniature card with 331
making card first in stack with 128
moving a card with 127, 128
Paste Field command (Edit menu) 237, 240, 241
Paste Picture command (Edit menu) 263, 326-329
Paste Text command (Edit menu) 301
patterns, Changing 309-313
Patterns menu
changing or creating a pattern on 270-271
choosing a pattern from 2068, 269, 288, 291
editing a pattern on 270-271
tearing off 252
Patterns palette 252-253
choosing a pattern from 288, 291
shortcut for showing or hiding 252
peeking
at buttons 171-172
at fields 221
Pencil
drawing with 281, 287
editing a graphic with 307
phrase, searching for 4647
Pickup command (Paint menu) 311-313
picture insert, adding to report template 350,
352-355
pictures. See background picture; card picture;
graphics
planning a stack 75
pointers
arrow
with Button tool 157
copying a graphic with 325
moving a graphic with 292-293
Brush shape 265
Bucket
changing a graphic’s pattern or color with

310-311

38

positioning 268-269, 311

crosshair
drawing circles, ovals, or rectangles with
281-282

drawing an irregular polygon with 285-286
drawing lines or free-form shapes with 280
drawing polygons with 283
selecting a graphic with 254-255
I-beam 51
adding Paint text with 298
editable field shown by 211, 212
for editing text 51, 52
failure to appear 212-213
locked field and 243
Spray tool 266
Tools palette and 70 .
polygons, drawing 283-286
Polygon Sides dialog box 283-284
choosing shape in 283-284
Polygon tool
choosing 285
Draw Filled option with 289-290
drawing with 285-286
Power Keys option 23, 319-320
power keys listed 320
Prev command (Go menu), Back command vs.
35-36
Preview dialog box, checking report layout with 356
Print Card command (File menu) 336

Print dialog box
choosing a card template with 337
choosing a report template with 341 ‘

copying a template with 301
creating a card template with 343-348
creating a report template with 348-359
deleting a template with 362
exporting a template with 360
printing all or range of cards with 337-340
printing cards in stack with 337-340
printing a report with 340-343
renaming a template with 361-362

printer driver required 7
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printing 333-359
card pictures 340-343
cards 336-340
creating template for 343-348
entire stack 336—-340
single 336
specific 336, 338
field text 340-343
mailing labels 359
Page Setup options for 334-336
preparing for 334-336
reports 340-343. See also report template(s)
Private Access check box 101
protected cards, deleting 135
protected stacks

ing 30
trying to delete 111
types of 101

protecting a background from deletion 145-146
protecting a card from deletion 132-133
protecting a stack 101-110

from changes or deletion 103-105

on a file server 109—110

by limiting user level 106-108

with a password 101-102
Protect Stack dialog box

limiting user level with 106-108

preventing changes or deletion with 103-105

removing a password with 108

restricting access with 101-102

setting file server access with 109, 110

s’ng password with 101-102

Q

Quit HyperCard command (File menu) 57
for closing stack 31

R

radio button
Auto Hilite and 186
Share Hilite and 187

RAM icon, checking memory with 7-8

readymade buttons 67, 154-155
copying 154-157

readymade graphics, copying 262-263

Recent command (Go menu) 49

rectangles, drawing 281-283

Rectangle tool 281

rectangular area of graphic, selecting 265-255

Regular polygon tool 283-285

removing button text 176

removing an icon 177-178

removing a password 108-109

removing search paths 26

renaming a background 143

renaming a button 191-192

renaming a card 130

renaming a field 228-229

renaming a Home card 117-118

renaming a stack 93-94

renaming a template 361-362

reordering buttons 195-196

reordering cards. See repositioning cards

reordering fields 233-235

reordering graphics. See repositioning graphics

reports, printing 340-343. See alsoreport template(s)

report template(s) 336, 340, 343
copying within the same stack 361
creating 348-359
deleting 362
editing 341-342
exporting to another stack 360
for mailing labels 359
naming 349
previewing cell layout for 356
renaming 361-362
saving 359
selecting 341
specifying content for 350, 352-356
specifying footer for 358-359
specifying header for 357-358
specifying layout for 351-352

repositioning buttons 192-193
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repositioning cards 127-128
repositioning fields 230
repositioning graphics 263, 292-293, 303, 326
after copying 326
after moving 327, 329
resizing a button 173
to show text 160
resizing a field 222-223
for viewing hidden text 212
resizing a graphic 308
resource fork, icons stored in 167
restoring a graphic 323-324
restricting access. See protecting a stack
Revert command (Paint menu) 319, 323-324
Rotate Left command (Paint menu) 315-316
Rotate Right command (Paint menu) 315-316
rotating a graphic 315-316
Rounded Rectangle tool 281

S
Save A Copy command (File menu) 98
Save A Copy dialog box 98-99
saving graphics 323
saving a report template 359
saving a stack copy 98-99
scanned graphics, as card element 66
scanner, importing graphics via 329-330
Scripting level, defined 19
Blind Typing option 24
scripts 63
background, viewing 85
button, viewing 81, 203
button name changes and 192
card, viewing 84
copying, error messages and 91
creating links with 183-185
deleting 91
field, viewing 83
field name changes and 229
for linking 183-185

pre-programmed 154

380

stack, viewing 86
stack modification warning 78-79
viewing 80-80, 203
Scrolling field style, in Field Info dialog box 224
searching for text 43—47
exclusions when 46, 131, 143—144, 244
Paint text excluded from 300
Shared Text option and 220
in a specific field 4546, 47
speeding up 45
stopping 44
for whole word or phrase 4647
scarch paths 25
Search Paths cards 24-26
Select All command (Paint menu) 261
Select command (Paint menu) 258, 259, 260
selecting a button 72 ‘
selecting a field 73
selecting a graphic 74, 253-261
all in current layer 260
after creation 259
entire card or background picture 261
nonrectangular area 255-257
rectangular area 254-255
selecting an icon vs. 254
without blank space 255, 257-259, 260
selecting an icon, selecting a graphic vs. 254
selecting a pattern 253
selecting printing options 334-3306, 339
selecting text format 217-218
Selection tool 74, 254, 257, 261
Send Farther command (Objects menu) .
reordering buttons with 195
reordering fields with 234
Set Password button (Protect Stack dialog box) 101
shapes
drawing
circles, ovals, and rectangles 281-283
free-form 280-281
polygons 283-286
drawing patterned borders for 291-292
filled, drawing without borders 292

Index




Shared Text option, making text appear on every card

with 219-220
Share Hilite option 187-189
Shift key, using with Paint tools 321
Show All Cards command (Go menu) 42
size of button, changing 173
size of field, changing 222-223
size of graphic, changing 308
software requirements 7
special graphic effects 293-297
Spray tool 264
painting with 266-267
Spray tool pointer 266
stack(s) 5-6
adding cards to 122-125
bagkup, importance of 10
c¥® templates for, saving 348
on CD-ROM 56
changing name of 93-94
closing 31
color set for, changing 95-98, 274-275
compacting before closing 31
copying buttons between 167, 168-171
copying a template within 362
creating 59-78
card layer vs. background layer 63-65
by copying from other stacks 88-91, 90-91
evaluation while 76-77
by modifying existing stacks 78-87
planning 75
scripts for 63
ps in 88-91
ools for 68-71
creating new backgrounds for 138
deleting 110111
examining parts of 80-86
exporting a template to 360
on file server 55
getting information about 86, 92
icons for 5
links between 6
creating 180-185

locating buttonsin 171-172
locked 13
making a card first in 128
modifying 78-87
moving between 48
moving a card in 127-128
moving a template between 360
moving through 21-23, 32-50
with arrow keys 3940
with buttons 38
by clicking text 39
by flipping through cards 42-43
with Go menu 34-36
with Go palette 36-37
with Message box 4243
reviewing cards viewed 48—49
by searching for text 43—47
naming or renaming 93-94
opening 27-30
adding a button to Home card for 112—113
readymade buttons for 155
planning 75
printing all cards in 336-340
printing options saved with 335
protecting 101-110
from changes or deletion 103-105
on a file server 109-110
by limiting user level 106-108
from unauthorized access 101-102
readymade elements in 67
readymade graphics from, copying 262-263
reclaiming free space in 99-100
renaming 93-94
report templates for 340
creating 348-359
saving 359
selecting 340-342
repositioning cards in 127-128
sample 60-63
saving a copy of 98-99
scripts and 63
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stack icons 5
startup from 12
Stack Info command. See Stack Info dialog box
Stack Info dialog box 86, 92
changing color set with 96-97
for a stack 274-275
checking free space with 100
checking number of backgrounds with 137
shortcut for choosing 92
stack menus 32
stack names, in Finder vs. on button 27-28
stack script, viewing 86
starting HyperCard 10-13
at Apple 11Gs startup 119
Startup Info dialog box (AppleShare network) 119
style of button, choosing 174-176
style of button text, setting 176-177
style of field, changing 223-224
style of field text. See text format
Style menu
choosing button style with 175-176
choosing field text format with 218
choosing field style with 224
setting button text with 176
system software requirements 7

Tab key, moving through fields with 214-216
reordering fields and 234
template(s). See card template(s); report template(s)
Template dialog box
choosing cards to print with 338
creating a card template with 344-348
Templates menu commands
Delete 362
Edit Template 338, 341-342
creating a card template with 344-348
creating a report template with 349, 357-359
Export 360
New Template 344, 348-349

testing a button 157

388

after copying 200
after moving 203
testing a link 182, 185
text. See also button text; field text; Paint text
Arrow Keys in Text option 21-23, 3940, 213
combining with an icon 164
creating a button with 158-161
formatting. See text format
role of 205
searching for 43—47
exclusions when 406, 131, 143-144, 244
Paint text excluded from 300
Shared Text option and 220
types of 206
determining 212
Text Arrows option 21-23, 3940
moving through text with 213 ‘
text fields. See field(s)
text format
choosing 217-218
for Paint text 298-299
specifying in report template 354-355
Text Style dialog box
for button text style 176-177
for choosing field text format 217-218
for choosing report font 354-355
for Paint text 298-299
shortcut for opening 217
text style. See text format
Tilde (~) key
for looking through cards viewed 48
for undeleting a graphic 263, 332 ’
Tools menu 68-71. See also specific tools
choosing a border tool from 292
Draw Filled option and 289
shortcuts
for choosing General tools 154, 209
for painting commands 320
tearing off 70
for working with buttons 72, 153-154
for working with fields 73, 208-209
for working with graphics 74, 249-253
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Shared Text option, making text appear on every card locating buttons in 171-172

with 219-220 locked 13
Share Hilite option 187-189 making a card first in 128
Shift key, using with Paint tools 321 modifying 78-87
Show All Cards command (Go menu) 42 moving between 48
size of button, changing 173 moving a card in 127-128
size of field, changing 222-223 moving a template between 360
size of graphic, changing 308 moving through 21-23, 32-50
software requirements 7 with arrow keys 3940
special graphic effects 293-297 with buttons 38
Spray tool 264 by clicking text 39
painting with 266-267 by flipping through cards 42-43
Spray tool pointer 266 with Go menu 34-36
stack(s) 5-6 with Go palette 36-37
adding cards to 122-125 with Message box 4243
bggwup, importance of 10 reviewing cards viewed 48-49
c¥® templates for, saving 348 by searching for text 4347
on CD-ROM 56 naming or renaming 93-94
changing name of 93-94 opening 27-30
closing 31 adding a button to Home card for 112-113
color set for, changing 95-98, 274-275 readymade buttons for 155
compacting before closing 31 planning 75
copying buttons between 167, 168—171 printing all cards in 336-340
copying a template within 362 printing options saved with 335
creating 59-78 protecting 101-110
card layer vs. background layer 63-65 from changes or deletion 103-105
by copying from other stacks 88-91, 90-91 on a file server 109-110
evaluation while 76-77 by limiting user level 106-108
by modifying existing stacks 78-87 from unauthorized access 101-102
planning 75 readymade elements in 67
scripts for 63 readymade graphics from, copying 262-263
psin 88-91 reclaiming free space in 99-100
ools for 68-71 renaming 93-94
creating new backgrounds for 138 report templates for 340
deleting 110-111 creating 348-359
examining parts of 80—86 saving 359
exporting a template to 360 selecting 340-342
on file server 55 repositioning cards in 127-128
getting information abour 86, 92 sample 60-63
icons for 5 saving a copy of 98-99
links between 6 scripts and 63

Creating 180-185
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Tools palette
choosing a tool from 70-71
creating 70
Trace Edges command (Paint menu) 314
transparent buttons
changing opaque buttons to 197
creating 157-158
transparent fields
changing opaque fields to 235
creating 210
finding 211
transparent graphics, creating 303-305
Typing level, defined 19
typing mistakes, correcting 87. See also correcting
mistakes

U
undeleting a card 135
undeleting field text 217
undeleting graphics 263-264, 332
Undo command (Edit menu) 87
low memory and 318
Revert command vs. 323
undeleting a card with 135
undeleting field text with 217
undeleting a graphic with 263, 332
unlocking a field 243
updating Search Paths card 25-26
user levels 17-21. See also specific levels
Arrow Keys in Text option and 21

Blind Typing option and 24

Compact Stack command and 31

File and Edit menus with 20

limiting 106-108

listed 19

Power keys option and 23

setting or changing 17-18

User Preferences card vs. stack 21
User Preferences card 17-24

Arrow Keys in Text option 21-23, 39

Blind Typing option 24

Power Keys option 23, 319-320

stack user level vs. 21

\’r
viewing cards quickly 42-43
viewing cards seen recently 48-49
viewing scripts 80-86, 203

W

white paint, blank space vs. 253
Wide Margins, for fields 225-226
word, searching for 4647

write-protected stack, opening 30

XY, Z

XCMD, adding a color set with 273
to background 148, 278
to a card 134, 276
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